Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
23.11.2020, 20:18:00

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24814
  • Letzte: GrischanB
Statistiken
  • Beiträge insgesamt: 696323
  • Themen insgesamt: 56359
  • Heute online: 705
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Wie kann ich ein ISCSI-Laufwerk beim Start automatisch einhängen?  (Gelesen 2875 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo zusammen,
ich benutze Mint17 cinnamon und habe ein ISCSI-Laufwerk von meiner DS von Synology erfolgreich eingerichtet.
Ich bekomme es als /dev/sdb1/ in Nemo unter Geräte angezeigt. nach einem Klick auf das Gerät wird es eingehängt und ich kann ganz normal darauf zugreifen.
Soweit so gut.

Ich benutze für mein Backup backintime.
Wie stelle ich es an, dass mein iscsi beim PC - Start automatisch eingehängt wird?

Irgendwie hab ich da ein Brett vorm Kopf
Gruß
duk64
« Letzte Änderung: 24.08.2014, 22:10:44 von duk64 »


Hallo DocHifi,
danke für deine Antwort.

Das ich Partitionen über die fstab einbinden (mounten kann ist mir bekannt, ich habe mehrere NAS - Freigaben dort eingetragen.

Jedoch hier habe ich hier ein ISCSI-Laufwerk aus meiner NAS. Siehe Anhang.
Ds geht doch damit gar nicht, soweit ich weiß.

Ich hatte das so verstanden, das die HDD im Rechner verbaut ist, weil sie als /dev/sdb1 genannt ist.

Ist ja kein Thema!
Jede Antwort ist hilfreich.
Ich hatte das sogar mal probiert wenn ich nicht irre..

Wie genau ist die denn mit dem Rechner verbunden ?

Ich habe mich nach http://wiki.ubuntuusers.de/iSCSI dieser Anleitung gerichtet.
Über open iscsi ist das gemacht. Unten bei Client im Artikel habe ic in Mint angewendet. die Synology-NAS stellt den Server dar, dies kann https://www.synology.com/de-de/support/tutorials/488
hier nachgelesen werden.

Ich wollte das probieren und für mein Backup ist das optimal finde ich.


Der Artikel ist ziemlich alt, 10.04 ist lange her, möglicher Weise stimmt das so für 14.04 nicht mehr.
Es hat sich ja seit dem schon einiges geändert.
Hier http://www.pug.org/mediawiki/index.php/ISCSI_unter_Debian steht:
Zitat
Nach einem erneuten überprüfen, sehen wir den Wert von node.conn[0].startup = auf automatic stehen. Damit sollte beim erneuten Start des Initiators Open-ISCSI, die Speicher lokal eingebunden werden.
Möchten wir, dass dieser Modus automatisch eingetragen wird, müssen wir in der /etc/iscsid.conf den Wert node.conn[0].startup = automatic eintragen.

Hast du das so versucht ?
« Letzte Änderung: 24.08.2014, 20:17:48 von DocHifi »

Ich habe hier mal meine iscsid.conf angehängt, vielleicht ist da der Fehler.

Oh hat sich überschnitten.
Ja das habe ich eingetragen.

Zeig mal mit eingehängtem Laufwerk die Ausgabe von mount

/dev/sdb1 on /media/hw/a2471898-19a3-4007-8f37-9cde5741f4cf type ext4 (rw,nosuid,nodev,uhelper=udisks2)

Ich würde mal auf doof es so in der fstab versuchen.
UUID=a2471898-19a3-4007-8f37-9cde5741f4cf  /media/hw  ext4 defaults 0 0Dann im Dateimanager aushängen und im Terminal sudo mount -a testen ob sie eingehängt wird.

jep geht tadellos!!     :D
nun könnte ich unter Startprogramme das Laufwerk mounten meinst du das??

Nein sollte beim Neustart so gehen.