Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.09.2020, 14:42:14

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 685196
  • Themen insgesamt: 55454
  • Heute online: 668
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Libreoffice aus ppa führt zu Konflikt bei der Aktualisierung  (Gelesen 1121 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo,

auf meinem Rechner habe ich
Linux Mint 13 Maya
Prozessor AMD II X2 250 1,7 GB
Libreoffice 4.3.0.4 aus
ppa.launchpad.net/libreoffice/ubunutu/precise main etc.

Die Ausgabe in Synaptik ist
Zitat
Die Abhängigkeiten von 2 Paketen auf Ihrem System sind defekt
libreoffice
libreoffice base
Zitat

Wie kann ich den Aktualisierungsfehler beseitigen?

Vielen Dank für eine rasche Hilfe.

Lieber Gruß aus Brandenburg
« Letzte Änderung: 19.08.2014, 21:13:51 von 21harald07 »

Re: Libreoffice aus ppa führt zu Konflikt bei der Aktualisierung
« Antwort #1 am: 17.08.2014, 19:25:36 »
Du könntest mal ein sudo apt-get install -f versuchen.
Die Ausgabe am Ende im Zweifel zeigen.

Re: Libreoffice aus ppa führt zu Konflikt bei der Aktualisierung
« Antwort #2 am: 17.08.2014, 21:20:26 »
Hallo vielen Dank für deine Hilfe.

Hier der Eintrag:
harald@harald-desktop ~ $ sudo apt-get install -f
[sudo] password for harald:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
Abhängigkeiten werden korrigiert... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libreoffice-base
Vorgeschlagene Pakete:
  libreoffice-gcj libreoffice-report-builder unixodbc
Die folgenden Pakete werden aktualisiert (Upgrade):
  libreoffice-base
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
15 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 2.138 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 2.614 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? J
(Lese Datenbank ... 199654 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Ersetzen von libreoffice-base 1:4.3.0-0ubuntu1~precise1 (durch .../libreoffice-base_1%3a4.3.0-3ubuntu1~precise1_i386.deb) ...
Ersatz für libreoffice-base wird entpackt ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libreoffice-base_1%3a4.3.0-3ubuntu1~precise1_i386.deb (--unpack):
 Versuch, »/usr/lib/libreoffice/share/basic/script.xlc« zu überschreiben, welches auch in Paket libreoffice-common 1:4.3.0-3ubuntu1~precise1 ist
dpkg-deb (Unterprozess): Unterprozess data wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
dpkg-deb: Fehler: Unterprozess <Dekompression> gab den Fehlerwert 2 zurück
dpkg: Fehler: --compare-versions akzeptiert drei Argumente: <Version> <Beziehung> <Version>

Nutzen Sie dpkg --help für Hilfe zur Installation und Deinst. von Paketen
;

Benutzen Sie »dselect« oder »aptitude« für benutzerfreundliches Paketmanagement;
Nutzen Sie dpkg -Dhelp für eine Liste von Debug-Flags von dpkg;
Nutzen Sie dpkg --force-help für eine Liste von Optionen zum Erzwingen;
Nutzen Sie dpkg-deb --help für Hilfe zum Manipulieren von *.deb-Dateien;

Optionen mit
geben viel aus - schicken Sie es durch »less« oder »more«!

Trigger für menu werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libreoffice-base_1%3a4.3.0-3ubuntu1~precise1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Gruß

EDIT: Ausgabe in [code][/code]-Block gepackt

Re: Libreoffice aus ppa führt zu Konflikt bei der Aktualisierung
« Antwort #3 am: 18.08.2014, 17:08:55 »
Hi,

mit diesem Problem habe ich mich am Samstag auch rumschlagen müssen.

Ich kann Dir leider nicht mehr die genaue Reihenfolge meiner Befehle posten, aber u.a. habe ich folgende Befehle genutzt:
sudo apt-get clean && sudo apt-get autocleansudo rm /var/lib/dpkg/info/libreoffice*sudo apt-get purge libreoffice-basesudo apt-get install libreoffice
Hylli

Re: Libreoffice aus ppa führt zu Konflikt bei der Aktualisierung
« Antwort #4 am: 18.08.2014, 20:53:39 »
Hallo hylli,

vielen Dank für deine Info... vielleicht hast du noch ein Hinweis auf die Quelle. Ich möchte ungern das LO gefährden, da ich viel auch dienstlich damit arbeite.

Ist das Problem bei dir gelöst?

Vielen Dank für eine rasche Antwort.

Lieber Gruß


Re: Libreoffice aus ppa führt zu Konflikt bei der Aktualisierung
« Antwort #5 am: 18.08.2014, 21:21:13 »
Eine Quelle kann ich Dir nicht nennen, bin nur nach den Fehlermeldungen gegangen und habe damit Google gefüttert.

Halt, doch! Eine Quelle kann ich Dir nennen:
http://wiki.ubuntuusers.de/Paketverwaltung/Problembehebung#Die-Installation-Deinstallation-von-Paketen-endet-mit-Fehlermeldungen

...und ja, ich konnte mein Problem damit lösen.

Edit:
Schau mal unter folgenden Links:
http://ubuntuforums.org/showthread.php?t=2240047&p=13100919#post13100919
http://forums.linuxmint.com/viewtopic.php?f=47&t=175950

Hylli
« Letzte Änderung: 18.08.2014, 21:30:54 von hylli »

Re: Libreoffice aus ppa führt zu Konflikt bei der Aktualisierung
« Antwort #6 am: 18.08.2014, 21:46:00 »
Hallo,

super und danke ....

lieber Gruß

Re: Libreoffice aus ppa führt zu Konflikt bei der Aktualisierung
« Antwort #7 am: 19.08.2014, 20:01:48 »
Hallo,

hat alles geklappt und damit ist das Problem gelöst!

Herzlichen Dank an die Mitwirkenden.

Lieber Gruß aus Südostbrandenburg