Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
13.12.2017, 23:45:29

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 19251
  • Letzte: MattG
Statistiken
  • Beiträge insgesamt: 497663
  • Themen insgesamt: 39974
  • Heute online: 470
  • Am meisten online: 679
  • (03.04.2017, 15:20:01)
Benutzer Online

Autor Thema:  Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus  (Gelesen 2739 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« am: 08.08.2014, 12:59:35 »
Hallo.

Kurz und knapp:
Ich habe das Problem, dass mein Linux (Linuxmint 17 KDE 64-Bit) im Unterschied zum parallel installierten Windows 7 64-Bit auf einem UEFI-Mainboard im Non-UEFI-Modus eine enorm lange Bootzeit (ca. 3-4 Minuten) beansprucht.

Jetzt im Detail mit Gründen, warum es so ist wie es ist:
Ausgangslage war ein System (altes Board) mit normalem BIOS und parallel installiertem Windows 7 64-Bit zum Zocken und LinuxMint17 64 Bit KDE zum Arbeiten mit einer SSD als Systemplatte (MSDOS-MBR, nicht GPT !). Der SATA-Controller (SATA2) war für die SSD ein Flaschenhals, also neues Board (Asus M5A99FX Pro 2.0 mit AMD 8350 CPU und 8GB Speicher. Zeitraubende Arbeiten für die Migration wollte ich in jedem Fall vermeiden. Demnach stand der Versuch im Raum zumindest das Windows zu migrieren. Ein funktionierender Migrati-onspfad für massive Hardwareänderung bei Linux war mir nicht bekannt, also in diesem Fall=Neuinstallation.

1. Vollsicherung via Acronis TrueImage (für alle Fälle); aber nicht benötigt.
2. Altes Board raus, neues rein.
3. Ich habe nie eine Funktion von UEFI vermisst und will auch Windows nicht neu instal-lieren (mit GPT und EFI-Partition). Also ALLE UEFI-Einstellungen auf Legacy-BIOS eingestellt (CSM enabled, Legacy-BIOS erzwungen wo es nur ging, KEIN Secure-Boot, KEIN Fastboot......wie bei ubuntuusers im wiki bestens dokumentiert).
4. Systemstart via noch vorhandenem Grub2 ins Windows (abgesicherter Modus).
5. Alte Windows-Treiber deinstalliert; neue Treiber für die Board-Komponenten installiert; Reboot; Windows fertig; performt bestens; lt. Benchmarks wird die Leistungs-bandbreite der SSD jetzt im Unterschied zu vorher voll ausgereizt; Mission für Windows) abgeschlossen ;-)
6. LinuxMint 17 64 Bit KDE Live via USB3-Stick gestartet (mit dem Zusatz „noefi“ bei den Kernel-Options). Enorm schneller Boot, sehr schön !
7. Installation lief einwandfrei, Paketrepositories via Script wieder hergestellt, Pakete mit mintbackup nachinstalliert, User definiert, Partitionen (insbesondere home) gemoun-tet. Alles wie vorher, perfekt, fast.........
8. Reboot und ellenlang warten.....unglaublich

Und das passiert aus meiner Sicht:
Das Grub2-Menü erscheint wie gewohnt schnell. Aber wenn ich Linux auswähle und starte braucht das System ewig. Die HD-LED (in diesem Fall wohl die SSD) flackert permanent, als ob etwas gesucht würde. Habe herausgefunden, dass der Kernel geladen wird, ebenso die Initial-Ramdisk und dann passiert das geheimnisvolle Warten. Nach ca. 3-4 Minuten ist das System wohl fertig mit dem was auch immer es getan hat und startet. Die HD-LED flackert nicht mehr sondern leutet kurz permanent (=viele I/Os), das LinuxMint-Logo erscheint wie erwartet und schon kann man sich anmelden. Der eigentliche Initialisierungsprozess dauert demnach lediglich ca. 10 Sekunden (dank der SSD). Ich habe mir via webmin sowohl das Kernel-log, als auch das System-Log angezeigt und keine Auffälligkeiten gefunden. Das liegt hauptsächlich daran, dass es keine Timestamps gibt, die älter als 10-15 Sekunden sind. Sprich was auch immer das System während der Wartezeit treibt.......es wird (noch) nicht protokolliert, zumindest nicht dort wo ich gesucht habe.

Ich habe dann analog zum Installationsprozess in der grub.cfg für den normalen Boot ebenfalls zusätzlich die Kernel-Option „noefi“ eingetragen in der Hoffnung damit Erfolg zu haben. Das bringt aber nichts..........

In hoffe hier jemanden zu finden, der mir sagen kann was das Problem ist und wie ich es loswerde.........

Danke schon mal im voraus !!!

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #1 am: 08.08.2014, 13:03:04 »
Zitat
Ich habe dann analog zum Installationsprozess in der grub.cfg für den normalen Boot ebenfalls zusätzlich die Kernel-Option „noefi“ eingetragen in der Hoffnung damit Erfolg zu haben. Das bringt aber nichts..........
Hast du danach auch ein sudo updte-grub gemacht ?

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #2 am: 08.08.2014, 13:07:34 »
Falls "update-grub" keine Änderung bringt oder bereits gemacht wurde,
könnte das evtl Aufkärung bringen :  http://wiki.ubuntuusers.de/GRUB-Umgebung_analysieren?highlight=boot-info-script#Umfassende-Analyse-mittels-Boot-Info-Script

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #3 am: 08.08.2014, 13:09:13 »
Nein. Ich war nicht in der /etc...... sondern direkt in der /boot/grub/grub.cfg. (ich weiss, das ist suboptimal, aber musste schnell gehen).
Ich verwende auch nicht die bei der Installation erzeugte grub.cfg, sondern meine alte (deutlich gestutzte) aus der vorhergehenden Installation und somit verwende ich auch keine efi-module, wie sie in der neu erzeugten drin sind. Die Original-Datei habe ich aber zuvor gesichert und auch damit einen Test gemacht, also ohne "efi", sondern exakt so, wie der Installationsprozess die Datei hinterlassen hat. Es macht leider keinen Unterschied..........

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #4 am: 08.08.2014, 13:10:22 »
Das mit dem Boot-Info-Skript ist eine gute Idee, danke. Werde ich heute Abend ausprobieren. Mal schauen was zu sehen sein wird......

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #5 am: 08.08.2014, 13:19:24 »
Nein. Ich war nicht in der /etc...... sondern direkt in der /boot/grub/grub.cfg. (ich weiss, das ist suboptimal, aber musste schnell gehen)...
Na ich weiß nicht so recht, ob es nicht ratsam ist, sich für eine derartige Aktion Zeit zu nehmen und sich an die System-Empfehlungen zu halten ?
Vermeintliche Abkürzungen kosten dann unterm Strich wesentlich mehr Zeit und Nerven  :D

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #6 am: 08.08.2014, 13:30:29 »
Werde ich beherzigen, danke.
Zumindest ist das Kind noch nicht in den Brunnen gefallen, da die Originaldateien sowohl in /etc, als auch in /boot/grub noch existieren. Ein update-grub sollte den vom Distributor gewollten Zustand wieder herstellen, obwohl der (wie gesagt) am gleichen Problem krankt...

In beiden Fällen heisst die Aufgabe  aber: Skript editieren. Versteht mich nicht falsch, das bekomme ich schon hin, mache das aber nicht täglich. Mich stören am Original-Skript meistens nur die vielen Suboptionen. Habe zusätzlich als Gimick mein Hintergrundbild drin und setze 1280x1024 als Auflösung (1680x1050 ging nicht...).

Gibt es für diejenigen unter uns, die sowas nicht täglich machen ein gutes grafsiches Programm, mit dem man die grub.cfg am richtigen Ort relativ sicher so editieren kann wie man es möchte ?

Aber dies ist nur der Nebenkriegsschauplatz...........Das Problem ist immer noch der Boot und das was das System während dessen treibt.

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #7 am: 08.08.2014, 13:48:24 »
Zitat
... ein gutes grafisches Programm, mit dem man die grub.cfg am richtigen Ort relativ sicher so editieren kann wie man es möchte ?
https://launchpad.net/grub-customizer
Ist aber hier im Forum ziemlich umstritten -  viele raten davon ab, den zu verwenden,
weil damit auch Unheil angerichtet werden kann.
Wenn man weiß, was das Ding macht, braucht man es eigentlich nicht.

Zum Grub gibt es im Wiki der Ubuntuusers vorzügliche Informationen :
zB : http://wiki.ubuntuusers.de/GRUB_2/Aussehen
« Letzte Änderung: 08.08.2014, 13:53:09 von aexe »

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #8 am: 08.08.2014, 14:52:48 »
Eventuell spuckt die Eingabe
dmesgim Terminal aus, was du suchst.

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #9 am: 08.08.2014, 15:53:42 »
dmesg -T zeigt den Zeitstempel in einem für Menschen besser lesbaren Format an.

Mit der Option desmeg -l [Level]  lässt sich die meist recht umfangreiche Ausgabe filtern,
mögliche [Level] sind:
 emerg (system is unusable)
 alert (action must be taken immediately)
 crit (critical conditions)
 err (error conditions)
 warn (warning conditions)
 notice (normal but significant condition)
 info (informational)
 debug (debug-level messages)

Auch nützlich ist die Option  -x (decode facility and level to readable string)
« Letzte Änderung: 08.08.2014, 16:13:06 von aexe »

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #10 am: 08.08.2014, 17:01:33 »
Ok. Ich schicke hier einfach mal sowohl die Ausgabe von boot-info und die von dmesg.
Insbesondere in dmesg sind zwar Dinge drin, die auch mir auffallen, aber da werft Ihr besser mal nen bösen Blick drauf.........

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #11 am: 08.08.2014, 17:02:47 »
.

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #12 am: 08.08.2014, 17:07:30 »
Hast du ein Netzlaufwerk in der fstab stehen?

Zeig mal

cat /etc/fstabbitte.
Hat sich erledigt, steht ja in der RESULTS.txt...
« Letzte Änderung: 08.08.2014, 17:11:21 von Marco77 »

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #13 am: 08.08.2014, 17:29:27 »
Zitat
...
[Fr Aug  8 16:43:34 2014]  sdd: sdd1
[Fr Aug  8 16:43:34 2014] sd 8:0:0:0: [sdd] No Caching mode page found
[Fr Aug  8 16:43:34 2014] sd 8:0:0:0: [sdd] Assuming drive cache: write through
--[Fr Aug  8  16:43:34 2014] sd 8:0:0:0: [sdd] Attached SCSI removable disk
[Fr Aug  8 16:44:29 2014] FAT-fs (sdd1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[Fr Aug  8 16:44:49 2014] sdd: detected capacity change from 2002747392 to 0
[Fr Aug  8 16:44:52 2014] usb 3-3: USB disconnect, device number 2
--[Fr Aug  8 16:45:56 2014] SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled
...
Da steckt ein Wurm. Das dauert über 2 Min.
Steckt da eine USB-Festplatte dran ? (/dev/sdd)

Wenn ja :
Windows starten, Laufwerk sicher entfernen, USB-Stecker abziehen,
neu starten.
Denk ich jetzt mal.
« Letzte Änderung: 08.08.2014, 17:48:10 von aexe »

Re: Lange Boot-Zeit mit UEFI-BIOS im Non-UEFI-Modus
« Antwort #14 am: 08.08.2014, 18:46:14 »
Es liegt am grub von LM. Habe opensuse installiert und siehe da es funktioniert, auch LM bekommt jetzt den Hintern hoch. Ich schicke Euch mal die Dateien zum Vergleich.