Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
01.06.2020, 21:02:49

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24073
  • Letzte: wol
Statistiken
  • Beiträge insgesamt: 663482
  • Themen insgesamt: 53673
  • Heute online: 589
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  frische Installation LM-17 Cinnamon, ich bitte um Hilfe bei Feinjustierung  (Gelesen 2070 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

ahoi zusammen,

ich habe mich heute mittag entschlossen, mein Ubuntu zu plätten und habe nun LM 17 frisch aufgesetzt. Grund dafür hier: https://www.linuxmintusers.de/index.php?topic=20649.0

nun hätte ich gern ein paar Tipps bei der Feinjustierung:

1. ich habe folgendes an Partitionen (s.a. Anhang) /Daten angelegt, allerdings keine separate /home. nun speichert LM wohl alles automatisch im /home des Hauptverzeichnisses. ich möchte aber, das immer alle Daten im /Daten landen. wie kann ich das erreichen?

2. ich habe meine alte fstab gesichertt mit diesem Ihnalt # /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=ee10cb00-5350-46ae-afe9-f946d834a5f5 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=f2971bfa-3103-4e4b-ad77-2f2dd2493d74 /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=dda989b5-0b11-4125-9218-66116224445d none            swap    sw              0       0
//192.168.178.33/Multimedia /media/Multimedia cifs noauto,users,uid=1000,credentials=/home/detlef/.smbcredentials 0 0
//192.168.178.33/Daten /media/Daten cifs noauto,users,uid=1000,credentials=/home/detlef/.smbcredentials 0 0
kann ich die jetzige fstab des Systems einfach entsprechend ergänzen? die smbcredentials speichere ich entsprechend im /home.

3. mein Browser Chromium ist auf Englisch....stört nicht wirklich, aber er will sich nciht auf dt. stellen, obwohl die Sprachpakete installiert sind.
edit: erledigt nach Neustart Chromium

4: ich kann auf das Verzeichnis /Daten nicht zugreifen, das gehört root, nicht mir.  :o  wie kann ich das ändern??
herzlichen Dank schonmal im Voraus!  :)
« Letzte Änderung: 13.07.2014, 11:22:09 von al.bert »

gem

  • *
Hi al.bert,

wenn Du den Dateibrowser im Terminal oder Alt/F2 mit gksudo nemo aufrufst, kannst Du auf /Daten zugreifen.

Gruß gem

Den Datei-Manager als "root" zu benutzen, ist keine gute Idee in diesem Fall, finde ich.

Die Datenpartition wurde ja vom System angelegt, gehört also zunächst mal "root".
Der User muss sich nun nur noch zum Besitzer  machen.
Dies geht per Terminal per sudo chown -R  *user /Pfad/zu/DATEN**muss entsprechend angepasst werden*

Man kann es auch einmalig mit dem "als Root geöffneten"-Dateimanager machen.
(Rechtsklick > Eigenschaften > Berechtigungen)

EDIT :
siehe hierzu und auch zu 1) :
https://www.linuxmintusers.de/index.php?action=wiki;page=4%29_Nachtr%C3%A4glich_eine_Partition_in_fstab_einbinden
« Letzte Änderung: 12.07.2014, 19:59:43 von aexe »

wenn Du den Dateibrowser im Terminal oder Alt/F2 mit gksudo nemo aufrufst, kannst Du auf /Daten zugreifen.
Möglich, aber keine dauerhafte Lösung...

Zu der ersten Frage: https://www.linuxmintusers.de/index.php?topic=13933.msg151451#msg151451
und zu dem Rechte-Problem:

Zeig mal bitte die Ausgabe von
cat /etc/fstab
EDIT: Link eingefügt
« Letzte Änderung: 12.07.2014, 20:10:11 von Marco77 »

Die Ausgabe von sudo lsblk -o NAME,UUID,LABEL,SIZE,FSTYPE,MOUNTPOINTwäre auch gut (Befehl nicht abtippen, copy & paste ist einfacher.
Ich denke, der Daten-Partition fehlt auch noch eine gute Bezeichnung (Label)

PS: Die riesigen Bildschirmfotos sind furchtbar unübersichtlich.


Zeig mal bitte die Ausgabe von
cat /etc/fstab
EDIT: Link eingefügt
@ThinkPad-X220 ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=74ada4f0-b432-4f1c-b43c-b385ae1c60f3 /               ext4    errors=remount-ro 0       1
# /Daten was on /dev/sda6 during installation
UUID=cbbcfff3-4bc8-4d6a-a7d6-95f5a6950b50 /Daten          ext4    defaults        0       2
# swap was on /dev/sda5 during installation
#UUID=83b44d94-3f75-44cf-abf9-9bde68fa8626 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

Die Ausgabe von sudo lsblk -o NAME,UUID,LABEL,SIZE,FSTYPE,MOUNTPOINTwäre auch gut (Befehl nicht abtippen, copy & paste ist einfacher.
Ich denke, der Daten-Partition fehlt auch noch eine gute Bezeichnung (Label)

PS: Die riesigen Bildschirmfotos sind furchtbar unübersichtlich.
NAME   UUID                                 LABEL   SIZE FSTYPE MOUNTPOINT
sda                                               119,2G       
├─sda1 74ada4f0-b432-4f1c-b43c-b385ae1c60f3        11,2G ext4   /
├─sda2                                                1K       
├─sda5                                              953M       
└─sda6 cbbcfff3-4bc8-4d6a-a7d6-95f5a6950b50       107,1G ext4   /Daten
und das die screenshots riesig sind, sehe ich gar nicht. bei mir sind die klein, nur wenn ich drauf klicke, werden die groß...ist das bei dir anders?

Also, wie du ja schon erkannt hast gehört der Mountpoint root, das ändert ein
sudo chown -R $USER /Daten
Und dann kannst du auch die Ordner für Musik, Downloads usw. auf diese Partition verlegen, z.B. so wie in dem Link oben beschrieben

Die Screenshots sind in 3erlei Hinsicht ungeschickt
  • um was zu lesen muss ich die groß machen → riesig
  • der Speicherplatz der benötigt wird ist um ein vielfaches größer als der eines Codeblocks → riesig
  • und vor allem kann man aus den Bildern keine Textstellen rauskopieren und das ist ungeschickt
Mal abgesehen davon haben auch manche einen Volumen-Vertrag und sind froh wenn nicht so viel runtergeladen wird

Ach so, und beim Antworten seh ich das Bild nicht, Daten aus dem Codeblock kann ich unter dem Antwortfeld nachlesen...

hm, ist ja blöd mit den screenshots....aber ich wusste/weiß nicht. wie ich am besten den codeblock auslesen kann zum einstellen.

das Problem mit den Verzeichnissen gehe ich morgen an.

die Frage mit dem Zugriff habe ich gelöst mit sudo nemo und dann die Rechte zu mir gesetzt.

gute N8 für heute

moin :)

anscheinend kapiere ich das mit den Verzeichnissen und Verknüpfungen noch nicht so ganz. ich habe folgende gemacht:
zb ln -s /home/detlef/Daten/Videos /home/detlef/Videos. usw für die weiteren Ordner.

es existieren nun unter /home/detlef/ die Ordner Musik, Bilder usw. und auch im Verzeichnis /Daten. (mein /Daten ist ja bei der Installation direkt im Wurzelverzeichnis angelegt worden). Der oben angegebene code produziert einen link, der aber beim Klick darauf als fehlerhaft angezeigt wird. Das Verzeichnis /home/detlef/Daten existiere nicht, klaro, hab ich auch nie angelegt.

ich habe dann das versucht:
ln -s /Daten/Videos /home/detlef/Videosdas funktioniert aber nicht korrekt, es kommt ln: Die symbolische Verknüpfung »/home/detlef/Videos/Videos“ konnte nicht angelegt werden: Die Datei existiert bereits. Wieso steht da dann /Videos 2mal?

hm, wat nu?

Ich vermute, daß sich ein Fehler in die Pfadangabe eingeschlichen hat :
statt ln -s /home/detlef/Daten/Videos /home/detlef/Videos evtl
Zitat
ln -s /media/detlef/Daten/Videos /home/detlef/Videos
?
Die alten, falschen Symlinks musst Du vorher löschen oder umbenennen.
Sonst kommt die Meldung, daß der schon existiert - logisch. Doppelt geht nicht. 

http://wiki.ubuntuusers.de/ln?highlight=Symlinks#Beispiele
« Letzte Änderung: 13.07.2014, 09:00:13 von aexe »

hm, das funzt auch nicht wirklich:
ln -s /media/detlef/Daten/Videos /home/detlef/Videos legt eine Verknüpfung an im entsprechenden Ordner. Beim Doppelklick auf den link im Ordner kommt die Fehlermeldung
Zitat
Diese Verknüpfung kann nicht verwendet werden, da ihr Ziel »/media/detlef/Daten/Videos« nicht existiert.

wenn ich dann das eingebe ln -s /media/Daten/Videos /home/detlef/Videos
ln: Die symbolische Verknüpfung »/home/detlef/Videos/Videos“ konnte nicht angelegt werden: Die Datei existiert bereits
seltsam, denn ich habe im entsprechenden Ordner keinen link gefunden.

ich habe wie gesagt beim Installieren eine Partition /Daten angelegt. die ist aber nicht unter /media eingebunden, ich sehe sie direkt im Dateimanager im Hauptverzeichnis? ist nur eine Vermutung meinerseits als Laie, dass das die Ursache ist für die Fehlermeldung.
Im Verzeichnis /media gibts nur den Ordner "detlef", sonst nix. könnte der Pfad zB dann so richtig sein?
ln -s /Daten/detlef/Videos /home/detlef/Videos
edit: tuts nicht, Fehlermeldung: ln: Die symbolische Verknüpfung »/home/detlef/Videos/Videos“ konnte nicht angelegt werden: Die Datei existiert bereits

Den Befehl musst du schon auf deine Situation anpassen...

also z.B. für "Dokumente":
mkdir /Daten/Dokumenteln -s /Daten/Dokumente /home/detlef/Dokumente
Bevor du das machst muß der Ordner "Dokumente" im Home-Verzeichnis gelöscht werden (vorher nachsehen ob nix drin ist was du noch brauchst).
Das dann für jeden Ordner den du umziehen willst wiederholen. Auch die Links die bei deinen Versuchen vorher entstanden sind musst du erstmal wieder löschen.

das ist ganz schön umständlich, und der Vorteil einer reinen Datenpartition ist mir nicht klar.

ich habe daher entschieden, wie schon unter Kubuntu ein großes /home zu machen und die Kiste neu installiert....war ja so gut wie nix drauf bisher, ging daher ratzfatz.

danke aber für die Tipps. ich betrachte den Teil mal als "gelöst"

jetzt ist eigentlich nur offen, ob die automatische Einbindung der NAS-freigaben läuft. im Dateimanager werden sie mir brav angezeigt, wenn ich sie manuell eingebunden habe....aber ob das so bleibt nach Neustarts? da habe ich noch keine Erfahrung.
« Letzte Änderung: 13.07.2014, 11:21:57 von al.bert »