Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.11.2019, 22:13:17

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22836
  • Letzte: Icemann
Statistiken
  • Beiträge insgesamt: 620201
  • Themen insgesamt: 50068
  • Heute online: 698
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  Pae Parameter  (Gelesen 1561 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Pae Parameter
« am: 04.07.2014, 07:24:00 »
Hallo Freunde des gepflegten Grüns,

Linuxmint 17 Mate 32 bit

Frage: Wie bekommt man(frau) dden Bootparameter =forcepae in ein installiertes System

Beim Livesystem ist das kein Problem, aber nach Installation auf Festplatte kommt dann immer No operating System found.
Also wieder Livesystem und auf Festplatte zugegriffenund nachgeschaut. Alles drauf.
Nur starten von Festplatte geht nicht.
Habe die config Datei etc/default/grub die Zeile mit sqietplash um forcepae erweitert und gespeichert.
Ein update-grub wollte ich dann machen. Bekomme aber eine Fehlermeldung:  irgendwas mit canonical path
Kann es im Moment nicht genau schreiben da mit einem anderen Rechner im Netz.
Bitte nun um einen Ansatzpunkt wie man ein update-grub aus einem Livesystem in ein installiertes System bekommt.
Was muß ich da genau im Terminal eingeben?

Gruß aus der Rhön
ullimell

Re: Pae Parameter
« Antwort #1 am: 04.07.2014, 08:00:51 »
Zitat
Bitte nun um einen Ansatzpunkt wie man ein update-grub aus einem Livesystem in ein installiertes System bekommt.
Das geht mit chroot:
sudo mount /dev/sdXY /mnt(XY ersetzen, je nach dem, wo das System installiert ist.)
sudo mount -o bind /dev /mnt/devsudo mount -o bind /sys /mnt/syssudo mount -t proc /proc /mnt/procsudo cp /proc/mounts /mnt/etc/mtabsudo chroot /mnt /bin/bashNun befindet man sich mit dem Terminal als root im installierten Sytem.
update-grubNun die chroot-Umgebung mit
exitverlassen und hoffen, dass der Rechner wieder ohne das Live-System startet.
« Letzte Änderung: 04.07.2014, 08:09:27 von helli »

Re: Pae Parameter
« Antwort #2 am: 04.07.2014, 10:20:59 »
Genauso wie Du beim Live-System den Bootstring mit "forcepae" ergänzt,
kannst Du dies doch auch beim Grub des installierten Systems tun.
[ E ] drücken im Grubfenster, "forcepae" eintippen, starten mit [Strg]+[ X ],
dann im laufenden Mint die /etc/default/grub entsprechend editieren.
Dann sollte es dauerhaft sein.
http://wiki.ubuntuusers.de/Bootoptionen#Optionen-beim-GRUB-Auswahlmenue

Re: Pae Parameter
« Antwort #3 am: 04.07.2014, 10:45:52 »
Zitat
No operating System found.
...hört sich aber so an, als ob das Grub-Menü gar nicht erscheint.
Eventuell müsste vor update-grub Grub erst noch mal in den MBR installiert werden mit:
grub-install /dev/sda
« Letzte Änderung: 05.07.2014, 12:22:58 von helli »

Re: Pae Parameter
« Antwort #4 am: 04.07.2014, 11:31:43 »
Stimmt, die schlechte Meldung habe ich übersehen.
Das deutet auf mehr Fehler hin, als nur Fehlen von "nonpae", denke ich auch.
Also doch nur "Chroot" möglich.
Wo ist der Grub installiert ? Immer wieder gut zu wissen. sudo bash -c "for d in \$(fdisk -l|grep -o \"/dev/[^ :]*\");do case \$(hexdump -v -s 0x80 -n 2 -e '2/1 \"%x\" \"\n\"' \$d) in 'aa75'|'5272') echo \$d: Grub Legacy;;'48b4'|'7c3c'|'020') echo \$d: Grub 2;;*) echo \$d;;esac;done"

Re: Pae Parameter
« Antwort #5 am: 05.07.2014, 07:11:06 »
 helli,

scheitert irgendwie schon am Anfang

mint@mint ~ $ sudo mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy
mint@mint ~ $ sudo mount -o bind /dev /mnt/dev
mount: mount point /mnt/dev does not exist

hi aexe,

siehe Ausgabe
mint@mint ~ $ sudo bash -c "for d in \$(fdisk -l|grep -o \"/dev/[^ :]*\");do case \$(hexdump -v -s 0x80 -n 2 -e '2/1 \"%x\" \"\n\"' \$d) in 'aa75'|'5272') echo \$d: Grub Legacy;;'48b4'|'7c3c'|'020') echo \$d: Grub 2;;*) echo \$d;;esac;done"
/dev/sda: Grub 2
/dev/sda1
/dev/sda2
/dev/sda5

ullimell


MSmint

  • Gast
Re: Pae Parameter
« Antwort #6 am: 05.07.2014, 08:19:50 »
Moin, da ich demnächst vor habe M17XFCE auf meinen T42 zu werfen eine kurze Frage zum Thema "forcepae".

Kurz am PC geschaut:
cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.2.0-65-generic root=UUID=d221304b-fb93-4b9a-9980-33805c3f5790 ro quiet splash vt.handoff=7
Wo kommt diese Zeile letzendlich her?

Weil in /etc/default/grub steht:
GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Dann muß:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"geändert werden in ?:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash forcepae"
Sehe ich das so richtig?

Re: Pae Parameter
« Antwort #7 am: 05.07.2014, 08:22:07 »
@ullimel: Du must die Partition mounten, nicht die ganze ganze Festplatte

@MSmint: Ja, siehst du richtig

MSmint

  • Gast
Re: Pae Parameter
« Antwort #8 am: 05.07.2014, 08:23:39 »
Yupp Danke!  8)

Re: Pae Parameter
« Antwort #9 am: 05.07.2014, 10:13:06 »
Hallo atze,

Frage Welche Partition soll ich denn mounten.

ullimell

Re: Pae Parameter
« Antwort #10 am: 05.07.2014, 11:09:06 »
Die Partition, auf der du Linux installiert hast.

Re: Pae Parameter
« Antwort #11 am: 05.07.2014, 11:09:26 »
Frage Welche Partition soll ich denn mounten.
Die auf der dein Linux installiert ist. Wenn du nicht weißt welche das ist zeig mal
sudo parted -l

Re: Pae Parameter
« Antwort #12 am: 05.07.2014, 12:13:07 »
SIEHE


mint@mint ~ $ sudo parted -l
Model: ATA FUJITSU MHU2100A (scsi)
Disk /dev/sda: 99.9GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  98.9GB  98.9GB  primary   ext4            boot
 2      98.9GB  99.9GB  1072MB  extended
 5      98.9GB  99.9GB  1072MB  logical   linux-swap(v1)


Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Error: Invalid partition table - recursive partition on /dev/sr0.         
Ignore/Cancel?

Re: Pae Parameter
« Antwort #13 am: 05.07.2014, 12:17:07 »
sudo mount /dev/sda1 /mnt...muss der erste Befehl lauten.

Re: Pae Parameter
« Antwort #14 am: 05.07.2014, 13:31:29 »
Hallo an Alle Mitstreiter,

Labtop T42 startet wie es sich für ein Linux gehört.

OS: Linuxmint17 Quiana Mate 32 bit

Vielen Dank für ausführliche Hilfe von

helli,
Marco77,
atze,
aexe.

Ziehe meinen Hut vor Euch und gehe nun zum gemütlichen Teil über.

Werde auf Eure Gesundheit und Hilfe im Freundeskreis eins zwei viele Biere trinken,

Gruß aus der Rhön
ullimell