Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
02.03.2021, 02:51:51

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25330
  • Letzte: s1rv1val
Statistiken
  • Beiträge insgesamt: 719201
  • Themen insgesamt: 58167
  • Heute online: 470
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 2
Gäste: 346
Gesamt: 348

Autor Thema: [gelöst]  zu Windows 8.1, Mint debia über UEFI installieren  (Gelesen 981 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] zu Windows 8.1, Mint debia über UEFI installieren
« am: 27.06.2014, 16:07:48 »
Hallo,

Ich hab auf dem Laptop Windows 8.1 Laufen. Jetzt habe ich Mint Debian installiert, wollte es als parallel Betriebssystem auf dem Laptop haben.

Windows wird über UEFI gebootet. Also wollte ich natürlich Mint auch über UEFI booten lassen.

So sieht das System aussudo blkid
/dev/sda1: LABEL="Windows RE tools" UUID="121A86BF1A869F7B" TYPE="ntfs"
/dev/sda10: LABEL="Daten & Programm" UUID="4B804C5551444662" TYPE="ntfs"
/dev/sda4: LABEL="Windows 8" UUID="B67E6F5A7E6F1283" TYPE="ntfs"
/dev/sda5: UUID="5AD05230D052131D" TYPE="ntfs"
/dev/sda6: UUID="A85A53445A530E86" TYPE="ntfs"
/dev/sda7: LABEL="SAMSUNG_REC2" UUID="3A68AE3C68ADF733" TYPE="ntfs"
/dev/sda8: LABEL="SAMSUNG_REC" UUID="FC91-4D34" TYPE="vfat"
/dev/sda2: LABEL="SYSTEM" UUID="9A21-121D" TYPE="vfat"
/dev/sda9: UUID="1deaf8a7-0885-4f3b-9d8c-b45fe1d9413c" TYPE="ext4"

Auf sda2 ist der UEFI bootloader. Also habe ich grub auch dort installieren lassen.

Jetzt kann ich aber nur Mint starten.

Ich hab bisschen gegoogelt und das hier gefunden
Ich bin noch nicht so sicher mit Linux. Ist es mein Problem?


Ich habe im Efibootmgr folgende Einträge: sudo efibootmgr
BootCurrent: 000A
Timeout: 0 seconds
BootOrder: 000A,0008,000B,0004,0003,0006,0007,0009
Boot0000  Setup
Boot0001  Boot Menu
Boot0002  Recovery
Boot0003* SATA HDD:
Boot0004* SATA CD:
Boot0005* CD-ROM:
Boot0006* USB CD:
Boot0007* USB FDD:
Boot0008* USB HDD:
Boot0009  NETWORK:
Boot000A* linuxmint
Boot000B* Windows Boot Manager

und /etc/default/grub : # If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Muss ich also zum eintrage der Windwos-Option in der grub.cfg den wert eintragen?GRUB_DISTRIBUTOR=`Windows Boot Manager`
--------------------------------------------------------------
davon abgesehen

Kann ich den aktuellen Wert in der grub.cfg von GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian` zu GRUB_DISTRIBUTOR=`linuxmint` ändern, ohne da Mint verloren geht?
--------------------------------------------------------------

Sorry für die vielen Fragen und danke für die Mühe, beim beantworten.


EDIT: Hab jetzt ausprobiert: wenn ich in der Console "sudo efibootmgr --bootnext 000B" eingebe, wird windows geladen. Also muss nur der Eintrag im grub passen. Ich bin mir aber unsicher ob der richtig ist, wie ich es mir denke.
« Letzte Änderung: 27.06.2014, 16:50:56 von Pyccak »

Re: zu Windows 8.1, Mint debia über UEFI installieren
« Antwort #1 am: 27.06.2014, 16:41:50 »
Was willst du überhaupt mit Mint Debian?

Re: zu Windows 8.1, Mint debia über UEFI installieren
« Antwort #2 am: 27.06.2014, 16:50:41 »
ok, ein einfaches "update-grub" hat gereicht. Grub hat dann automatisch Windows erkannt und es für mich eingetragen.

Jetzt habe ich beim rescharschieren über EFI gelesen. Habe ich das richtig verstanden, das EFI eigentlich schon ein Bootloader ist. Sprich habe ich jetzt so das EFI den Grub startet und Grub dann Windows bzw. Linux. Ist doch doppelt gemoppelt.

Kann man über EFI ein Menü bekommen, zur Betriebssystem Auswahl?

Re: zu Windows 8.1, Mint debia über UEFI installieren
« Antwort #3 am: 27.06.2014, 16:53:17 »
Was willst du überhaupt mit Mint Debian?

wieso nicht? Ist doch das selbe wie ubuntu basiertes mint

Re: zu Windows 8.1, Mint debia über UEFI installieren
« Antwort #4 am: 27.06.2014, 17:02:12 »
wieso nicht? Ist doch das selbe wie ubuntu basiertes mint
Nein ist es nicht Mint Debian basiert auf Debian Testing das „normale“ Mint basiert auf der jeweils aktuellen Ubuntu LTS Version.
Mint Debian ist nicht gerade für Einsteiger geeignet. Es ist nicht so stabil, und in eineigen Punkten etwas „komplizierter“ z.B. Installtion.
Ich rate allen Einsteigern zu Linux Mint 17 LTS

Re: zu Windows 8.1, Mint debia über UEFI installieren
« Antwort #5 am: 27.06.2014, 18:57:30 »
das „normale“ Mint basiert auf der jeweils aktuellen Ubuntu LTS Version.
Nein, das gilt so erst ab sofort für die Zukunft. Generell kannst du das nicht so sagen.