Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
29.11.2020, 04:56:35

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24832
  • Letzte: Kowa
Statistiken
  • Beiträge insgesamt: 697313
  • Themen insgesamt: 56434
  • Heute online: 508
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 3
Gäste: 323
Gesamt: 326

Autor Thema:  Boot-Stick Probleme mit UEFI  (Gelesen 3284 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Boot-Stick Probleme mit UEFI
« am: 12.05.2014, 09:30:15 »
Hallo zusammen!

Ich verzweifel langsam, komme einfach nicht weiter. Worum geht’s?

Ich habe mir einen neuen Laptop gekauft (Acer Aspire), diesen extra ohne Betriebssystem bestellt. Plan war, wie bislang auch meinen Altgeräten hier Linux Mint drauf zu ziehen. Hat schon etliche Mal wunderbar funktioniert: Mit Unetbootin einen USB-Stick mit der neuesten Mint Version bestückt und in kürzester Zeit war alles fertig und lief.

Nur bei dem neuen Laptop ging das bislang nicht. Ich sitzt da schon ein paar Tage dran. Das was ich bislang herausgefunden habe: Das Bios sieht aus wie ein Bios, hat aber nur UEFI, lässt sich auch nicht auf Legacy oder irgendetwas anderes umstellen. Da funktionierten meine allerersten Versuche auch so gar nicht, da der Rechner den Stick nicht als bootfähigen Stick erkannte. Und ja, die Bootreihenfolge habe ich selbstverständlich gleich zu beginn entsprechend umgestellt.

Ich habe viel viel im Internet gesucht und gelesen. Neben dem Problem mit dem UEFI fand ich auch raus, dass man auch eine 32-Bit Version nutzen darf. Kein Problem, habe ich eben ne 64er Version drauf gepackt. Auch nichts.

Woanders laß ich, dass es mit Ubuntu besser klappen soll. Ok, habe ich versucht, auch wenn ich ja eigentlich weiter Mint nutzen will. Hier ein kleiner Teilerfolg: Das System erkennt was, bootet und fragt ob Ubuntu getestet oder installiert werden will. WOW! Der Durchbruch? Nein, leider nicht. Egal, was ich da auswähle, danach geht es nicht weiter und der Bildschirm bleibt schwarz.

Lange Rede, kurzer Sinn: Ich brauche eine Anleitung, wie ich einen bootfähigen USB-Stick mit Linux Mint für ein UEFI System erstelle. Die Anleitung am Besten so formuliert, wie man es einem Grundschüler erklären würde, da ich echt nur dummer Anwender bin.

Ich habe wirklich schon viel viel viel gesucht (auch hier im Forum), aber ich habe nichts gefunden, was mich weitergebracht hätte.

Für hilfreiche Tipps schon mal einen großen Dank im Voraus!

Re: Boot-Stick Probleme mit UEFI
« Antwort #1 am: 12.05.2014, 09:33:24 »

Hanuman

  • Gast
Re: Boot-Stick Probleme mit UEFI
« Antwort #2 am: 12.05.2014, 09:41:23 »
Hi,

wenn ich dich richtig verstehe, dann hast du nen 2ten Rechner mit nem LinuxMint zur Verfügung?

Dann starte den mal, installier dir Unetbootin sudo apt-get install unetbootin steck den Stick, den du zum Installieren benutzen möchtest, ein und poste noch die Ausgabe von sudo parted -l ##kleines L.

Von Vorteil wäre noch, wenn die Installationsdaten auch schon auf dem Rechner sind, dann könnten wir das mehr oder weniger in einem Rutsch erledigen.

Zur Kenntnissnahme:

Secureboot muß für Mint ausgeschaltet sein

Es geht nur 64 Bit und bei Mint nur mit Mint 16

Falls du Secureboot nicht ausschalten kannst, geht nur SuSe, Fedora oder *buntu

Re: Boot-Stick Probleme mit UEFI
« Antwort #3 am: 12.05.2014, 10:56:34 »
Ok, einen klitzekleinen Schritt bin ich weiter.

Ich habe mir, wie hier (http://wiki.ubuntu-forum.de/index.php?title=Benutzer:Klaus_P
M
) empfohlen, rufus gezogen. Damit konnte ich anders als mit UNetbootin den Stick besser auf UEFI vorbereiten.

Ich habe dann mit entsprechenden Einstellung in Rufus Linux Mint 16 64 Bit draufgepackt. Und siehe da, es wird tatsächlich gebootet und gefragt, ob Mint gestartet werden soll. Ich höre danach sogar den Startsound "Klingkling", wenn Linux Mint 16 hochgefahren ist. Doch leider bleibt der Bildschirm die ganz Schwarz.

Nochmal zu den Bios Einstellungen: Ja, Secure Boot ist stets ausgeschaltet. Ansonsten habe ich beim Boot-Modus keinerlei Auswahlmöglichkeiten, Fastboot, Legacy oder anderes steht gar nicht erst zur Auswahl, es gibt nur UEFI.

@Hanuman: Auch wenn ich Linux Mint jetzt schon seit ein paar Jahren nutze, gibt es so einige, bei denen ich immer noch so gar keine Ahnung habe. Wo gebe ich diese von dir benannten Befehle mit "sodu" ein?

UNetbootin habe ich über die Softverwaltung installiert.


Re: Boot-Stick Probleme mit UEFI
« Antwort #4 am: 12.05.2014, 11:08:30 »
Das Prob mit dem schwarzen Bildschirm hat mE nichts mehr mit UEFI zu tun, sondern mit der Grafik! Dazu verrät uns dein Post allerdings nichts.

Die Textbefehle sind für das Terminal. Obige haben sich jetzt aber erledigt.
« Letzte Änderung: 12.05.2014, 11:13:28 von toffifee »

Re: Boot-Stick Probleme mit UEFI
« Antwort #5 am: 12.05.2014, 11:27:51 »
"Es könnte so einfach sein, isses aber nicht"   >:(

Ok, das nächste Problem heißt also Grafik *seufz*

Es soll ein Intel HD GPU für die Grafik verantwortlich sein - falls diese Angabe zweckdienlich sein sollte.

Keine Ahnung, was ich jetzt was tun soll?!


Re: Boot-Stick Probleme mit UEFI
« Antwort #6 am: 12.05.2014, 11:33:20 »
Wenn du uns das genaue Laptop Modell mal verraten würdest, wäre das hilfreicher als ein "soll"...  ;)

Re: Boot-Stick Probleme mit UEFI
« Antwort #7 am: 12.05.2014, 11:40:57 »
Das krieg ich hin.
Und zwar handelt es sich um ein Acer Aspire E1-510-35204G50MNKK.

Re: Boot-Stick Probleme mit UEFI
« Antwort #8 am: 12.05.2014, 11:48:24 »
Das ist doch einer dieser neuen lahmen Atom-basierenden Billig-Prozessoren von Intel.
Falls du Cinnamon hast, könnte es da ein Problem mit der 3D-Grafik geben. Mal Mate probieren stattdessen und beim Starten die Bootoption nomodeset angeben.
Möglicherweise unterstützt der neue Kernel in LM 17 diese CPU besser.

Re: Boot-Stick Probleme mit UEFI
« Antwort #9 am: 12.05.2014, 12:08:57 »
Billig steh ich drauf  ;-) 
Ich brauche in der Regel nicht mehr, als eine bessere internetfähige Schreibmaschine.

Ok, dann werde ich nachher in einer ruhigen Minute mir mal Mate holen und auf den Stick ziehen.

Wie und wo ich dann genau "nomodeset" angeben soll, habe ich nicht ganz verstanden. Vielleicht ergibt sich mir die Erkenntnis während des Boot-Vorgangs.

Dass Linux Mint 17 vielleicht Abhilfe schafft, war auch schon meine geheime Hoffnung, allerdings will ich den neuen Rechner  nicht so lange in der Ecke stehen lassen.

Re: Boot-Stick Probleme mit UEFI
« Antwort #10 am: 12.05.2014, 12:15:31 »
Hi CptKiosk,
guck hier:
http://wiki.ubuntuusers.de/Bootoptionen
lg
limi12

Re: Boot-Stick Probleme mit UEFI
« Antwort #11 am: 12.05.2014, 12:22:25 »
Dass Linux Mint 17 vielleicht Abhilfe schafft, war auch schon meine geheime Hoffnung, allerdings will ich den neuen Rechner  nicht so lange in der Ecke stehen lassen.
Die ersten RCs von LM 17 müssten dieser Tage langsam raus kommen, Ende Mai soll schon die Final da sein.

Re: Boot-Stick Probleme mit UEFI
« Antwort #12 am: 13.05.2014, 17:48:09 »
So, da bin ich wieder.

Ich habe also Linux Mint 16 64 Bit Mate auf den Stick installiert, habe mich in die Beschreibung für Bootoptionen eingelesen, habe es tatsächlich geschafft dort hinzugelangen, wo die entsprechende Zeile mit 'nomodeset' ergänzt wird.

Und siehe da, beim anschließenden Booten sehe tatsächlich das grüne Linux Mint Logo. Doch Millisekunden bevor ich zu Freudensprüngen ansetze, erscheint ein hellblauer Bildschirm mit einer Fehlermeldung:

"Failed to start the x server (your graphical interface). It is likely that it is not set up correctly."

Die angebotene Diagnose beschreibt einen 'Fatal server error: no screens found' beim Laden der extension GLX

Zudem werde ich an doe X.Org Foundation verwiesen und aufgefordert 'Please check also the log file at "/var/log/xorg.0.log" für addition'

Schließlich bekomme ich noch den 'detailed x server output' zu sehen. Da hier seeeehr viel steht, spare ich mir erstmal das abtippen, da ich nicht weiß, welche Info hier von Nutzen sein könnte.

Mein Fazit bis hier:  HÄH?!

Re: Boot-Stick Probleme mit UEFI
« Antwort #13 am: 13.05.2014, 17:57:34 »
Dann wird deine Grafik erstmal nicht richtig erkannt.
Versuche mal zusätzlich zu nomodeset die Option "xforcevesa".

Re: Boot-Stick Probleme mit UEFI
« Antwort #14 am: 13.05.2014, 18:02:24 »
Wo gebe ich das ein?

edit: wie gebe ich das ein? mit Leerzeichen nach nomodeset oder wie?
« Letzte Änderung: 13.05.2014, 18:08:06 von CptKiosk »

 

1. Advent
1. Advent