Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
15.09.2019, 20:56:20

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22538
  • Letzte: Kenobi
Statistiken
  • Beiträge insgesamt: 607923
  • Themen insgesamt: 49200
  • Heute online: 573
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  USB-Laufwerk wird als Nicht-Admin-User (manchmal) nicht richtig erkannt  (Gelesen 3322 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Beim Zugriff auf eine USB-Festplatte mit Nemo bekomme ich die Fehlermeldung:

Zitat
Konnte >>/media/lxuser/TOSHIBA EXT<< ncith anzeigen
Der Angegebene Ort ist kein Ordner.

Wenn ich das gleiche als admin versuche:

su admin
sudo nemo

geht es.

Der Fehler tritt auch nicht immer auf, habe also auch schonmal
als NIcht-Admin-User auf die Daten zugreifen kännen.

Das USB-Laufwerk wird generell automatisch erkannt.

Vielen Dank für Hilfe!
« Letzte Änderung: 23.02.2014, 16:16:13 von RaMint4 »

Habe gerade festegestelt, dass ähnliche Fehlermeldungen auch bei
CD-Laufwerk und USB-Stick kommen.

Mint Version? Desktop? IMMER angeben!

Auch bitte zeigen:
ls -la /homeund
ls -la /media

Version:
Linux Mint 16 Petra

Zitat
ls -la /home
insgesamt 28
drwxr-xr-x  7 root   root   4096 Feb 21 11:28 .
drwxr-xr-x 23 root   root   4096 Feb 22 22:45 ..
drwxr-xr-x 21 admin  admin  4096 Feb 22 09:48 admin
drwxr-xr-x 36 lxuser lxuser 4096 Feb 23 08:23 lxuser
drwxr-xr-x 25 prax   prax   4096 Feb 21 11:30 prax
drwxr-xr-x 31 std    std    4096 Feb 23 08:23 std
drwxr-xr-x 20 www    www    4096 Feb 21 19:07 www

Zitat
ls -la /media
insgesamt 20
drwxr-xr-x   5 root root 4096 Feb 21 11:20 .
drwxr-xr-x  23 root root 4096 Feb 22 22:45 ..
drwxr-x---+  5 root root 4096 Feb 23 08:20 lxuser
drwxr-x---+  2 root root 4096 Feb 20 22:54 prax
drwxr-x---+  2 root root 4096 Feb 23 08:20 std

möchte noch mal darauf hinweisen :
"su" öffnet ein  Root-Terminal, erkennbar am Zeichen "#" vor dem Prompt.
Benötigt in der Folge kein sudo. Alle weiteren Eingaben werden ohnehin als ROOT ausgeführt.
Bis zum "exit" Kommando.

"sudo" einem Befehl vorangestellt, führt nur diesen mit Root-Recht aus.

Das ist ein Unterschied, den man beachten sollte, wenn man sich die Rechte nicht verdrehen will.
In der Regel reicht "sudo" , "su" ist nur sehr selten erforderlich.
pm@T400 ~ $ su
Passwort:
T400 pm # exit
exit
pm@T400 ~ $ sudo fdisk -l
[sudo] password for pm:
....
Auch ein User "admin" ist in der Regel überflüssig, denn der Hauptnutzer (der als erster angelegt wurde) hat dieses "admin"=root-Recht bei Bedarf bereits mit "sudo" zur Verfügung.
Ein Root-Terminal zu öffnen geht auch mit
sudo -iAlle weiteren Eingaben werden dann als Root ausgeführt, ist praktisch, wenn größere Admin-Aktionen anstehen und man nicht vor jedem Befehl "sudo" eintippen will.

Um grafische Anwendungen (zB nemo) mit Rootrecht auszuführen, soll
"gksudo" verwendet werden
« Letzte Änderung: 23.02.2014, 10:55:21 von aexe »

Die Ordner in media sollten m.E. in diesem Fall nicht root gehören.
Mach zum Beispiel mal

sudo chmod 775 /media/lxuserSiehe
http://askubuntu.com/questions/204119/mount-issue-in-ubuntu-12-10/204226#204226
« Letzte Änderung: 23.02.2014, 10:57:34 von leonidas »

Hier gehört /media auch komplett Root und alles funktioniert.
ls -la /media
insgesamt 28
drwxr-xr-x   7 root root 4096 Feb  8 22:51 .
drwxr-xr-x  25 root root 4096 Jan  6 09:50 ..
drwxr-xr-x   2 root root 4096 Feb  8 22:45 Ablage
lrwxrwxrwx   1 root root    6 Dez 20  2012 cdrom -> cdrom0
drwxr-xr-x   2 root root 4096 Dez 20  2012 cdrom0
drwxr-xr-x   2 root root 4096 Feb  8 22:44 Daten
drwxr-x---+  3 root root 4096 Feb 22 17:20 heinz
lrwxrwxrwx   1 root root    4 Dez 20  2012 usb -> usb0
drwxr-xr-x   2 root root 4096 Dez 20  2012 usb0

Aber gibt es bei Dir mehrere Benutzer?
Dadurch entsteht anscheinend das Problem, siehe Link, den ich oben noch hinzugefügt habe. Und bei ihm gibt es ja mehrere.

Nee hier gibt es  nur einen Benutzer.
Da es beim TE aber nur manchmal passiert, wird es daran nicht liegen, die Rechte verstellen sich ja nicht von selbst.
Schon gar nicht nur manchmal.

Verstellen tun sie die nicht, aber das ist auch nicht die Frage. Wir wissen nämlich nichts genaues darüber, was er da gemacht hat, und ob er vielleicht das Ding als ein User gemountet hat, sich dann als ein anderer angemeldet hat und dann zugreifen will. Dann würde nämlich diese Meldung kommen, und dem wäre dann abzuhelfen durch etwa
sudo chmod 775 /media/lxuser
Wenn er hingegen sich als ein User anmeldet und dann einfach zugriffe, würde es eben normal gehen.
Steht alles in dem Link oben. Und es ist durchaus so wahrscheinlich, dass es sich bei ihm um diese Sachlage handelt, dass es wert ist, es zu probieren.
« Letzte Änderung: 23.02.2014, 10:54:56 von leonidas »

Doc, bei Deiner Ausgabe handelt es sich auch um kein neueres Mint, da kommt nämlich bei media erstmal /*user* und in dem Verzeichnis befinden sich dann die "Medien".
Allerdings hat der TE offenbar keines in Gebrauch??
Das sollte schon geklärt werden, es lesen ja auch andere und die Mehrzahl wird LinuxMint verwenden.

Edit: Tippfehler korrigiert "eines" statt "keines"
« Letzte Änderung: 23.02.2014, 11:25:19 von aexe »

Doch, hat er
Version:
Linux Mint 16 Petra
Verstehe auch nicht ganz, was Du da jetzt meinst.

Die Laufwerke habe ich bisher gar nicht selbst gemountet.
Die werden bei meiner Installationsversion anscheinend immer automatisch erkannt.

Wieso gehört das CD-Laufwerk root?

Wenn ich mich erst als std anmelden würde,
und dann das USB-Laufwerk verbinde,
gehört es dann std?

Es enthält Windows-erstellte Dateien, deswegen
kann der Besitzer eigentlich gar nicht root sein,
sondern nur beim mounten auf root gesetzt worden sein,
oder?

Auch hier gibt es /media/benutzer.
drwxr-x---+  3 root root 4096 Feb 22 17:20 heinz