Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.02.2021, 23:51:25

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25306
  • Letzte: phase0
Statistiken
  • Beiträge insgesamt: 718317
  • Themen insgesamt: 58098
  • Heute online: 654
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Mauszeiger klickt automatisch - wie Abstellen?  (Gelesen 6067 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Mauszeiger klickt automatisch - wie Abstellen?
« am: 14.05.2013, 21:57:27 »
Hallo, 

seit einiger Zeit gibt es ein neues Mauszeiger-Verhalten:
Nach einer Bewegung läuft er von oben nach unten grün an und klickt automatisch. Bei sehr faulem Internetsurfen wirkt das manchmal ein bißchen schick, aber beim Bedienen eines Programms oder irgendetwas Anspruchsvollerem ist es sehr ärgerlich bis gefährlich (zB beim Onlinebanking... ein falscher Klick... Oder ein wichtiges Fenster wird ohne es zu wollen geschlossen wenn der Cursor an die falsche Stelle kommt usw...)
Oder jetzt beim Schreiben wenn ich an die Stelle im Text klicke in die ich schreiben will und der Cursor verrutscht und springt an eine falsche Stelle.
Nein ich muß mich korrigieren:
Es ist nicht ein bißchen "schick", es nervt mich zu Tode! Wie kann ich das Abstellen??
Kann so nur mit Mühe einen Text schreiben stelle ich auch gerade fest..

Viele Grüße semreH

Nutze Mint Maya Cinnamon 64 Bit, Kernel 3.2.0-41 und Backports.
« Letzte Änderung: 12.02.2021, 16:40:34 von toffifee »

triborn

  • Gast
Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #1 am: 14.05.2013, 22:06:28 »
Nach einer Bewegung läuft er von oben nach unten grün an und klickt automatisch.

Sowas hab ich noch nie gehört. Würde glatt auf eine Infektion tippen, sofern es das gibt.

Schonmal eine andere Maus ausprobiert? Vieleicht liegt es ja nicht an Mint.

Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #2 am: 14.05.2013, 22:26:06 »

Sowas hab ich noch nie gehört. Würde glatt auf eine Infektion tippen, sofern es das gibt.
Schonmal eine andere Maus ausprobiert? Vieleicht liegt es ja nicht an Mint.

Ist auf einem Laptop mit Touchpad.
So was wie eine "Infektion" könnte ich mir höchstens vorstellen wenn es nur im Firefox wäre - aber der Mauszeiger verhält sich überall identisch.
Das "Grün anlaufen" hört sich vielleicht komisch an, aber es ist das typische Mintgrün und sieht nach Cinnamon-Effekt und auch nicht wie ein Bug aus.
« Letzte Änderung: 14.05.2013, 22:30:21 von semreH »

Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #3 am: 14.05.2013, 22:31:07 »
Touchpad....... das kenn ich, fast jedenfalls.
je nachdem wie nahe ich dem touchpad mit Teilen der Hand komme beim tippen, "klickt" es an irgendeiner Stelle.
Kannst Du das "tipp-klick" oder wie man das nennt abstellen? Also das klicken mit dem Finger anstatt der Taste?
Seit ich ein anderes Teil habe bei dem die Position des touchpads anderswo ist hab ich das Problem kaum noch.

Das mit dem grün..... seltsam...

Vielleicht mal alle Mauszeigereffekte abstellen falls vorhanden?

Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #4 am: 14.05.2013, 22:40:56 »
Man kann eine Region des Touchpads festlegen auf der die clicks nicht erkannt werden. Ich habe das selbe bei meiner Schwester auf dem Laptop so eingerichtet, das nur noch der Bereich dafür verwendet wird, der auch dafür vorgesehen ist.

Leider weiß ich gerade nicht mehr genau wie das geht, ich werde aber danach suchen und es hier dann posten.

Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #5 am: 14.05.2013, 22:42:54 »
Ich hatte zuerst auch gedacht es wäre das Touchpad.
Es fühlt sich ähnlich wie ein hoch-übersensibles Touchpad an, aber das ist es nicht. Ich kann den Mauszeiger normal bewegen, bleibe stehen - dann kommt sofort der "Mintgrün-Anlaufen"-Effekt. Unabhängig davon ob der Finger noch auf dem Touchpad liegt oder nicht. Dann ist der Pfeil wieder weiß und damit hat der Cursor/Mauszeiger eine Linksklick bzw. Fingertipp auf das Touchpad ausgeführt. Ein bißchen wie ein GIF. Übrigens stellt sich immer klarer raus - ein Katastrophe für das Schreiben und Editieren von Texten!

lupu

  • Gast
Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #6 am: 14.05.2013, 22:48:09 »
Man könnte auch einfach mal versuchsweise in den Einstellungen für Maus und Touchpad das Klicken per Tippen abstellen.
Das Touchpad hat doch auch Tasten mit denen man klicken kann.
Oder hab ich was falsch verstanden?
Für diffizile Einstellungen des Touchpads gibt es in den Repos irgendein synaptics-util Paket dafür

Edit: gpointing-device-settings hab ich gemeint
« Letzte Änderung: 14.05.2013, 22:52:07 von lupu »

Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #7 am: 14.05.2013, 22:58:09 »
Kannst Du das "tipp-klick" oder wie man das nennt abstellen? Also das klicken mit dem Finger anstatt der Taste?

Vielleicht mal alle Mauszeigereffekte abstellen falls vorhanden?

Habe gerade unter "Maus und Touchpad" bei Touchpad den Haken bei "Mausklicks per Touchpad freischalten" entfernt. Keine Änderung außer daß das Touchpad eben nicht mehr auf Tipps reagiert.

Wo lassen sich Mauszeigereffekte abstellen? Das wäre eine heiße Spur vielleicht habe aber nicht herausgefunden ob/wo das geht.


Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #8 am: 14.05.2013, 23:03:20 »
Sodele habe hier jetzt mal den Lappi vor Ort, also erst mal habe ich das Touchpad beim Tippen deaktiviert, das kann man in den "Maus und Touchpad" Einstellungen ändern.

Damit solltest du zumindest beim Tippen keine Probleme mehr haben.

Ansonsten habe ich noch eingestellt das er den rechten Button nur unten Rechts auf dem dafür vorgesehen button nutzt, falls das von Interesse sein sollte, dann unter /etc/X11/xorg.conf.d/ die Datei 51-synaptics.conf erstellen und folgendes Eintragen:
Section "InputClass"
Identifier "Default clickpad buttons"
MatchDriver "synaptics"
Option "SoftButtonAreas"  "50% 0 82% 0 0 0 0 0"
EndSection

Weitere Informationen dazu: https://wiki.archlinux.org/index.php/Touchpad_Synaptics

Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #9 am: 14.05.2013, 23:14:26 »
Hallo NeXxGeN,

Sodele habe hier jetzt mal den Lappi vor Ort, also erst mal habe ich das Touchpad beim Tippen deaktiviert, das kann man in den "Maus und Touchpad" Einstellungen ändern.

Damit solltest du zumindest beim Tippen keine Probleme mehr haben.


Auch das Touchpad beim Tippen deaktivieren ist eingestellt und bewirkt keine Veränderung.
Wenn ich zB einen Text markieren will muß ich draufbleiben und links gedrückt halten andernfalls ist nichts mehr markiert wenn ich zB auf Entf drücke. Weil der ruhende Cursor einen Klick ausführt wenn ich ihn nach dem Markieren auch nur ein bißchen bewege.

Das Touchpad selbst verhält sich eigentlich wie immer.
Ich denke es hat mit dem Mauszeiger zu tun. Gibt es da keine Einstellungsmöglichkeiten?! Kann ich mir fast nicht vorstellen...
« Letzte Änderung: 14.05.2013, 23:35:12 von semreH »

triborn

  • Gast
Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #10 am: 15.05.2013, 10:25:47 »
Mich würde interessieren ob er das bei der Live CD auch macht. Ist zwar keine Lösung, aber... wie auch immer...

Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #11 am: 15.05.2013, 20:45:02 »
Das Verrückte ist:
Heute ist der Effekt vollkommen verschwunden. Habe aber von meiner Frau die Bestätigung daß ihr das auch aufgefallen war (sie hatte das Gerät die letzte Zeit benutzt). Habe Updates gemacht, aber schon gestern als das noch aufgetreten ist. Vielleicht war das Runterfahren nötig?! Hatte glaube ich zwischendrin sogar einen Neustart drin ohne daß das Grünfärben mit Klick ausführen verschwunden wäre.

Sehr rätselhaft was das war. Vielleicht irgendein versehentlich ausgelöster Shortcut zu dieser versteckten Funktion?! Einstellung zum Mauszeiger scheint es ja tatsächlich nicht zu geben.
Eventuell ein Gnome-Feature, daß bei Cinnamon abgestellt ist aber irgendwie doch aktiv war?!
Optisch gut integriert mit dem gleichen Mintgrün wie beim Textmarkieren beim "Anlaufen" und ungewollten Klick. Merkwürdig.

Jedenfalls wenn jemand das Phänomen auch kennt oder noch eine Idee hat, BITTE schriebt hier kurz rein, auch wenn ihr ebenfalls keine Ahnung habt was das ist...

Danke für Eure Antworten!
Grüße semreH


EDIT:
Zu früh gefreut. Als ich einen Java (Iced Tea)-Schach-Client aufgerufen habe war das grüne Anlaufen des Mauszeigers mit automatischem Klick wieder da. :-( Ob das Zufall war oder durch Java ausgelöst wurde weiß ich nicht.

Runterfahren und neu einschalten: Keine Änderung.
Neustart mit älterem Kernel 3.2.0-39: Keine Änderung.
Nochmaliger Neustart mit Kernel 3.2.0-41: Alles wieder in Ordnung!
Aufrufen des Java (Iced Tea)-Clients: Immer noch alles in Ordnung.

Ich tippe auf einen Cinnamon/Gnome-Bug der scheinbar willkürlich auftritt.

« Letzte Änderung: 15.05.2013, 23:41:47 von semreH »

javac

  • Gast
Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #12 am: 16.05.2013, 00:13:17 »
... Heute ist der Effekt vollkommen verschwunden ...
... Habe Updates gemacht, aber schon gestern ...
Runterfahren und neu einschalten: Keine Änderung.
Neustart mit älterem Kernel 3.2.0-39: Keine Änderung.
Nochmaliger Neustart mit Kernel 3.2.0-41: Alles wieder in Ordnung ...
... Ich tippe auf einen Cinnamon/Gnome-Bug der scheinbar willkürlich auftritt.
Ich tippe, dass sich manchmal alte Pakete mit neuen Kernel nicht vertragen und umgekehrt.

Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #13 am: 23.05.2013, 23:07:52 »
Also zur Dokumentation:
Der Bug tritt unregelmäßig, aber relativ häufig und meistens gleich nach dem Start auf. Manchmal ist ohne mein Zutun gleich nach dem Start dieses Fenster auf (siehe Anhang).
"Überfahrklick (Hover-Klick)" und 4 Optionen, leider ohne Deaktivieren.

Unter Ubuntu kann (konnte?) man diesen Überfahrklick anscheinend unter "Barrierefreiheit" aktivieren bzw deaktivieren. Bei Cinnamon gibt es diese Möglichkeit nicht. Sieht irgendwie so aus als ob eine in Cinnamon unterdrückte Gnome-Funktion manchmal fehlerhaft zum Vorschein kommt, oder?!

Gibt es in Cinnamon irgendwo die Möglichkeit, einen "Überfahrklick" ein bzw. auszuschalten?

Grüße semreH

Re: Mauszeiger klickt automatisch - wie Abstellen?
« Antwort #14 am: 20.05.2020, 10:21:25 »
Gibt es in Cinnamon irgendwo die Möglichkeit, einen "Überfahrklick" ein bzw. auszuschalten?

Im Jahre 2020, war ich temporär auch von dieser extrem lästigen Fehlererscheinung betroffen.

Bei mir ließ sie sich nach zwei Tagen Suche, wie folgt wieder los werden:

Unter:
Programm Einstellungen Barrierefreiheit Maus

War folgender lästiger Punkt aktiviert:
Darübebewegenklick

Wie ich zu dieser extrem lästigen Einstellung, in einem meiner Meinung nach vorher nie zuvor besuchtem Menü gekommen bin, ließ sich bisher nicht nach vollziehen.
« Letzte Änderung: 20.05.2020, 10:31:56 von John.Miller »