Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
20.04.2019, 12:41:57

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21855
  • Letzte: Margit
Statistiken
  • Beiträge insgesamt: 585290
  • Themen insgesamt: 47371
  • Heute online: 303
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  Startbildschirm bleibt dunkel  (Gelesen 1217 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Startbildschirm bleibt dunkel
« am: 10.03.2018, 08:34:45 »
Mint 18.2 - 64 - KDE
Dell Precision M4600 Laptop (mobile Workstation)
Baujahr 2011, Intel i5-2520M 2.50GHz, 8GB, Grafikkarte NVIDiA Quadro 1000M
vollverschlüsselte SSD


Hallo ihr Lieben,

habe vorhin den Laptop gewohnt gestartet und war entsetzt als der Monitor dunkel blieb.  :o
Normalerweise bekomme ich zunächst die Passwortabfrage zur Entschluesselung des Laufwerks.

Den PC also aus- und wieder angeschaltet.

Es erschien ein Menü mit Recovery Möglichkeit.
Unter der Recovery Option folgt eine Liste verschiedener, wohl bis jetzt installierter Linux Kernel.
Ich musste ein wenig probieren um den richtigen zu finden, aber darueber liess sich das System dann starten.

Problem: Der PC lässt sich nunmehr nur noch auf diese Weise hochfahren.
1. Erststart gefolgt von dunklem Monitor
2. Neustart und Weiterleitung zur Recovery Auswahl

Abhilfe: ??

Ich bedanke mich schonmal im Vorraus. :)

Edit:
Was mir gerade noch auffällt ist, dass das System erheblich verlangsamt ist.
Normal ist eine FPS-Rate von etwa 40, aktuell sind es aber höchstens 10.
Was ist da nun geschehen, und wie kann man den alten Zustand wieder herstellen?
« Letzte Änderung: 12.03.2018, 23:59:11 von thurnus »

Re: Startbildschirm bleibt dunkel
« Antwort #1 am: 10.03.2018, 09:16:42 »
Ich würde alle Kernel die neuer sind als der mit dem er startet löschen.

Re: Startbildschirm bleibt dunkel
« Antwort #2 am: 10.03.2018, 09:24:48 »
Gestartet habe ich wohl den letzten Kernel in der Liste (irgendwas mit ".53"). Und das ist wohl auch der Neueste (wenn aufsteigende Nummern dies aussagen). - Einen Neueren löschen kann ich also wohl nicht.

BTW: Wie löscht man einen Kernel?

Die Performace-Einschränkung ist am gravierendsten. :(

Re: Startbildschirm bleibt dunkel
« Antwort #3 am: 10.03.2018, 09:30:04 »
Aktualiesierungsverwaltung --> Anzeige --> Linux-Kernel

Re: Startbildschirm bleibt dunkel
« Antwort #4 am: 10.03.2018, 10:26:13 »
Sodele. :)

Die neusten installierten Kernels sind
4.13.0-32 und 4.13.0-36
Mit Beiden gibt es beim Neustart Kernelpanik

Mit dem 4.13.0-31 hingegen läuft es. Damit gibt es auch keine Performance-Probleme mehr. :)

Allerdings bleibt beim Erststart nach wie vor der Bildschirm dunkel.
Das Problem hierbei könnten also die nachinstallierten Kernels (4.13.0-32 und 4.13.0-36) sein, nach deren Löschung der PC wieder normal startet?

« Letzte Änderung: 10.03.2018, 11:14:56 von thurnus »

Re: Startbildschirm bleibt dunkel
« Antwort #5 am: 10.03.2018, 11:15:47 »
Ich vergewissere mich lieber nochmal, bevor ich irgendetwas Falsches mache.
Das fehlte mir noch, dass das ganze System unbrauchbar wird...
Bitte also nochmal bestätigen, ob eine Löschung der nachfolgende Kernels keine anderen Probleme verursacht.
Danke. :)

Re: Startbildschirm bleibt dunkel
« Antwort #6 am: 10.03.2018, 11:42:15 »
Das Problem hierbei könnten also die nachinstallierten Kernels (4.13.0-32 und 4.13.0-36) sein, nach deren Löschung der PC wieder normal startet?
Das Entfernen inaktiver Kernel hat logischerweise keine Auswirkungen auf das System, dürfte also das Problem nicht lösen.

Re: Startbildschirm bleibt dunkel
« Antwort #7 am: 10.03.2018, 11:53:40 »
Das Problem hierbei könnten also die nachinstallierten Kernels (4.13.0-32 und 4.13.0-36) sein, nach deren Löschung der PC wieder normal startet?
Das Entfernen inaktiver Kernel hat logischerweise keine Auswirkungen auf das System, dürfte also das Problem nicht lösen.

Ja, so denke ich mir das nämlich auch.

Aber wie kommt man dem Problem auf die Schliche?
Gibt es irgendeine Diagnosetool welches das System checkt?

Re: Startbildschirm bleibt dunkel
« Antwort #8 am: 10.03.2018, 11:57:24 »
Es gibt eine ganze Reihe von Diagnosetools. Das übersichtlichste ist der Terminal-Befehl
Zitat
inxi -F
Damit werden sehr viele Hardware-Eigenschaften angezeigt, und man kann auch Hinweise auf fehlende oder fehlerhafte Treiber ableiten.

Re: Startbildschirm bleibt dunkel
« Antwort #9 am: 10.03.2018, 13:35:20 »
Danke, TomS.

Hier die Ausgabe. - Ich sehe da nichts Verdächtiges, oder?
luna@M4600 ~ $ inxi -F
System:    Host: M4600 Kernel: 4.13.0-31-generic x86_64 (64 bit) Desktop: KDE Plasma 5.8.8
           Distro: Linux Mint 18.2 Sonya
Machine:   System: Dell (portable) product: Precision M4600 v: 01
           Mobo: Dell model: 08V9YG v: A00 Bios: Dell v: A17 date: 05/12/2017
CPU:       Dual core Intel Core i5-2520M (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 3200 MHz 1: 2494 MHz 2: 2494 MHz 3: 2494 MHz 4: 2494 MHz
Graphics:  Card: NVIDIA GF108GLM [Quadro 1000M]
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.91hz, 1920x1080@59.93hz
           GLX Renderer: NVC1 GLX Version: 3.0 Mesa 17.2.8
Audio:     Card-1 NVIDIA GF108 High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-31-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: eno1 state: down mac: d0:67:e5:3c:43:dc
           Card-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi
           IF: wlp3s0 state: up mac: 24:77:03:23:c3:7c
Drives:    HDD Total Size: 250.1GB (29.3% used) ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB
Partition: ID-1: / size: 221G used: 61G (29%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 472M used: 444M (100%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 8.54GB used: 0.00GB (0%) fs: swap dev: /dev/dm-2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 65.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 204 Uptime: 3:13 Memory: 3030.6/7932.7MB Client: Shell (bash) inxi: 2.2.35

Re: Startbildschirm bleibt dunkel
« Antwort #10 am: 10.03.2018, 14:09:08 »
Laufen tut "nur" der Nouveau-Treiber.
Was ist per Treiberverwaltung installert?

dpkg -l | grep nvidialspci -nnk | grep -i VGA -A2

Re: Startbildschirm bleibt dunkel
« Antwort #11 am: 10.03.2018, 14:11:12 »
Zitat
Graphics:  Card: NVIDIA GF108GLM [Quadro 1000M]
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.91hz, 1920x1080@59.93hz
           GLX Renderer: NVC1 GLX Version: 3.0 Mesa 17.2.8

Da ist der falsche Grafiktreiber geladen. Das erklärt zwar nicht den schwarzen Startbildschirm, sollte aber trotzdem geändert werden. Dazu in der Treiberverwaltung den empfohlenen NVidia-Treiber auswählen, rebooten und schauen, was passiert.

Ich vermute auch, dass die Probleme vom 4.13 Kernel kommen. Ich würde den neuesten Kernel der 4.4-Linie testen, ob sich dann was verbessert.

Re: Startbildschirm bleibt dunkel
« Antwort #12 am: 10.03.2018, 15:16:40 »
Anmerkung: vor solchen Änderungen empfiehlt es sich, das System mit TimeShift zu sichern. Sollte was schiefgehen, kann man so in wenigen Minuten den alten Zustand wieder herstellen.

Re: Startbildschirm bleibt dunkel
« Antwort #13 am: 10.03.2018, 19:28:51 »
Laufen tut "nur" der Nouveau-Treiber.
Was ist per Treiberverwaltung installert?

dpkg -l | grep nvidialspci -nnk | grep -i VGA -A2

luna@M4600 ~ $ dpkg -l | grep nvidia
iF  nvidia-384                                      384.111-0ubuntu0.16.04.1                                 amd64        NVIDIA binary driver - version 384.111
iU  nvidia-opencl-icd-384                           384.111-0ubuntu0.16.04.1                                 amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                                    0.8.2linuxmint1                                          amd64        Tools to enable NVIDIA's Prime
ii  nvidia-prime-applet                             1.0.6                                                    all          An applet for NVIDIA Prime
ii  nvidia-settings                                 361.42-0ubuntu1                                          amd64        Tool for configuring the NVIDIA graphics driver

luna@M4600 ~ $ lspci -nnk | grep -i VGA -A2
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108GLM [Quadro 1000M] [10de:0dfa] (rev a1)
        Subsystem: Dell GF108GLM [Quadro 1000M] [1028:04a3]
        Kernel driver in use: nouveau

Zitat
Graphics:  Card: NVIDIA GF108GLM [Quadro 1000M]
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.91hz, 1920x1080@59.93hz
           GLX Renderer: NVC1 GLX Version: 3.0 Mesa 17.2.8

Da ist der falsche Grafiktreiber geladen. Das erklärt zwar nicht den schwarzen Startbildschirm, sollte aber trotzdem geändert werden. Dazu in der Treiberverwaltung den empfohlenen NVidia-Treiber auswählen, rebooten und schauen, was passiert.

Ich vermute auch, dass die Probleme vom 4.13 Kernel kommen. Ich würde den neuesten Kernel der 4.4-Linie testen, ob sich dann was verbessert.

In der Treiberverwaltung ist der empfohlene NVidia-Treiber (nvidia-384 384.111-0ubuntu0.16.04.1) bereits installiert.
Keine Ahnung warum inxi -F da etwas anderes ausgibt.

Bis gestern lief noch alles einwandfrei.
Gestern noch ein Update eingespielt. Was genau es war weiss ich aber nicht mehr, jedenfalls nichts systemkritisches.

Die 4.4 Kernel Linie wird in meiner Kernel Liste nicht angezeigt.

Danke fuer den Tip mit "Timeshift". :)

Re: Startbildschirm bleibt dunkel
« Antwort #14 am: 10.03.2018, 19:54:30 »
Zitat
In der Treiberverwaltung ist der empfohlene NVidia-Treiber (nvidia-384 384.111-0ubuntu0.16.04.1) bereits installiert.
Keine Ahnung warum inxi -F da etwas anderes ausgibt.

Ging mir und 1000 anderen genauso. Die etwas hektischen Updates nach den jüngst bekannt gewordenen Angriffen durch Meltdown und Spectre haben auf allen Betriebssystemen für sehr chaotische Verhältnisse gesorgt :)

Versuch mal Folgendes (ohne Erfolgsgarantie!):

- mit TimeShift das aktuelle System sichern
- in der Treiberverwaltung wählst Du "xserver-xorg-video-noveau" als Treiber (falls nicht vorhanden: abbrechen, hier nochmal fragen :) )
- neu booten
- in der Aktualisierungs-Verwaltung auf Anzeigen -> Linux Kernel
- auf 4.4 klicken
- den neuesten Kernel installieren  (sollte gerade 4.4.0-116 sein)
- Neustart
- in der Treiberverwaltung den empfohlenen Nvidia-Treiber auswählen. Reboot
- wenn das System ohne schwarzen Bildschirm startet: inxi -Fz hier posten. Falls nicht: dann müssen wir uns was anderes überlegen :) :) :)