Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
22.07.2019, 14:18:45

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22272
  • Letzte: WS_2019
Statistiken
  • Beiträge insgesamt: 599570
  • Themen insgesamt: 48563
  • Heute online: 566
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  Shift + PrintScreen via "gnome-screenshot" funktioniert nur einmal  (Gelesen 2353 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Zitat
Linux Mint 17.3 Cinnamon 64-bit

Hallo zusammen

Ich nutze das Programm "gnome-screenshot", um Screenshots zu erstellen. Es beinhaltet u.a. folgende Möglichkeiten:

1) Shift + Print-Screen = PrintScreen des gewünschten Bildausschnitts mit Speicherung in einem beliebigen Ordner
2) Control + Print-Screen = PrintScreen des aktuellen Fensterns ohne Taskleiste mit Speicherung in einem beliebigen Ordner
3) PrintScreen = PrintScreen des gesamten Bildschirms mit Speicherung in einem beliebigen Ordner

Variaten (2) und (3) funktionieren einwandfrei, mit (1) habe ich jedoch Probleme. Und zwar kann ich die Funktion nach einem GUI-Neustart jeweils ein einziges Mal benutzen, danach funktioniert sie nicht mehr.

Der Befehl „gnome-screenshot -a“ funktioniert via Terminal einwandfrei, auch mehrmals hintereinander, allerdings beendet es sich mit der Meldung „** Message: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11.“
Versuche ich hingegen, es via Tastenkürzel (Shift + Print-Screen) aufzurufen, geschieht bis zum nächsten GUI-Neustart überhaupt nichts (s.o.).

Die Sache ist aufgetreten, nachdem ich diesem Webauftritt eine Präsentation in einem neuen Tab geöffnet und versucht habe, von einer Präsentationsseite einen Screenshot zu erstellen. Der erste Bildausschnitt hat wie gewohnt einwandfrei geklappt, der zweite Versuch war dann allerdings nicht mehr möglich. Das war vor etwa einer Stunde, seit jenem Zeitpunkt tritt das Probleme auf.

Mein Adblock Plus ist deaktiviert, ansonsten nutze ich einen DNS-Filter, welchen ich nicht auf einer einzelnen Seite deaktivieren kann, weshalb ich die Präsentationsspeicherung via Print-Screen versucht habe.

Wie kann ich das genauer diagnostizieren oder welche Lösung gibt es für diese Angelegenheit?

Vorläufig habe ich mir ein anderes Screenshot-Programm installiert, jedoch war ich mit gnome-screenshot sehr zufrieden, weshalb ich es gerne weiterhin nutzen möchte.

Liebe Grüsse

Hi :)
was passiert denn bei
bildschirmfoto im menü (suchen)

geht das dann?

Z-App

  • Gast
Unter LM 17 läuft das noch einwandfrei (Die Fehlermeldung bei Start übers Terminal kommt auch dort, sollte also nicht stören). Das beschriebene Problem tritt seit LM 17.1 auf, daher dürften bereits andere Lösungen im Netz existieren.

Mein Workaround hat nur den kleinen Schönheitsfehler, dass ein kleines Terminal während der Aufnahme links oben sichtbar wird; Man kann es über den Parameter -geometry aber auch wo anders platzieren (s.a. man x bzw. http://manpages.ubuntu.com/manpages/trusty/en/man7/X.7.html).
Menü → Einstellungen → Tastatur → Tastenkombinationen → Eigene Tastenkombinationen erstellen →
  Name → selbsterklärend
  Befehl → gnome-terminal --geometry=1x1+0+0 --hide-menubar -e 'gnome-screenshot -a'
  Tastenkombination → Umschalt+Druck   (shift+print)

Es erfolgt eine Rückfrage, da diese Tastenkombination ja schon benutzt wird, ob diese nun für den gerade erstellten Befehl verwendet werden soll. → JA!