Windows10 Und LinuxMint Im Uefi Installieren

Windows10 und LinuxMint im uefi installieren

Da es immer wieder zu neuen Threads kommt die eine Win10 und LinuxMint (hier 17.3) Installation im UEFI betreffen habe ich hier meine Vorgehensweise dokumentiert. Beide Systeme in 64-bit.
Edit:
Mittlerweile ist als 3. System LM 18.2 Cinn dabei und es funktioniert noch alles. Auffallend ist das das Grubmenue etwas zugemüllt aussieht. Wird beobachtet!
Editit: Das Grubmenue zeigte sich auch kurz aufgeräumt nach mehreren

sudo update-grub in beiden Linuxsystemen. Dies gelingt aber nicht immer. Daher gehe ich von einer bestimmten Reihenfolge für das   sudo update-grub  aus ... wird noch weiter beobachtet!

ich hoffe es hilft etwas ...  ::)


Kleine Tipp-Liste für: Windows10 und LinuxMint im uefi installieren.

PC:
Octa-AMD FX8350 auf UEFI Board ASUS M5A97 LE R2.0 mit 8 GB ram, 4GB Graka, 500 GB hdd, DVD-Brenner und DVD-Rom.
BIOS.V.2.10.1208 America Meg....

Die Installations-Stricks für win und LM hatte ich normal erstellt!! Soll angeblich nur im speziell vorbereitetem UEFI-Modus gehen ?!?
sonst : https://wiki.ubuntuusers.de/UNetbootin/#Verwendung-fuer-U-EFI

Für Windows kann es auch erforderlich sein, sich das Win-Iso mit Rufus unter einem Windowssystem auf einen Datenträger zu ziehen.
Geht auch für LinuxMint wenn man sich dieses System erstellen will.
https://rufus.akeo.ie/

1. Bootreihenfolge ändern: 1. USB ; 2. CD/DVD ; 3. HDD/SSD
    Ging bei mir (Sohn) nicht, hat aber USB-Stick automatisch als Installation-Medium erkannt.
    Näheres:  http://linuxwelt.blogspot.co.ke/2014/03/boot-reihenfolge-im-bios-andern.html
    und  http://linuxwelt.blogspot.co.ke/2015/02/bootreihenfolge-andern-anleitung-linux.html

2. Secure-Boot abschalten / anderes Betriebssystem wählen. (Secure-Boot muss wohl nicht mehr abgeschaltet werden da
    Mint das wohl kann. Ab LM18 am besten Testen!  ;) )

3. Fast-Boot Abschalten (Damit Win immer beim beenden ganz runter fährt und nichts in Bereitschaft bleibt!)

3.a) CSM am besten im UEFI-Setup deaktivieren, damit das Installationsmedium nicht im
       BIOS-Modus gestartet werden kann.
       Sollte das nicht gehen : Alles auf UEFI Einstellen! Netzwerk kann auf disable

4. erst Win 10 installieren
    Näheres:
    1 HDD/SSD: http://linuxwelt.blogspot.co.ke/2015/12/linux-neben-windows-10-installieren.html

    Mehrere: http://linuxwelt.blogspot.co.ke/2015/12/linux-ubuntu-neben-windows-10.html

4.a) Fast-Boot Abschalten im Schnellstart im Windows-System
http://techmixx.de/schnellstart-unter-windows-10-deaktivieren/

4.b)  Die Neugier von Win 10 etwas aus bremsen:
http://www.heise.de/newsticker/meldung/Windows-10-Datensammelwut-beherrschen-2774941.html

5. Partitionen verändern unter Win !
   d.h.: Für Linux Platz machen, da wo Windows sein System hat! Aber das besser nur unter Windows machen!

5.a) Linux Bootmedium einstecken legen und Windows runterfahren. 

5.b) Neu booten: Linux aausprobieren --> CD-Ikon auf dem Desktop anklicken --> Linux installieren

6. Auswahl LinuxMint installieren:  etwas anderes → ja
  Für die Grub-Installation die von Win angelegte EFI-Partition wählen! Ist oft die sda2!
   Die Auswahl ist für die Grub-Installation ist im unteren Teil des Fensters zum partitionieren!
   Und die Links unter Punkt 4 beachten!

7. Nach der Installation eventuell noch "ubuntu" im UEFI-Setup unter dem Reiter Boot in
    der Bootreihenfolge an die oberste Stelle setzen.
   
    Wurde bei mir automatisch erledigt!!

8. Beten das es klappt!

Noch ein weiteres ergänzendes Info zu UEFI ist der Ubuntu-Wiki und
http://wiki.ubuntu-forum.de/index.php?title=Benutzer:Klaus_P#

Das BOOT-MENUE sah dann so aus:

1. LinuxMint 17.3 ...
2. Erweiterte Optionen LinuxMint 17.3 …
3. Windows Bootmanager (auf /dev/sda2)
4. System … (hier kommt man noch mal in das UEFI-BIOS!)

Jetzt beim 3. System:

1. LinuxMint 18.2 ...
2. Erweiterte Optionen LinuxMint 18.2 …
3. Windows Bootmanager (auf /dev/sda2)
4. LinuxMint 17.3  >> weiteres Untermenü (welches vermüllt wird!)
5. System … (hier kommt man noch mal in das UEFI-BIOS!)

Alles richtig? Dann sieht es je nach HDD/SDD so aus:

~ $ inxi -Fz
System:    Host: lms-pc Kernel: 3.19.0-32-generic x86_64 (64 bit) Desktop: Cinnamon 2.8.6
           Distro: Linux Mint 17.3 Rosa
Machine:   Mobo: ASUSTeK model: M5A97 LE R2.0 v: Rev 1.xx Bios: American Megatrends v: 2601 date: 03/24/2015
CPU:       Octa core AMD FX-8350 Eight-Core (-MCP-) cache: 16384 KB
           clock speeds: max: 4000 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz 4: 1400 MHz 5: 2100 MHz 6: 1400 MHz
           7: 1400 MHz 8: 1400 MHz
Graphics:  Card: NVIDIA GF108 [GeForce GT 630]
           Display Server: X.Org 1.17.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1280x1024@75.0hz
           GLX Renderer: GeForce GT 630/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 352.63
Audio:     Card-1 NVIDIA GF108 High Definition Audio Controller driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k3.19.0-32-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (2.7% used) ID-1: /dev/sda model: ST3500418AS size: 500.1GB
Partition: ID-1: / size: 94G used: 5.4G (6%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 8.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 9.4C mobo: N/A gpu: 26C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 215 Uptime: 21 min Memory: 730.5/7886.4MB Client: Shell (bash) inxi: 2.2.28

 ~ $ sudo parted -l
[sudo] password for ***:
Modell: ATA ST3500418AS (scsi)
Festplatte  /dev/sda:  500GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt  Nummer  Anfang  Ende   Größe   Dateisystem     Name                          Flags
 1      1049kB  473MB  472MB   ntfs            Basic data partition          versteckt, diag
 2      473MB   578MB  105MB   fat32           EFI system partition          boot
 3      578MB   595MB  16,8MB                  Microsoft reserved partition  msftres
 4      595MB   251GB  250GB   ntfs            Basic data partition          msftdata
 5      251GB   259GB  8193MB  linux-swap(v1)
 6      259GB   362GB  102GB   ext4           (LM 17.3)
 7      362GB   392GB  30,7GB  ext4           (LM 18.2)
 8      392GB   500GB  108GB   ext4


Nr 7 ist eine Reserve-Part zum ausprobieren andere OS. Jetzt ist dort das LM 18.2 Cinn installiert, welches auch automatisch als 1. OS gebootet wird. Bei der Installation ist darauf zu achten, das auch hier der Grub in die EFI System Partition installiert  wird (in meinem Fall war das die sda2).
Nr 8 ist eine Datenpartition und mit /daten bei der Partitionierung des LM Systems während der Installation, also da wo / ; swap und die  Grub-Installation angelegt werden! Hier landen per Systemlink, die später noch angelegt werden müssen ,Dokumente, Fotos ect ... .

Sollten irgendwann die Links nicht mehr funktionieren da es sie nicht mehr gibt, bitte PM an mich da ich sie als PDF-Datei habe!

Wenn Optionen im UEFI-BIOS nicht zu Verfügung stehen, hilft vielleicht ein UEFI-BIOS Update.
Aber bitte nur wenn man Ahnung hat, keine Gewähr!  ;)

In diesen Systemen wurde auch noch nie durch irgendein Update/Upgrade eines der 3 installierten OS ein anderes oder gar die EFI System Partition beschädigt !!!
(Nur das WIN hat sich jetzt im August 2017 bei einem Update selber abgeschossen ... Mal schauen.   :-X
Linunxsysteme funktionieren noch wie gewohnt ...  ;D

Viel Spass inne Backen! :-)

Gruß Nuffi  8)

Letzte Änderung von Nuffi am 26.08.2017 !