LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Installation & Updates => Thema gestartet von: dirkschwarz am 21.03.2012, 09:05:07

Titel: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 21.03.2012, 09:05:07
Hallo zusammen,

habe Linux MInt Lisa auf meinem PC neben Windows 7 Prof. installiert. Beim Neustart bekomme ich jedoch keine Auswahlmenü, sondern Windows startet direkt durch. Wie komme ich nun zum Auswahlmenü um das passende Betriebssystem zu wählen?

Herzlichen Dank!

PS: gleicher Installationsvorgang hat bei meinem Laptop problemlos geklappt. Hier kann ich beim starten auswählen welches Betriebssystem startet...
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: gas103 am 21.03.2012, 12:07:17
Hallo Dirkschwarz,

normalerweise wirst Du beim Installieren gefragt ob und wohin Du Grub, also den Bootloader von Linux installieren willst.
Standardmäßig landet der dann im Masterboootrecord Deiner Festplatte.

Das Problem schlägt öfter hier auf, schau Dir einfach mal den Lösungsvorschlag von Frieder aus einem anderen Thread an,
der installiert Dir Grub neu: https://www.linuxmintusers.de/index.php?topic=5841.msg49524#msg49524 (https://www.linuxmintusers.de/index.php?topic=5841.msg49524#msg49524)

Du benötigst dafür nur eine beliebige Linux Live CD und schon kann es losgehen.

gruß
gas
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 20:24:34
klappt leider immer noch nicht....bekomme kein Auswahlmenü von GRUB angezeigt. Windows startet einfach durch!!

SuperGrub Disk erkennt Linux MInt und Windows und ich kann problemlos beide starten!

sudo update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done

sudo fdisk -l
Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 Köpfe, 63 Sektoren/Spur, 38913 Zylinder, zusammen 625142448 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf4f895e3

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *        2048     2459647     1228800    7  HPFS/NTFS/exFAT
/dev/sda2         2459648   386662399   192101376    7  HPFS/NTFS/exFAT
/dev/sda3       386664446   604659711   108997633    5  Erweiterte
/dev/sda4       604659712   625139711    10240000    7  HPFS/NTFS/exFAT
/dev/sda5       386664448   592435199   102885376   83  Linux
/dev/sda6       592437248   604659711     6111232   82  Linux Swap / Solaris

Ich finde keine Lösung. Auch das Inet hat mir nicht wirklich weitergeholfen...hat noch jemand eine Idee?

Danke!
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Sauron am 24.03.2012, 20:40:28
Wenn Du mit SuperGrubDisk Mint gestartet hast dann probier mal Grub in /sda zu installieren. sudo grub-install /dev/sda und Grub updaten sudo update-grub
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 21:14:01
Frust!!!!

beide Befehle ohne Fehlermeldung ausgeführt! -> Neustart -> KEIN Grub-Menü, direkter Start von Windows :-((

 - noch jemand eine Idee oder einen Hinweis?
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 21:21:30
ok, neuer Versuch - hast du eine Live-Version mit der gleichen Architektur (32/64 Bit) wie das installierte System - wenn ja, dann starte die mal und meld dich aus dem Live-System heraus

Greetz

Frieder
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Sauron am 24.03.2012, 21:25:09
Und mal zeigen wo Grub installiert ist grub-probe -t device /boot/grub Oder handelt es sich um GPT ?
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 21:32:55
@Frieder108

bin jetzt mal mit einen Live/-System / Linux Mint drauf...und nu   ;D
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 21:35:55
...und nu   ;D

nu versuchen wir mal, dein Problem zu lösen.

Als erstes hätte ich jetzt gerne nochmal die sudo fdisk -l haste zwar schon mal weiter vorne gebracht - aber sicher ist sicher ;)
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 21:38:21
sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf4f895e3

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048     2459647     1228800    7  HPFS/NTFS/exFAT
/dev/sda2         2459648   386662399   192101376    7  HPFS/NTFS/exFAT
/dev/sda3       386664446   604659711   108997633    5  Extended
/dev/sda4       604659712   625139711    10240000    7  HPFS/NTFS/exFAT
/dev/sda5       386664448   592435199   102885376   83  Linux
/dev/sda6       592437248   604659711     6111232   82  Linux swap / Solaris

Disk /dev/sdc: 4016 MB, 4016046080 bytes
66 heads, 25 sectors/track, 4753 cylinders, total 7843840 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000eefca

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *        2048     7843839     3920896    c  W95 FAT32 (LBA)
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 21:43:55
Ok, jetzt tu mir noch den Gefallen, und setz das Ganze in nen Codeblock, das brauchen wir noch ein paar mal und das macht für mich und andere, die mitlesen, die geschichte übersichtlicher.

Geh dazu nochmal auf deinen Beitrg, klicke auf ändern > markiere die Terminalausgabe mit der Maus > klicke auf das #-Symbol oberhalb der Smileys und du bekommst so eine Ausgabe  ;)
Wie gesagt, das macht es übersichtlicher und wir brauchen das noch ein paar mal.

Übrigens, bitte bei den Befehlen und den entsprechenden Ausgaben immer mit Copy+Paste arbeiten, selbst ein Leer-Zeichen ist wichtig.

Bis gleich

Frieder
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 21:45:21
erledigt...
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 21:55:30
sauberle, sieht doch gleich viel besser aus ;)

ok, jetzt nacheinander sudo mount /dev/sdxY /mnt sudo mount -o bind /dev /mnt/dev sudo mount -o bind /sys /mnt/sys sudo mount -t proc /proc /mnt/proc sudo cp /proc/mounts /mnt/etc/mtab sudo cp /etc/resolv.conf /mnt/etc/resolv.conf sudo chroot /mnt /bin/bash
wenn bis hierher alles sauber durchläuft, dann befindest du dich in deinem installierten System

viel Erfolg - bis gleich

Frieder

p.s. eventuelle Fehlermeldungen natürlich bitte posten
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 22:04:58
mint@mint ~ $ sudo mount /dev/sda5 /mnt
mint@mint ~ $ sudo mount -o bind /dev /mnt/dev
mint@mint ~ $ sudo mount -o bind /sys /mnt/sys
mint@mint ~ $ sudo mount -t proc /proc /mnt/proc
mint@mint ~ $ sudo cp /proc/mounts /mnt/etc/mtab
mint@mint ~ $ sudo cp /etc/resolv.conf /mnt/etc/resolv.conf
mint@mint ~ $ sudo chroot /mnt /bin/bash
mint / #

KEINE Fehler bisher... :)
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 22:12:13
super

jetzt mal das, was Sauron vorher schon mal angefragt hat grub-probe -t device /boot/grub evtl muß da noch ein "sudo" vorne dran.

Mußte einfach kurz durchprobieren, wär ganz interessant, zu sehen, ob und wenn ja, wohin sich Grub verkümmelt hat (ich denke, XP hat den geplättet)

Grüßle

Frieder
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 22:15:24
mint / # grub-probe -t device /boot/grub
/dev/sda5
mint / #

Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 22:21:01
OK, Grub ist an der falschen Stelle, der gehört nach "sda" ohne Zahl

mach mal ein simples sudo grub-install /dev/sda und poste die Ausgabe.

Fertig wären wir dann aber noch nicht, das wäre jetzt die einfachste Variante, aber danach muß noch sauber rebootet werden ;)
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 22:23:29
mint / # sudo grub-install /dev/sda
sudo: unable to resolve host mint
Installation finished. No error reported.
mint / #

gut oder schlecht..... :'(
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 22:26:45
zusaetzlich zu Windows 7 gibt es noch eine Recovery-Partition von Lenovo. Kann die vielleicht den Bootsektor blockieren....
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 22:29:55
Glaub ich nicht - du darfst nur niemals auf die "ThinkVantage-Taste" drücken  :P

Mach mal nochmal den "grub-install" ohne "sudo" und poste das dann
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 22:32:46
mint / # grub-install /dev/sda
Installation finished. No error reported.
mint / #

kein Fehler  ;D
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 22:33:43
aber immer noch

mint / # grub-probe -t device /boot/grub
/dev/sda5
mint / #
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 22:37:23
ok, das wollte ich sehen.

jetzt fehlt noch ein update -grub und danachgrub-probe -t device /boot/grub
Bitte beide Ausgaben nacheinander ausführen und die Ausgabe hier posten (kannste am Stück machen)

p.s. wart mal bis ich soweit bin, vielleicht muß ich ja auch mal pinkeln gehen ;)
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 22:42:11
nur zu....keinen Stress / finde es eh toll, wie du dich kuemmerst...

mint / # update -grub
No command 'update' found, did you mean:
 Command 'uupdate' from package 'devscripts' (main)
 Command 'lupdate' from package 'qt4-linguist-tools' (main)
 Command 'lupdate' from package 'qt3-dev-tools' (main)
update: command not found
mint / #
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 22:46:06
sorry, Tippfehler meinerseits (das mit den Leerzeichen hatte ich ja angesprochen, richtig ist
update-grub
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 22:50:47
mint / # update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
mint / # grub-probe -t device /boot/grub
/dev/sda5
mint / #

immer noch /dev/sda5..
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 22:55:28
immer noch /dev/sda5..

verwirrt mich gerade auch ein bischen - muß kurz recherchieren. Solange kannst du mir ja mal  dd if=/dev/sda count=1 | hexdump -C zeigen
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 22:59:13
mint / # dd if=/dev/sda count=1 | hexdump -C
1+0 records in
1+0 records out
512 bytes (512 B) copied, 2.5369e-05 s, 20.2 MB/s
00000000  eb 0e 0a 00 04 00 d7 09  00 00 00 00 00 00 4e 50  |..............NP|
00000010  fa 33 c0 bc 00 66 8e d0  50 07 50 1f fb fc be 09  |.3...f..P.P.....|
00000020  00 89 14 bf 00 08 be 00  7c b9 00 01 f3 a5 50 bf  |........|.....P.|
00000030  34 08 57 cb bb 00 06 be  02 08 0f b6 0c b8 01 02  |4.W.............|
00000040  ba 80 00 cd 13 ba 05 00  bf 00 06 b9 00 02 e8 24  |...............$|
00000050  01 b9 05 00 bb 00 12 be  00 06 03 f1 e8 ff 00 eb  |................|
00000060  0a b3 01 be a7 12 88 1c  e9 89 00 e8 2d 00 3c 01  |............-.<.|
00000070  74 ef e8 52 00 3c 01 74  e8 ba 04 00 bf 00 0a b9  |t..R.<.t........|
00000080  a7 08 e8 f0 00 e8 35 05  e9 88 01 be 05 08 0a 04  |......5.........|
00000090  88 04 b1 01 bb 00 08 e8  b9 00 c3 be 00 06 e8 17  |................|
000000a0  00 be 23 06 80 3c 00 74  0c 3c 00 74 08 b0 02 e8  |..#..<.t.<.t....|
000000b0  d9 ff b0 01 c3 b0 00 c3  b9 00 02 4e 32 c0 8b d9  |...........N2...|
000000c0  8a 10 32 c2 e2 f8 c3 b9  05 00 51 b8 00 02 f7 e1  |..2.......Q.....|
000000d0  05 00 08 8b f0 e8 e0 ff  5e 56 0f b6 8c 05 06 e3  |........^V......|
000000e0  04 38 c1 75 06 59 e2 e2  b0 00 c3 59 b0 01 e8 9a  |.8.u.Y.....Y....|
000000f0  ff b0 01 c3 be 07 08 0f  b6 0c b8 01 02 bb 00 7c  |...............||
00000100  ba 80 00 cd 13 be 00 7c  e8 ad ff be 06 08 0f b6  |.......|........|
00000110  0c e3 1c 38 c1 74 18 b0  04 e8 6f ff be af 07 e8  |...8.t....o.....|
00000120  8c 02 be a7 12 80 3c 01  74 03 e8 0a 01 cd 18 be  |......<.t.......|
00000130  be 09 bf be 7d b9 20 00  f3 a5 ba 04 00 bf 00 7c  |....}. ........||
00000140  b9 be 01 e8 2f 00 be 09  00 8b 14 33 c0 50 bf 00  |..../......3.P..|
00000150  7c 57 cb 32 ed b8 01 03  ba 80 00 cd 13 c3 51 4e  ||W.2..........QN|
00000160  0f b6 0c e3 08 b8 01 02  ba 80 00 cd 13 81 eb 00  |................|
00000170  02 59 e2 ea c3 52 57 51  b8 00 bb cd 1a 72 2b 66  |.Y...RWQ.....r+f|
00000180  83 f8 00 75 25 81 f9 02  01 7c 1f 66 81 fb 54 43  |...u%....|.f..TC|
00000190  50 41 75 16 33 c0 8e c0  66 33 f6 b8 07 bb 66 33  |PAu.3...f3....f3|
000001a0  c9 66 33 d2 59 5f 5a cd  1a c3 59 5f 5a c3 00 00  |.f3.Y_Z...Y_Z...|
000001b0  6d 00 00 00 00 62 7a 99  e3 95 f8 f4 00 00 80 20  |m....bz........ |
000001c0  21 00 07 1b 02 99 00 08  00 00 00 80 25 00 00 1b  |!...........%...|
000001d0  03 99 07 fe ff ff 00 88  25 00 00 78 e6 16 00 fe  |........%..x....|
000001e0  ff ff 05 fe ff ff fe 07  0c 17 02 58 fe 0c 00 fe  |...........X....|
000001f0  ff ff 07 fe ff ff 00 60  0a 24 00 80 38 01 55 aa  |.......`.$..8.U.|
00000200
mint / #

..jetzt wird es ja spannend / aber verstehen kann ich das ja spaeter...
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 24.03.2012, 23:00:07
Zeig mal bitte
for d in $(sed -ne 's/^.*\(sd.*\)/\1/p' /proc/partitions);do echo -e "$d\t ID: $(sudo hexdump -v -s 0x80 -n 2 -e '2/1 "%x" "\n"' /dev/$d)";done;echo -e "\nGRUB 1: 5272/aa75\nGRUB 2: 7c3c/48b4/020"
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:02:04
mint / # for d in $(sed -ne 's/^.*\(sd.*\)/\1/p' /proc/partitions);do echo -e "$d\t ID: $(sudo hexdump -v -s 0x80 -n 2 -e '2/1 "%x" "\n"' /dev/$d)";done;echo -e "\nGRUB 1: 5272/aa75\nGRUB 2: 7c3c/48b4/020"
sudo: unable to resolve host mint
sda ID: a78
sudo: unable to resolve host mint
sda1 ID: 55aa
sudo: unable to resolve host mint
sda2 ID: 55aa
sudo: unable to resolve host mint
sda3 ID: 00
sudo: unable to resolve host mint
sda4 ID: 55aa
sudo: unable to resolve host mint
sda5 ID: 00
sudo: unable to resolve host mint
sda6 ID: 00
sudo: unable to resolve host mint
sdc ID: 7c66
sudo: unable to resolve host mint
sdc1 ID: 7815

GRUB 1: 5272/aa75
GRUB 2: 7c3c/48b4/020
mint / #
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 24.03.2012, 23:03:42
Dann ohne sudo wieder!, also nur
for d in $(sed -ne 's/^.*\(sd.*\)/\1/p' /proc/partitions);do echo -e "$d\t ID: $(hexdump -v -s 0x80 -n 2 -e '2/1 "%x" "\n"' /dev/$d)";done;echo -e "\nGRUB 1: 5272/aa75\nGRUB 2: 7c3c/48b4/020"
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:06:36
mint / # for d in $(sed -ne 's/^.*\(sd.*\)/\1/p' /proc/partitions);do echo -e "$d\t ID: $(hexdump -v -s 0x80 -n 2 -e '2/1 "%x" "\n"' /dev/$d)";done;echo -e "\nGRUB 1: 5272/aa75\nGRUB 2: 7c3c/48b4/020"
sda ID: a78
sda1 ID: 55aa
sda2 ID: 55aa
sda3 ID: 00
sda4 ID: 55aa
sda5 ID: 00
sda6 ID: 00
sdc ID: 7c66
sdc1 ID: 7815

GRUB 1: 5272/aa75
GRUB 2: 7c3c/48b4/020
mint / #
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 23:09:01

schaut, soweit ich das beurteilen kann, doch ganz gut aus - warten wir mal noch leo´s Analyse ab
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Sauron am 24.03.2012, 23:10:49
fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:12:01
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / #
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Sauron am 24.03.2012, 23:13:15
sudo grub-install --root-directory=/mnt /dev/sda
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:14:35
mint / # sudo grub-install --root-directory=/mnt /dev/sda
sudo: unable to resolve host mint
Installation finished. No error reported.
mint / #

ohne sudo ?
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Sauron am 24.03.2012, 23:15:47
Nein, ist doch durchgelaufen. Mal noch update-grub und wieder den Befehl  fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:17:34
mint / # update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / #
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:18:38
nicht gut - oder?
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Sauron am 24.03.2012, 23:19:20
OK. Die Abfrage muss angepasst werden.

Zuerst
exitdann die gemounteten Sachen wieder aushängen und neu starten.
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 23:20:05
also ich hätt jetzt grub-install --recheck /dev/sda und wenn das nicht hilft grub-install --force /dev/sda vorgeschlagen und dann jeweils nochmals den Befehl mit den vielen "kein Grub" durchlaufen lassen.

Grüßle

Frieder

p.s. du darfst die "Chroot-Umgebung" jedenfalls nicht einfach verlassen,( nur so am Rande Bemerkt) jetzt mußt du hier bleiben bis zum (bitteren?) Ende  ;D :P
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 24.03.2012, 23:20:55
Ja, hätt ich auch erst noch probiert.
Mach mal
grub-install --recheck /dev/sdaupdate-grub
Er ist ja in der chroot-Umgebung, da kann er nicht /mnt als root-directory nehmen.
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:24:08
mint / # grub-install --recheck /dev/sda
Installation finished. No error reported.
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / # grub-install --force /dev/sda
Installation finished. No error reported.
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / #

habe mich mal dafuer entschieden.... ::)
leider ohne Erfolg.
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 23:26:33
blödes "update-grub", das vergess ich immer (danke leo) -den mußt du natürlich auch immer machen.

Sorry, mein Fehler
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: The_Raven am 24.03.2012, 23:27:38
Mal ne ganz blöde frage: Ist ev. im bios die option aktiv das der bootsektor geschützt ist?
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:31:09
mint / # grub-install --recheck /dev/sda
Installation finished. No error reported.
mint / # update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / # grub-install --force /dev/sda
Installation finished. No error reported.
mint / # update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / #

inzwischen sind wir weit  ueber meine Kenntnisse raus, aber kann das Problem vielleicht doch noch woanders liegen? Bios? Bootsektor geschuezt?
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 23:35:16
Hm, mir gehen die Ideen aus - und der Gedanke von Raven hat was.

Womöglich hat es doch was mit der Recovery-Partition zu tun.

Was fürein Lenovo hast du da eigentlich im Einsatz?

Ich hab selber mehrere ThinkPads hier im Haus zu verwalten, aber da gab es noch nie Probleme damit.
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:36:17
Lenovo M91 /  Windows 7 Prof.
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 24.03.2012, 23:37:25
Hm, geschützt, kann sein... oder auch nicht sein.  :'(
Aber ich würd jetzt doch mal raus aus der chroot-Umgebung mit
exit/mnt nicht aushängen, sondern die root-directory-Methode jetzt probieren mit
sudo grub-install --root-directory=/mnt /dev/sdasudo update-grub
Dann noch einmal Abfrage mit dem Befehl da. Und dann, was immer das Ergebnis sei, würde ich es drauf ankommen lassen und mal versuchen, neu zu starten. Vielleicht ist es ja auch doch schon gegangen und nur die Abfrage tut grad nicht richtig.
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: The_Raven am 24.03.2012, 23:37:37
Im bios gibt es bei gewissen geräten eine option. Heisst je nach hersteller immer anders. Von "protect boot sector" bis "virus protection" oder sowas habe ich schon vieles gesehen. Das muss sowas sein, anders kann man das nicht erklären.
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 24.03.2012, 23:46:21
so was ähnliches wie leonidas wollte ich auch gerade vorschlagen - ich würds auch mal drauf ankommen lassen.

Also wie empfohlen mit "exit" raus aus chroot  und der Anleitung von leo folgen.

Den Ansatz von Raven sollte man auch mal weiter verfolgen.

@ Dirk, haste mal nen Link zu deinem M91 - die Reihe ist mir nämlich völlig unbekannt.
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:49:46
sorrr / habe gerade mal im Bios nachgeschaut / da ist nix
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:52:16
http://www.google.de/products/catalog?hl=de&biw=1393&bih=872&q=usff+m91&bav=on.2,or.r_gc.r_pw.r_qf.,cf.osb&um=1&ie=UTF-8&tbm=shop&cid=7963747266119397012&sa=X&ei=_U9uT_SYEeb24QTFxfS_Ag&ved=0CEcQ8wIwAw (http://www.google.de/products/catalog?hl=de&biw=1393&bih=872&q=usff+m91&bav=on.2,or.r_gc.r_pw.r_qf.,cf.osb&um=1&ie=UTF-8&tbm=shop&cid=7963747266119397012&sa=X&ei=_U9uT_SYEeb24QTFxfS_Ag&ved=0CEcQ8wIwAw)

Link M91
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 24.03.2012, 23:56:10
mint / # exit
exit
mint@mint ~ $ sudo grub-install --root-directory=/mnt /dev/sda
grub-probe: error: cannot find a device for /boot (is /dev mounted?).
Installation finished. No error reported.
mint@mint ~ $

habe euch gegnueber langsam ein schlechtes Gewissen....
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 25.03.2012, 00:00:17
Mach erst nochmal
sudo mount --bind /dev/ /mnt/devund dann nochmal
sudo grub-install --root-directory=/mnt /dev/sdasudo update-grub
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 25.03.2012, 00:02:17
mint@mint ~ $ sudo mount --bind /dev/ /mnt/dev
mint@mint ~ $ sudo grub-install --root-directory=/mnt /dev/sda
grub-probe: error: cannot find a device for /boot (is /dev mounted?).
Installation finished. No error reported.
mint@mint ~ $ sudo update-grub
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
mint@mint ~ $
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Sauron am 25.03.2012, 00:03:23
/dev/sda  :)
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 25.03.2012, 00:03:45
habe euch gegnueber langsam ein schlechtes Gewissen....

brauchste nicht zu haben - du machst ja auch super mit  8)

Und wenn wir zu keinem Ergebniss kommen, dann hast du zumindest erfahren, wie man Codeblocks erstellt  ;D

Frieder
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 25.03.2012, 00:05:05
wahrscheinlich habe ich nach dem neuboot was falsch gemacht...?

mint@mint ~ $ sudo mount /dev/sda5 /mnt
mint@mint ~ $ sudo mount -o bind /dev /mnt/dev
mint@mint ~ $ sudo mount -o bind /sys /mnt/sys
mint@mint ~ $ sudo mount -t proc /proc /mnt/proc
mint@mint ~ $ sudo cp /proc/mounts /mnt/etc/mtab
mint@mint ~ $ sudo cp /etc/resolv.conf /mnt/etc/resolv.conf
mint@mint ~ $ sudo chroot /mnt /bin/bash
mint / # exit
exit

dies habe ich nach dem Neustart eingegeben....
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 25.03.2012, 00:10:19
geben wir uns geschlagen?  :-X

Falls ja - VIELEN DANK fuer eure engagierte Hilfe!
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 25.03.2012, 00:11:37
und Codeblocks kann ich jetzt auch  ;D
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 25.03.2012, 00:14:15
Ne, noch nicht ganz geschlagen (aber vielleicht gleich).
Das update-grub war Denkfehler von mir, wir sind ja noch im Live-System. Kurz bitte
sudo hexdump -v -s 0x80 -n  2 -e '2/1 "%x" "\n"'  /dev/sda(die Ausgabe hiervon muss "020" sein, dann wäre alles gut).  :)
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 25.03.2012, 00:15:16
mint@mint ~ $ sudo hexdump -v -s 0x80 -n  2 -e '2/1 "%x" "\n"'  /dev/sda
020
mint@mint ~ $

JUHU
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 25.03.2012, 00:17:13
Dann mal neu starten ohne Live-CD, ob der Grub dann kommt. Wenn kein Menü erscheint, auch mal "Esc" drücken, vielleicht ist das dann nur versteckt.
Wenn sich das Mintsystem dann starten lässt, dann sogleich
sudo update-grubdort ausführen.
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 25.03.2012, 00:23:10
WOW!! Menü war da!!!!!!!!!!

Habe aber auch gleichzeitig ESC gedrückt - damit ich jetzt nichts falsch mache....

bin jetzt im richtigen System - NICHT mehr Live-System!!

ich mache jetzt ein:

sudo update-grub
im originalen System - richtig?
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 25.03.2012, 00:23:38
Richtig.  8)
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 25.03.2012, 00:24:20
Und wenn das alles in deinem installierten Mint endet, dann darfst du richtig JUUHUU schreien ;D

Daumen drück

Frieder
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 25.03.2012, 00:25:43
dirkschwarz@ThinkCentre-M91 ~ $ sudo update-grub
[sudo] password for dirkschwarz:
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
dirkschwarz@ThinkCentre-M91 ~ $

und jetzt einen Reboot??  :P
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 25.03.2012, 00:27:37
yepp

und wehe, da kommt kein JUUHUU
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 25.03.2012, 00:31:39
Ist an sich gar nicht nötig jetzt. Du musst dann beim nächsten Reboot, wann auch immer Du den machen möchtest, schauen, welcher der beiden Windows-Einträge, die da offenbar sind, bootet. Es müsste eigentlich der erste sein (denn Du hast Win doch nur einmal installiert, oder?). Das können wir uns dann ein andermal noch anschauen, wie wir ggf. den unnötigen dann wegmachen.

Ansonsten solltest Du Dein System vielleicht noch aktualisieren mit
sudo apt-get update && sudo apt-get dist-upgrade
Wenn das durchgelaufen ist, dann solltest Du eh neu starten. Aber, falls es dabei Probleme geben sollte (ist eigentlich nicht zu erwarten!), ich sag für heute ehrlichgesagt dann schon mal gute Nacht! Morgen ist schließlich auch wieder ein Tag.  :)
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 25.03.2012, 00:32:07
JUHUUUUUUUUUUUUUUUU -  :-* :-* :-* :-* :-* :-* :-* :-* :-*

Vielen, Vielen Dank! Ihr seid toll!

Wenn Ihr nicht schon total genervt seid.....könnt Ihr mir vielleicht noch erklären, wo das Problem lag?? Was Ihr da gemacht habt geht weit über meine Kenntnisse hinaus, aber man kann ja immer dazu lernen...

Danke!
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 25.03.2012, 00:38:51
habe noch ein:

sudo apt-get update && sudo apt-get dist-upgrade
einziger "Fehler":

update-initramfs: Generating /boot/initrd.img-3.0.0-16-generic
Warning: No support for locale: de_DE.utf8
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.0.0-16-generic /boot/vmlinuz-3.0.0-16-generic
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 25.03.2012, 00:41:00
Ne, so ganz kann jedenfalls ich es nicht. Ich vermute aber, dass das Problem möglicherweise im Kern wesentlich weniger lange überhaupt bestanden hat als wir das dachten. Vielleicht aber ging auch wirklich erst die Grub-Installation zuletzt aus dem Live-System ohne chroot. Weiß man nicht so genau. Im Grunde gegangen ist es nur darum, Grub irgendwie in den MBR zu kriegen. Warum, das wäre die eigentliche Frage, das bei Dir nicht - wie normalerweise - schon bei der Installation stattfand, weiß ich auch nicht jetzt. Ist aber doch auch egal jetzt eigentlich. Die Sache läuft ja jetzt.

Den "Fehler" da kannst Du ignorieren. Wenn irgendwas mit dem Deutsch nicht passt, drücke mal in den Systemeinstellungen auf "Sprachunterstützung".
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: Frieder108 am 25.03.2012, 00:43:22
 (http://www.cheesebuerger.de/images/smilie/nahrung/a015.gif) (http://www.cheesebuerger.de/smilie.php)

@ dirk, viel Spaß und freude mit deinem Mint.

Grüße

Frieder
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: dirkschwarz am 25.03.2012, 00:44:37
ok - prima!

habe jetzt im Startmenü von Grub zweimal Windows drin - sda1 und sda2

aber das können wir auch ein andermal beheben ....

Herzlichen Dank & Gute Nacht!
Dirk
Titel: Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
Beitrag von: leonidas am 25.03.2012, 00:46:09
Ja, schau dann mal, ob der erste Eintrag für Windows bootet.
Aber, wie gesagt, das nicht mehr heute.
Gute Nacht.