LMU - Das Hilfe Forum für Linux Mint

Hardware => Hardware stellt sich quer? => Thema gestartet von: Manny_K am 13.01.2021, 06:24:32

Titel: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 13.01.2021, 06:24:32
Hallo Leute,

ich habe vor ein paar Tagen Linux Mint 20.1 Cinnamon neben Win10 als Dualboot installiert.
Unter anderem benutze ich unter Windows eine Technisat SkyStar 2 eXpress HD.
Leider bekomme ich die unter mint nicht zum laufen.
Ich habe es mit folgender Anleitung probiert.

https://wiki.ubuntuusers.de/TechniSat_SkyStar_2_eXpress_HD/

Leider hat es nicht funktioniert.
Ich wäre auch bereit mir eine anderer Sat-Karte zu kaufen.
Sie sollte möglichst einfach zu installieren sein und stabil laufen.
Ich bin für jede Info/Hilfe dankbar.

Meine verbaute Hardware

CPU: AMD Ryzen 7 3700X
Board: MSI MEG X570 Unify
BIOS: E7C35AMS.A70
RAM: 2 x 16 GB Corsair CMK32GX4M2B3000C15
Netzteil:Straight Power 10 600 Watt
SSD 1: Samsung SSD 970 EVO Plus 500 GB
SSD 2: Samsung SSD 840 EVO 500 GB
SSD 3: SanDisk SDSSDA 2 TB
Grafikkarte: NVIDIA GeForce GTX 1660 SUPER
TV Karte: TechniSat SkyStar 2 eXpress HD

Gruß Manny_K
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 13.01.2021, 09:12:15
Hi
Zitat
Leider hat es nicht funktioniert.

Tja , wenn man wüßte was nicht ging ?

Hast du :
wget -P ~/Downloads/ "http://search.cpan.org/CPAN/authors/id/J/JW/JWB/Proc-ProcessTable-0.59.tar.gz"
tar xfvz Proc-ProcessTable-0.59.tar.gz
cd ~/Downloads/Proc-ProcessTable-0.59
perl Makefile.PL
make
make test
make install
Das ausgeführt ?   mit 59 , da 50 veraltet ist .
und dann das hier gemacht:
sudo apt install linux-headers-$(uname-r)
sudo make && make install
sudo apt install build-essential

git clone https://github.com/tbsdtv/media_build.git

ls
cd media_build/
ls
./build il
sudo apt install lsdiff
sudo apt install patchutils libproc-processtable-perl
./build
sudo make install
sudo make rmmod
sudo modprobe saa716x_tbs-dvb
lspci

Und wo kam ein Fehler ?

MfG soyo
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 13.01.2021, 11:00:42
Hallo soyo,

bei

tar xfvz Proc-ProcessTable-0.59.tar.gz

geht es nicht weiter

manfred@manfred-Linux:~$ wget -P ~/Downloads/ "http://search.cpan.org/CPAN/authors/id/J/JW/JWB/Proc-ProcessTable-0.59.tar.gz"
--2021-01-13 10:47:48--  http://search.cpan.org/CPAN/authors/id/J/JW/JWB/Proc-ProcessTable-0.59.tar.gz
Auflösen des Hostnamens search.cpan.org (search.cpan.org) … 151.101.2.132, 151.101.66.132, 151.101.194.132, ...
Verbindungsaufbau zu search.cpan.org (search.cpan.org)|151.101.2.132|:80 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 301 Moved Permanently
Platz: https://cpan.metacpan.org/authors/id/J/JW/JWB/Proc-ProcessTable-0.59.tar.gz [folgend]
--2021-01-13 10:47:48--  https://cpan.metacpan.org/authors/id/J/JW/JWB/Proc-ProcessTable-0.59.tar.gz
Auflösen des Hostnamens cpan.metacpan.org (cpan.metacpan.org) … 151.101.130.217, 151.101.2.217, 151.101.194.217, ...
Verbindungsaufbau zu cpan.metacpan.org (cpan.metacpan.org)|151.101.130.217|:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: 75949 (74K) [application/x-gzip]
Wird in »/home/manfred/Downloads/Proc-ProcessTable-0.59.tar.gz.2« gespeichert.

Proc-ProcessTable-0 100%[===================>]  74,17K  --.-KB/s    in 0,03s   

2021-01-13 10:47:49 (2,20 MB/s) - »/home/manfred/Downloads/Proc-ProcessTable-0.59.tar.gz.2« gespeichert [75949/75949]

manfred@manfred-Linux:~$ tar xfvz Proc-ProcessTable-0.59.tar.gz
tar (child): Proc-ProcessTable-0.59.tar.gz: Funktion open fehlgeschlagen: Datei oder Verzeichnis nicht gefunden
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now

Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: moehre am 13.01.2021, 11:32:49
Hallo Manny_K,
Beim ersten Befehl wget -P ~/Downloads/ "http://search.cpan.org/CPAN/authors/id/J/JW/JWB/Proc-ProcessTable-0.59.tar.gz"steht am Ende, dass es in die Datei ....tar.gz.2 heruntergeladen wurde, danach versuchst du aber, ....tar.gz zu entpacken, die es nicht gibt.

Außerdem lädst du in das Verzeichnis Downloads  herunter, willst aber die Datei im Home-Verzeichnis entpacken.
Hoffentlich hilft das weiter
Gruß moehre
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 13.01.2021, 11:39:40
Hi
Ja!
Grund:

Downloads/Proc-ProcessTable-0.59.tar.gz.2

Die runtergeladene Datei , heißt nun (vermutlich mehrer Versuche)  tar.gz.2

Verlangt wird aber :

tar xfvz Proc-ProcessTable-0.59.tar.gz

Also mach im Download Verzeichnis , ne Umbenennung von tar.gz.2  n tar.gz
und danach wieder ab :

tar xfvz Proc-ProcessTable-0.59.tar.gz

weiter.
MfG soyo

Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 13.01.2021, 12:01:02
Hallo moehre,

Nachdem ich mit dem Terminal ins Downloadverzeichnis gewechselt bin ging es weiter.

Jetzt hänge ich bei sudo make && make install

manfred@manfred-Linux:~/Downloads/Proc-ProcessTable-0.59$ sudo make && make install
"/usr/bin/perl" -MExtUtils::Command::MM -e 'cp_nonempty' -- ProcessTable.bs blib/arch/auto/Proc/ProcessTable/ProcessTable.bs 644
Manifying 4 pod documents
"/usr/bin/perl" -MExtUtils::Command::MM -e 'cp_nonempty' -- ProcessTable.bs blib/arch/auto/Proc/ProcessTable/ProcessTable.bs 644
Manifying 4 pod documents
Files found in blib/arch: installing files in blib/lib into architecture dependent library tree
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ERROR: Can't create '/usr/local/lib/x86_64-linux-gnu/perl/5.30.0/Proc'
Do not have write permissions on '/usr/local/lib/x86_64-linux-gnu/perl/5.30.0/Proc'
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 at -e line 1.
make: *** [Makefile:836: pure_site_install] Fehler 13
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: cherusci am 13.01.2021, 12:15:43
Hast Du auch einfach mal versucht einen Scan mit w_scan zu machen?

Könnte es nicht sein das die Karte in Wirklichkeit schon funktioniert?
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 13.01.2021, 12:22:20
Also mach im Download Verzeichnis , ne Umbenennung von tar.gz.2  n tar.gz
und danach wieder ab :

tar xfvz Proc-ProcessTable-0.59.tar.gz

Ich habe hier den Download mehrmals durchgeführt daher die .2 und .3. Aber die Originaldatei ist ja trotzdem noch im Verzeichnis
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 13.01.2021, 12:25:10
Hast Du auch einfach mal versucht einen Scan mit w_scan zu machen?

Dann erhalte ich folgendes Ergebis

w_scan
w_scan
w_scan version 20170107 (compiled for DVB API 5.10)
guessing country 'DE', use -c <country> to override
using settings for GERMANY
DVB aerial
DVB-T Europe
scan type TERRESTRIAL, channellist 4
output format vdr-2.0
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
main:4007: FATAL: ***** NO USEABLE TERRESTRIAL CARD FOUND. *****
Please check wether dvb driver is loaded and
verify that no dvb application (i.e. vdr) is running.


Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 13.01.2021, 12:47:20
Hi
Das hier :
ERROR: Can't create '/usr/local/lib/x86_64-linux-gnu/perl/5.30.0/Proc'
Do not have write permissions on '/usr/local/lib/x86_64-linux-gnu/perl/5.30.0/Proc'
Sieht nach einem Rechtefehler aus .

Ich würde jetzt , statt :
sudo make && make install


sudo make

und dann mal nen

sudo make install

ausführen , Also jeden Befehl für sich .
MfG soyo
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 13.01.2021, 13:48:31
Ich würde jetzt , statt :
sudo make && make install


sudo make

und dann mal nen

sudo make install

Ich habe jetzt folgenden Code ins Terminal kopiert (Verzeichnis Download)

sudo apt install linux-headers-$(uname-r)
sudo make
make install
sudo apt install build-essential

dann erhalte ich folgende Ausgabe:

root@manfred-Linux:/home/manfred/Downloads# sudo apt install linux-headers-$(uname-r)
bash: uname-r: Befehl nicht gefunden
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Virtuelle Pakete wie »linux-headers« können nicht entfernt werden.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 3 nicht aktualisiert.
root@manfred-Linux:/home/manfred/Downloads# sudo make
make: *** Es wurden keine Ziele angegeben und keine „make“-Steuerdatei gefunden.  Schluss.
root@manfred-Linux:/home/manfred/Downloads# make install
make: *** Keine Regel, um „install“ zu erstellen.  Schluss.
root@manfred-Linux:/home/manfred/Downloads# sudo apt install build-essential
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
build-essential ist schon die neueste Version (12.8ubuntu1.1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 3 nicht aktualisiert.
root@manfred-Linux:/home/manfred/Downloads#

Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: cherusci am 13.01.2021, 14:22:10
main:4007: FATAL: ***** NO USEABLE TERRESTRIAL CARD FOUND. *****
Please check wether dvb driver is loaded and
verify that no dvb application (i.e. vdr) is running.

Ok, das Ding arbeitet wirklich nicht!
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 13.01.2021, 14:44:00
Hi
Kannst du mal hiermit weitermachen ?
git clone https://github.com/tbsdtv/media_build.git

ls
cd media_build/
ls
./build il
sudo apt install lsdiff
sudo apt install patchutils libproc-processtable-perl
./build
sudo make install
sudo make rmmod
sudo modprobe saa716x_tbs-dvb
lspci
MfG soyo
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 13.01.2021, 14:59:14
So ich habe mich bis

git clone https://github.com/tbsdtv/media_build.git

vorgearbeit!

Bei der Eingabe im Terminal kommt es zu folgender Fehlermeldung

root@manfred-Linux:/home# git clone https://github.com/tbsdtv/media_build.git
-bash: git: Befehl nicht gefunden
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 13.01.2021, 15:01:32
Hi
Das Programm SYNAPTIC öffnen , Git suchen , Git installieren.
MfG soyo
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: tam am 13.01.2021, 16:35:56
root@manfred-Linux:/home/manfred/Downloads# sudo apt install linux-headers-$(uname-r)
bash: uname-r: Befehl nicht gefunden
So kann das auch nicht funktionieren. Der Befehl muss heissen:
uname -rBeachte das Leerzeichen hinter uname. Dann sollte es auch mit der Installation der headers funktionieren.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 13.01.2021, 18:13:53
Das Programm SYNAPTIC öffnen , Git suchen , Git installieren.

habe ich gemacht. Wie es aussieht komme immer ein paar Zeilen weiter

Jetzt hänge ich bei "sudo apt install lsdiff"

es kommt zu folgender Fehlermeldung

manfred@manfred-Linux:~/Downloads/Proc-ProcessTable-0.59/media_build$ sudo apt install lsdiff
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket lsdiff kann nicht gefunden werden.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 13.01.2021, 18:32:18
So kann das auch nicht funktionieren. Der Befehl muss heissen:
Code: [Auswählen]

uname -r

Beachte das Leerzeichen hinter uname. Dann sollte es auch mit der Installation der headers funktionieren.

Hatte ich halt so aus der Anleitung kopiert und im Terminal eingefügt.
Ich tue mir halt sehr schwer, da meine Linuxkenntnisse gegen Null gehen.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 13.01.2021, 19:05:17
Hi

mit kleinem L am Anfang !!  Nicht mit großem I   

lsdiff   nicht  Isdiff . Sieht Optisch gleich aus .
MfG soyo
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 13.01.2021, 19:13:41
mit kleinem L am Anfang !!  Nicht mit großem I   

Habe ich so eingegeben! Es bleibt leider bei der Fehlermeldung.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: tam am 14.01.2021, 00:00:54
lsdiff befindet sich im Paket patchutils.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 14.01.2021, 07:05:19
lsdiff befindet sich im Paket patchutils.

laut der Packetverwaltung ist das Paket patchutils bereits installiert. Auch ein erneutes installieren brachte nichts.
Weiterhin wird angezeigt, dass das Paket lsdiff nicht gefunden werden konnte.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 14.01.2021, 08:14:03
Hi
Du befindest dich im Terminal noch hier :
manfred@manfred-Linux:~/Downloads/Proc-ProcessTable-0.59/media_build$

Also im Ordner Downloads , Unterodner Proc-Proces..... , im Unterodner media_build
Also such das Terminal auch nur hier nach  lsdiff .

Mach das Terminal zu . Starte es neu , dann bist Du wieder am Anfang etwa so
manfred@manfred-Linux:~$

und dann gibst du dort
sudo apt install lsdiff

ein.
MfG soyo
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 14.01.2021, 09:49:41
Mach das Terminal zu . Starte es neu , dann bist Du wieder am Anfang etwa so
manfred@manfred-Linux:~$

und dann gibst du dort
sudo apt install lsdiff

hab ich gemacht. Das Ergebnis ist leider wie bei den vorherigen Versuchen

manfred@manfred-Linux:~$ sudo apt install lsdiff
[sudo] Passwort für manfred:       
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket lsdiff kann nicht gefunden werden.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Diatone_GTR349 am 14.01.2021, 12:24:13
lsdiff ist in patchutils.
sudo apt-get install libproc-processtable-perl subversion mercurial patchutils linux-headers-$(uname -r) build-essentialgit clone https://github.com/tbsdtv/media_build.gitcd media_build./buildsudo make installsudo rebootda ich kein *.deb System mehr verwende kann ich es nicht testen, sollte aber so laufen.

Edit.: Habe es gerade noch mal geändert. Und teste ob es kompiliert wird.
Unter Kernel 5.10.6 läuft es durch.
make[2]: Leaving directory '/usr/lib/modules/5.10.6-arch1-1/build'
./scripts/rmmod.pl check
found 738 modules
make[1]: Verzeichnis „/media_build/v4l“ wird verlassen
**********************************************************
* Compilation finished. Use 'make install' to install them
**********************************************************
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 14.01.2021, 13:01:06
lsdiff ist in patchutils.
sudo apt-get install libproc-processtable-perl subversion mercurial patchutils linux-headers-$(uname -r) build-essentialgit clone https://github.com/tbsdtv/media_build.gitcd media_build./buildsudo make installsudo rebootda ich kein *.deb System mehr verwende kann ich es nicht testen, sollte aber so laufen.

Edit.: Habe es gerade noch mal geändert. Und teste ob es kompiliert wird.
Unter Kernel 5.10.6 läuft es durch.
make[2]: Leaving directory '/usr/lib/modules/5.10.6-arch1-1/build'
./scripts/rmmod.pl check
found 738 modules
make[1]: Verzeichnis „/media_build/v4l“ wird verlassen
**********************************************************
* Compilation finished. Use 'make install' to install them
**********************************************************

Ich habe deinen Code eingegeben und er lief ohne Fehler durch.
Leider bin ich nicht weitergekommen.

w_scan zeigt folgendes an
w_scan
w_scan version 20170107 (compiled for DVB API 5.10)
guessing country 'DE', use -c <country> to override
using settings for GERMANY
DVB aerial
DVB-T Europe
scan type TERRESTRIAL, channellist 4
output format vdr-2.0
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
   /dev/dvb/adapter0/frontend0 -> "STV090x Multistandard" doesnt support TERRESTRIAL -> SEARCH NEXT ONE.
main:4007: FATAL: ***** NO USEABLE TERRESTRIAL CARD FOUND. *****
Please check wether dvb driver is loaded and
verify that no dvb application (i.e. vdr) is running.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 14.01.2021, 13:37:37
Hi
Sieht schon besser aus .
Grund :
alt:
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
main:4007: FATAL: ***** NO USEABLE TERRESTRIAL CARD FOUND. *****
nun:
Info: using DVB adapter auto detection.
   /dev/dvb/adapter0/frontend0 -> "STV090x Multistandard" doesnt support TERRESTRIAL -> SEARCH NEXT ONE.
Also , gefunden , kann aber logischerweise kein DVB-T/T2  ;D

Starte den Rechner mal neu und gib das hier ein :

dmesg | grep DVB
Dann die Antwort zeigen.

MfG soyo
Ps: das "nackte W_SCAN" nützt bei dir nichts .  Du hast DVB-S (Sat tv)
Da muß es schon so heißen (Bei Astra 19.2)

w_scan -fs -s S19E2 -c DE -L > channels.xspf
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 14.01.2021, 14:45:08
Hi
Sieht schon besser aus .
Grund :
alt:
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
main:4007: FATAL: ***** NO USEABLE TERRESTRIAL CARD FOUND. *****
nun:
Info: using DVB adapter auto detection.
   /dev/dvb/adapter0/frontend0 -> "STV090x Multistandard" doesnt support TERRESTRIAL -> SEARCH NEXT ONE.
Also , gefunden , kann aber logischerweise kein DVB-T/T2  ;D

Starte den Rechner mal neu und gib das hier ein :

dmesg | grep DVB
Dann die Antwort zeigen.

MfG soyo
Ps: das "nackte W_SCAN" nützt bei dir nichts .  Du hast DVB-S (Sat tv)
Da muß es schon so heißen (Bei Astra 19.2)

w_scan -fs -s S19E2 -c DE -L > channels.xspf


Ich habe vor ein paar Minuten ein ugrade auf mint 20.1 durchgeführt.
Ich hoffe das ich dadurch nicht noch mehr Probleme verursacht habe.

Ich habe dann dein Script bis
./build il
ausgeführt.

Nach ./build il wurde ich aufgefordert make install einzugeben
make[2]: Leaving directory '/usr/src/linux-headers-5.4.0-62-generic'
./scripts/rmmod.pl check
found 739 modules
make[1]: Verzeichnis „/home/manfred/Downloads/Proc-ProcessTable-0.59/media_build/v4l“ wird verlassen
**********************************************************
* Compilation finished. Use 'make install' to install them
**********************************************************
Dann kam folgende Anzeige
make -C /home/manfred/Downloads/Proc-ProcessTable-0.59/media_build/v4l install
make[1]: Verzeichnis „/home/manfred/Downloads/Proc-ProcessTable-0.59/media_build/v4l“ wird betreten
-e
Removing obsolete files from /lib/modules/5.4.0-62-generic/kernel/drivers/media/common:


-e
Removing old /lib/modules/5.4.0-62-generic/kernel/drivers/media/common/siano files:
smsdvb.ko rm: remove write-protected regular file '/lib/modules/5.4.0-62-generic/kernel/drivers/media/common/siano/smsdvb.ko'?
smsmdtv.ko rm: remove write-protected regular file '/lib/modules/5.4.0-62-generic/kernel/drivers/media/common/siano/smsmdtv.ko'?

-e
Removing old /lib/modules/5.4.0-62-generic/kernel/drivers/media/usb/gspca/stv06xx files:
gspca_stv06xx.ko rm: remove write-protected regular file '/lib/modules/5.4.0-62-generic/kernel/drivers/media/usb/gspca/stv06xx/gspca_stv06xx.ko'?

-e
Removing old /lib/modules/5.4.0-62-generic/kernel/drivers/media/pci/pluto2 files:
pluto2.ko rm: remove write-protected regular file '/lib/modules/5.4.0-62-generic/kernel/drivers/media/pci/pluto2/pluto2.ko'?

usw.
Ich hab das jeweils mit der Eingabetaste bestätigt ich hoffe das war richtig?

Bei
erhalte ich folgendes Ergebnis
w_scan -fs -s S19E2 -c DE -L > channels.xspf
w_scan -fs -s S19E2 -c DE -L
w_scan version 20170107 (compiled for DVB API 5.10)
using settings for 19.2 east Astra 1KR/1L/1N/1M
scan type SATELLITE, channellist 68
output format vlc xspf playlist
output charset 'ISO-8859-1'
Info: using DVB adapter auto detection.
main:4007: FATAL: ***** NO USEABLE SATELLITE CARD FOUND. *****
Please check wether dvb driver is loaded and
verify that no dvb application (i.e. vdr) is running.

Bei der Eingabe von "dmesg | grep DVB" passiert gar nichts
manfred@manfred-Linux:~/Downloads/Proc-ProcessTable-0.59/media_build$ dmesg | grep DVB
manfred@manfred-Linux:~/Downloads/Proc-ProcessTable-0.59/media_build$


Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 14.01.2021, 14:49:09
Hi
Zitat
Ich habe vor ein paar Minuten ein ugrade auf mint 20.1 durchgeführt.
Ich hoffe das ich dadurch nicht noch mehr Probleme verursacht habe.
Ja.
Dadurch kannst du erneut beginnen .
Grund : Mit der Sache , die wir z.Zt mit deiner Karte machen , ist , du veränderst den Kernel !
Nun hast du nen neuen Kernel , also von vorn.

Ev. hat er nen paar Sachen behalten , aber den Kernelpatch mit Sicherheit nicht .
MfG soyo
Das übt aber .
Unter Open Suse durfte ich das von Version 10.3 bis Version 12.1 mit meiner Karte machen .


Also das was Diatone_GTR349 geschrieben hat sollte reichen .
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 14.01.2021, 15:34:02
Dadurch kannst du erneut beginnen .
Grund : Mit der Sache , die wir z.Zt mit deiner Karte machen , ist , du veränderst den Kernel !
Nun hast du nen neuen Kernel , also von vorn.

Ev. hat er nen paar Sachen behalten , aber den Kernelpatch mit Sicherheit nicht .
MfG soyo
Das übt aber .
Unter Open Suse durfte ich das von Version 10.3 bis Version 12.1 mit meiner Karte machen .

Hab ich inzwischen die Inatallationsschritte wieder ausgeführt!
Jetzt hänge ich wieder bei
sudo apt install lsdiff
Mit der Angabe, das das Paket lsdiff nicht gefunden werden kann
Die patchutils sind installiert!

Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Diatone_GTR349 am 14.01.2021, 15:39:34
Ich habe vor ein paar Minuten ein ugrade auf mint 20.1 durchgeführt.
Warum machst du denn so einen Scheiß. Die Karte lief doch schon, da fehlte doch nur der richtige w_scan Befehl. Dann hättest du zumindest gewusst ob die Karte läuft.
Am besten du fängst noch mal von vorne an.

Das media_build Verzeichnis löschen,
Kernel zurücksetzen,
sudo apt-get install --reinstall linux-headers-$(uname -r) linux-image-$(uname -r) linux-image-extra-$(uname -r) 
und dann ab git clone nochmal.

 
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 14.01.2021, 16:11:58
Das media_build Verzeichnis löschen,
Kernel zurücksetzen,
Code: [Auswählen]

sudo apt-get install --reinstall linux-headers-$(uname -r) linux-image-$(uname -r) linux-image-extra-$(uname -r) 

und dann ab git clone nochmal.

Das Mediaverzeichnis habe ich gelöscht!
Wie setze ich den Kernel zurück?
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Diatone_GTR349 am 14.01.2021, 17:07:41
sudo apt-get install --reinstall linux-headers-$(uname -r) linux-image-$(uname -r) linux-image-extra-$(uname -r)
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 14.01.2021, 19:33:52
sudo apt-get install --reinstall linux-headers-$(uname -r) linux-image-$(uname -r) linux-image-extra-$(uname -r)

Langsam bin am verzweifeln! Ich hab den Code eingegeben.
Ergebnis

manfred@manfred-Linux:~$ sudo apt-get install --reinstall linux-headers-$(uname -r) linux-image-$(uname -r) linux-image-extra-$(uname -r)
[sudo] Passwort für manfred:       
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket linux-image-extra-5.4.0-62-generic kann nicht gefunden werden.
E: Mittels des Musters »linux-image-extra-5.4.0-62-generic« konnte kein Paket gefunden werden.
E: Mittels regulärem Ausdruck »linux-image-extra-5.4.0-62-generic« konnte kein Paket gefunden werden.

Sollte ich mint neu installieren? Wenn ja, welche version? 20 oder 20.1
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Diatone_GTR349 am 14.01.2021, 19:43:10
Nimm das extra einfach raus. Ich habe das aus meinen alten Post's kopiert.
sudo apt-get install --reinstall linux-headers-$(uname -r) linux-image-$(uname -r)
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 14.01.2021, 20:47:07
Nimm das extra einfach raus. Ich habe das aus meinen alten Post's kopiert.
sudo apt-get install --reinstall linux-headers-$(uname -r) linux-image-$(uname -r)

Hat funktioniert!

Mit
w_scan -fs -s S19E2 -c DE -L > channels.xspf
hat er hunderte Programme erkannt.

manfred@manfred-Linux:~$ dmesg | grep DVB
[    4.772154] dvbdev: DVB: registering new adapter (SAA716x dvb adapter)
[    5.029795] SAA716x Budget 0000:25:00.0: DVB: registering adapter 0 frontend 0 (STV090x Multistandard)...

Wie muss ich weiter vorgehen?
Ich habe probeweise Kaffeine gestartet, konnte dort allerdings keine Programme finden.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Diatone_GTR349 am 14.01.2021, 21:15:10
Da ich damit nichts mache, kann ich dir da nicht weiterhelfen.
Ich denke, soyo meldet sich da noch mal zu.
Wenn der scan durch gelaufen ist, müsstest du die channels.xspf mit vlc öffnen können.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 14.01.2021, 23:34:38
Da ich damit nichts mache, kann ich dir da nicht weiterhelfen.
Ich denke, soyo meldet sich da noch mal zu.
Wenn der scan durch gelaufen ist, müsstest du die channels.xspf mit vlc öffnen können.

Erstmal vielen Dank für deine Unterstützung. Ich habs jetzt geschaft mit VLC und Kaffeine  Sat Programme zu öffnen.
Der ganze Weg dahin war nicht sehr geradelinig. Die Codezeilen die Du mir gezeigt hast, hätten die alleine zum Erfolg geführt. Oder war da noch Code von soyo dabei. Ich möchte einfach den genauen Weg der Installation Dokumentieren.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 15.01.2021, 23:32:38
Ich möchte mich hiermit bei allen bedanken, die mich hier mit Ihren Beiträgen unterstützt haben!
Ich jetzt ein gutes Stück weitergekommen und habe für fast alle Software unter Windows geeignete Alternativen für Linux gefunden.

Gruß

Manny_K
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 16.01.2021, 14:22:26
Hi
So schön !
Sorry , eher nicht genug Zeit gehabt .

Die Codes , oder den Link hierher , solltest Du aufheben .
Grund : Nach jedem Kernel Update , wird deine Karte vermutlich nicht mehr laufen , bis es mal einen Kernel gibt , der deine Karte out of the box laufen läßt. Kann aber dauern . (Bei mir damals ca.2 Jahre)
Würde also den Kernel , den du z.Zt hast nie löschen !  Dann kannst du immer nen Rückfall auf diesen machen .

Ok.
VLC und Kaffeine ist ne gute Wahl !!  Hab ich auch getroffen .

Tip 1.
VLC starten , Einstellungen (in aussehen EINFACH) auf Interface gehen .
Dort im Punkt Wiedergabeliste und Instanzen , den Haken bei NUR EINE INSTANZ ERLAUBEN rausnehmen und speichern .
Grund : Nun kannst du VLC so oft starten wie du möchtest . Dadurch wird die ne Aufnahme ev. nicht versaut , wenn du aus Versehen mal nicht dran denkst und VLC öffnest .

Tip 2.
Kanallisten .
Bei DVB-T2 und seinen paar Sendern , ist nen sortieren in Kaffeine , ja noch ganz nett zu machen .
Aber bei DVB-C (bei mir) oder sogar bei DVB-S (bei Dir ) sehr sehr mühevoll .
Also hab ich den SQLITE BROWSER installiert (nix fürs Internet , mehr Datenbearbeitung)
Kaffeine , legt seine Kanalliste in HOME  , im versteckten Ordner .local  unter share , unter kaffeine , in der Datei sqlite.db   ab.
Die öffnet man dann (am beste erstmal ne Kopie) mit SQLITE BROWSER , geht in SQLITE auf den Reiter DATENDURCHSUCHEN.
Dann siehst du schon worum es geht .

Wenn du öffter , und mehr Aufnahmen machst , kann ich dir noch Tips geben  . War halt unter Windows auch DVBVIEWER PRO verwöhnt .

MfG soyo

PS. Da das grundsätzlich Problem ja erledigt ist , könntes Du (kannst nur Du) das Thema auf erledigt setzen . Wir können ja trotzdem hier weiterschreiben.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 16.01.2021, 19:40:06
Tip 1.
VLC starten , Einstellungen (in aussehen EINFACH) auf Interface gehen .
Dort im Punkt Wiedergabeliste und Instanzen , den Haken bei NUR EINE INSTANZ ERLAUBEN rausnehmen und speichern .
Grund : Nun kannst du VLC so oft starten wie du möchtest . Dadurch wird die ne Aufnahme ev. nicht versaut , wenn du aus Versehen mal nicht dran denkst und VLC öffnest .

Tip 2.
Kanallisten .
Bei DVB-T2 und seinen paar Sendern , ist nen sortieren in Kaffeine , ja noch ganz nett zu machen .
Aber bei DVB-C (bei mir) oder sogar bei DVB-S (bei Dir ) sehr sehr mühevoll .
Also hab ich den SQLITE BROWSER installiert (nix fürs Internet , mehr Datenbearbeitung)
Kaffeine , legt seine Kanalliste in HOME  , im versteckten Ordner .local  unter share , unter kaffeine , in der Datei sqlite.db   ab.
Die öffnet man dann (am beste erstmal ne Kopie) mit SQLITE BROWSER , geht in SQLITE auf den Reiter DATENDURCHSUCHEN.
Dann siehst du schon worum es geht .

Ich nutze unter Windows auch den DVB Viewer Pro. Dort habe ich unter Favoriten ca. 50 Kanäle. In Kaffeine habe ich einfach alles gelöscht bis auf die 50 Kanäle das ging eigentlich recht schnell. Auf den ersten Eindruck finde ich Kaffeine übersichtlicher. Unter VLC fehlen sehr viele HD Sender von ARD und ZDF. Gibt es eine Senderliste für VLC zum Download mit allen freien SD- und HD-Sendern aus dem deutschsprachigen Raum? Die Listen die ich gefunden habe sind gerade im HD Bereich sehr lückenhaft.
Den SQLITE BROWSER schaue ich mir auf jeden Fall mal an.
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 16.01.2021, 20:28:19
Hi
Geht Diese ?
http://www.satip.info/Playlists/ASTRA_19_2E.m3u

MfG soyo
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 16.01.2021, 20:49:50
[url]http://www.satip.info/Playlists/ASTRA_19_2E.m3u[/url]


Leider lassen sich keine Programme in der Liste öffnen.

Gruß Manny_K
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 17.01.2021, 11:25:00
Hi
Dann hilft nur :

w_scan -t 3 -fs -s S19E2 -c DE -L > channels.xspf

oder

w_scan -t 3 -fs -s S19E2 -c DE -X > channels.conf

MfG soyo
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: Manny_K am 17.01.2021, 18:41:13
w_scan -t 3 -fs -s S19E2 -c DE -L > channels.xspf

Ich hab mir jetzt mit w_scan -t 3 -fs -s S19E2 -c DE -L > channels.xspf eine List e erstellt. Die ich dann angepasst habe.

Mal sehen ob ich in Zukunft VLC oder Kaffein einsetzen werde.

Gruß Manny_K
Titel: Re: TechniSat SkyStar 2 eXpress HD läuft nicht
Beitrag von: soyo am 17.01.2021, 19:05:44
Hi
Nun ja , wenn du mal über die Konsole ne zeitgesteuerte Aufnahme für VLC programmiert hast , da mach ich das lieber mit Kaffeine .
Wenn in Kaffeine ne Aufnahme läuft  , kann ich in VLC immer noch gleichzeitig IPTV schauen und auch Dieses ev. mit FreeTuxTV aufnehmen .
Soweit ist Hypnotix nehmlich noch nicht.
MfG soyo