LMU - Das Hilfe Forum für Linux Mint

Software => Ärger mit Software? => Thema gestartet von: skoopy am 30.11.2020, 11:02:59

Titel: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: skoopy am 30.11.2020, 11:02:59
Hallo zusammen,

unter Linux Mint 20 Cinnamon nutze ich gerne die Funktion im Kontextmenü "Per E-Mail versenden", die beim Rechtsklick auf eine Datei erscheint. Neuerdings wird die Datei nicht mehr als Anhang eingebunden. Thunderbird öffnet sich zwar, um die Nachricht zu verfassen, der Anhang bleibt aber leer. Ich muss ihn in Thunderbird durch einen Klick auf "Anhang" selbst auswählen. Kann jemand von euch das gleiche Verhalten beobachten oder hat eine Idee, wie sich das wieder ändern lässt? Sämtliche Einstellungen in Nemo und Thunderbird habe ich überprüft.

Liebe Grüße,
skoopy
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: ZeckeSZ am 30.11.2020, 12:09:33
Probier's mal testweise mit einem neuen Nutzer und einem neuen Thunderbird-Profil. Hier kann der Fehler nicht nachvollzogen werden, alles funktioniert wie es soll.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: RWBrf am 30.11.2020, 12:51:00
Ich hab zwar kein LM20, sondern 19.3 Cinnamon, aber bei mir öffnet sich auch nur ein leerer eMail-Verfassen-Entwurf ohne den gewünschten Dateianhang. Der Entwurf kommt mit meiner Standard-Verśandadresse.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: ZeckeSZ am 30.11.2020, 13:51:52
Mit 19.3 Cinnamon habe ich hier mittlerweile auch das Problem. Sowas in der Art hatten wir schon mal: https://www.linuxmintusers.de/index.php?topic=59226 (https://www.linuxmintusers.de/index.php?topic=59226)
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Jang am 30.11.2020, 14:16:53
Hallo,

hab es eben auch mal schnell getestet. Weder unter LM 19.3 noch unter LM 20 wurde die Datei angehängt. TB Version 68.10.0. Dateiname war blah_blah_blah.jpg

Auf meinem LMDE4, TB 78.5.0, wurde die Datei angehängt. Auch mit z.B Leerzeichen im Dateinamen.

MfG Jang
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: skoopy am 30.11.2020, 20:30:42
Okay, dann scheint es sich doch um einen allgemeinen Bug zu handeln. Unter LMDE 4 und Debian mit Thunderbird 78.5.0 funktioniert der Mailanhang aus dem Kontextmenü heraus, nur in LM 20 mit TB 68.10.0 nicht. Ich habe das Ganze mit verschiedenen Dateien (.jpg, .txt, .pdf, .odt) getestet, alle Dateinamen ohne Leer- oder Sonderzeichen.
Ich nutze für alle Systeme dasselbe Thunderbird-Profil, in LMDE und Debian wurde bloß irgendwann auf die Version 78.x aktualisiert. Da ihr das gleiche Verhalten schildert, liegt es denke ich auch nicht am Benutzer.
Dann hoffe ich mal, dass es mit einem der nächsten Updates behoben wird. Liegt dann vermutlich am Ubuntu-TB? Vielleicht sende ich mal einen Bug-Report.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 30.11.2020, 20:43:58
Okay, dann scheint es sich doch um einen allgemeinen Bug zu handeln. Unter LMDE 4 und Debian mit Thunderbird 78.5.0 funktioniert der Mailanhang aus dem Kontextmenü heraus, nur in LM 20 mit TB 68.10.0 nicht.
Falls es sich tatsächlich um einen Bug handeln sollte, so tritt der zumindest nicht durchgängig auf.
Jedenfalls funktioniert dieses Kontextmenü hier tadellos, egal um welche Dateiformate es sich handelt.

TB  68.10.0
Desktop: Cinnamon 4.6.7
Distro: Linux Mint 20 Ulyana
Kernel: 5.4.0-54

Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: skoopy am 30.11.2020, 21:07:59
@Parmenides: Das ist ja sonderbar. Bisher funktionierte diese Funktion in LM 20 bei mir auch tadellos. Ich habe keine Ahnung, weshalb es jetzt nicht mehr klappt. Vielleicht findet sich der Fehler ja noch. Tröstlich ist, dass dieses Verhalten auch bei anderen Nutzern auftritt. ;)
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: kuehhe1 am 30.11.2020, 21:29:04
Ich dachte schon ich stehe allein da.

Habe hier zwei identische ML20 Cin. Kernel: 5.4.0-56 Installationen...
mit Thunderbird 68.10.0: per Email versenden öffnet Thunderbird das Neue Nachricht Fenster aber ohne eingefügten Anhang.

mit Thunderbird 78.5.0: per eMail versenden öffnet nur den Thunderbird ohne das "Neue Nachricht" Fenster. Thunderbird zeigt aber hier noch einen anderen Fehler, CC und BCC werden nicht mehr neben den Adresszeilen sondern oberhalb in der Menüleiste angezeigt, wirrwar.

Vielleicht hängt es mit diesem Vorgestern (Sat Nov 28 12:06:42 2020) aktualisiertem Paket zusammen:
xdg-utils (1.1.3-2ubuntu1) to 1.1.3-2ubuntu1.20.04.1
Edit: nach Erzwingen der alten Version (xdg-utils (1.1.3-2ubuntu1)) und Neustart wird in TB 78.5.0 der zu versendende Anhang wieder automatisch eingefügt.

TB 68.10.0 ist davon unbeeindruckt und öffnet sein Fenster "Neue Nachricht" nicht...
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: detlev56 am 30.11.2020, 21:43:26
Habe Linux Mint 20 Cinnamon,

Mit Thunderbird 68.10.0: per Email versenden öffnet Thunderbird und der gewählte Anhang erscheint so wie es sein soll.


Titel: Nach Installation anderer PRG: "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: theodor am 30.11.2020, 22:43:23
Mint 20: nachdem ich gestern einige Mailprogramme installiert habe, funktioniert in Nemo der Rechtsklick "Per e-mail versenden" nicht mehr. Das Dateifeld in Thunderbird (68.10.0) ist und bleibt leer.

"nautilus-sendto" habe ich erneut installiert, für Nemo direkt gibt es das nicht.

An Thunderbird liegt das meiner Meinung nach nicht. Ich denke, eines der Mailprogramme (Balsa, Sylpheed, Claws, ...) hat da was bei Nemo verbogen.

Irgendwelche Ideen zu einer echten Lösung?
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: theodor am 30.11.2020, 22:53:16
Habe Nautilus installiert und dort funktioniert es.

Was ist also bei Nemo kaputt?
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 01.12.2020, 00:57:39
@kuehhe1 -  ¹/² O-Ton
Mir ist aufgefallen, dass du einen neueren Kernel installiert hast als ich (5.4.0-56 vs. 5.4.0.-54). Dachte also, vielleicht hängt die Mailanhang-Geschichte damit zusammen.

Mich wundert dieser alte Kernel, da ich immer alle Aktualisierungen zeitnah durchführe und nichts auf die Negativliste gesetzt habe.
Nun stelle ich fest, dass sich der Kernel 5.4.0-56 nicht installieren lässt. Es kommt zwar keine Fehlermeldung, der Kernel wird aber dennoch nicht upgedatet. Habe das jetzt mehrmals vergeblich incl. Neustarts probiert.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: tommix am 01.12.2020, 01:18:22
Kannst du 5.4.0-56 deinstallieren?
Dann mache es und installiere ihn neu.
Er ist derzeit nur für LM 20 verfügbar nicht aber LM 19.3.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 01.12.2020, 01:24:50
Kernel 5.4.0-56 lässt sich nicht deinstallieren, da er nicht installiert ist.
Angeboten wird nur "installieren".

Gelistet ist er ja in der Aktualisierungsverwaltung (LM 20), aber die Installation läuft ins Leere.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: kuehhe1 am 01.12.2020, 08:35:45
Hallo,
Mir ist aufgefallen, dass du einen neueren Kernel installiert hast als ich (5.4.0-56 vs. 5.4.0.-54).
der Kernel 5.4.0-56 wurde Hier Gestern auf beiden Systemen automatisch über die Akt.-Verwalt. angezeigt und installiert.
Gelistet ist er ja in der Aktualisierungsverwaltung (LM 20), aber die Installation läuft ins Leere.
mal den Server gewechselt, hier ist netcologne eingestellt.


Ich habe jetzt beide LM20 Cin. Systeme im Grubmenü mit Kernel 5.4.0.-54 gestartet um damit das "per E-mail versenden" aus nemo heraus zu prüfen.

Gleicher Status wie Gestern, mit alter Version xdg-utils (1.1.3-2ubuntu1):
TB 68.10.0 öffnet kein Neues "Verfassen Fenster"
TB 78.5.0 öffnet ein Neues "Verfassen Fenster" und der zu versendende Anhang wird automatisch eingefügt, s.Anhang #1

Das Problem resultiert anscheinend nicht vom Kernel oder Thunderbird.
Wohl eher aus den xdg-utils, denn ein ähnliches Problem bestand hier in der Vergangenheit mit LM19.1Cin.:
https://www.linuxmintusers.de/index.php?topic=55570.msg750938#msg750938

Dort wurde die thunderbird-desktop verändert und durch eine userapp-Thunderbird-123xyz.desktop Datei ersetzt weshalb nemo die Datei nicht mehr an Thunderbird versendete/übergab. Jetzt sieht es hier wieder genau so aus, es befinden sich aktuell neun (9) thunderbird und userapp.desktop Dateinen im Verzeichnis ~/.local/share/applications :o s. Anhang #2

Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 01.12.2020, 10:05:41
Das Problem resultiert anscheinend nicht vom Kernel
Merkwürdig, hier kann ich das genaue Gegenteil verifizieren, nämlich dass der Kernel 5.4.0-56 der Übeltäter ist.

Heute früh wurde mir der 56er endlich wie gewohnt aktiv zur Installation angeboten und korrekt installiert (und nicht wie zuvor nur in der Kernelübersicht aufgeführt).
Ansonsten wurden keine weiteren Updates eingespielt und endlich kann auch ich euren Mailanhangsfehler bestaunen. ;)

Ich denke mal, da wird in Kürze eine Korrektur erfolgen. Das Einfachste wird sein, das Problem auszusitzen.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: ZeckeSZ am 01.12.2020, 10:21:33
Ich hatte keine Lust, lang nach einem Fehler zu suchen (der dürfte m.E. in xdg-email, send-by-mail.py oder send-by-mail.nemo_action liegen), daher ein anderer Weg:

Nemo öffnen ==> Bearbeiten ==> Module ==> "Per E-Mail versenden" deaktivieren

Script erstellen:
xed ~/.local/share/nemo/actions/attach.nemo_action

Inhalt:
[Nemo Action]
Active=true
Name=Per E-Mail versenden
Exec=thunderbird -compose to=,"attachment='%F'"
Icon-Name=mail-attachment
Selection=Any
Extensions=nodirs
Separator=,
Dependencies=thunderbird;

Funktioniert hier mit LM 19.3 Cinnamon/Thunderbird 68.10.0 und LM 20 Cinnamon/Thunderbird 68.10.0

Oder aber global in der Datei
sudo -H xed /usr/share/nemo/actions/send-by-mail.nemo_action"Exec" und "Dependencies" gegen die oben genannten austauschen. Die Frage ist allerdings, ob das das nächste Update überleben wird...
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: kuehhe1 am 01.12.2020, 10:55:45
Hallo,
Script erstellen:
Code: [Auswählen]
xed ~/.local/share/nemo/actions/attach.nemo_action
so hatte ich es seinerzeit: https://www.linuxmintusers.de/index.php?topic=55570.msg750296#msg750296 auch gelöst, warte jetzt aber auch erstmal ab.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: ehtron am 01.12.2020, 12:56:22
Hi :)
mensch leute.. der kernel verändert doch keine anwendungsprogramme  :-\

btw.. hier auf lm20 cin gehts auch nicht... für mich unwichtig da ich per d&d rein ziehe... somit keine ahnung woher es kommt... TB oder desktop?
per e-mail versenen modul ist in nemo aktviert.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: skoopy am 01.12.2020, 13:25:13
Ich glaube auch nicht, dass der Kernel Schuld ist. Der Fehler taucht hier gleichermaßen beim Kernel 5.4.0-54 und 5.4.0-56 (der kam heute als Update) auf.
Ich kann mir gut vorstellen, dass xdg-utils 1.1.3-2ubuntu1.20.04.1 der Übeltäter ist, warte aber auch erst mal ab.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 01.12.2020, 13:28:22
mensch leute.. der kernel verändert doch keine anwendungsprogramme
Hat so auch niemand behauptet. Was genau der Kernel verändert hat, weiß ich nicht. Das Changelog ergibt für mich keinen Hinweis auf unser Thema.

Hier noch mal meine Begründung, weshalb ich den Kernel als Ursache ansehe:

Testdauer 5 Minuten

1. Test des Kontextmenüpunkts "per E-mail versenden" > Ergebnis: OK, funktioniert.
2. Kernelupdate von 5.4.0-54 auf 5.4.0-56 (es wurden keine weiteren Updates oder sonstige Änderungen durchgeführt).
3. Neustart
4. Test des Kontextmenüpunkts "per E-mail versenden" > Ergebnis: funktioniert nicht mehr. TB wird zwar gestartet, jedoch ohne den Anhang automatisch einzubinden.

Habe jetzt nochmal den Kernel 5.4.0-54 reaktiviert. Der Fehler bleibt bestehen.
Da fahre ich mit meiner Logik offenbar gegen eine Wand. ???
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: skoopy am 01.12.2020, 13:37:49
@Parmenides: Wann kam denn bei dir das Update xdg-utils 1.1.3-2ubuntu1.20.04.1?

Zitat
remove attachment handling from mailto in scripts/xdg-email.in
https://launchpad.net/ubuntu/+source/xdg-utils
Aus den Bug-Reports werde ich aber auch nicht schlau: https://ubuntu.com/security/CVE-2020-27748
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 01.12.2020, 13:39:37
Gestern Abend.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: MegaV0lt am 01.12.2020, 13:54:20
System:    Kernel: 5.4.0-54-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.7
           Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal
Machine:   Type: Desktop Mobo: ASUSTeK model: H110M-A/M.2 v: Rev X.0x serial: <filter>
           UEFI [Legacy]: American Megatrends v: 4202 date: 02/28/2019
CPU:       Topology: Quad Core model: Intel Core i7-6700 bits: 64 type: MT MCP arch: Skylake-S rev: 3
           L2 cache: 8192 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54398
           Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 879 2: 899 3: 878 4: 1025 5: 912 6: 868
           7: 942 8: 902
Graphics:  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1200~60Hz
           OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 20.0.8 direct render: Yes
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus ID: 00:1f.3
           Sound Server: ALSA v: k5.4.0-54-generic
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 1.60 TiB used: 1.00 TiB (62.9%)
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZALQ256HAJD-000L2 size: 238.47 GiB
           ID-2: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB
           ID-3: /dev/sdb vendor: Samsung model: HD103UJ size: 931.51 GiB
Partition: ID-1: / size: 211.69 GiB used: 28.99 GiB (13.7%) fs: ext4 dev: /dev/nvme0n1p1
           ID-2: /home size: 400.10 GiB used: 130.96 GiB (32.7%) fs: ext4 dev: /dev/sda1
           ID-3: swap-1 size: 8.50 GiB used: 2.37 GiB (27.9%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 23.0 C mobo: 27.8 C
           Fan Speeds (RPM): cpu: 1031 fan-1: 913 fan-5: 0 fan-6: 0
Info:      Processes: 319 Uptime: 14d 2h 42m Memory: 15.51 GiB used: 5.47 GiB (35.3%) Init: systemd runlevel: 5
           Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17 inxi: 3.0.38

Heute hab ich versucht wie üblich per Kontextmenü einige PDF per Mail zu versenden. Und es geht bei mir auch nicht mehr. ;-(
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 01.12.2020, 13:59:11
Und wieder spricht das gegen den Kernel als Ursache.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: aexe am 01.12.2020, 14:17:35
Zitat
Jens Mueller discovered that xdg-utils incorrectly handled certain URI.
An attacker could possibly use this issue to expose sensitive information.
The problem can be corrected by updating your system to the following package versions:
 xdg-utils - 1.1.3-2ubuntu1.20.04.1
https://ubuntu.com/security/notices/USN-4649-1
Möglicherweise gibt es da einen Zusammenhang zu "per email versenden" im Nemo?

Abgesehen davon sind email-Anhänge ohnehin als Sicherheitsrisiko verrufen.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 01.12.2020, 14:39:01
Wie jetzt schon von verschiedener Seite vermutet, liegt die Ursache tatsächlich im Update von xdg-utils 1.1.3-2ubuntu1.20.04.1.

Habe per Timeshift das System auf den Stand von vor 2 Tagen zurückgesetzt.
Danach alle Updates außer xdg-utils 1.1.3-2ubuntu1.20.04.1. erneut eingespielt.
Nun funktioniert das automatische Einfügen eines Anhangs in TB wieder. Auch mit dem neuen Kernel 5.4.0-56.

Nach dem Hinweis von @aexe auf den (Un)-Sicherheitsakpekt dieser Funktion, scheint mir aber Verzicht angeraten. Für mich kein großes Problem, da ich diesen Komfort eh selten genutzt habe.
Bequemlichkeit scheint mal wieder der Sicherheit zuwider zu laufen.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: ZeckeSZ am 01.12.2020, 15:23:34
Danach alle Updates außer xdg-utils 1.1.3-2ubuntu1.20.04.1. erneut eingespielt.
Und warum hast du dir nicht einfach deine eigene "per_mail_senden.nemo_action" geschrieben (AW #17)? Dann hättest du kein Problem mit dem Versand und auch keines mit einem alten, nicht aktualisierten Paket.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 01.12.2020, 15:59:29
Weshalb sollte ich, wenn ich doch die Funktion gar nicht brauche?
Es hat mich einfach interessiert, diesem Problem auf den Grund zu gehen und Ungereimtheiten zu klären.

Für alle, die diese Funktion öfters benutzen, ist dein Script aber sicher eine gangbare Lösung. Wobei aber meine Linuxkenntnisse nicht ausreichen, die angesprochenen Sicherheitsaspekte im Bezug auf das Script beurteilen zu können.

Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: skoopy am 01.12.2020, 17:17:54
Ich werde wie gesagt auch erst mal abwarten, bis dieser Fehler hoffentlich bald behoben wird. Auf jeden Fall danke @ZeckeSZ für dein Skript.

Weiß jemand von euch, wie man bei Ubuntu einen Bug meldet? Auf der verlinkten Seite scheint es nur über ein Konto bei launchpad.net zu gehen und nicht via Github ::). Oder hat jemand von euch zufällig ein Launchpad-Konto?  ;)
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: kuehhe1 am 01.12.2020, 21:22:24
@aexe,
Abgesehen davon sind email-Anhänge ohnehin als Sicherheitsrisiko verrufen.
Das kann man doch so nicht unbedingt sagen, wie bitte versendet man im privaten und geschäftlichen Bereich heutzutage Dokumente?

@skoopy,
ne las mal ich hatte einmal das Vergnügen, die benötigten zu meinem Problem (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1811254) dreizehn (13) Protokoll-Dateien und die Konversation in English. 

Anmelden kannst du dich dort: https://login.launchpad.net/naxTe7K1jLYtt3tW/+decide
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: skoopy am 02.12.2020, 14:34:02
Ich habe auch keine Ambitionen, mir extra dafür ein Konto einzurichten. Vielleicht kommt ja zeitnah ein Update, oder ich versuche den Bug Debian zu melden - von dort kommt wohl u.a. der Patch.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: kuehhe1 am 02.12.2020, 15:16:47
Ich hoffe das es bald behoben wird.
Denn @eaxe's Antwort #26 ist zu entnehmen das dem Paket xdg-utils vorübergehend die Funktion Anhänge direkt aus nemo zu versenden aufgrund einer Sicherheitslücke entzogen wurde.

Sollte die Lücke nicht geschlossen werden besteht nur immer noch die Möglichkeit Anhänge manuell einzufügen oder via @ZeckeSZ's Script automatisch per E-Mail zu versenden. Aber wie gesagt die selbe Problematik bestand zumindest bei mir bereits unter LM19.1.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: skoopy am 02.12.2020, 15:24:37
Dass die Funktion absichtlich gestrichen wurde, hatte ich noch gar nicht durchschaut. Das ist natürlich möglich. Hoffentlich wird da in jedem Fall bald noch nachgebessert.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: kuehhe1 am 02.12.2020, 16:55:34
Nun ja, absichtlich gestrichen schon, nur bringt die Akt.-Verwaltung das Paket automatisch ins System und verursacht in diesem Fall ein ziemliches Durcheinander.
Hier mal die Übersetzung aus dem Zitat Antwort #26
Zitat
Jens Mueller entdeckte, dass xdg-utils bestimmte URI falsch handhabte. Ein Angreifer könnte dieses Problem möglicherweise verwenden, um vertrauliche Informationen preiszugeben. Das Problem kann behoben werden, indem Sie Ihr System auf die folgenden Paketversionen aktualisieren: xdg-utils - 1.1.3-2ubuntu1.20.04.1

Und hier das Änderungsprotokoll des Paketes:
Zitat
xdg-utils (1.1.3-2ubuntu1.20.04.1) focal-security; urgency=medium

  * SECURITY UPDATE: local file inclusion vulnerability
    - debian/patches/CVE-2020-27748.patch: remove attachment handling from
      mailto in scripts/xdg-email.in.

    - CVE-2020-27748

 -- Leonidas S. Barbosa <leo.barbosa@canonical.com>  Tue, 24 Nov 2020 14:16:38 -0300
der Hickhack hätte durch "ausschliessen" bzw."vernachlässigen" dieser Aktualisierung durchaus verhindert werden können. Aber mal ehrlich, wer schaut schon vor jedem Paket*e Upgrade ins Änderungsprotokoll? Irgendwie vertraut man doch der Akt.-Verwaltung.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 02.12.2020, 18:53:39
Ehrlich gesagt kann ich hier keinen „Hickhack“ erkennen.
Wenn xdg-utils ein potentielles Sicherheitsproblem darstellen, ist es nur konsequent, dieses Paket via Aktualisierungsverwaltung automatisch zu aktualisieren.
Falls einem die damit entfallene Funktion der automatischen Dateianhänge unverzichtbar erscheint, lässt sich dieses Update ja ausschließen.
Hingegen muss sich der „normale“ Mintuser darauf verlassen können, dass erkannte potentielle Sicherheitslücken obligatorisch geschlossen werden.

Irgendwie vertraut man doch der Akt.-Verwaltung.
Eben! ;)
Im Zweifel geht Sicherheit vor Bequemlichkeit.

Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: kuehhe1 am 03.12.2020, 19:48:13
Hallo, sehe ich nicht ganz so
Ehrlich gesagt kann ich hier keinen „Hickhack“ erkennen.
nun der Hickhack besteht hier durch die plötzliche Existenz von neun (9) userapp.desktop Dateien, siehe Antwort #15 Anhang 2

Wenn xdg-utils ein potentielles Sicherheitsproblem darstellen, ist es nur konsequent, dieses Paket via Aktualisierungsverwaltung automatisch zu aktualisieren.
dem stimme ich unter der Voraussetzung zu wenn der "normale" Mintuser die automatische Aktualisierung eingestellt hätte.

Ich lasse mir anstehende Aktualisierungen der Akt.-Verwalt. immer erst Anzeigen und konnte in diesem Fall keinen entsprechenden Hinweis auf den Verlust einer Funktionalität entnehmen:
Zitat
xdg-utils bietet - unabhängig von der verwendeten grafischen
Arbeitsumgebung - die Möglichkeit, Anwendungen in diese grafische
Arbeitsumgebung einzubinden.

Folgende Möglichkeiten werden angeboten:

 * xdg-desktop-menu - Install desktop menu items
 * xdg-desktop-icon - Install icons on the user's desktop
 * xdg-email - Compose a new email in the user's preferred email client,
   potentially with subject and other info filled in
 * xdg-icon-resource - Install icon resources
 * xdg-mime - Query and install MIME types and associations
 * xdg-open - Open a URI in the user's preferred application that
   handles the respective URI or file type
 * xdg-screensaver - Enable, disable, or suspend the screensaver
 * xdg-settings - Get or set the default web browser and URI handlers
Wäre ein Hinweis angezeigt worden hätte ich entscheiden können ob ich das Update wahlweise installieren lasse.

So bedurfte es erst 26 Antworten um an die Hintergründe dieses Sicherheitsupdates zu gelangen:
Jens Mueller discovered that xdg-utils incorrectly handled certain URI.
An attacker could possibly use this issue to expose sensitive information.
The problem can be corrected by updating your system to the following package versions:
 xdg-utils - 1.1.3-2ubuntu1.20.04.1
auch hier erlese ich keinen Zwang eher denn einen Hinweis auf eine Bereinigung des Problems.

Bin neugierig ob sich der lokale Hickhack meiner (9) userapp.desktop Dateien durch ein erneutes xdg-utils Update selbst bereinigt.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: skoopy am 03.12.2020, 20:23:07
Ist es denn so sicher, dass die Funktion mit Absicht entfernt wurde? Ich lese das in AW 26 nicht zwangsläufig heraus. Falls es sich doch um ein Versehen handelt, würde das den fehlenden Hinweis erklären.

EDIT: Wurde in AW 35 eigentlich schon beantwortet, hab's überlesen.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: kuehhe1 am 03.12.2020, 21:16:15
Und hier das Änderungsprotokoll des Paketes:
Zitat
xdg-utils (1.1.3-2ubuntu1.20.04.1) focal-security; urgency=medium

  * SECURITY UPDATE: local file inclusion vulnerability
    - debian/patches/CVE-2020-27748.patch: remove attachment handling from
      mailto in scripts/xdg-email.in.
    - CVE-2020-27748

 -- Leonidas S. Barbosa <leo.barbosa@canonical.com>  Tue, 24 Nov 2020 14:16:38 -0300
dem Änderungsprotokoll nach war es beabsichtigt. Nur hatte ich dort nicht genau gelesen.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: Parmenides am 03.12.2020, 21:24:59
dem stimme ich unter der Voraussetzung zu wenn der "normale" Mintuser die automatische Aktualisierung eingestellt hätte.
Hatte mich da wohl etwas missverständlich ausgedrückt. Meinte nicht automatisch als Update-Einstellung in der Aktualisierungsverwaltung, sondern automatisch im Sinne von wird in den verfügbaren/angebotenen Updates mit aufgeführt.
Aus Interesse sichte auch immer flüchtig die Beschreibungen, der bereitgestellten Updates. Manchmal kann ich damit etwas anfangen, oft sind mir aber die Hintergründe unklar oder es gibt erst gar keine Beschreibung zu einzelnen Updates.
Eine explizite Warnungen, dass nach eine Update eine Funktion entfällt, habe ich allerdings noch nie gesehen oder kann mich zumindest nicht daran erinnern.

Ist es denn so sicher, dass die Funktion mit Absicht entfernt wurde? Ich lese das in AW 26 nicht zwangsläufig heraus.
Eigentlich hatte ich den Link aus AW # 26 so verstanden. Aber bei genauerer Betrachtung muss ich dir da recht geben. Kann zwar sein, aber so eindeutig steht das dort nicht geschrieben. Zumal mir bisher gar nicht klar war, welche Fülle von Funktionen durch die xdg-utils bereitgestellt werden.

Edit:
Ist inzwischen geklärt mit AW 39 von @kuehhe1
Die Antwort auf unsere Diskussion lag mal wieder zu nahe, als dass sie jemand bemerkt hätte. ;)

Also alle wieder zurück auf LOS, bzw. auf AW #17 von @ZeckeSZ
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: theodor am 08.12.2020, 12:53:37
Die Lösung aus Antwort 17 hat sofort geholfen, der Versand von Dateien funktioniert wieder per Rechtsklick.

Danke!
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: sonar am 12.12.2020, 13:23:25
Hallo,
mein System:
Kernel: 5.9.12-050912-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.7
Distro: Linux Mint 20 Ulyana

Ich nutze TB aus den Verzeichnissen von:

https://archive.mozilla.org/pub/thunderbird/releases/
in der Version 78.5.1.

Damit ist es mir auch nicht möglich, Dateien direkt aus Nemo über TB zu versenden.

Nach einem Versuch TB aus der Anwendungsverwaltung erfolgreich zu installieren, erscheint in meinem Nemo mit Rechtsklick auf eine beliebige Datei "Per E-Mail versenden".
Es öffnet sich dann der TB in Version 68.10.0. Wenn ich mein TB entsprechend umstellen würde gehe ich davon aus, das ich diese Datei aus TB versenden kann. Dies wird auch dadurch bestätigt, dass unter Systemeinstellungen > Bevorzugte Anwendungen Thunderbird dann als E-Mail-Programm erscheint - was zuvor nicht der Fall war.

Diese Vorgehen helfen dem Einen oder Anderen vielleicht entsprechende Überlegungen anzustellen.

Gruß sonar
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: kuehhe1 am 15.12.2020, 14:11:57
Es öffnet sich dann der TB in Version 68.10.0. Wenn ich mein TB entsprechend umstellen würde gehe ich davon aus,
Wichtig wäre ob sich TB öffnet und den zu versendenden Anhang auch eingefügt hat...
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: sonar am 15.12.2020, 14:22:43
@kuehhe1
Ja, der Anhang erscheint dann auch in TB.
Titel: Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
Beitrag von: skoopy am 17.12.2020, 22:47:23
Seit dem Thunderbird Update auf 78.6.0 in LMDE 4 und Debian 10 klappt dort das Einfügen des Anhangs aus dem Kontextmenü wieder. Nur Thunderbird 68.10.0 in LM 20 weigert sich nach wie vor.