LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Installation & Updates => Thema gestartet von: ReinhardT am 21.08.2020, 13:27:57

Titel: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ReinhardT am 21.08.2020, 13:27:57
Linux Mint 20 Mate 64 Bit

Hallo,

ich habe hier einen Laptop, der scheinbar nicht so richtig mit Linux Mint klarkommt.
https://www.linuxmintusers.de/index.php?topic=61162.msg811262#msg811262 (https://www.linuxmintusers.de/index.php?topic=61162.msg811262#msg811262)

Das er wären des Startens mehrere Male in den Standby geht, daran habe ich mich langsam gewöhnt.
Nachdem ich ein Update auf Linux Mint 20 gemacht habe, in der Hoffnung das das Problem dann weg ist,
habe ich jetzt das richtige Desaster.
Ich kann mich einloggen, aber der Bildschirm ist nicht zu erkennen, fast nur Streifen.
Interessant ist, das wenn ich die Netztaste drücke um ihn runterzufahren, das Bild
auf einmal für eine Sekunde glasklar da ist.
Der Effekt trat mit Mint 19.3 auch mal auf, aber sehr selten.
Die Grafikkarte ist eine Geforce Go 7950 GTX, einen extra Treiber hatte ich nicht installiert.
Was kann ich tun, hat jemand eine Idee?

Gruß Reinhard
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ehtron am 21.08.2020, 15:07:04
Hi :)
da du ja ein update gemacht hast, sollten ältere kernel, so auch der mit dem das system gestartet hat, noch vorhanden sein.
somit damit im grub starten.
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: OnLinux am 21.08.2020, 15:19:58
Nachdem ich ein Update auf Linux Mint 20 gemacht habe, in der Hoffnung das das Problem dann weg ist
Du meinst upgrade. Bei einem upgrade nimmst Du so einiges von der Vorversion mit, u.U. auch Fehler. Wie wärs mal mit einer sauberen Neuinstallation ?
(Zumal Du im verlinkten Thread schreibst, dass von der DVD einwandfrei hochgefahren wird).

Geforce Go 7950 GTX, einen extra Treiber hatte ich nicht installiert
Mal den in der Treiberverwaltung empfohlenen Treiber installieren.
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ReinhardT am 21.08.2020, 15:37:31
da du ja ein update gemacht hast, sollten ältere kernel, so auch der mit dem das system gestartet hat, noch vorhanden sein.
somit damit im grub starten.

Gute Idee, ältere Kernel sind da, allerdings habe ich da den gleichen Effekt.

Du meinst upgrade. Bei einem upgrade nimmst Du so einiges von der Vorversion mit, u.U. auch Fehler. Wie wärs mal mit einer sauberen Neuinstallation ?
(Zumal Du im verlinkten Thread schreibst, dass von der DVD einwandfrei hochgefahren wird).

Ja Upgrade ist wohl korrekt. Du hast Recht, ich informiere mich mal, wie eine komplette Neuinstallation gemacht wird.

Mal den in der Treiberverwaltung empfohlenen Treiber installieren.

Da komme ich leider ja nicht mehr hin.

Gruß Reinhard
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ehtron am 21.08.2020, 15:40:42
Hi :)
vielleicht mal mit dem grub parameter
nomodeset
starten... oder abgesicherter modus könnte auch was bringen.
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ReinhardT am 21.08.2020, 15:55:44
Hi
vielleicht mal mit dem grub parameter
nomodeset
starten... oder abgesicherter modus könnte auch was bringen.

Ich versuche gerade herauszufinden wie das funktioniert.
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ReinhardT am 21.08.2020, 16:12:48
Das hat erst mal geklappt!
Ich habe  "quiet splash" durch "nomodeset" ersetzt und der Rechner
ist hochgefahren, ohne zwischendurch in der Standby zu gehen.
Der Desktop ist erst mal da, aber in einer niedrigen Auflösung
und die treiberverwaltung sagt, das der Rechner keine zusätzlichen
Treiber benötigt.
Die Bildschirmauflösung beträgt 1280 x 1024 mit 77 Hz und beide
Parameter sind nicht änderbar.
Die Monitorauflösung des Laptops beträgt 1920 x 1200.

Gruß Reinhard
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ehtron am 21.08.2020, 16:19:21
Hi :)
tja.. die alte 7050 wird m.e. nicht mehr von proprietären treiber modulen unterstützt.
vermutlich gibt es da auch probleme mit dem mesa subsystem.

wenn auch die älteren kernel nichts bringen, solltest du per timeshift wieder auf die alte 19er version gehen.
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ReinhardT am 21.08.2020, 16:26:27
Hi :)
tja.. die alte 7050 wird m.e. nicht mehr von proprietären treiber modulen unterstützt.
vermutlich gibt es da auch probleme mit dem mesa subsystem.

wenn auch die älteren kernel nichts bringen, solltest du per timeshift wieder auf die alte 19er version gehen.

Das funktioniert, ich kann jetzt per Timeshift in der 20er Version auf die 19er zurückkehren?
Wie kommt es, das der Rechner jetzt wärend des Startens nicht in den Standby Modus geht,
kann das auch mit der Grafikkarte zusammenhängen?

Ganz herzlichen Dank für die Unterstützung! :)
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ehtron am 21.08.2020, 16:41:36
Hi :)
da die graka die selbe ist, kann sie nicht verantwortlich sein...
allerdings treiber und andere software komponenten.
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ReinhardT am 22.08.2020, 20:25:25
Hab mittlerweile Linux Mint 18.3 oben und damit
läuft Alles ohne Probleme.
Der Rechner fährt auch beim Hochfahren nicht mehr in den Standby Modus.

Vielen Dank noch Mal! :)
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: Fredenpunkt am 23.08.2020, 10:20:06
Hab mittlerweile Linux Mint 18.3 oben und damit läuft Alles ohne Probleme....
Das Problem holt dich auf dem PC aber spätestens im April 2021 wieder ein...
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ehtron am 23.08.2020, 15:26:43
Hi :)
nö.. bis dahin gibt es vielleicht kernel linien die keine probleme mehr machen.  (rückportierung)

@reinhardt
wenn du nun auf 18.3 bist, und zeit hast.. upgrade doch auf 19.3 und dann auf 20
dann bleibt der laufende kernel ja vorhanden... (neuere entfernen und die kernel automatik ausschalten) findet sich auch auf meiner page.
Titel: Re: Leider kein Bild, nur Streifen und Klötzchen.
Beitrag von: ReinhardT am 23.08.2020, 16:55:01
Das Problem holt dich auf dem PC aber spätestens im April 2021 wieder ein...
@reinhardt
wenn du nun auf 18.3 bist, und zeit hast.. upgrade doch auf 19.3 und dann auf 20
dann bleibt der laufende kernel ja vorhanden... (neuere entfernen und die kernel automatik ausschalten) findet sich auch auf meiner page.

Hallo,

ich brauche den Laptop nur, wenn ich mal unterwegs bin und das ist immer seltener.
Ich hab da Windows XP drauf, da meine Autocadversion nur unter XP läuft (Autocad 2000).
Ansonsten das Übliche, Internet und mal was schreiben usw.
Ich lass die Version 18.3 erst mal drauf, die tut es erstmal und wenn es mal Probleme gibt,
dann kann ich ja immer noch Handeln.

Gruß Reinhard