LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Systemverwaltung => Thema gestartet von: kay0815 am 11.11.2019, 20:22:33

Titel: System friert ein
Beitrag von: kay0815 am 11.11.2019, 20:22:33
Hallo zusammen,

ich hoffe ich bin im richtigen Subforum.
Seit einigen Tagen hab ich das Problem das mein Mint 19.2 so ein oder zweimal in einer halben Stunde einfriert. An manchen Tagen gibt es aber auch überhaupt keinen Absturz. Bis dahin kannte ich keine Abstürze von Linux. Symptom ist immer das sich der Mauspfeil nicht mehr bewegen lässt und die Tastatur nicht mehr reagiert. Es hilft nur Ausschalten. Hardware ist unverändert.
Ich bin leider mit Linux nicht sonderlich vertraut, gibt es sowas wie eine Schritt für Schritt Anleitung um das Problem einzugrenzen? Danke schon mal.

Víele Grüße
Titel: Re: System friert ein
Beitrag von: ole_hilja am 11.11.2019, 20:35:51
Hallo,
Willkommen im Grünen. Als erstes müssten wir wissen welche Hardware du hast und welchen Desktop (Cinnamon, xfce etc). Für die Hardware bitte im Terminal
inxi -Fzx und das Ergebnis hier im Codeblock posten.
Titel: Re: System friert ein
Beitrag von: kay0815 am 12.11.2019, 17:28:21
Hi, hier ist die Ausgabe:

System:
  Host: ZBOX51050 Kernel: 4.15.0-66-generic x86_64 bits: 64 compiler: gcc
  v: 7.4.0 Desktop: Cinnamon 4.2.4 Distro: Linux Mint 19.2 Tina
  base: Ubuntu 18.04 bionic
Machine:
  Type: Desktop Mobo: ZOTAC model: ZBOX-EK31050 v: XX serial: <filter>
  UEFI: American Megatrends v: 5.12 date: 05/15/2018
CPU:
  Topology: Quad Core model: Intel Core i5-7500T bits: 64 type: MCP
  arch: Kaby Lake rev: 9 L2 cache: 6144 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21696
  Speed: 1206 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 1205 2: 1253
  3: 1204 4: 1246
Graphics:
  Device-1: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ZOTAC
  driver: nvidia v: 430.50 bus ID: 01:00.0
  Display: x11 server: X.Org 1.19.6 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 3840x2160~60Hz
  OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 430.50
  direct render: Yes
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio
  vendor: ZOTAC Sunrise Point-H driver: snd_hda_intel v: kernel
  bus ID: 00:1f.3
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
  v: kernel bus ID: 01:00.1
  Sound Server: ALSA v: k4.15.0-66-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ZOTAC driver: r8169 v: 2.3LK-NAPI port: d000 bus ID: 02:00.0
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ZOTAC driver: r8169 v: 2.3LK-NAPI port: c000 bus ID: 03:00.0
  IF: enp3s0 state: down mac: <filter>
  Device-3: Intel Wireless 3165 driver: iwlwifi v: kernel port: c000
  bus ID: 04:00.0
  IF: wlp4s0 state: up mac: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 269.36 GiB (57.8%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT500P1SSD8 size: 465.76 GiB
Partition:
  ID-1: / size: 456.96 GiB used: 269.35 GiB (58.9%) fs: ext4
  dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: 36.5 C mobo: 29.8 C gpu: nvidia temp: 27 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 219 Uptime: 2m Memory: 15.63 GiB used: 1.03 GiB (6.6%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
  inxi: 3.0.32
Titel: Re: System friert ein
Beitrag von: ole_hilja am 12.11.2019, 22:30:31
Da habe ich eine Vermutung, dass die Kombi aus CPU, Graka und Kernel für das Einfrieren verantwortlich sind. Da könnte man auf den Kernel 5.3 gehen und schauen ob damit es besser läuft.

Zuerst im Menue -->Systemverwaltung-->Treiberverwaltung, dort auf den nouveau-Treiber gehen und reboot.
Dann im menue -->Systemverwaltung-->Aktualisierungsverwaltung öffnen
Dort unter Ansicht-->Linux-Kernel wählen, Linux-Kernel 5.3.0-19 auswählen und installieren, danach reboot.
Dann wieder in der Treiberverwaltung auf den Nvidia-Treiber gehen und letzer reboot.
Probieren wie es läuft und dann hier bitte Rückmeldung
Titel: Re: System friert ein
Beitrag von: steje am 12.11.2019, 22:41:37
Hatte ich auch mal! Prüfe mal den RAM auf Fehler und oder den Treiber der Grafikkarte.

Bei mir war in der Vergangenheit mal ein RAM-Modul defekt und dann war es mal der falsche NVIDIA Treiber.

Memtest
Titel: Re: System friert ein
Beitrag von: Hollex am 12.11.2019, 22:54:21
Seit einigen Tagen hab ich das Problem das mein Mint 19.2 so ein oder zweimal in einer halben Stunde einfriert. An manchen Tagen gibt es aber auch überhaupt keinen Absturz.
Ein noch anderer Ansatz:
Ich würde mal versuchen, einen neuen "frischen" User anzulegen als Test und dann
schauen, ob Cinnamon stabil läuft. Falls das geht, könnte eventuell dann wohl nur die Session defekt sein.
Dann könnte folgendes helfen:
rm -rf ./.config/cinnamon-session ./.local/share/cinnamon ./.cinnamonDanach ist der Account so neu, dass Cinnamon alles wieder sauber anlegt.
Titel: Re: System friert ein
Beitrag von: kay0815 am 13.11.2019, 20:18:58
Hallo zusammen,

danke für die verschiedenen Ansätze, ich werd es der Reihe nach abarbeiten.
Hab auf den nouveau-Treiber umgestellt, aufgrund unscharfer Desktopschrift hab ich den vor einigen Monaten auf den Nvidia-Treiber umgestellt. Naja, trotz Umstellung auf nouveau und mehrerer Neustarts ist die Schrift bisher noch scharf geblieben.
Den Kernel hätte ich gern ebenfalls umgestellt aber ich finde nur den 4.15 in vielen Varianten. Ich meine den 5.3.0-x auch dort schon gesehen zu haben, aktuell ist er jedenfalls nicht da. Warum bzw. wie komm ich zu diesem Kernel?

Viele Grüße, Kay
Titel: Re: System friert ein
Beitrag von: ole_hilja am 13.11.2019, 22:18:00
Bisher mit dem nouveau-Treiber einen Freeze gehabt?
In meinem Testsystem 19.2 wird der Kernel 5.3 angeboten.

Edit:
Mit dem 5.3er Kernel bitte warten, scheint hier im Moment gerade Änderungen zu geben: https://www.linuxmintusers.de/index.php?topic=57783.msg776029 (https://www.linuxmintusers.de/index.php?topic=57783.msg776029)
Titel: Re: System friert ein
Beitrag von: ole_hilja am 14.11.2019, 19:57:52
In Sachen Kernel können wir jetzt weiter machen, ist wieder alles im Lot. Als erstes über die Aktualisierungsverwaltung das System aktualisieren. Dann ein reboot (da wahrscheinlich auch ein neuer 4.15er dabei ist). Weiter gehts, wie schon beschriebn mit dem Installieren vom 5.3er Kernel.

Hast du in der Zwischenzeit die anderen Lösungsansätze probiert? Gibt es Erkenntnisse daraus?

Titel: Re: System friert ein
Beitrag von: kay0815 am 15.11.2019, 13:57:44
bisher nur auf den nouveau-Treiber gewechselt, und seitdem kein Absturz. Aktualisierungsverwaltung zeigt seit gestern auch die anderen Kernel an, aber ich hab dort noch nichts verändert. Mittlerweile gibt es auch einen neueren NVIDIA-Treiber.
Bin aktuell etwas unschlüssig, ob weiter auf den nächsten freeze warten oder neuen Kernel und neuesten NVIDIA Treiber direkt installieren?
memtest steht noch aus.

Viele Grüße, Kay
Titel: Re: System friert ein
Beitrag von: kay0815 am 15.11.2019, 18:22:22
Sorry, noch mehr Fragen:
...hab gerade nochmal in die Treiberverwaltung geschaut, dort kann ich nichts mehr umstellen und obwohl ich mir sicher bin, den nouveau-Treiber ausgewählt zu haben, bin ich mir nicht sicher was mir die Ansicht sagen möchte. Ich kann auch nichts auswählen, die Radiobuttons sind alle inaktiv..., warum?
Aktuell noch kein freeze.

Viele Grüße, Kay
Titel: Re: System friert ein
Beitrag von: ole_hilja am 15.11.2019, 21:54:59
Dein warum kann ich leider von hier nicht beantworten. Bez. aktuellen Grafiktreiber bitte inxi -G damit man den Stand sieht. Dann bitte das System aktualisieren. Sollte danach in der Treiberverwaltung immer noch der jetzige Zustand herrschen, dann löschen wir übers Terminal mal alle Nvidia-Treiber.
sudo apt purge nvidia*
Danach ist es deine Entscheidung ob du neuen Nvidia oder den anderen Kernel ausprobieren möchtest. Gib einfach Bescheid  :)
Titel: Re: System friert ein
Beitrag von: kay0815 am 15.11.2019, 22:24:06
:~$ inxi -G
Graphics:
  Device-1: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nvidia v: 430.50
  Display: x11 server: X.Org 1.19.6 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 3840x2160~60Hz
  OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 430.50

NVIDIA Treiber mit purge deinstalliert.
Ich teste den neuen NVIDIA und anschließend den neuen Kernel, falls noch Abstürze auftreten...
Nach dem Neustart zeigt inxi -G
Graphics:
  Device-1: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nouveau
  v: kernel
  Display: x11 server: X.Org 1.19.6 driver: nouveau
  unloaded: fbdev,modesetting,vesa resolution: 3840x2160~30Hz
  OpenGL: renderer: NV137 v: 4.3 Mesa 19.0.8

Mittels Treiberverwaltung sind nun auch die verschiedenen Treiber auswählbar, ich installiere darüber den NVIDIA 435...
Titel: Re: System friert ein
Beitrag von: kay0815 am 15.11.2019, 22:47:50
...leider erneut ein Absturz mit dem aktuellsten Treiber, jetzt teste ich zusätzlich den Kernel

Titel: Re: System friert ein
Beitrag von: kay0815 am 16.11.2019, 12:34:14
...Kernel installiert soweit ganz gut, heute kurz nach dem Desktop laden nach der Anmeldung Absturz

wie genau bekomme ich memtest zu laufen? Hab einen Stick zum Installieren verwendet und sehe keine Memtest bzw. Speichertestfunktion. Soweit ich bisher in Erfahrung bringen konnte müsste man von uefi auf bios umstellen, wie macht man das genau? Gibt es Alternativen?

Viele Grüße, Kay
Titel: Re: System friert ein
Beitrag von: ole_hilja am 17.11.2019, 20:54:05
Bei der Kernelinstallation 5.3 wie in AW #3 erst auf den nouveau gegangen, dann Kernel installiert und danach den Nvidia? Der Nvidia wird immer für einen Kernel installiert, d.h. wenn du ihn bei 4.15-xx installiert hast und installierst 4.15-xy oder 5.3-xx, dann hast du den Treiber für einen vorherigen Kernel und das führt zu Problemen. Das könnte auch ein Grund sein, dass ein manuell installierter Treiber angezeigt wurde.

Bez. Memtest, bei Biosinstallation befindet es sich im Grub-Menue. Bei Uefi muss ich passen, habe zwar Uefi-Rechner aber der ist im Legacy-Mode, d.h. der arbeitet mit Bios.

Edit:
Beim Nvidia-Treiber haben wir auch noch Chance hier ein PPA einzubinden und somit die neusten Treiber zu bekommen.
Titel: Re: System friert ein
Beitrag von: BR01 am 17.11.2019, 21:33:54
Nur so am Rande, wenn man die Nvidiatreiber mittels sudo apt purge nvidia* entfernt hatte, bleibt meist immer noch etwas zurück. Ein
dpkg -l | grep nvidia listet es auf und was dann ausgegeben wird, weg purgen mittels sudo apt purge.... Allerdings zuvor den freien Treiber aktivieren. War bei mir vor kurzen in Mint 19.2 Cinnamon so.

Zum Systemeinfrieren, was ich auch schon unter XFCE sowie Mate als GUI hatte, half bei meinem i5-5200U seinerzeit eine Bootoption im grub, jenes zu beseitigen. Der TE hat zwar einen höheren i5, aber testen kann er ja es einmal.
Jene Zeile in /etc/default/grub, so abgeändert: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"Danach noch ein sudo update-grubund jenes beobachten.
Versuch macht kluch (klug).
Titel: Re: System friert ein
Beitrag von: kay0815 am 21.11.2019, 19:37:20
danke für die Rückmeldungen:
habe heute in dieser Reihenfolge folgendes gemacht:
-auf den nouveau-Treiber gewechselt und neu gestartet
-sudo apt purge nvidia*
tatsächlich gibt es anschließend mit dpkg -l | grep nvidia noch eine ganze Menge Einträge
-sudo apt purge bis eine leere Liste angezeigt wird
-intel_idle.max_cstate=1 in der grub datei ergänzt
-sudo update-grub durchgeführt
-Neustart

Die Aktualisierungsverwaltung möchte noch einiges updaten, das mache ich auch noch? Nvidiatreiber nochmal installieren?

Viele Grüße, Kay
Titel: Re: System friert ein
Beitrag von: ole_hilja am 21.11.2019, 21:38:16
System aktuell halten --> ja, d.h. über die Aktualisierungsverwaltung updates durchführen
Ich würde jetzt 1 -2 Tage so arbeiten um zu prüfen ob in diesem Zustand ein freeze passiert und dann den Nvidia-Treiber installieren
Titel: Re: System friert ein
Beitrag von: kay0815 am 22.11.2019, 14:41:22
ok, wird gemacht. Danke.
Titel: Re: System friert ein
Beitrag von: kay0815 am 30.11.2019, 10:10:46
...nachdem ich bis heute keinen Freeze mehr hatte, hab ich den NVIDIA-Treiber installiert. Leider nach einer halben Stunde den ersten Freeze.  :o

Viele Grüße, Kay
Titel: Re: System friert ein
Beitrag von: toffifee am 30.11.2019, 10:58:04
Bei deiner Hardware, wie oben schon mal erwähnt, den 5.3er Kernel mal probieren. Vorher wieder zurück auf Nouveau.
Titel: Re: System friert ein
Beitrag von: steje am 01.12.2019, 00:33:37

Post von  @Hashikawa. Ich habe zwar nur einen AMD, aber seit ich das hier so eingestellt habe, hatte ich keinen freeze mehr.
Dachte auch es wäre die Grafikkarte. Habe alles probiert. Aber das hier war für mich die Lösung.

Vielleicht geht das bei deinem Intel ja auch. Probieren kann man das ja mal, falls es die Einstellung bei dir im Bios gibt, k.A.
______________________________________________________________________________________________________

Schau Dir mal den Thread unter http://forum.asrock.com/forum_posts.asp?TID=7890 an.

Ich hatte bei meinem MSI x370 SLI Plus Mainboard mit Ryzen 7 1800x CPU die gleichen Symptome mit dem Einfrieren des ganzen Systems bei wenig Last oder im Idle Betrieb.

Abhilfe brachte im Bios bei den CPU Features "Core C6 State" auf "disabled" zu setzen.

Schau mal ob es diese Einstellung bei Dir im Bios auch gibt. Kann sein, dass bei neueren Bios Versionen der Punkt auch "Global C States" heißt. Evtl. auch noch wie oben im Thread beschrieben die "Power Supply Idle Control" auf "Typical Current Idle" stellen.