LMU - Das Hilfe Forum für Linux Mint

Software => Ärger mit Software? => Thema gestartet von: tolomeo-user am 04.11.2019, 07:34:59

Titel: git gui: Rechtschreibprüfung nicht verfügbar
Beitrag von: tolomeo-user am 04.11.2019, 07:34:59
Nach der Installation und dem Start von `git gui` erhalte ich folgende Fehlermeldung:

Zitat
git gui: Rechtschreibprüfung nicht verfügbar
(siehe Screenshot).

Habe schon `sudo locale-gen` sowie `sudo locale-gen de_DE.UTF-8` und Neustart durchgeführt. Fehlermeldung kommt weiterhin.

Auf der Konsole erhalte ich folgende Hinweise:
Error in startup script: can't invoke "grab" command: application has been destroyed
    while executing
"grab release $grab"
    (procedure "::tk::RestoreFocusGrab" line 11)
    invoked from within
"::tk::RestoreFocusGrab $w $focus"
    (procedure "::tk::MessageBox" line 288)
    invoked from within
"::tk::MessageBox {*}$args"
    (procedure "tk_messageBox" line 2)
    invoked from within
"tk_messageBox -icon error -type ok -title Fehler -message {Rechtschreibprüfung nicht verfügbar:

Fehler: No word lists can be found for the language..."
    ("eval" body line 1)
    invoked from within
"eval $cmd"
    (procedure "error_popup" line 10)
    invoked from within
"error_popup [strcat [mc "Spell checking is unavailable"] ":\n\n$err"]"
    (procedure "_connect" line 28)
    invoked from within
"_connect $this $pipe_fd"
    (procedure "spellcheck::init" line 7)
    invoked from within
"spellcheck::init  $spell_fd  $ui_comm  $ui_comm_ctxm  "
    invoked from within
"if {[winfo exists $ui_comm]} {
set GITGUI_BCK_exists [load_message GITGUI_BCK utf-8]

# -- If both our backup and message files exist use the
#    ..."
    (file "/usr/lib/git-core/git-gui" line 3914)
Wie kann ich die Sprache Deutsch einstellen?
Titel: Re: git gui: Rechtschreibprüfung nicht verfügbar
Beitrag von: tolomeo-user am 23.11.2019, 19:03:54
Hab's gelöst. - Linux Mint 18.3 scheint für die Sprache `DE` unvollständig ausgeliefert zu sein.
Es musste folgendes nachinstalliert werden:

sudo apt install language-selector-gnome
und außerdem:
sudo apt-get install aspell-de

Danach ist der Fehler verschwunden.
Titel: Re: git gui: Rechtschreibprüfung nicht verfügbar
Beitrag von: toffifee am 23.11.2019, 19:12:41
Prima, dann setze bitte noch ein "gelöst" oder "erledigt": dazu den Eröffnungspost "ändern" und das Präfix setzen. Dann sehen andere gleich, dass hier keine Hilfe mehr notwendig ist. (Anleitung: https://www.linuxmintusers.de/index.php?topic=3603.0)
Titel: Re: git gui: Rechtschreibprüfung nicht verfügbar
Beitrag von: tolomeo-user am 23.11.2019, 23:46:11
👍