LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Installation & Updates => Thema gestartet von: flist am 03.07.2018, 22:09:50

Titel: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: flist am 03.07.2018, 22:09:50
Hey!

Ich habe heute Linux Mint 19 Mate installiert und bei mehrmaligen reboots ist mir aufgefallen, dass das booten sehr lange dauert.
Allerdings geht hierbei die meiste Zeit beim Vorgang vom Linux-Symbol am Anfang zum Anmeldebildschirm drauf.
Nachdem ich im Grub Linux Mint ausgewählt habe, dauert es ca. 11 Sekunden, bis das Linux-Logo aufgetaucht und wieder verschwunden ist. Dann vergehen ganze 120 Sekunden bis die Anmeldemaske erscheint. Der Login funktioniert dann wieder in normaler Geschwindigkeit.

systemd-analyze blame:
10.101s ntp.service
          6.343s NetworkManager-wait-online.service
           351ms NetworkManager.service
           286ms udisks2.service
           251ms dev-sda5.device
           206ms systemd-resolved.service
           179ms ubuntu-system-adjustments.service
           177ms networkd-dispatcher.service
           135ms systemd-journal-flush.service
           120ms ModemManager.service
           113ms lightdm.service
           112ms accounts-daemon.service
           107ms avahi-daemon.service
           104ms plymouth-quit-wait.service
            84ms upower.service
            73ms speech-dispatcher.service
            69ms networking.service
            69ms grub-common.service
            68ms rsyslog.service
            67ms systemd-udev-trigger.service
            63ms lm-sensors.service
            62ms apparmor.service
            59ms polkit.service

systemd-analyze time:
Startup finished in 4.383s (kernel) + 16.298s (userspace) = 20.681s
graphical.target reached after 16.287s in userspace

Hat jemand eine Idee, woran das liegen könnte? Unter Mint 18.3 hatte ich keinerlei Probleme.

Aktiver Kernel ist 4.15.0-24

Danke für Eure Antworten!
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Notiz am 03.07.2018, 22:23:02
Aktiver Kernel ist 4.15.0-24

Mit dem 24er Kernel haben einige Leute Probleme - boote mal mit einem älteren Kernel. Gibt auch schon ein paar Threads dazu.
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: flist am 03.07.2018, 22:45:28
Tatsächlich... mit dem 20er funktionierts ohne Probleme. Danke dir!
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: OlliFri am 04.07.2018, 00:33:00
Habe nach langen stöbern im Netz, im Debian Forum einen interessanten Post gefunden. Dem nach braucht man nur
sudo apt install havegedinstallieren und der Spuck ist vorbei.
Bei mir hat es voll gefunzt.
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Nolan am 04.07.2018, 02:26:31
Hallo Olli, habe es eben ausprobiert und es läuft alles tadellos. Super.

Nolan
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Fritx am 04.07.2018, 06:31:07
...und der Spuck ist vorbei.

Spuk vorbei. Erste Sahne!  :)
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Porco am 14.07.2018, 09:05:16
Ausprobiert, leider Spuk nicht vorbei. Naja, ansonsten läuft. Andere Kernel ausprobiert ! Braucht 38 Sekunden.

Windows 10 auf einer anderen SSD braucht 5 Sekunden.

Kann es sein weil ich beim partionieren LVM verwende ?
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Explorer4x4 am 15.07.2018, 11:03:11
Warum ist es soooooo wichtig, wie lange das BS zum hochfahren braucht? Ob 5 sec oder 2 min, ich will das BS doch nicht dauernd rauf und runter fahren, sondern mit arbeiten, und wenn es gestartet ist, läuft es doch problemlos, oder habt ihr dann immer noch Schwierigkeiten?.
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: hanfiey am 16.07.2018, 10:38:13
Es wird einen Grund haben warum das so lahm läuft und den würde ich auch wissen wollen. Ist die CPU Auslastung zu hoch oder der RAM alle?, das wäre für mich ein Grund das update zu verschieben oder auszulassen. Es gab vor Jahren schon mal das Problem mit der Performance und ich hab den Eindruck das bei Mint Fehler "mitgeschleppt" werden aus alten Tagen.
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: toffifee am 16.07.2018, 11:00:06
Bei Bootverzögerungen sollte der erste Blick der fstab gelten, ob alle dort eingetragenen Partitionen auch erreichbar sind. Wenn nicht, sorgt das Warten für 90 Sekunden Pause... ::)
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Hollex am 16.07.2018, 11:10:06
Zitat
Ausprobiert, leider Spuk nicht vorbei. Naja, ansonsten läuft. Andere Kernel ausprobiert ! Braucht 38 Sekunden.

Windows 10 auf einer anderen SSD braucht 5 Sekunden.

was sagt denn bitte:
journalctl -xb -p err
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Porco am 16.07.2018, 17:34:05
-- Logs begin at Fri 2018-07-13 10:49:45 CEST, end at Mon 2018-07-16 17:34:58 CEST. --
Jul 16 17:29:55 Kern kernel: nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 3e6684 [ IBUS ]
Jul 16 17:29:55 Kern kernel: nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 10ac08 [ IBUS ]
Jul 16 17:29:58 Kern lightdm[992]: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jul 16 17:29:58 Kern lightdm[992]: PAM adding faulty module: pam_kwallet.so
Jul 16 17:29:58 Kern lightdm[992]: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Jul 16 17:29:58 Kern lightdm[992]: PAM adding faulty module: pam_kwallet5.so
Jul 16 17:29:59 Kern lightdm[1091]: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jul 16 17:29:59 Kern lightdm[1091]: PAM adding faulty module: pam_kwallet.so
Jul 16 17:29:59 Kern lightdm[1091]: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Jul 16 17:29:59 Kern lightdm[1091]: PAM adding faulty module: pam_kwallet5.so
Jul 16 17:30:02 Kern colord-sane[956]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Jul 16 17:30:04 Kern lightdm[1291]: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jul 16 17:30:04 Kern lightdm[1291]: PAM adding faulty module: pam_kwallet.so
Jul 16 17:30:04 Kern lightdm[1291]: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Jul 16 17:30:04 Kern lightdm[1291]: PAM adding faulty module: pam_kwallet5.so
Jul 16 17:30:10 Kern pulseaudio[1584]: [pulseaudio] pid.c: Daemon already running.
Jul 16 17:30:34 Kern pulseaudio[1481]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
lines 1-19/19 (END)

Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Hollex am 16.07.2018, 19:28:07
scheinbar hat dein Rechner bei booten mit dem Program kwallet zu tun...
evt. mit einem fehlerhaften oder nicht vorhandenen link (/lib/security/pam_kwallet.so), wie Du selbst siehst.

https://askubuntu.com/questions/879557/slow-boot-on-ubuntu-16-04-issue-with-pam-kwallet5-so

wenn Du Wlan benutzt, könnte auch dort die lange Bootzeit ihre Ursache haben.
ein Check des Wlan-Treiber könnte nix schaden.
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Porco am 16.07.2018, 21:08:18
Habe das nicht installiert und nutze kein Wlan und ist auch kein WLAN Modul verbaut :(
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: hanfiey am 17.07.2018, 12:06:03
Es soll Probleme mit dem Zufallsgenerator geben, weil nicht genug Zahlen zur Verfügung stehen wartet der Rechner einfach. Die Zahlen werden durch Eingaben wie Maus + Tastatur erzeugt und die benutzt niemand beim Booten. Ich hatte da gestern noch was gelesen zu....Warum haveged keine Abhilfe schaft weiß ich jetz auch nicht da dieses Programm einfach Zahlen liefert ohne Eingabegeräte
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Pengu am 17.07.2018, 16:20:10
Ich habe mal geschaut wo es bei mir hackt, denn die 19er Mate Version bootet an die 30 Sekunden langsamer
an die 15 sekunden braucht das scanning for btrfs file systems warum auch immer, die 18.3 nur 3 Sekunden  :o 

Habe bei mir dann wieder die 18.3 Mate drauf gemacht da die 19er noch nicht wirklich Fehlerfrei ist
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Porco am 17.07.2018, 17:09:06
Ich warte so 1-2 Wochen ab, vielleicht tut sich da noch was  :D
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Armin_2015 am 17.07.2018, 18:05:10
Die letzten Tage habe ich eine Hand voll Laptops und Zboxen auf Linux Mint 19 Cinnamon umgestellt (jeweils Neuinstallation).

Bei allen Rechnern ist der Bootvorgang deutlich länger geworden. Das Mint-Logo erscheint z. B. ca. doppelt so lang, bevor der Anmeldebildschirm kommt. Zur Fehlersuche bzw. Optimierung fehlt mir momentan die Zeit.

Danke allerdings für diese Diskussion und den vielversprechenden Lösungsmöglichkeiten. Es beruhigt mich, dass ich nicht der Einizige mit dem Problem bin.

Viele Grüße

Armin
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Porco am 18.07.2018, 09:42:46
Das andere auch das Problem haben beruhigt mich auch  :D :(
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: sven0907 am 26.07.2018, 23:31:44
Hallo Zusammen,

ich nutze auch LM 19 mit Cinamon. Das Notebook ist ein Aspire v3 mit core i5 16 GB RAM und SSD. und irgend ne interne onboard Grafik....
Ich habe das selbe Problem und wie ich gerade festgestellt habe  wohl noch einige mehr. haveged bringt gar nichts. Aber die Ausgabe von  journalctl folgende Erkenntnis.

Kann es ggf an der Fehlenden SWAP Partition liegen? Ich hab keine da ich die bei 16 GB Ram nicht benötige.

  - Logs begin at Tue 2018-07-24 00:03:50 CEST, end at Thu 2018-07-26 23:25:11 CEST. --
Jul 26 22:43:22 Aspire-V3 kernel: [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to versio
Jul 26 22:43:22 Aspire-V3 kernel: ACPI Error: No handler for Region [RAM_] (00000000eea0d895) [EmbeddedControl] (2017083
Jul 26 22:43:22 Aspire-V3 kernel: ACPI Error: Region EmbeddedControl (ID=3) has no handler (20170831/exfldio-299)
Jul 26 22:43:22 Aspire-V3 kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.EC0._REG, AE_NOT_EXIST (20170
Jul 26 22:43:22 Aspire-V3 kernel: ACPI Error: No handler for Region [RAM_] (00000000eea0d895) [EmbeddedControl] (2017083
Jul 26 22:43:22 Aspire-V3 kernel: ACPI Error: Region EmbeddedControl (ID=3) has no handler (20170831/exfldio-299)
Jul 26 22:43:22 Aspire-V3 kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.EC0._REG, AE_NOT_EXIST (20170
Jul 26 22:43:23 Aspire-V3 bluetoothd[931]: Failed to set mode: Blocked through rfkill (0x12)
Jul 26 22:43:24 Aspire-V3 wpa_supplicant[914]: dbus: wpa_dbus_get_object_properties: failed to get object properties: (n
Jul 26 22:43:24 Aspire-V3 wpa_supplicant[914]: dbus: Failed to construct signal
Jul 26 22:43:24 Aspire-V3 lightdm[1128]: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open
Jul 26 22:43:24 Aspire-V3 lightdm[1128]: PAM adding faulty module: pam_kwallet.so
Jul 26 22:43:25 Aspire-V3 lightdm[1214]: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open
Jul 26 22:43:25 Aspire-V3 lightdm[1214]: PAM adding faulty module: pam_kwallet.so
Jul 26 22:43:32 Aspire-V3 pulseaudio[1558]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent
Jul 26 22:43:32 Aspire-V3 pulseaudio[1598]: [pulseaudio] pid.c: Daemon already running.

Und nun?

- Was soll das mit dem Firmware Bug? Ich hab unter LM18.xx immer in der Treiberverwaltung proprietäre Treiber bekommen nun nicht mehr.
- Das mit der Fehlenden Lib mag ich auch nicht verstehen  woher bekomme ich die?
- Bluetooth hab ich immer deaktiviert und noch nicht getestet aber unter LM 18.xx hat es immer funktioniert.
- Kernel hab ich vom 04.15-0-20 bis 29 alle ausprobiert aber keine Besserung.
- Bei mir ist es so das nach dem Einschalten das V3 Logo kommt dann sieht man die Hintergrundbeleuchtung des Displays (und waaaaartet)
Dann kommt das Mint Logo und ab da geht es recht schnell.

- Es gibt in vielen Foren Meldungen dazu aber irgendwie noch keine Lösung.
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: tommix am 27.07.2018, 00:30:58
Das Problem könnte jetzt
sudo apt install havegedsein.

Hatte das Problem auf meinem i7 auch nach der Installation von haveged.
Ein Systemstart dauerte dann so ca. 15 Min.
Habe auf der  SSD  dann eine neue GPT erstellt und Cinnamon, Mate Xfce und Xfce Ultimate neu installiert. Jetzt summt er wieder wie ein Binchen mit Kernel 4.15,0 - 29.
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Porco am 27.07.2018, 10:09:32
Frage:

Mate Xfce und Xfce Ultimate , wo das der Vorteil dran und wie installiere ich 3 verschiedene Linux Version auf einer GPT ?
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: tommix am 27.07.2018, 14:43:10
@Porco

GPT ist doch die neue Partitionstabelle, vor allem für UEFI - Rechner. (msdos ist die alte)
Man erspart sich mit der GPT das gefummel mit Prämieren und erweiterten Partitionen, weil alles Primäre sind.
Dann teilt man mit GParted die Platte auf.
z.B.: bei UEFI- Rechnern im UEFI - Mode

1. eine EFI Partition (FAT32) wo grub installiert wird z.B.: 512 MB und setzt die Flag's esp und boot für dies Partition.
2. soviel ext4 Partitionen erstellen, wie man Systeme installieren will.
    In meinem Fall dann noch ein SWAP - Partition weil LM 18.3.2 Xfce Ultimate.

Und so sieht das HDD oder SSD dann aus:

Und dann fängt man an zu installieren über den Zweig "etwas anderes" 
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: sven0907 am 28.07.2018, 22:22:58
@ tommix, das klingt super und ich werde das bei Gelegenheit mal probieren aber das löst ja das eigentliche Problem nicht.

Mir sind inzwischen ein paar sehr merkwürdige Sachen aufgefallen. Vorab das Problem mit der  fehlenden (pam_kwallet.so) das gibt es auch unter LM18.2.

Ich hab bei meiner Config zwar eine Swappartition aber diese ist deaktiviert. Ebenso setzte ich in der sysctl.conf --> vm.swappiness=0. Sollte ich Dinge tun wo voraussichtlich die 16 GB Ram nicht genügen kann ich diese bei bedarf mounten. Ebenso nutze ich einig tmpfs inkl. einer 6GB RAm Disk welche ich ebenfalls nur bei Bedarf mounte. Anbei der Auszug aus der fstab.

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=f0b84299-60ec-46d4-bf88-dd8d0282e9bb /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=d0c1a1a9-4598-4557-b5f5-254191ebfa5f /boot           ext4    defaults        0       2
# /home was on /dev/sda3 during installation
UUID=4133b3d2-ad0c-464d-892e-2f5d1d981969 /home           ext4    defaults        0       2
# swap was on /dev/sda4 during installation
UUID=91965834-0130-421b-aea2-9facc38b6522 none swap sw,noauto 0 0
 
tmpfs  /home/sven/.cache    tmpfs   defaults,nosuid,size=1G     0   0
tmpfs   /tmp                  tmpfs   defaults,nosuid,size=2G     0   0
tmpfs   /RAM-Disk/              tmpfs   nosuid,noauto,size=6G       0   0

Und da auch ich Faul bin habe ich die swap Partition immer über das mitgelieferte Disk (Laufwerks Tool) deaktiviert. siehe Bild im Anhang:
Aber unter LM19 geht das nicht Ich konnte sie zwar abschalten aber ich konnte über das Tool nicht wie sonst verhindern das diese automatisch beim Start Eingehangen wird.
Irgendwie scheint es immer wahrscheinlicher das es irgendwelche Probleme mit den Partitionstabellen von msdos gibt. Ich bin hier leider kein Profi und
hab jetzt wieder LM18.2 drauf bin damit aber unglücklich zudem gab es unter LM 18.3 auch schon Problem mit Nemo und nun das.....

@ tommix kann man das ggf prüfen oder genauer Feststellen ob das msdos hier wirklich das Problem ist?

Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Porco am 02.08.2018, 10:10:03
@tommix

Ich glaube das mach auch mal so :-),

LM Cinnamon 19
LM 18.3.2 Ultimate

, kannst mir noch die tollen Features von Ultimate sagen und wo man die bezieht   :D ?
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Porco am 11.08.2018, 09:01:35
So , habe es hiermit versucht

sudo apt install haveged
sudo systemctl enable haveged
sudo systemctl start haveged

,klappt leider nicht da folgende Fehlermeldung

Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: tommix am 11.08.2018, 16:59:20
@tommix

Ich glaube das mach auch mal so :-),

LM Cinnamon 19
LM 18.3.2 Ultimate

, kannst mir noch die tollen Features von Ultimate sagen und wo man die bezieht   :D ?

Dann schau mal da rein!

https://www.linuxmintusers.de/index.php?topic=46737.msg676668#msg676668 (https://www.linuxmintusers.de/index.php?topic=46737.msg676668#msg676668)
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: tommix am 11.08.2018, 17:50:37
So , habe es hiermit versucht

Das sollte sich mit dem 4.15.0 - 29 oder 4.15.0 - 30 auch erledigt haben!? 
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: sven0907 am 13.08.2018, 11:02:58
Also mit dem 4.15.x 29/30 besteht das Problem weiterhin.

Wer sagt eigentlich was dieses ominöse Paket "haveged" tut? Ich lese nur, "das Installieren alle" aber niemand fragt was das macht und wohhr es kommt....
Und wieso kommt hier keine Abhilfe von seitens der Mint Entwickler? Das war schon bei dem Anzeige Problem der 18.3 Version so. Langsam nervt es....
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: CLImate am 13.08.2018, 11:32:31
Das wurde in anderen Threads schon besprochen., z. B.
https://www.linuxmintusers.de/index.php?topic=49525.msg691229#msg691229
apt show haveged
Zitat
Und wieso kommt hier keine Abhilfe von seitens der Mint Entwickler?
Mint nutzt den Unterbau von Ubuntu. Wer sagt denn, dass sie sich nicht bereits an Ubuntu gewendet haben wie das Problem zu lösen sei?

Off-Topic:
Außerdem, was motzt du hier rum? Du hast den Thread gekapert. :P
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: ehtron am 13.08.2018, 11:55:28
Hi :)
ich denke niemand der sich informiert hat, wird sich das installieren.. ist auch nicht nötig.. war nur ein work around für den -23er der probleme hatte den random demon zu initialisieren.
bloss weil etwas empfohlen wird, sollte man es nicht grundsätzlich machen ;)

überlege wie viele dinge dir im leben empfohlen wurden, und wie übel das ausgegangen wäre, wärst du immer brav gefolgt ;)
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Porco am 14.08.2018, 10:03:54
@Porco

GPT ist doch die neue Partitionstabelle, vor allem für UEFI - Rechner. (msdos ist die alte)
Man erspart sich mit der GPT das gefummel mit Prämieren und erweiterten Partitionen, weil alles Primäre sind.
Dann teilt man mit GParted die Platte auf.
z.B.: bei UEFI- Rechnern im UEFI - Mode

1. eine EFI Partition (FAT32) wo grub installiert wird z.B.: 512 MB und setzt die Flag's esp und boot für dies Partition.
2. soviel ext4 Partitionen erstellen, wie man Systeme installieren will.
    In meinem Fall dann noch ein SWAP - Partition weil LM 18.3.2 Xfce Ultimate.

Und so sieht das HDD oder SSD dann aus:

Und dann fängt man an zu installieren über den Zweig "etwas anderes"

Du meinst während der Installation "etwas anderes" oder wo kommt es vor  und wieso ist deine SWAP zu riesig ?

@tommix

Ich glaube das mach auch mal so :-),

LM Cinnamon 19
LM 18.3.2 Ultimate

, kannst mir noch die tollen Features von Ultimate sagen und wo man die bezieht   :D ?

Dann schau mal da rein!

https://www.linuxmintusers.de/index.php?topic=46737.msg676668#msg676668 (https://www.linuxmintusers.de/index.php?topic=46737.msg676668#msg676668)

Ui, das aber ein sehr kribbliges Erscheinungsbild in der Live Ultimate Mint Version  :o
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: tommix am 14.08.2018, 12:46:20
wieso ist deine SWAP zu riesig ?

Intel i7 mit 16 GB RAM!
18 GB waren noch frei also soll er ruhig alles nehmen! was soll ich sonst mit 2 GB anfangen?
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: tommix am 14.08.2018, 12:48:47
Ui, das aber ein sehr kribbliges Erscheinungsbild in der Live Ultimate Mint Version  :o

UE läuft aber recht gut!
Bei mir sogar jetzt als Ultimate Edition als LM 19!
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Porco am 14.08.2018, 15:48:56
Ok, aber lässt sich über Themes doch ändern oder ?
Titel: Re: Linux Mint 19 Mate bootet langsam: mögliche Lösung
Beitrag von: weissnimma am 08.09.2018, 11:04:09
Hallo, nur als Hilfe: Bei mir bootete LM nach Upgrade auf die 19 plötzlich gut 40 Sek. auf der SSD. Habe dann alles mögliche ausprobiert und wurde schließlich hier fündig: https://forums.linuxmint.com/viewtopic.php?t=272947
Kurz: mithilfe des Grub-Eintrags GRUB_CMDLINE_LINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d" plus Ausklammern der Zeile GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" wurde bei mir folgender Fehler sichtbar: Das System blieb recht lange bei Scanning for BTRFS file system hängen.

Wer dieses Dateisystem gar nicht nutzt, kann die Unterstützung dafür komplett abschalten, siehe hier: https://forums.linuxmint.com/viewtopic.php?f=46&t=272960
Bitte dort schauen, ansonsten hier als Backup der Code:
sudo apt-get purge btrfs-tools
sudo update-initramfs -ukall
sudo apt purge btrfs-progs
sudo update-initramfs -ukall
Anschließend Neustart. Jetzt braucht der Start bis zur Anmeldung nur noch 7 Sekunden  :D
Die Änderungen in der Grub habe ich wieder rückgängig gemacht, sieht weniger verwirrend aus...
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Doppellhelix am 20.09.2018, 17:19:27
Hallo,

sudo apt-get purge btrfs-tools
sudo update-initramfs -ukall
sudo apt purge btrfs-progs
sudo update-initramfs -ukall



Leider hat das bei mir nicht funktioniert.

Ist es normal, daß bei dem Updatebefehl "Fehlermeldungen" auftreten?

sudo update-initramfs -ukall
update-initramfs: Generating /boot/initrd.img-4.15.0-34-generic
W: initramfs-tools configuration sets RESUME=UUID=288d6b66-e0b5-4375-9b10-3b3a7d336251
W: but no matching swap device is available.
update-initramfs: Generating /boot/initrd.img-4.15.0-33-generic
W: initramfs-tools configuration sets RESUME=UUID=288d6b66-e0b5-4375-9b10-3b3a7d336251
W: but no matching swap device is available.
update-initramfs: Generating /boot/initrd.img-4.15.0-20-generic
W: initramfs-tools configuration sets RESUME=UUID=288d6b66-e0b5-4375-9b10-3b3a7d336251
W: but no matching swap device is available.

Bin noch ziemlich neu in der Linuxmaterie.

Gruß Helix
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: CLImate am 20.09.2018, 18:41:52
Zitat
Ist es normal, daß bei dem Updatebefehl "Fehlermeldungen" auftreten?
Nein, und genau deshalb wird wohl 90 Sekunden gewartet.
cat /etc/fstab
cat /etc/initramfs-tools/conf.d/resume
sudo blkid
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Doppellhelix am 20.09.2018, 19:19:00
doppellhelix@doppellhelix-Lenovo-E50-80:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
# /boot/efi was on /dev/sda2 during installation
UUID=3E3E-22D3  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/sda7 during installation
#UUID=11a683d6-56b7-4db6-9970-b2c0a5159581 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0
# Mounten von NAS Filme/Serien
//192.168.33.2/Public /media/NAS cifs defaults,uid=1000,username=xxx,password=xxx
#Mounten von NAS Doppellhelix
//192.168.33.2/doppellhelix /media/NAS-Dcifs defaults,uid=1000,username=xxx,password=xxx

UUID=fc3a6277-ca8f-4c59-ac3d-1e919a85d308 / ext4 errors=remount-ro,x-gvfs-name=Mint 0 1
doppellhelix@doppellhelix-Lenovo-E50-80:~$ cat /etc/initramfs-tools/conf.d/resume
RESUME=UUID=288d6b66-e0b5-4375-9b10-3b3a7d336251
doppellhelix@doppellhelix-Lenovo-E50-80:~$ sudo blkid
[sudo] Passwort für doppellhelix:
/dev/sda1: UUID="2C2654EE2654BB12" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="2be9f578-226f-4a8c-9638-6626961cdf42"
/dev/sda2: UUID="3E3E-22D3" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="3f5830b3-4eae-47a2-823b-e5d38ef45e1d"
/dev/sda4: UUID="D232413232411D3B" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="764315ac-2472-4c64-b482-44ca02c3e228"
/dev/sda5: LABEL="Daten" UUID="2EB2A66DB2A638EB" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="1a42308c-1998-4a96-a59f-159ab2294e22"
/dev/sda6: UUID="fc3a6277-ca8f-4c59-ac3d-1e919a85d308" TYPE="ext4" PARTUUID="e5fa1e35-6e51-4f03-aa6a-cf86533e5dcb"
/dev/sda7: UUID="11a683d6-56b7-4db6-9970-b2c0a5159581" TYPE="swap" PARTUUID="4283fee7-43ce-453f-8950-064c228925ca"
/dev/mapper/cryptswap1: UUID="a7881c43-e19e-4bb1-9598-f968b4b5456d" TYPE="swap"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="57b7bdd4-8007-4571-a9ce-c5d551708a98"


P.S.
Wie stelle ich Code hier im Forum da?
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: billyfox05 am 20.09.2018, 19:23:34
entweder
siehe oben Hilfe oder
siehe Bild
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: CLImate am 20.09.2018, 19:28:08
Da es sich um eine zufällig-verschlüsselte swap handelt, ist ein Ruhezustand (bzw. Aufwachen = resume) eh nicht möglich, d. h. der Inhalt der Datei /etc/initramfs-tools/conf.d/resume kann mit erweiterten Rechen gelöscht werden. Danach das bereits bekannte
sudo update-initramfs -ukall
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Doppellhelix am 20.09.2018, 19:50:16
entweder
siehe oben Hilfe oder
siehe Bild

Danke. Hab vergessen die Seite in No Script frei zu schalten. Daher kein Menü.  :(


Da es sich um eine zufällig-verschlüsselte swap handelt, ist ein Ruhezustand (bzw. Aufwachen = resume) eh nicht möglich, d. h. der Inhalt der Datei /etc/initramfs-tools/conf.d/resume kann mit erweiterten Rechen gelöscht werden. Danach das bereits bekannte
sudo update-initramfs -ukall

Ok, habe ich gemacht.
Ausgabe:

sudo update-initramfs -ukall
update-initramfs: Generating /boot/initrd.img-4.15.0-34-generic
cryptsetup: WARNING: target cryptswap1 has a random key, skipped
update-initramfs: Generating /boot/initrd.img-4.15.0-33-generic
cryptsetup: WARNING: target cryptswap1 has a random key, skipped
update-initramfs: Generating /boot/initrd.img-4.15.0-20-generic
cryptsetup: WARNING: target cryptswap1 has a random key, skipped

Habe noch nicht gebootet. Wollte erst fragen, ob das jetzt so ok ist.
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: CLImate am 20.09.2018, 22:02:04
Ups, sorry. Vollverschlüsselung kenne ich besser als Teilverschlüsselung. Also dann doch die Datei löschen:
sudo rm /etc/initramfs-tools/conf.d/resumegefolgt von …
sudo update-initramfs -ukall
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: CLImate am 21.09.2018, 10:48:19
… Wobei ich hier (https://forum.ubuntuusers.de/post/8949382/) den Vorschlag lese, dass die cryptswap eingetragen werden solle. Was meines Wissen nach nicht funktionieren kann, aber vielleicht hat sich in der Zwischenzeit etwas geändert.

@Doppellhelix
Da du das Thema nicht gestartet hast, wäre es für die Dokumentation hilfreich, welches Betriebssystem du einsetzt.
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Doppellhelix am 21.09.2018, 16:51:06
Hallo,

nachdem ich den Inhalt der Resume Datei gelöscht habe, habe ich mitlerweile gebootet.
Das hat schon was gebracht, im Gegensatz zu früher ist der Start schneller.

@CLimate
natürlich habe ich auch Linux Mint 19 (Cinnamon) drauf.
Kernel: 4.15.0-34-generic
Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: sven0907 am 13.10.2018, 22:07:04
Hallo Zusammen,

Ich habe auch das Problem mit dem langsamen Booten und mich nun schon durch unzählige Foren gequält aber  nichts passendes gefunden.
Und ich muss hier nochmal Ausholen denn hier ist irgendwie nichts gelöst und ich möchte nicht zurück auf 18.2.

Also Mein Rechner Acer Aspire V3-371 (Intel core i5 , SSD und 16 GB RAM) LM Cinamon 19 ohne Verschlüsselung mit dem  Kernel 4.15.0-36-generic

Wo hakt es: Ich schalte den Rechner ein es kommt das Acer Logo sehr schnell, Dann eine gaaaaaanze weile nur ein schwarzer Bildschirm und dann das Mint Logo.
Alss ab dem LM Logo geht es ganz normal wie bei LM 18.2

Hier die Infos zur Hardware
inxi -Fxz

System:    Host: Aspire-V3 Kernel: 4.15.0-36-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Acer product: Aspire V3-371 v: V1.20 serial: N/A
           Mobo: Acer model: Aspire V3-371 v: V1.20 serial: N/A UEFI [Legacy]: Insyde v: V1.20 date: 06/16/2015
Battery    BAT0: charge: 38.9 Wh 100.0% condition: 38.9/48.9 Wh (79%) model: LGC AC14B8K status: Discharging
CPU:       Dual core Intel Core i5-5257U (-MT-MCP-) arch: Broadwell rev.4 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10775
           clock speeds: max: 3100 MHz 1: 2241 MHz 2: 1626 MHz 3: 2287 MHz 4: 2474 MHz
Graphics:  Card: Intel Iris Graphics 6100 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.05hz
           OpenGL: renderer: Mesa DRI Intel Iris 6100 (Broadwell GT3) version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-36-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 01:00.0
           IF: enp1s0 state: down mac: <filter>
           Card-2: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 240.1GB (3.6% used)
           ID-1: /dev/sda model: KINGSTON_RBU size: 240.1GB
Partition: ID-1: / size: 29G used: 6.3G (24%) fs: ext4 dev: /dev/sda2
           ID-2: /boot size: 453M used: 147M (35%) fs: ext4 dev: /dev/sda1
           ID-3: /home size: 183G used: 1.8G (2%) fs: ext4 dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 50.5C mobo: 40.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 201 Uptime: 2 min Memory: 1165.1/15961.9MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

Meine erste Frage. Wie bekomme ich raus was er genau macht wenn der Bildschirm Schwarz ist?

Was ich bisher Versucht habe ist natürlich das mit der "resume" genauso wie der unfung mit havged. Das bring alle nichts zumal das Problem ja aus meiner Sicht viel früher besteht.

Hier mal folgende Ausgaben obwohl ich der Meinung bin das dass Problem viel früher beginnt

systemd-analyze critical-chain
graphical.target @1.584s
└─multi-user.target @1.584s
  └─getty.target @1.584s
    └─getty@tty1.service @1.583s
      └─system-getty.slice @1.583s
        └─setvtrgb.service @1.570s +12ms
          └─systemd-user-sessions.service @1.491s +3ms
            └─network.target @1.490s
              └─NetworkManager.service @1.252s +237ms
                └─dbus.service @1.206s
                  └─basic.target @1.192s
                    └─sockets.target @1.192s
                      └─avahi-daemon.socket @1.192s
                        └─sysinit.target @1.190s
                          └─systemd-timesyncd.service @1.061s +128ms
                            └─systemd-tmpfiles-setup.service @1.044s +11ms
                              └─local-fs.target @1.040s
                                └─home.mount @1.024s +15ms
                                  └─systemd-fsck@dev-disk-by\x2duuid-88860215\x2d6ece\x2d4fed\x2dad8a\x2d826891b3da85.service @931ms +92ms
                                    └─local-fs-pre.target @930ms
                                      └─keyboard-setup.service @182ms +747ms
                                        └─systemd-journald.socket @176ms
                                          └─system.slice @176ms
                                            └─-.slice @173ms

systemd-analyze blame (hier nur der Anfang)
Ja Keepord ist langsam aber das ist immer noch zu schnell als das es die Bootzeiten erklären würde.
root@Aspire-V3:~# systemd-analyze blame
           747ms keyboard-setup.service
           662ms dev-sda2.device
           253ms systemd-journal-flush.service
           237ms NetworkManager.service
           214ms udisks2.service
           208ms systemd-logind.service
           206ms systemd-resolved.service
           174ms ubuntu-system-adjustments.service
           172ms networkd-dispatcher.service
           132ms accounts-daemon.service
           128ms systemd-timesyncd.service
           126ms systemd-rfkill.service
           121ms thermald.service
           119ms ModemManager.service
           116ms bluetooth.service
           105ms apport.service
            92ms systemd-fsck@dev-disk-by\x2duuid-88860215\x2d6ece\x2d4fed\x2dad8a\x2d826891b3da85.service
            85ms systemd-fsck@dev-disk-by\x2duuid-2244e722\x2d52fe\x2d4a4b\x2d8c78\x2d61c496b88dd4.service

Was mir aufgefallen ist, wenn ich vor der Installation von CD starte bekomme ich schon folgende Fehlermeldungen.
(Siehe Bild)

Hat hier jemand eine Lösung? Oder noch eine Idee? Ich vermute irgend ein Timeout im grub noch vor dem booten. Kennt sich jemand damit aus?

Titel: Re: Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)
Beitrag von: Bleureux am 20.10.2018, 02:40:13
Ich schalte den Rechner ein es kommt das Acer Logo sehr schnell, Dann eine gaaaaaanze weile nur ein schwarzer Bildschirm und dann das Mint Logo.
Alss ab dem LM Logo geht es ganz normal wie bei LM 18.2

Vielleicht muss Dein Grub einfach zu viele (alte) Kernel suchen bevor er weiter machen kann.

Off-Topic:
Ansonsten mach für Dein Problem lieber einen eigenen Thread auf. Fremde zu kapern erhöht nicht die Übersicht im Forum. Wer liest sich mit einem anstehenden Problem schon einen derart langen Themenkomplex mit drei unterschiedlichen Fehlern, Rechnern und / oder Systemen durch?