LMU - Das Hilfe Forum für Linux Mint

Software => Ärger mit Software? => Thema gestartet von: Benny136 am 12.11.2017, 18:05:40

Titel: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 12.11.2017, 18:05:40
Liebe "Grüne",   ;D

bin vor 2 Tagen von einer ATI Radeon HD 7770 auf eine NVIDIA GTX 1060 umgestiegen. Hat alles wunderbar geklappt. Allerdings startet mein Linux Backuprogramm "Redo" zum backupen von Win7 und LM nicht mehr wie gewohnt. Ich starte das Programm vom Stick und wähle dann über das Boot Menü den Redo Stick aus. Dann kommt das blaue Auswahlfenster mit "Default Settings", "Redo Starten" etc. Soweit alles wie gehabt. Nach dem Start von Redo kommt dann das fehlerhafte Startbild (siehe anbei) und danach ein dunkler Schirm.
Sieht ganz so aus, als ob Redo mit der technisch über ein Jahr alten Grafikkarte nicht klar kommt.

Hatte jemand ein ähnliches Problem oder kann mir hier jemand helfen?  Vielen Dank.   :)
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: toffifee am 12.11.2017, 18:08:31
Da wirst du mal Bootoptionen probieren müssen wie "nomodeset" oder "xforcevesa". Genauer kann ich es dir im Moment nicht geben.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 12.11.2017, 18:11:58
Ich komme ja gar nicht ins Linux/Win7 Boot Menü. Nach dem BIOS Boot Menü, was ich ja mit F12 händisch aufrufe, gibts ja nur noch einzelne Hardware Devices. Es wird außer dem Redo-USB-Stick nichts geladen.
Zitat
nomodeset" oder "xforcevesa"
gibts hier nicht, oder?
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: toffifee am 12.11.2017, 18:21:09
Ich meine das Startmenü des Redo Sticks! Der ist es ja, der nicht richtig bootet, nicht deine installierten Systeme!
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 12.11.2017, 20:07:24
Mit der "Safe Mode" Option und nachfolgender Auswahl einer Grafikauflösung hab ich Redo letztlich zum laufen gebracht.   ;D
Jetzt habe ich gesucht, wo die Grafikauflösung beim Start in einer ini/config-Datei mitgegeben werden kann. Leider konnte ich weder in der autorun.inf noch in einer anderen config Datei eine entsprechende Einstellung finden. Zumindest habe ich sie nicht erkannt.
Habt Ihr mir einen Tipp wo die steht, bzw. welcher Parameter das sein könnte?
Zitat
nomodeset" oder "xforcevesa"
hab ich nirgends gefunden.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: aexe am 12.11.2017, 20:43:34
http://wiki.ubuntuusers.de/Bootoptionen#Optionen-bei-Live-Medien
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 13.11.2017, 18:46:42
Zitat
[url]http://wiki.ubuntuusers.de/Bootoptionen#Optionen-bei-Live-Medien[/url]

Heißt das ich muss F6 drücken während Redo gestartet wird? Ich will ja keine Linux Live CD starten, wie in dem Beispiel geschrieben wird.
Der istallierte NVIDIA Treiber wird ja in diesem Fall auch gar nicht geladen. Damit sollte der XServer doch ausschließlich aktiv sein.

Also F6 beim Start vom Redo Stick bewirkt bei mir nichts, oder blick ich da was nicht?
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 14.11.2017, 09:43:51
Zitat
Ich meine das Startmenü des Redo Sticks! Der ist es ja, der nicht richtig bootet, nicht deine installierten Systeme!
Hier gibt es keine Menüpunkte wo man "nomodeset" auswählen könnte.  :'(  Nur mit dem Menüpunkt "Save Mode" laufen alle möglichen Codezeilen durch und stoppen dann an der Grafikabfrage. Die muss man dann mit einem Buchstaben, der gewünschten Auflösung beantworten. Bei mir wäre das "l" (1920x1080 32). Dann bekomme ich ein korrektes Bild. Dauert aber und ist umständlich. Ich muss doch irgendwie Redo den Parameter mitgeben können. Vermutlich in irgend einem config-File.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: toffifee am 14.11.2017, 12:31:43
Dauert aber und ist umständlich.
Ist dann wohl so. Brauchen die meisten Anwender ja auch nicht.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 14.11.2017, 13:51:45
Zitat
Ist dann wohl so. Brauchen die meisten Anwender ja auch nicht.
Das Seltsamme ist ja nur, dass das Problem erst mit meiner neuen Grafikkarte auftrat (AMD Radeon HD 7770 wurde vor wenigen Tagen getauscht gegen NVIDIA GTX 1060). Unter der alten AMD Karte lief alles wunderbar.
Daher auch die Frage, hat jemand mit der GTX 1060 und Redo ähnliche Probleme?

Off-Topic:
Das Problem verschärft sich ja auch noch, weil die Grafikausgabe nach dem Ruhezustand mit der neuen Grafikkarte auch nicht mehr funktioniert. Siehe meinen Thread
https://www.linuxmintusers.de/index.php?topic=45275.msg644494#msg644494 (https://www.linuxmintusers.de/index.php?topic=45275.msg644494#msg644494)
Der neuste NVIDIA Treiber ist eingespielt.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: ehtron am 14.11.2017, 14:15:23
Hi :)
der von redo genutzte kernel dürfte mit deiner neuen karte nicht mehr klar kommen... thats all ;)
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 14.11.2017, 15:00:14
Zitat
der von redo genutzte kernel dürfte mit deiner neuen karte nicht mehr klar kommen... thats all
Das kann natürlich sein.  :(  Komisch ist nur, das man Redo "händisch" im Save Mode starten kann.

Diesen Grafik Auflösungs-Parameter "l" (klein L) denn ich da händisch eingeben muss, kann ich sicher irgendwie Redo beim Start mitgeben. Nur wie?
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: aexe am 14.11.2017, 15:27:27
Neueste verfügbare Version: redobackup-livecd-1.0.4.iso    2012-11-21
Da darf man nicht viel Automatik erwarten, was neue Hardware anlangt.
Wenn es 'per Hand' funktioniert, Glück gehabt.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 14.11.2017, 15:36:38
Zitat
Neueste verfügbare Version: redobackup-livecd-1.0.4.iso    2012-11-21
Diese Version hab ich. Ich verwende Redo erst seit ca. 1/2 Jahr.  ;)
Automatik erwarte ich gar nicht aexe.  ;D  Bevor Redo gestartet wird kommt ja ein Menü mit Einträgen wir Start mit Default Settings, Start Redo, Save Start,... Sieht aus wie ein Dos Programm. Kann da ja leider keinen Screen Dump machen.
Das sieht für mich aus wie eine Vormenü, wie beim Grub zum Booten. Das muss doch irgendwo auf dem Stick liegen. Sonst machte es ja auch keinen Sinn "Default Settings" und Start Redo in zwei Punkte zu packen, oder?

So sieht die Dateistruktur vom Redo Stick aus:
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 14.11.2017, 15:54:40
Ich glaube ich hab die betreffende Startdatei mit den Aufrufen (syslinux.cfg). Schaut mal im anhängenden Code in den Blocks
- menu label Default
- menu label Start Redo Backup
- menu label Safe Mode
stehen die jeweiligen Aufrufe. Leider kann ich damit nichts anfangen.

default menu.c32
prompt 0
menu title UNetbootin
timeout 100

label unetbootindefault
menu label Default
kernel /ubnkern
append initrd=/ubninit boot=casper vga=791 quiet splash --

label ubnentry0
menu label Start Redo Backup
kernel /casper/vmlinuz
append initrd=/casper/initrd.lz boot=casper  vga=791 quiet splash --

label ubnentry1
menu label Safe Mode
kernel /casper/vmlinuz
append initrd=/casper/initrd.lz boot=casper  xforcevesa nomodeset vga=ask toram --

label ubnentry2
menu label Check CD for defects
kernel /casper/vmlinuz
append initrd=/casper/initrd.lz boot=casper integrity-check  --

label ubnentry3
menu label Memory test
kernel /install/memtest
append initrd=/ubninit -
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: ehtron am 14.11.2017, 15:59:11
Hi :)
yep
es wird der vesa vga modus genutzt und mit nomedeset die nutzung der kernel treiber für die graka abgeschaltet.
den kann (fast) jede grafk karte.

als fallback, falls der kernel treiber nicht läuft.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 14.11.2017, 16:07:35
Kann ich das nicht einfach irgendwie in meinen "Default" Aufruf oben packen, und er läuft dann im selben Mode wie Save Mode an, ohne mich was zu fragen oder 100 Meldungen anzuzeigen?  ;)
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: ehtron am 14.11.2017, 16:13:39
Hi :)
du müsstest die grub eintagungen des redo sticks anpassen..
und den grub neu konfigurieren.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 14.11.2017, 16:22:42
Du meinst immer den Grub auf dem Redo Stick?
Den will ich ja anpassen und zwar am besten im schon vorhandenen "Default" Menüeintrag.
Zitat
label unetbootindefault
menu label Default-Bennys Einstellungen
kernel /ubnkern
append initrd=/ubninit boot=casper vga=791 quiet splash --
Nur was muss ich da eintragen, damit es läuft?
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: ehtron am 14.11.2017, 16:58:54
Hi :)
da müsste sich schon jemand, den es interessiert, die mühe machen das auf dem redo image mal anzusehen.
denke da wird niemand aus der hüfte schiessen können ;)
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: toffifee am 14.11.2017, 17:01:21
Ich frage mich ja ehrlich, warum so ein Stick nicht so konfiguriert ist, dass er auf JEDER Grafikhardware ohne Klimmzüge läuft....

Übrigens: wenn du im Redo Startmenü den Eintrag "Redo starten" auswählst und Tab drückst (so wie es drunter steht), kommen die Booteintragungen, und man kann die erwähnten Bootoptionen dahinter schreiben, dann Enter, und es sollte mit diesen Einträgen auch starten. Versucht?
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: geobart am 14.11.2017, 22:57:24
Er möchte das aber auf Dauer haben. ::)
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: aexe am 15.11.2017, 00:07:52
Off-Topic:
Wie wäre es denn mit einem anderen Backup-Programm?
Die Auswahl ist nicht dauerhaft winzig klein und sicher nicht schlechter:
– Clonezilla (der Klassiker)
– SystemBack
– Fsarchiver (mein Favorit mit Qt5-GUI)
– ?
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 17.11.2017, 16:06:45
Zitat
Wie wäre es denn mit einem anderen Backup-Programm?
Die Auswahl ist nicht dauerhaft winzig klein und sicher nicht schlechter:
Vielen Dank aexe. Bin durch die Auswahl eigentlich zu Beginn meiner BackUp Schau mal durchgegangen, und habe mich dann für Redo entschieden. Werde erst mal versuchen es zum laufen zu bekommen, bevor ich auf was Neues umsteige. Hier lockt auch der Ehrgeiz.   ;D
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 17.11.2017, 16:09:06
Zitat
Übrigens: wenn du im Redo Startmenü den Eintrag "Redo starten" auswählst und Tab drückst (so wie es drunter steht), kommen die Booteintragungen, und man kann die erwähnten Bootoptionen dahinter schreiben, dann Enter, und es sollte mit diesen Einträgen auch starten. Versucht?

Ja, hab ich versucht. Nur sehe ich da eine ganze Kommandozeile wo ich nicht weiß, welchen Parameter oder Befahl ich durch was ersetzten muss. Ein ähnliches Problem wie oben mit der config Datei.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: toffifee am 17.11.2017, 16:38:04
Nur sehe ich da eine ganze Kommandozeile wo ich nicht weiß, welchen Parameter oder Befahl ich durch was ersetzten muss.
Ersetzen tust du gar nichts. Ans Ende schreibst du entweder nomodeset ODER xforcevesa.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 17.11.2017, 16:45:30
Zitat
Ersetzen tust du gar nichts. Ans Ende schreibst du entweder nomodeset ODER xforcevesa.
ok, danke.
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 18.11.2017, 19:31:54
Habe "nomodeset" in den Standard Menüpunkt eingebunden. So erscheint die Redo Grafikausgabe ohne Fehler bei Start des Menüpunkts "Default (GTX 1060)":
Zitat
label unetbootindefault
menu label Default (GTX 1060)
kernel /ubnkern
append initrd=/ubninit boot=casper nomodeset vga=791 quiet splash --
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: toffifee am 18.11.2017, 19:47:22
Also gelöst? Prima. Dann bitte noch den Thread entsprechend markieren....
Titel: Re: LM 18.2: Redo läuft unter NVIDEA GTX 1060 nicht mehr
Beitrag von: Benny136 am 18.11.2017, 20:17:38
Zitat
Also gelöst? Prima. Dann bitte noch den Thread entsprechend markieren....
Vergesse ich nicht, hab nur gerade meinen anderen Thread aktualisiert.  ;D Hier gibt es scheinbar einen Kernel Bug.  :(