LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Newbie Fragen => Thema gestartet von: andi.brendel am 19.03.2016, 12:36:36

Titel: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: andi.brendel am 19.03.2016, 12:36:36
Hallo Leute,

ich bin seit 2 Wochen komplett auf Linux Mint 17.3 umgezogen und habe Windows 7 in einer VMware laufen. Ich hätte nie gedacht, dass ich das mal in dieser Reihenfolge nenne :-).
Ich bin aber von Linux Mint total begeistert. Bis auf ein zwei Programme, die es nur für Windows gibt und für die auch Wine keine Alternative ist, habe ich fast alles hinbekommen.

Ja, leider nur fast. Wenn das Problem mit dem Sound bei Linux nicht wäre. Ich habe in Foren einiges darüber gelesen und Linux tut sich da wohl etwas schwer mit.

Ich habe nun folgendes Problem. Egal mit welchem Player und mit welchem Mixer ich gerade Musik abspiele, wenn ein neues Lied anfängt stellen sich jedes Mal die Soundeinstellungen zurück, die ich vorher mit dem Mixer eingestellt habe. Ich habe einige Player und Mixer versucht. Hängengeblieben bin ich beim Decibil Audio Player und beim PulseAudio Mixer.

Aber auch mit den Standard Tools wie Klang und Vlc ist es das Gleiche. Erst wenn ich im Tool Klang von 2.0 auf 5.1 oder umgekehrt umstelle oder im PulseAudio Mixer auf Apply Settings drücke stimmt der Sound wieder.

Irgendwo ist eine eine Default-Einstellung auf die immer wieder zurückgesprungen wird, wenn eine neues Lied beginnt.

Kenn jemand das verhalten und gibt es dafür eine Lösung. Ich stelle mir vor, dass man irgendwo den PulseAudio Mixer als Default einstellen muss.

Gruß,

Andi

Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: toffifee am 19.03.2016, 12:49:44
Willkommen im Grünen!
Stehst du auf Spam, oder warum posaunst du deine Mailadresse in alle Welt...? ;)
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: andi.brendel am 19.03.2016, 13:09:04
Ja hast ja Recht. Habe beim Anmelden nicht richtig aufgepasst. Kann man das ändern? Beim Profil kann man den Namen nicht ändern.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: toffifee am 19.03.2016, 13:10:28
Da musst du dich an den Admin wenden, der macht das für dich.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: andi.brendel am 19.03.2016, 13:14:03
Ok danke, gerade gemacht.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: andi.brendel am 19.03.2016, 13:23:06
Habe mir gerade mal den PulseAudio Lautstärkeregler heruntergeladen. Man sieht beim Liedwechsel, dass er zum "Internes Audio Analog Surraound 5.1" zurückspringt.
Er müsste aber beim LADSPA Plugin Multiband EQ stehen bleiben.

Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: nativeworld am 19.03.2016, 13:24:59
Ist das als Ausweichoption gesetzt? Könnte man eventuell mal versuchen, zu deaktivieren.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: ehtron am 19.03.2016, 13:27:33
Hi :)
normalerweise sollte das gespeichert werden..
hast du dir beim spielen evtl. rechte zerschossen?
teste mal mit
find ~ -user root -lswenn da was kommt, ist es so.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: andi.brendel am 19.03.2016, 13:34:13
Danke nativeworld,

das war schon mal der erste richtige Hinweis. Jetzt bleibt es auf LADSPA stehen. Leider ist der Sound nach jedem Lied immer verstellt. Ich muss bei jedem Lied einmal auf "Internes Audio Analog Surround 5.1" und wieder zurück auf LADSPA stellen. Irgendwo muss ich den Standard ändern.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: andi.brendel am 19.03.2016, 13:41:01
hi ehtron,

da kommt folgendes zurück:

983690    4 -rw-------   1 root     root         1024 Mär 16 22:47 /home/leon/Downloads/~

Es ist aber egal von wo ich die Musik abspiele. Ist immer das gleiche verhalten.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: ehtron am 19.03.2016, 13:49:55
Hi :)
ok ist nur downloads..  aber korrigiere das trotzdem mal

genau so kopieren und einfügen
sudo chown -R -v $USER:$USER /home/$USER/
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: nativeworld am 19.03.2016, 13:55:31
Off-Topic:
@ ehtron
Hab das spaßeshalber mal bei mir auf meinem frisch installierten KDE eingegeben. Besteht Handlungsbedarf? Ich weiß, ist OT, will aber nicht erst nen Thread eröffnen...  :)
find ~ -user root -ls
525048    4 drwx------   3 root     root         4096 Mär 18 01:35 /home/XXXXXXX/.dbus
find: "/home/XXXXXXXX/.dbus": Keine Berechtigung
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: andi.brendel am 19.03.2016, 13:57:03
ok da wurde jetzt ganz schön viel geändert. Es hätte ja sein können, dass die Einstellungen wegen der falschen Rechte nicht abgespeichert werden. Hat aber auch noch nicht geholfen.
Ich werde den Rechner mal durchstarten.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: nativeworld am 19.03.2016, 13:57:30
Irgendwo muss ich den Standard ändern.
Schau mal hier, nicht dass du dir was zerschiesst...
https://wiki.ubuntuusers.de/Soundsystem/
https://wiki.ubuntuusers.de/Sound_Problembehebung/
https://wiki.ubuntuusers.de/.asoundrc/
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: ehtron am 19.03.2016, 13:57:31
Hi :)
dbus.. das ist nicht gut, dann kannst du als user (bzw. darauf laufende programme) vermutlich daran nix ändern..
handlungsbedarf m.e. ja.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: ehtron am 19.03.2016, 13:58:29
Hi :)
denke nicht das viel geändert wurde..  listet nur auf was er findet...
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: andi.brendel am 19.03.2016, 14:08:02
hi nativeworld,

ich habe da gleich auf der ersten Seite was gelesen:

ALSA
Der kürzeste Weg ist die direkte Kommunikation mit den ALSA-Treibern:

Soundquelle  ->  ALSA-Treiber  ->  Hardware

PulseAudio
Ab Ubuntu 8.04 wird PulseAudio verwendet. Mittlerweile können die meisten Programme direkt mit PulseAudio kommunizieren:

Soundquelle  ->  PulseAudio  ->  ALSA-Treiber  ->  Hardware

Kann es sein, dass da bei mir etwas durcheinandergekommen ist?

Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: andi.brendel am 19.03.2016, 14:09:00
@ehtron:

danke, dann habe ich das falsch interpretiert.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: nativeworld am 19.03.2016, 14:12:40
Normalerweise nicht, da Pulse aben nur noch dazwischenhängt. Damit kannst du mit ALSA und PULSE regeln.
Gib mal im terminal
alsamixerein und schau, ob die Einstellungen dort passen.
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: ehtron am 19.03.2016, 14:14:08
Hi :)
hast du das mal versucht?
https://wiki.ubuntuusers.de/PulseAudio/#Reset (https://wiki.ubuntuusers.de/PulseAudio/#Reset)
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: andi.brendel am 19.03.2016, 14:42:03
@ehtron:

Das war es. Ich habe alles zurückgesetzt und jetzt geht es. Da habe ich mir wohl beim Testen der Player und Mixer was zerschossen.
Das mit dem Pulse zrücksetzen war genau der richtige Tip. Danke euch allen für die Unterstützung.

Jetzt ist der Sound noch besser. Ich rocke hier gerade ab :-)
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: ehtron am 19.03.2016, 14:44:57
Hi :)
na prima.. ;)

dann setze den thread mal auf gelöst/erledigt. dann ist für andere der abschluss des threads ersichtlich und keine hilfe mehr erforderlich. 
dein erster post > ändern > präfix setzen
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: mylinux am 05.01.2019, 14:02:10
Hallo,

ich hatte auf meinen Laptop Linux Mint 17.3 64 Bit allerdings mit Mate Desktop und habe vor kurzem auf Mint 19 64bit Mate upgegradet.

Das Soundproblem habe ich leider immer noch.

Grundsätzlich kommt Sound aus den eingebauten Lausprechern und auch über die Bluetooth Schnittstelle auf einen Externen Bluetooth Lautsprecher ... nur gehe ich über den Kopfhöhrer Ausgang kommt verzerrtes und blecherndes
Ich dachte zuerst an einen Defekt in der Buchse ... und habe mir eine Externe USB Soundkarte bestellt... hier das gleiche..
Komisch ist auch dass es zuerst funktionierte .. wurde eventuell etwas über ein Update noch in 17.3 was geändert?

Hat jemand so ein Ähnliches Problem...?

Besten Dank.
mylinux
Michael S.
 
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: tommix am 05.01.2019, 14:05:36
Hallo,

wir hängen uns hier nicht an fremde Threads an.

Bitte deinen eigenen bei Mate eröffnen!

Danke
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: ehtron am 05.01.2019, 14:06:13
Hi :)
warum gräbst du einen thread von 2016 aus, statt einen eigenen auf zu machen?
Titel: Re: Sound Problem im Linux Mint 17.3 64 Bit cinnamon
Beitrag von: mylinux am 05.01.2019, 17:53:27
Oh Sorry