LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Installation & Updates => Thema gestartet von: lemmi am 26.08.2015, 08:51:00

Titel: LM17 KDE von USB Stick installieren
Beitrag von: lemmi am 26.08.2015, 08:51:00
So, nun helft mir mal über die gedankliche Brücke.
Hier habe ich beschrieben, dass nach der Installation es verhältnismäßig lange dauert, bis bootet.

https://www.linuxmintusers.de/index.php?topic=28612.new;topicseen#new (https://www.linuxmintusers.de/index.php?topic=28612.new;topicseen#new)

Ich hab nun gedacht, könnte ein Installationsfehler sein, lege also noch einmal USB Stick ein und stolper nun darüber:
- USB Stick bleibt (von dort habe ich ja neu gebootet) eingehängt.
- lasse ich die Platte geführt vollständig installieren, so wird Swap als sda5 angezeigt.

Mithin wird er wohl den USB Stick irgendwie eingearbeitet haben.
(ein Stick mit Multisystem der mehrere Distris und Tools hat)
Da ich aber diesen nicht lösen kann, (will ja schließlich von dort installieren) bleibt der wohl irgendwie eingebunden.
Dies könnte u.U. die Bootverzögerung ausmachen.

Wie kann ich den um diese Klippe kommen?
Oder bin ich mal wieder voll zugedrönt?

Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: DocHifi am 26.08.2015, 08:53:07
Zitat
Wie kann ich den um diese Klippe kommen?
In dem du etwas anderes machen wählst und die Partitionen selber zuweist.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: lemmi am 26.08.2015, 08:55:07
Grübel, manuell noch nie gemacht, obwohl schon so oft installiert.

der Stick bleibt dabei aber dennoch eingebunden...
(wird als sde angezeigt)

Selbst, wenn ich über manuell gehe.

Im Übrigen, moin Doc
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: toffifee am 26.08.2015, 08:56:32
Versteh ich nicht. Das, worüber du da stolperst, ist doch völlig normal!
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: DocHifi am 26.08.2015, 08:59:48
Zitat
Grübel, manuell noch nie gemacht, obwohl schon so oft installiert.
Dann wird es ja mal Zeit.
Zitat
- lasse ich die Platte geführt vollständig installieren, so wird Swap als sda5 angezeigt.
Das wäre die 5. Partition auf der ersten Festplatte, was ist denn nun der Fehler ?
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: lemmi am 26.08.2015, 08:59:49
Nach dem ersten Installationsversuch war er sehr langsam bei booten.
also noch mal gemacht.
aber, er hatte mir ohne stick angezeigt, dass er nicht, wie erwartet sda1 und sda2 kannte, sondern sda1 und 5
Also versuche ich das Ganze noch mal einzurichten, kann doch nicht sein, dass die kiste so langsam ist.
Dunkle Vermutung von mir war / ist dass bei der Installation via Stick per se der Stick in Grub mit eingebunden wird.
Da dieser dann aber abgezogen wird, könnte es ... verzögerungen geben.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: DocHifi am 26.08.2015, 09:02:11
Zitat
Dunkle Vermutung von mir war / ist dass bei der Installation via Stick per se der Stick in Grub mit eingebunden wird.
Da dieser dann aber abgezogen wird, könnte es ... verzögerungen geben.
Nein.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: lemmi am 26.08.2015, 09:04:20
Ok, melde mich wieder, wenn durchgelaufen. Wenn dann nicht richtig läuft, hau ich was anderes drauf. So ist ja Frust vorprogrammiert.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: ZeckeSZ am 26.08.2015, 09:06:38
lasse ich die Platte geführt vollständig installieren, so wird Swap als sda5 angezeigt.
Somit die erste logische Partition innerhalb der automatisch angelegten erweiterten Partition - das hat jetzt aber mit dem USB-Stick (sd?, nicht sda?) absolut nichts zu tun.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: lemmi am 26.08.2015, 09:10:25
Ok, kann mir dann mal jemand erklären, warum die swap dann als sda5 angelegt wird?
Eigentlich sollte er ja richtig zählen können.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: DocHifi am 26.08.2015, 09:14:18
Ok, kann mir dann mal jemand erklären, warum die swap dann als sda5 angelegt wird?
Eigentlich sollte er ja richtig zählen können.
Das würde man sehen können, wenn man die Partitionierung kennen würde.
Die Automatik macht halt was sie für richtig hält, ob es denn optimal ist, lass ich mal dahin gestellt.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: helli am 26.08.2015, 09:40:01
Die erste Partition in einer erweiterten ist immer sdx5, egal wieviel primäre vorhanden sind.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: lemmi am 26.08.2015, 09:45:54
So, neu installiert ist er ...langsam ist er immer noch. (beim Booten)
Neuer Rekord 68 Sekunden, nach Bios Bootscreen.

Wie kann ich mir den Bootvorgang zeigen lassen?
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: helli am 26.08.2015, 09:52:00
dmesg...ins Terminal eingeben.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: lemmi am 26.08.2015, 09:58:49
Umpf, mal wieder falsch ausgedrückt. Bin ja ein Held.

Ich meine, statt des blank screens beim Booten.
Ich möchte einfach sehen, ob er an irgendeiner Stelle lange hängen bleibt.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: helli am 26.08.2015, 10:01:29
Zitat
Ich möchte einfach sehen, ob er an irgendeiner Stelle lange hängen bleibt.
...das zeigt doch
dmesgganz links steht die jeweilige Zeit.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: DocHifi am 26.08.2015, 10:02:43
Oder den Bootsplash abschalten, einfach mal beim booten die Pfeil runter taste drücken.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: ZeckeSZ am 26.08.2015, 10:09:56
Neuer Rekord 68 Sekunden, nach Bios Bootscreen
Versuch:
sudo fstrim -v /ausführen, Neustart. Falls sich nichts ändert, könnte auch ein schlichter Hardware-Defekt in Betracht kommen.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: lemmi am 26.08.2015, 10:10:26
Teilausgabe vom dmesg (passt hier nicht alles rein)

  4.190413] scsi 1:0:0:0: CD-ROM            TSSTcorp CDDVDW SH-S223C  me01 PQ: 0 ANSI: 5
[    4.205593] sr0: scsi3-mmc drive: 52x/52x writer dvd-ram cd/rw xa/form2 cdda tray
[    4.205597] cdrom: Uniform CD-ROM driver Revision: 3.20
[    4.205776] sr 1:0:0:0: Attached scsi CD-ROM sr0
[    4.205865] sr 1:0:0:0: Attached scsi generic sg4 type 5
[   34.972479] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[   34.972484] ata2.00: failed command: IDENTIFY PACKET DEVICE
[   34.972489] ata2.00: cmd a1/00:01:00:00:00/00:00:00:00:00/00 tag 22 pio 512 in
[   34.972489]          res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[   34.972491] ata2.00: status: { DRDY }
[   34.972494] ata2: hard resetting link
[   35.463788] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[   36.265023] ata2.00: configured for PIO4
[   37.064570] ata2: EH complete
[   64.375078] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   64.458757] random: nonblocking pool is initialized
[   64.678815] Adding 4192252k swap on /dev/sda5.  Priority:-1 extents:1 across:4192252k SSFS
[   64.859706] systemd-udevd[358]: starting version 204
[   64.926371] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   64.964330] lp: driver loaded but no devices found
[   64.982486] ppdev: user-space parallel port driver
[   64.992805] piix4_smbus 0000:00:14.0: SMBus Host Controller at 0xb00, revision 0
[   64.992856] piix4_smbus 0000:00:14.0: Auxiliary SMBus Host Controller at 0xb20
[   65.004059] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   65.016489] MCE: In-kernel MCE decoding enabled.
[   65.023017] EDAC MC: Ver: 3.0.0
[   65.025087] AMD64 EDAC driver v3.4.0
[   65.025125] EDAC amd64: DRAM ECC disabled.
[   65.025138] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
[   65.025138]  Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
[   65.025138]  (Note that use of the override may cause unknown side effects.)
[   65.029114] r8712u: module is from the staging directory, the quality is unknown, you have been warned.
[   65.029820] r8712u: Staging version
[   65.029841] r8712u: register rtl8712_netdev_ops to netdev_ops
[   65.029846] usb 1-2: r8712u: USB_SPEED_HIGH with 4 endpoints
[   65.034853] usb 1-2: r8712u: Boot from EFUSE: Autoload OK
[   65.086350] snd_hda_intel 0000:01:00.1: Handle VGA-switcheroo audio client
[   65.086910] snd_hda_intel 0000:01:00.1: irq 46 for MSI/MSI-X
[   65.112943] sound hdaudioC0D3: ALC888: SKU not ready 0x411111f0
[   65.112944] kvm: disabled by bios
[   65.113437] sound hdaudioC0D3: autoconfig: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[   65.113440] sound hdaudioC0D3:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   65.113441] sound hdaudioC0D3:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   65.113443] sound hdaudioC0D3:    mono: mono_out=0x0
[   65.113444] sound hdaudioC0D3:    dig-out=0x11/0x1e
[   65.113445] sound hdaudioC0D3:    inputs:
[   65.113447] sound hdaudioC0D3:      Mic=0x19
[   65.113449] sound hdaudioC0D3:      Line=0x1a
[   65.113450] sound hdaudioC0D3:      Aux=0x1c
[   65.120674] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input4
[   65.159235] input: HDA ATI SB Mic as /devices/pci0000:00/0000:00:14.2/sound/card0/input5
[   65.159299] input: HDA ATI SB Line as /devices/pci0000:00/0000:00:14.2/sound/card0/input6
[   65.159350] input: HDA ATI SB Line Out Front as /devices/pci0000:00/0000:00:14.2/sound/card0/input7
[   65.159402] input: HDA ATI SB Line Out Surround as /devices/pci0000:00/0000:00:14.2/sound/card0/input8
[   65.159460] input: HDA ATI SB Line Out CLFE as /devices/pci0000:00/0000:00:14.2/sound/card0/input9
[   65.159512] input: HDA ATI SB Line Out Side as /devices/pci0000:00/0000:00:14.2/sound/card0/input10
[   65.159561] input: HDA ATI SB Front Headphone as /devices/pci0000:00/0000:00:14.2/sound/card0/input11
[   65.451733] Bluetooth: Core ver 2.19
[   65.451788] NET: Registered protocol family 31
[   65.451790] Bluetooth: HCI device and connection manager initialized
[   65.453213] Bluetooth: HCI socket layer initialized
[   65.453219] Bluetooth: L2CAP socket layer initialized
[   65.453236] Bluetooth: SCO socket layer initialized
[   65.466732] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   65.466736] Bluetooth: BNEP filters: protocol multicast
[   65.466746] Bluetooth: BNEP socket layer initialized
[   65.502078] Bluetooth: RFCOMM TTY layer initialized
[   65.502213] Bluetooth: RFCOMM socket layer initialized
[   65.502224] Bluetooth: RFCOMM ver 1.11
[   65.610406] init: failsafe main process (608) killed by TERM signal
[   65.688645] init: cups main process (694) killed by HUP signal
[   65.688656] init: cups main process ended, respawning
[   65.834442] init: samba-ad-dc main process (729) terminated with status 1
[   65.996131] usb 1-2: r8712u: CustomerID = 0x0000
[   65.996136] usb 1-2: r8712u: MAC Address from efuse = 48:5d:60:19:46:b4
[   65.996138] usb 1-2: r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[   65.996206] usbcore: registered new interface driver r8712u
[   66.226136] r8169 0000:02:00.0 eth0: link down
[   66.226211] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   66.226394] r8169 0000:02:00.0 eth0: link down
[   66.240528] cfg80211: Calling CRDA to update world regulatory domain
[   66.488513] init: plymouth-upstart-bridge main process ended, respawning
[   66.922026] init: plymouth-stop pre-start process (1433) terminated with status 1
[   66.968350] r8712u 1-2:1.0 wlan0: 1 RCR=0x153f00e
[   66.969091] r8712u 1-2:1.0 wlan0: 2 RCR=0x553f00e
[   67.075968] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   67.076024] cfg80211: World regulatory domain updated:
[   67.076030] cfg80211:  DFS Master region: unset
[   67.076031] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   67.076034] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   67.076036] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   67.076037] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[   67.076039] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   67.076040] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   67.383473] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   67.822658] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[   67.822665] ata2.00: failed command: IDENTIFY PACKET DEVICE
[   67.822669] ata2.00: cmd a1/00:01:00:00:00/00:00:00:00:00/00 tag 7 pio 512 in
[   67.822669]          res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[   67.822672] ata2.00: status: { DRDY }
[   67.822675] ata2: hard resetting link
[   68.317942] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[   68.600136] r8169 0000:02:00.0 eth0: link up
[   68.600145] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   69.119387] ata2.00: configured for PIO4
[   69.931721] ata2: EH complete
[  100.790956] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[  100.790962] ata2.00: failed command: IDENTIFY PACKET DEVICE
[  100.790967] ata2.00: cmd a1/00:01:00:00:00/00:00:00:00:00/00 tag 4 pio 512 in
[  100.790967]          res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[  100.790969] ata2.00: status: { DRDY }
[  100.790972] ata2: hard resetting link
[  101.281997] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[  102.083580] ata2.00: configured for PIO4
[  102.898982] ata2: EH complete

Nach der Erkennung der CD hängt er allen Anschein nach



Edit:
Pfeil runter funzt nicht.
Aber... bevor die absolute Dunkelheit kommt, erscheint gaaaaanz kurz "creating nvram"

Dabei ist im Bios von Rechner nix von wegen Efi zu sehen.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: ZeckeSZ am 26.08.2015, 10:38:19
4.190413] scsi 1:0:0:0: CD-ROM            TSSTcorp CDDVDW SH-S223C  me01 PQ: 0 ANSI: 5
Um einen Defekt auszuschließen, würde ich zunächst testweise alle zu den Laufwerken führenden Kabel tauschen, dann das hier ausprobieren: https://paulphilippov.com/articles/how-to-fix-slow-boot-with-ata-errors (https://paulphilippov.com/articles/how-to-fix-slow-boot-with-ata-errors)

Nachtrag:
Zitat
Pfeil runter funzt nicht
Wie wär's mit
dmesg > Schreibtisch/log
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: lemmi am 26.08.2015, 10:55:14
Du wirst es nicht glauben, aber das war es....

Kann mir jemand mal erklären, was da bitte auf englisch steht?
So fit bin ich nun wirklich nicht.

Bootzeit ca 12 Sek. Unglaublich


Dies löst die langsame Bootzeit die hier auch gepostet ist:
https://www.linuxmintusers.de/index.php?topic=28612.msg380816#msg380816

Und wenn ich es richtig verstanden habe, wird swap immer als Nr. 5 geführt - warum auch immer
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: ZeckeSZ am 26.08.2015, 11:22:35
Kann mir jemand mal erklären, was da bitte auf englisch steht
Ganz grob, dass angebliche Fehler bei einer Festplatte erkannt werden, obwohl es sich ja eigentlich um ein DVD-Laufwerk handelt und du deshalb die
/lib/udev/rules.d/60-persistent-storage.rulesöffnen und den entsprechenden Abschnitt unter
# ATA/ATAPI devices (SPC-3 or later) using the "scsi" subsystemauskommentieren sollst.

Setzt du bitte noch einen Link in deinem zuerst erstellten Thema auf dieses hier und kennzeichnest beide als gelöst, der Nächste mit dem Problem wird es dir danken.
Titel: Re: LM17 KDE von USB Stick installieren
Beitrag von: lemmi am 26.08.2015, 11:25:18
Klaro... und noch mal danke....
Unglaublich, was das bisschen so ausmacht.

Wenn man sich dann nicht die Mühe macht, der Ursache auf die Spur zu kommen, bootet man jahrelang mit falschen Einstellungen.
Bleibt dies eigentlich erhalten, wenn neuer kernel kommt? Oder muss dies immer wieder neu eingetragen werden?