LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Installation & Updates => Thema gestartet von: ullimell am 19.05.2014, 10:55:43

Titel: Installation scheitert wegen Raid
Beitrag von: ullimell am 19.05.2014, 10:55:43
Hallo Freunde des gepflegten Grüns,

versuche nun schon geraume Weile Linux Mint 13 Mate 32 bit zu installieren , bleibe aber bei der Installationsbilder show hängen.

Was bisher versucht:

Rechner ist ein Firmenrechner älteres Baujahr.
Aufgespielt war Windows XP.
Daten waren schon gelöscht.
Es wird mir ein Raid angezeigt.

Mit gparted alles plattgemacht bis auf eine Partition. Wird angezeigt das Aushängen nicht möglich i busy.
Auf meines WIssensstandes erste Festplatte zur Installation vorbereitet.
Installvorgang gestarted.
Passwort, Zeitzone, Tastaturlayout zugewiesen und Installation fing an.
Bleibt aber  bei der Bildershow bei Bild "Hilfe finden" hängen.
Nach mehreren Versuchen immer das gleiche Ergebnis.
Bitte nun um Eure Hilfe.
Wenn noch was gewünscht, wird umgehendst nachgereicht.

ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: toffifee am 19.05.2014, 11:14:48
Hmm, weißt du nicht, wieviele Platten drin sind? Kannst RAID im BIOS ausschalten?
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 19.05.2014, 11:42:43
Evtl die Diaschau aus dem Live-System entfernen ?
sudo apt-get purge ubiquity-slideshow-mintund mal zeigen :
sudo parted -l
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 19.05.2014, 12:38:07
@toffifee, aexe,

so hab das hingekriegt mit Raid ausschalten und habe dann auch mit gparted beide Platten gesäubert und dann auf der ersten Platte aus dem Livesystem installiert.
Installation war ohne Fehlemeldung aber bei Neustart findet der Rechner keine kein Operating System.
so nun die Ausgabe
sudo parted -l



Invalid partition table - recursive partition on /dev/sda

Habe Aussage als Textdatei angehängt
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 19.05.2014, 13:34:00
Zitat
beide Platten gesäubert
Wie ? Neue Partitionstabelle erstellt ? (auf der sda insbesondere)
Warum geht die Ausgabe von parted denn nicht im Codeblock ?
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 19.05.2014, 14:19:17
@ aexe,

gesäubert bedeutet: Mit gparted beide Platten als ext4 formatiert.

sda habe ich nicht formatiert weil das mein Installmedium ist (Usb.stick).
Ausgabe in Codeblock habe ich zu spät realisiert, daß ich das auch im Livebetrieb machen kann und ich das auf einem anderen Rechner im Forum angemeldet war.

Starte nun den zu installierenden Rechner im Livemodus und melde mich dann von dort an.

ullimell

Ps> Bin jetzt mit Problemrechner da
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 19.05.2014, 14:45:22
Zitat
Invalid partition table - recursive partition
deutet eigentlich auf ein Problem mit der Partitionstabelle,
welches sich mit dem Formatieren /Anlegen neuer Partitionen uU nicht beseitigen lässt.
... sda habe ich nicht formatiert weil das mein Installmedium ist (Usb.stick)...
Bist Du da sicher ? Bzw ist es auch vom Live-System aus so ?
(Ich habe mir die Datei nicht heruntergeladen und sie also auch nicht gesehen)
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 19.05.2014, 15:03:16
 Hallo aexe,
siehe ausgabe
sudo parted -l
Model: Kingston DT 101 G2 (scsi)
Disk /dev/sda: 7747MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  7747MB  7746MB  primary  fat32        boot


Model: ATA MAXTOR STM325082 (scsi)
Disk /dev/sdb: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size   Type      File system     Flags
 1      1049kB  250GB  250GB  primary   ext4            boot
 2      250GB   250GB  525MB  extended
 5      250GB   250GB  525MB  logical   linux-swap(v1)


Model: ATA MAXTOR STM325082 (scsi)
Disk /dev/sdc: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start  End  Size  Type  File system  Flags


Error: /dev/zram0: unrecognised disk label   

ullimell


Ausgabe wurde justament im Livemodus erstellt
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 19.05.2014, 15:14:23
ah ja, jetzt kann man es auch sehen. Die Meldung bzgl. der Partitionstabelle kommt nicht mehr ?
sda ist der Stick.
Die Installationplatte sollte vermutlich sdb sein, in typischer Weise von der Installer-Automatik aufgeteilt.

Ich würde trotzdem jetzt auf der sdb die Partitionstabelle neu schreiben und die Partitionen neu anlegen (mit GParted)
dann halt mal neuer Versuch LinuxMint zu installieren. "Etwas anderes" wählen, Partitionen manuell zuweisen.
Oder ist da jetzt gerade auch schon neu installiert worden ?

Auf der sdc ist nichts mehr drauf ?  Wozu soll sie dienen ?
Wurden die Partitionen gelöscht, Partitiontabelle neu geschrieben ?
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 19.05.2014, 15:26:18
Hallo aexe,

sdc ist die zweite Festplatte im Rechner.
War als Spiegelplatte im Raid verbunden. lt. Aussage des Vorbesitzers.

Werde nun mit gparted sdb neu vorbereiten.
Wechsle nun den Rechner .
ullimell

Ist das so in Ordnung
sudo parted -l
Model: Kingston DT 101 G2 (scsi)
Disk /dev/sda: 7747MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  7747MB  7746MB  primary  fat32        boot


Model: ATA MAXTOR STM325082 (scsi)
Disk /dev/sdb: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  247GB  247GB   primary  ext4
 2      247GB   250GB  3146MB  primary  linux-swap(v1)


Model: ATA MAXTOR STM325082 (scsi)
Disk /dev/sdc: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start  End  Size  Type  File system  Flags


Error: /dev/zram0: unrecognised disk label   
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 19.05.2014, 15:36:37
Geschmacksache, 247 G für die System-Partition finde ich viel zu groß.
20 G reichen auch, dann eine erweiterte, darin eine logische Partition für DATEN, wäre mein Vorschlag.
Evtl Platz für ein 2. System lassen.

Ob sich diese RAID-Geschichte noch ungünstig auswirkt, wird man ja sehen.
Davon habe ich wenig Ahnung.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 19.05.2014, 16:04:28
@ aexe,

Deinen Vorschlag befolgt. Install ohne Fehlermeldung.
Nach Neustart kommt folgende Fehlermeldung:

pxe M0F: Exiting BootManage PXE ROM
Operatingsystem not found

So Stand der dinge.
Werde jetzt wieder in Livemodus wechseln.
Vielleicht hast Du noch ein paar Ansätze um das zum Laufen zu bringen.

ullimell

ps: wechsel zum anderen Rechner
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 19.05.2014, 16:06:10
Auf jeden Fall darauf achten, dass Grub auf der richtigen Platte installiert wird.
Die Voreinstellung im Installer wird wohl sda sein.
Wenn aber auf sdb installiert wird, gehört Grub nach sdb.

Um zu sehen, wo Grub sich befindet, gibt dieser Befehl Auskunft:
sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 19.05.2014, 16:11:14
Warum wechselst Du immer den Rechner? Du kannst doch mit dem Live-System auch hier posten.
Hellis Hinweis beachten !!

Es wundert mich sowieso, daß der Stick als sda gelistet wird, das ist normalerweise die erste Festplatte im Rechner.
Beim Hochfahren gibt es evtl auch die Möglichkeit auszuwählen, von welchem Laufwerk der Rechner starten soll.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 19.05.2014, 18:34:48
@ aexe, helli,

mußte leider den Rechner wechseln, hatte ausversehen sda neu formatiert und daraufhin war der livemodus weg.
Schreibe jetzt vom Problemrechner, bin aber immernoch im Livemodus da bei Neustart: No Operatihg System found.
Also alles noch mal neu gemacht.
sdb neu eingerichtetund neu installiert.
Gleiches Ergebniss.
Kann nicht von Festplatte starten.
Bootloader hab ich nach sdb installiert.
Bitte um weiterführende Hilfe.

ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: DocHifi am 19.05.2014, 18:37:25
Dann zeige doch mal die Ausgabe von hellis Befehl aus AW#12
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 19.05.2014, 18:43:48
@ DocHifi,

siehe
mint@mint ~ $ sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\"
>
>
ullimell

Befehl nochmal eingegeben (auch wieder mit copy und paste)
> sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\"
bash: Syntaxfehler beim unerwarteten Wort `)'

ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 19.05.2014, 18:49:26
Verzeihung, da fehlte am Ende ein Zeichen!

sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 19.05.2014, 18:54:04
@ helli, DocHifi, aexe,

neue Ausgabe
mint@mint ~ $ sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB 7c66
/dev/sda1: Kein GRUB 31c0
/dev/sdb: GRUB 2 v1.99
/dev/sdb1: Kein GRUB 00
/dev/sdb2: Kein GRUB 00
/dev/sdc: Kein GRUB 00

ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 19.05.2014, 19:33:11
Könnte es sein, dass der Rechner von der falschen Platte booten will?
Beim Start mal mit der F8 Taste versuchen, von der anderen Platte zu booten.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 19.05.2014, 19:56:03
Die entsprechende Taste wird doch auch meist kurz nach dem Einschalten auf dem Bildschirm angezeigt.
Manchmal ist es auch F12 oder eine andere oder eine Kombination, je nach Rechner.
zeig doch auch interessehalber nochmal sudo parted -l vom Live-System aus
und sudo lsblk -o NAME,LABEL,SIZE,FSTYPE,MOUNTPOINT
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 15:19:19
@ aexe, helli,

sudo parted -l
Modell: Kingston DT 101 G2 (scsi)
Festplatte  /dev/sda:  7747MB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 1      1049kB  7747MB  7746MB  primary  fat32        boot


Modell: ATA MAXTOR STM325082 (scsi)
Festplatte  /dev/sdb:  250GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende   Größe   Typ      Dateisystem     Flags
 1      1049kB  247GB  247GB   primary  ext4            boot
 2      247GB   250GB  3146MB  primary  linux-swap(v1)


Modell: ATA MAXTOR STM325082 (scsi)
Festplatte  /dev/sdc:  250GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende  Größe  Typ  Dateisystem  Flags


Fehler: /dev/zram0: unbekannte Partitionstabelle     

sudo lsblk -o NAME,LABEL,SIZE,FSTYPE,MOUNTPOINT
NAME   LABEL                       SIZE FSTYPE                     MOUNTPOINT
loop0                            987,3M squashfs                   /rofs
sr0                               1024M                           
zram0                            243,5M swap                       [SWAP]
sda    Linux Mint 13 MATE 32-bit   7,2G iso9660                   
└─sda1                             7,2G vfat                       /cdrom
sdb                              232,9G silicon_medley_raid_member
├─sdb1                             230G ext4                       
└─sdb2                               3G swap                       
sdc                              232,9G silicon_medley_raid_member

Wenn noch mehr kein Problem,
ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 20.05.2014, 16:26:07
Da ist wohl noch diese RAID-Installation am Werk, was stören könnte
Zitat
...
sdb                              232,9G silicon_medley_raid_member
├─sdb1                             230G ext4                       
└─sdb2                               3G swap                       
sdc                              232,9G silicon_medley_raid_member
Wie man das aber wegbringt ... k.A. !!
Im BIOS mal nachgesehen ?
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 20:21:40
@ aexe,

1. Habe jetzt nochmal alle Möglichkeiten im Bios ausprobiert.
2. Auch die Einstellungen Raid Alles auf delet und beide Platten im "Raid Configuration Utily" gelöscht.
3. Mit Gparted-CD Festplatte sda gelöscht auf sdb läßt gparted keine Option zu.
4. Mit Linuxmint 13 Livestick im Livemodus Terminalausgaben siehe

$ sudo parted -l
Modell: Kingston DT 101 G2 (scsi)
Festplatte  /dev/sda:  7747MB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 1      1049kB  7747MB  7746MB  primary  fat32        boot


Modell: ATA MAXTOR STM325082 (scsi)
Festplatte  /dev/sdb:  250GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende  Größe  Typ  Dateisystem  Flags


Modell: ATA MAXTOR STM325082 (scsi)
Festplatte  /dev/sdc:  250GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende  Größe  Typ  Dateisystem  Flags


Fehler: /dev/zram0: unbekannte Partitionstabelle                         

mint@mint ~ $ sudo lsblk -o NAME,LABEL,SIZE,FSTYPE,MOUNTPOINT
NAME   LABEL                       SIZE FSTYPE                     MOUNTPOINT
loop0                            987,3M squashfs                   /rofs
sr0                               1024M                           
zram0                            243,5M swap                       [SWAP]
sda    Linux Mint 13 MATE 32-bit   7,2G iso9660                   
└─sda1                             7,2G vfat                       /cdrom
sdb                              232,9G silicon_medley_raid_member
sdc                              232,9G silicon_medley_raid_member

Hast Du oder Andere vielleicht noch einen Trick auf Lager um Mint 13 Mate  doch noch aufzuspielen??
Ich gebe noch nicht auf.

ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 20.05.2014, 20:30:34
Eventuell musst du auf den Platten erst neue Partitionstabellen erstellen lassen, bevor du partitionierst.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 20.05.2014, 20:34:59
Ist bestimmt nicht verkehrt !
Holzhammer wäre (VORSICHT !!)
sudo dd if=/dev/zero of=/dev/hd**sorgfältig wählen, "b" und oder "c" (beschreibt die ganze Platte mit Nullen)
aber nur wenn nix anderes geht, ohne Gewähr, habe ich noch nie gemacht,
dauert wahrscheinlich sehr lange
evtl reicht auch :
sudo dd if=/dev/zero of=/dev/hd* bs=512 count=1(löscht MBR und Partitionstabelle)
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 20:44:05
@ aexe, helli,

so hab jetzt neue Partitionen erstellt.
Siehe

sudo parted -l
Modell: Kingston DT 101 G2 (scsi)
Festplatte  /dev/sda:  7747MB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 1      1049kB  7747MB  7746MB  primary  fat32        boot


Modell: ATA MAXTOR STM325082 (scsi)
Festplatte  /dev/sdb:  250GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      1049kB  250GB  250GB  primary  ext4


Modell: ATA MAXTOR STM325082 (scsi)
Festplatte  /dev/sdc:  250GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      1049kB  250GB  250GB  primary  fat32


Fehler: /dev/zram0: unbekannte Partitionstabelle                         

mint@mint ~ $ sudo lsblk -o NAME,LABEL,SIZE,FSTYPE,MOUNTPOINT
NAME   LABEL                       SIZE FSTYPE   MOUNTPOINT
loop0                            987,3M squashfs /rofs
sr0                               1024M         
zram0                            243,5M swap     [SWAP]
sda    Linux Mint 13 MATE 32-bit   7,2G iso9660 
└─sda1                             7,2G vfat     /cdrom
sdb                              232,9G         
└─sdb1                           232,9G ext4     
sdc                              232,9G         
└─sdc1                           232,9G vfat   

Wenn das so gut wage ich nun einen neuen Versuch.
ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 20.05.2014, 20:51:19
Sieht schon besser aus, aber die sdb1 ist doch viel zu groß für "/" (Linux-System-Partition) ??
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 20.05.2014, 20:55:20
Das sieht doch schon viel besser aus.
Denke zumindest an eine Swap, etwas größer als der RAM!
Ich würde auch nicht so eine große Partition für das System nehmen, 30 GB sollten reichen und den Rest als reine Datenpartition anlegen.
Eventuell eine Partition für ein weiteres Linux frei lassen.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 20:58:08
@ aexe,

Bitte um einen Vorschlag um die sdb1 vernüftig einzuteilen. (Aber keine Grundsatzdiskussion was gut oder nicht gut)
ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 20.05.2014, 21:00:29
hellis Vorschlag finde ich gut.
Also :
sdb1 20-30 G (System)
sdb2 20-30 G (2. System)
Rest erweiterte Partition: darin "Daten" (logische Partition)
alle ext4
und ganz hinten (rechts) SWAP

Das wäre grundsätzlich eine sinnvolle Einteilung, die auch Spielraum für Änderungen lässt.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 21:19:17
@ aexe,

so hab ich nun eingeteilt

sudo lsblk -o NAME,LABEL,SIZE,FSTYPE,MOUNTPOINT
NAME   LABEL                       SIZE FSTYPE   MOUNTPOINT
loop0                            987,3M squashfs /rofs
sr0                               1024M         
zram0                            243,5M swap     [SWAP]
sda    Linux Mint 13 MATE 32-bit   7,2G iso9660 
└─sda1                             7,2G vfat     /cdrom
sdb                              232,9G         
├─sdb1                            39,1G ext4     
├─sdb2                             3,4G swap     
├─sdb3                            38,8G ext4     
└─sdb4                               1K         
sdc                              232,9G         
└─sdc1                           232,9G vfat 

ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 20.05.2014, 21:27:10
Falls sdb4 die Erweiterte ist, musst du darin noch die Datenpatition anlegen.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 20.05.2014, 21:30:02
helli hat es schon geschrieben :
sdb4 ist vermutlich eine erweiterte Partition. Darin solltest Du noch eine logische Partition erstellen.
(für Daten) und am besten den Partitionen Bezeichnungen (Label) geben. (Rechtsklick in GParted auf die jeweilige Partition)
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 21:30:18
@ helli,

wie geht das?
Die Option daten oder Ähnliches habe ich nicht gefunden.

ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 20.05.2014, 21:34:19
Wie aexe schon schrieb, in der erweiterten eine logische über den gesamten verfügbaren Speicherplatz als ext4 anlegen.

Bei der Installation die Option Etwas Anderes wählen.
sdb1 als / (Systempartition) festlegen
sdb5 kannst du gleich als /home/dein-name/Daten festlegen, dann muss man es nicht nachträglich machen, muss aber nicht unbedingt sein.
Grub auf sdb installieren lassen

für "dein-name" den Benutzernamen kleingeschrieben verwenden
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 21:39:01
@ aexe, helli,

wäre das so in etwa das, dem Zweck entsprechend?
sudo lsblk -o NAME,LABEL,SIZE,FSTYPE,MOUNTPOINT
NAME   LABEL                       SIZE FSTYPE   MOUNTPOINT
loop0                            987,3M squashfs /rofs
sr0                               1024M         
zram0                            243,5M swap     [SWAP]
sda    Linux Mint 13 MATE 32-bit   7,2G iso9660 
└─sda1                             7,2G vfat     /cdrom
sdb                              232,9G         
├─sdb1                            39,1G ext4     
├─sdb2                             3,4G swap     
├─sdb3                            38,8G ext4     
├─sdb4                               1K         
└─sdb5 Daten                     151,6G ext4     
sdc                              232,9G         
└─sdc1                           232,9G vfat     


ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 20.05.2014, 21:40:33
"Daten" ist die Bezeichnung oder Label, kann aber auch anders benannt werden oder gar nicht.
Reicht wenn eine Partition vorhanden ist. Den Rest kann man auch später noch regeln.
Sieht gut aus. Jetzt halt beim Installieren "etwas anderes" wählen und die Partitionen manuell zuweisen. Zumindest die System-Partition "/" (Mountpunkt), verwenden als ext4, die swap wird automatisch erkannt.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 21:47:41
@ helli, aexe,

so werde nun auf's Neue versuchen zu installieren.
Bei Installation "etwas Anderes " wählen und dann nach sdb1 installieren und den Bootloader nach sdb.
Wäre das so richtig?

ullimell 
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 20.05.2014, 21:49:06
Ja, viel Erfolg!
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 21:53:20
@ helli, aexe,

werde nun auf anderen Rechner umsteigen, da ich während des Installationsvorgang ja nicht  im Forum schreiben kann um eventuell nachzufragen.
Hoffe das ist okay?
Beginne nun mit Install.
Drückt mir die Daumen.

ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 20.05.2014, 22:06:13
Viel Glück !
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 22:20:04
@ aexe, helli,

nach Neustart Schwarzer Bildschirm Operatingsystem not found und darunter einen blinkenden cursor  :-\ :-\

Nun steh ich wieder wie am Anfang.

ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 20.05.2014, 22:25:53
Es könnte sein, dass nicht von der richtigen Platte gebootet wird.
Mal von der anderen versuchen, oder beide mal probieren.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 22:31:17
@ helli,

meine Bootdevices erlauben nicht zwischen verschiedenen Platten zu wählen.
Einzige Möglichkeit ist "Boot from Hard Drive"

ullimell

Ps: Stelle hier mal das Bild vom löseungsversuch des Raids ein
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 20.05.2014, 22:40:39
Ich denke mal, wenn 2 Platten verbaut sind, müsste man auch zwischen beiden wählen können.
Aber fast jedes BIOS ist anders, da kann ich aus der Ferne schlecht einen Rat geben.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 20.05.2014, 22:44:07
Und was gibt es außer dem "Boot from Hard Drive" noch für Möglichkeiten ?
Ich wundere mich sowieso schon von Anfang an, warum der Stick immer sda ist,
das ist nämlich normalerweise nicht so.
Evtl könntest Du ja versuchen das System mal auf einen zweiten Stick zu installieren
(wenn vorhanden, 8G würden reichen),
ob der Rechner sich dann damit starten lässt.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 20.05.2014, 22:46:08
...oder auch auf die 2. Platte installieren, von einer müsste er dann ja booten.

Zitat
Ich wundere mich sowieso schon von Anfang an, warum der Stick immer sda ist,
das ist nämlich normalerweise nicht so.
Stimmtzwar, aber bei Nudels war es auch so, dass das Boot-Medium (der Stick) als sda geführt wurde.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 20.05.2014, 23:01:08
So ein Bild vom Bios
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 20.05.2014, 23:18:08
Unter PHYSICAL DRIVE sind doch 2 gleiche Platten aufgeführt.
Die 2. scheint nach meiner Meinung markiert zu sein.
Die erste wird wohl die richtige sein.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 20.05.2014, 23:19:05
Abgesehen davon, daß das Bild so riesig ist und kaum auf meinen bescheidenen Bildschirm passt,
erkenne ich da irgendetwas von RAID "low level formatting" done 25% ...
Wozu soll das denn gut sein ?
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 20.05.2014, 23:36:38
Hoffe, so kann man mehr erkennen:
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 20.05.2014, 23:44:48
helli, well done, danke ! Hätte ich auch drauf kommen können, bisschen Bildbearbeitung machen, stattdessen hab ich das Bild hin und her geschoben.

Aber trotzdem sehe ich da keine Bootoptionen und daß es 2 Platten gibt, wussten wir ja schon.
Mit RAID kenn ich mich nicht aus, bin dann auch mal weg für heute.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 21.05.2014, 01:36:08
Hoffentlich findet sich jemand, der sich mit dem BIOS besser auskennt!

In dem Bild sind wohl nur die Einstellungen für RAID zu sehen.
Was mich dabei stutzig macht, ist ebenfalls: Formatting.../   25% done.
Kommt mir so vor, als wäre es auf der 2. Platte noch nicht abgeschlossen.
Nach dem was ich bisher über RAID gelesen habe, hätte es wahrscheinlich genügt, den Punkt "Delete RAID set" anzusteuern und mit Enter zu bestätigen, aber ganz sicher bin ich mir nicht.

Unten steht Esc: Previous Menu, also vorhergehendes Menü.
Möglich, dass man von dort aus zu einem Menü gelangt, wo die Bootreihenfolge eingestellt werden kann.

Mehr kann ich leider auch nicht dazu sagen.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: linuxer01 am 21.05.2014, 03:01:46
Welche BIOS Version und was für ein Motherboard ist verbaut ?
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ehtron am 21.05.2014, 12:15:01
Hi :)
habe den thread nicht ganz durch.. 

fällt mir aber gerade ein, als ich das bios bild sehe..

create doch mal mit den beiden platten ein raid 0 (zusammenfassung der platten.. die platte wird also doppelt so gross)
oder raid 1 (platte wird intern gespiegelt, um ausfällen vorzubeugen)

da ein raid für das system transparent ist, kann man das ja mal versuchen,
und in der live mal schauen was lm dann anzeigt.

aber das man die raid funktion nicht gänzlich abschalten kann, wundert mich schon.

Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 21.05.2014, 15:31:10
Das Bild zeigt sehr wahrscheinlich das BIOS des RAID-Controllers.

Um die Bootreihenfolge einzustellen benötigt man aber das System-BIOS.
In den meisten Fällen gelingt dies mit der Taste [Entf], aber auch [F1] oder [F2] sind heiße Kandidaten.
http://www.chip.de/artikel/Workshop-RAID-bauen-4_12894000.html (http://www.chip.de/artikel/Workshop-RAID-bauen-4_12894000.html)
Auf dieser Seite geht es zwar um das Einrichten von RAID, eventuell helfen die Hinweise aber auch zum deativieren.
Ich halte es für denkbar, dass sich das RAID auch im System-BIOS deaktivieren lässt.
Dazu hab ich dies gefunden:
Zitat
Im BIOS die Option "SATA Mode Selection" (unter "Advanced") von "RAID" auf "IDE" oder "AHCI" umstellen.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: DocHifi am 21.05.2014, 16:10:21
Wenn man ein Raid bildet, schreibt dieses Informationen auf die HDD.
Hatte letztens einen Beitrag gelesen, wo der TE dieses erst wieder rückgängig machen musste.
Irgendwie musste das Raid erst aufgelöst werden, finde den Beitrag leider nicht mehr.
Erst danach konnte er installieren, ob das hier auch zutrifft ?
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 24.05.2014, 14:04:44
@ alle Mithelfer,

habe alle Möglichkeiten vom Bios-Setup ausgetestet. Erfolg  No Operating System found.
Einzig das Booten von Hard-Drive konnte auf enabled gestellt werden.

festplatten ausgebaut und einzeln eingebaut. Neuinstal. Neustart. No Operating System found.

von Dvd installiert. Neustart. No Operating System found.

Raidkarte ausgebaut. Keine Festplatte zum installieren gefunden.
Raidkarte wieder eingebaut. Andere Festplatte versucht einzubauen, kläglich gescheitert falsche Anschlüsse.

Orginalfestplatten eingebaut. Und Installiert.
Bin nun im Livemodus online und kann den Inhalt der Festplatte ansehen.
Aber nach Neustart. No Operating System found.
Bitte um weiterführende Tips.

Hier ein Screenie von der Festplatte.
ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: helli am 24.05.2014, 15:15:16
Ich glaube, du hast in deinem System-Bios noch nicht die richtige Einstellung gefunden oder vorgenommen.
Hier kommt ebenfalls die Fehlermeldung "No Operating System found" und im 1. Bild
http://support.lenovo.com/de_DE/diagnose-and-fix/detail.page?DocID=HT003120 (http://support.lenovo.com/de_DE/diagnose-and-fix/detail.page?DocID=HT003120)
steht zwar SATA RAID bereits auf Disabled, aber SATA AHCI auch noch auf Disabled.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: DocHifi am 24.05.2014, 15:20:25
Zitat
aber SATA AHCI auch noch auf Disabled.
Hat mit dem Problem nichts zu tun, sollte aber trotzdem aktiviert sein, weil schneller.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 24.05.2014, 15:30:28
@ DocHifi,

diese Möglichkeit SATA AHCI auf disabled gibt mein Bios nicht her.
ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: DocHifi am 24.05.2014, 15:51:37
helli meinte du hättest es vergessen, daher ging ich davon aus, das er es irgendwo gesehen hat.
Wenn du es nicht abstellen kannst, ist es ok, weil soll ja eh an sein. :D
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 24.05.2014, 16:08:58
@ DocHifi,

besteht denn keine Möglichkeit aus dem Livemodus das installierte System zum Starten zu bewegen?
Hintergrund der Frage ist: Um dann eventuell aus dem OS das booten von der Festplatte zu erzwingen.

ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: DocHifi am 24.05.2014, 16:14:15
Du könntest es mit der SuperGrubDisk versuchen.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 25.05.2014, 12:10:38
hi DocHifi,

habs mit Supergrubdisk probiert findet kein OS.
Nach vielen neuen Versuchen un Umpatritionieren festgestellt das auf der Festplatte einen Bereich gibt der nicht entfernt werden tut.
Siehe Screenie.
Meine Frage dazu : Wielösche ich diesen Bereich?
ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: DocHifi am 25.05.2014, 12:30:21
Den kannst du nicht löschen, das sind die 5 oder10 % die immer reserviert werden, damit Root noch ins System kommt, falls die HDD mal voll ist.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: ullimell am 25.05.2014, 16:09:31
Danke für Auskunft
Werde neuen Installversuch machen und berichten.
ullimell
Titel: Re: Installation scheitert wegen Raid
Beitrag von: Sitown am 07.11.2015, 14:31:25
Grundsätzlich gilt für Boards mit integrierten RAID Controller, dass zwei identische HDD (Firmware, Hersteller, Größe) vorliegen sollten!

Dann UEFI Secure Boot abstellen im BIOS (bei Mint) und den S-ATA AHCI-/IDE Modus auf Raid umstellen, speichern und Postboot abwarten.

Dann kommt im Idealfall der Raidcontroller ins Spiel und ein Auswahlmenü (F-Tasten) erscheint, dort werden die Platten hoffentlich erkannt und man muss noch für die zwei oder XYZ Platten bspw. Raid-0/1 usw., auswählen und mit Tab zu den "N" Feld springen und dort mit z/y auf eben "Y" umstellen, speichern und neu starten.

An der Stelle kann man das RAID auch wieder auflösen was man unbedingt in der Reihenfolge tun sollte bevor man im BIOS wieder auf S-ATA-AHCI -/IDE umstellt!

Auch die Partitionsgröße kann bei einigen Controllern hier ausgewählt werden für das RAID, mein Rat, lasst dies das OS machen.

Die Blockgröße sollte man bei 64 lassen (Standard).

Wenn alles gut läuft wird das neue Raid erkannt und man kann sein OS nach Wahl installieren.

So bei den MSI Boards mit -/ohne UEFI Bios aus den Jahren 2009 - 2015.

Linux Mint 17.2 64 Bit mit Cinnamon, Ubuntu 14.04 LTS oder eben Win 7-8 lassen sich dann meist ohne größere Probleme installieren.

Wer Raid-0 nutzt, hat hoffentlich eine dritte HDD für die Datensicherung, dass Ausfallrisiko bei Raid-0 verdoppelt sich in etwa und ist bei neuen HDD in den ersten 6. Monaten am höchsten.

Wer S.M.A.R.T im Bios aktiviert hat wird bei den MSI Boards frühzeitig während des Bootvorgangs informiert wenn etwas nicht koscher ist (defekte Sektoren). I.d.R kann noch eine Datensicherung durchgeführt werden und man sollte das Raid danach auflösen im BIOS und die beiden Platten genauestens checken lassen.

S.M.A.R.T oder andere Testfunktionen sowie der RAID Controller erhöhen die Bootzeit, man kann bei entsprechendem Wissen an Schrauben drehen und den Bootvorgang beschleunigen aber die Sicherheit (defekte Sektoren) sollte vorgehen.

Ich verwende die Sea Tools unter Windows, WD, Hitachi haben eigene Tools. Man kann auch HD-Tune unter Windows verwenden oder die Pedants für Linux um HDD zu testen.

Unter Windows, Linux oder im BIOS ist es möglich mit einer "Low Level" Formatierung eine HDD wieder in Schwung zu bringen, bei größeren Defekten (kratzende Geräusche usw.) sollte die HDD schnellsten ausgetauscht werden.

Bisher ist mir seit 2007 keine HDD im Raid-0 ausgefallen (WD, Hitachi und Seagate HDD), dass älteste Raid-0 hatte 29.870 Betriebsstunden mit identischen Platten.

Zur Geschwindigkeit unter Raid, bei Raid-0 mit zwei S-ATA 160er - 7.200-/ 8MB Cache werden unter Win 7 Pro 64 folgende Werte erreicht:

298 MB/ sec. Maximum
138 MB/ sec. Minimum
178 MB/ sec. Durchschnitt
17,2 ms Zugriff

Ermittelt mit HD-Tune Pro im langsamen (genauen) Modus

Bei moderneren HDD wie die Black Series mit Dualcore Controller und 128MB Cache von WD kommen die Werte bis auf den Zugriff locker an SSD heran.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: Sitown am 07.11.2015, 14:46:57
Richtig!

Aber auch ich war lange ein stiller Leser gerade von spezifischen Artikeln wie bspw. zum Thema Raid und finde es ok wenn man auch ältere Artikel ergänzt um eigene Erfahrung. Für das Board und für die Leute draussen.



Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 07.11.2015, 15:52:53
Off-Topic:
Die Absicht, zusätzliche sinnvolle Information zu dem schon etwas älteren Thema beizusteuern, erschließt sich eigentlich leicht, wenn man den Beitrag aufmerksam liest.
Könnte ja evtl als Energie- bzw Zeitverschwendung empfunden werden, allerdings sind das diese zurechtweisenden Meta-Diskussionen unter Umständen auch. Denn der Beitrag steht nun mal da und sollte mMn auch nicht wieder gelöscht werden.  ;)
RAID ist ja wohl keineswegs eine historische Angelegenheit.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: aexe am 07.11.2015, 16:54:33
Off-Topic:
... dass mir für Sitown's Beiträge verhältnismäßig oft der Kontext fehlt und dieser weit zurück reicht.
Off-Topic:
Ich packe jetzt auch mal meine Lupe aus : Ein fehlender Kontext kann weder kurz noch weit zurückreichen, wenn er fehlt, ist er einfach nur nicht vorhanden. So ist es jedenfalls nach meinem Verständnis.
Titel: Re: Installation scheitert wegen Raid
Beitrag von: Sitown am 07.11.2015, 20:06:47
Dann wollen wir die Informationen neu definieren.

Kontext: Charakterisieren der Situation einer Entität in Interaktion mit anderen Entitäten.  :P

Der TO hatte zwei identische Maxtor HDD die wenn ich es nicht übersehen habe, an einem Silicon Image Controller unter OS XP hingen?

Durch die einzelnen Schritte des TO, beginnend auf Seite 1 hat sich eine blöde Situation für Linux Anfänger oder generell für wenig erfahrene User aufgetan.

Ich hätte geraten RAID im BIOS zu deaktivieren, den S-ATA AHCI bzw. IDE Modus zu aktivieren und die beiden Platten erst einmal mit GPARTED oder einer Windows CD alle Partitionen zu löschen und auf FAT 32 zu formatieren. Also einen sauberen Reset der HDD unter Standard IDE bzw. S-ATA AHCI im BIOS.

Danach wieder umgekehrt RAID im BIOS aktivieren, S-ATA -/IDE Modus deaktivieren und ein neues RAID wie gewünscht zu bilden, die Optionen dazu waren im Bild des BIOS zu sehen. Alles andere kann man dann mit dem jeweiligen OS durchführen (Partition etc.)

Der Titel des Threads war -/ist irreführend, RAID hat vorher augenscheinlich unter XP funktioniert, erst die Maßnahmen des TO mit dem Willen Linux Mint zu installieren haben zu der Situation geführt.