LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Installation & Updates => Thema gestartet von: theslashy am 17.01.2013, 13:26:55

Titel: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 17.01.2013, 13:26:55
Hi,

ich versuche auf einem FUjitsu Lifebook 8410e Mint zum laufen zu bringen, allerdings scheint es probleme mit der Graka zu geben.

Cinnamon startet nach einer nackten installation normal, allerdings mit schweren grafikfehlern, nicht bedienbar.

Ich habe den nouveau-treiber via grub blacklisted (nouveau.blacklist=1)

dann läuft alles perfekt, aber nur mit 1024x786 und ohne grafikbeschleunigung.

Dann unter additional drivers die Nvidia treiberoptionen durchprobiert....hilft alles nix...teilweise friert dann nach dem reboot alles ein

Kann mir noch jemand nen tip geben?

danke schonmal!
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: DocHifi am 17.01.2013, 13:31:39
Diese Karte, sollte eigentlich, mit dem "nvidia-current" funktionieren.
Hast du dir auch eine "xorg.conf"erstellen lassen, bzw. eine angelegt ?
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 17.01.2013, 13:46:33
ja der meinung war ich auch,

sollte die xorg.conf nicht automatisch da sein/ bzw sich ändern wenn ich über die gui den nvidia-current aktiviere?

Was muss ich denn da tun?

bzw... was muss da rein?
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: DocHifi am 17.01.2013, 13:50:09
Zitat
Was muss ich denn da tun?
Zuerst einmal nachsehen, ob eine da ist und was drinn steht.
cat /etc/X11/xorg.conf
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 18.01.2013, 22:14:00
so habs endlich geschafft via recovery den nvidia-treiber wieder loszuwerden.

also die xorg.conf ist leer....

was jetzt?
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: DocHifi am 18.01.2013, 22:17:45
Zitat
was jetzt?

Jetzt wird wieder der freie Treiber verwndet und der braucht keine xorg.conf.
Die war übrigens nicht leer, sondern nicht vorhanden, dann öffnet sich eine leere Datei.
Hättest du den Nvidia nicht deinstalliert, hätte man eine anlegen lassen können.
Steht übrigens alles hier:
http://wiki.ubuntuusers.de/Grafikkarten/NVIDIA/nvidia (http://wiki.ubuntuusers.de/Grafikkarten/NVIDIA/nvidia)
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 18.01.2013, 22:31:19
Danke für den Link, ist mir jetzt klar.

hab jetzt den nvidia treiber installiert, dann die xorg.conf bearbeitet...mal neu starten und schaun was passiert

Das problem war bisher das ich vorher gar nix mehr machen konnte nur noch recovery

btw: das mit der xorg war mein fehler...muss mich erst dran gewöhnen beim pfad auch auf groß/kleinschreibung zu achten....
habe bei /etc/x11/ geschaut^^


//EDIT

also läuft nicht...beim hochfahren kommt kurz ein großes nvidia-logo dann hängt die maus
dann kommt kurz ein fenster "in 10 sec wird der benutzer angemeldet" dann nur noch grafikfehler
dann wieder alles von vorne..
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: DocHifi am 18.01.2013, 23:52:05
Zeige mal den Inhalt der xorg.conf bitte.
Oder hänge sie als Datei an.
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 19.01.2013, 06:36:10
Ok, hier mal was ich gemacht habe:

- Nvidia Treiber unter "Softwarequellen" aktiviert
- nvidida-xconfig ausgeführt
- reboot

danach die selbe symptome wie oben
hier mal der teil von der xconf der interessant sein dürfte....bekomme es irgendiwe ohne gui nicht hin mir die auf nen stick zu kopieren^^

Section "Monitor"
 Identifier "Monitor0"
 VendorName "Unknown"
 ModelName "UnKnown"
 HorizSync 28.0 - 33.0
 VertRefresh 43.0 - 72.0
EndSection

Section "Device"
 Identifier "Device0"
 Driver "nvidia"
 VendorName "Nvidida Corporation"
EndSection

Section "Screen"
 Identifier "Screen"
 Device "Device0"
 Monitor "Monitor0"
 DefaultDepth 24
 Subsection "Display"
  Depth 24
 EndSubSection
EndSection

hoffe das hilft....komme momentan nur mit ein bisschen glück ung STRG+ALT+F1 ins Terminal.
Sonst sehe ich nur Farbige Kästechen und Kreuze !?
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: leonidas am 19.01.2013, 10:12:14
Ich würde es an Deiner Stelle mal mit einer anderen "Standard"-xorg.conf probieren.
Am besten ist, Du nimmst das Live-System (startet bei Dir doch problemlos, oder?) und mountest die Partition mit dem installierten Mint nach /mnt:
sudo mount /dev/sda3 /mnt"sda3" ist hier NUR BEISPIEL, welche das bei Dir ist, musst Du herausfinden und dort einsetzen. Wenn Du das nicht weißt, dann schau Dir erst auf der Konsole im installierten System VORHER noch an mit
mountwelche Partition nach / gemountet ist. Da ist eine Zeile dabei wie (beispielhaft)
/dev/sda3 on / type ext4 (rw,noatime,discard,errors=remount-ro)
Wenn also diese Partition im Live-System mit dem ersten Befehl hier oben nach /mnt gemountet ist, dann benenne die xorg.conf mal um mit
sudo mv /mnt/etc/X11/xorg.conf /mnt/etc/X11/xorg.conf.bakDann mach eine neue mit
sudo gedit /mnt/etc/X11/xorg.confund kopier dort mal rein:
Section "Screen"
Identifier "Default Screen"
Device "Default Device"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "RegistryDwords" "EnableBrightnessControl=1"
Option "NoLogo" "True"
EndSection
Speichern, schließen, und wieder versuchen, das installierte System zu booten.

---------
Natürlich ist bei dem allen entscheidende Grundlage, dass wirklich das Treiberpaket korrekt installiert ist auf dem installierten System. Das vielleicht vorher nochmal checken auf der Konsole mit
dpkg -l | grep nvidiaHier sollte optimalerweise von den Treibepaketen nur nvidia-current installiert sein (es erscheinen natürlich noch die anderen Sachen mit "nvidia" im Namen wie settings etc.). - Wenn hier etwas nicht passt, dann bitte den Austausch der xorg.conf wie oben immer NACH einer eventuellen Treiber-Installation, jedenfalls über die GUI, ausführen, weil die Aktivierung dort die xorg.conf ja wieder überschreibt. Wenn Du den Weg gehst - statt den über das Live-System - erst den nvidia wieder zu entfernen und die xorg.conf, um wieder in die grafische Oberfläche zu kommen wie vorher, dann also wieder installieren (nvidia-current) und dann erst xorg.conf austauschen.
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: DocHifi am 19.01.2013, 10:51:53
Ich hätte im Zweifel, eine funktionierende xorg.conf, zumindest hat die bisher immer getan.
Auf mehreren Rechnern mit Geforce 7xx un 8xx.
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 19.01.2013, 21:30:22
Also in die Konsole komme ich mit etwas glück auch so noch ;-D

gut, also Gestartet, Konsole -> xorg.conf gesichert, neue gemacht, deine inhalte reinkopiert, sonst ist da nix mehr drin

Gleiche Symptome nach dem Reboot...

nur halt ohne nvidia logo^^
dann kommt kurz ein fenster "in 10 sec wird der benutzer angemeldet" dann nur noch grafikfehler
dann wieder alles von vorne..
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: DocHifi am 19.01.2013, 21:36:33
Ich hänge hier mal meine xorg an, kannst du ja mal testen.
Die Zeile Metamodes, musst du an deine Auflösung anpassen.
Und die Datei natürlich wieder umbenennen.
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 19.01.2013, 21:49:59
gemacht...metamode mal testweise auf 1024*768 geändert....
gleiche symptome...

da stimmt doch irgendwas nicht grml...
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: DocHifi am 19.01.2013, 21:52:55
Also diese Xorg, rennt hier auf 2 Rechnern, ohne Probleme, ich schieb die immer nur rüber und geht.
Auch in einem anderen Forum, hab ich die schon weiter gereicht und funzte.
Da muss wohl wirklich was im argen sein.
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: leonidas am 19.01.2013, 22:09:57
Teile mal bitte, nur als Routinekontrolle, mit, was
dpkg -l | grep nvidiazeigt.
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 20.01.2013, 16:55:25
Also da gibts 2 Zeilen
ii nvidia-current-Updates Nvidia xorg driver, Kernel Module and vdpau Library
ii nvidia-settings-Updates Tool for configuring the NVIDIA graphics driver

Hab jetzt nochmal neu aufgesetzt aber keine Änderung
Im BIOS kann man zu der Graka nicht wirklich was einstellen, aktuelles BIOS ist drauf.
Gleiches Problem gibt's bei ubuntu übrigens

Danke für eure Hilfe !!
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 21.01.2013, 20:14:31
Also mit win7 läuft alles wunderbar....ich bin mit meinem latein am ende....linux darauf lieber vergessen?
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: Blindenhund am 22.01.2013, 11:58:43
Mag das Ding den Cinnamon etwa nicht? Mal Mate versuchen...

Öhm... Das Ding hat 128MB Ram auf der Graka. Nutzt die dann automatisch Shared-Ram? Muss dazu was im BIOS eingestellt werden??
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: Korfox am 22.01.2013, 12:37:24
Mal eben eine schnelle Google-Recherche ergab, dass Blindi durchaus korrekt zu liegen scheint.
Es gibt einige Leute, die Probleme mit der Kombination Cinnamon - 8400m G - prop. Treiber haben (komischer Weise klappt bei denen mit nouveau aber alles halbwegs korrekt). Einen versuch mit MATE oder einer anderen Oberfläche wäre es also mal wert.

http://en.wikipedia.org/wiki/GeForce_8_Series#Problems (http://en.wikipedia.org/wiki/GeForce_8_Series#Problems) erläutert außerdem, dass diverse Chips der 8400m G (also der G86) mit Temperaturproblemen ausgeliefert wurden. Potentiell könnte auch deiner darunter fallen...
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: leonidas am 22.01.2013, 12:46:24
Also da gibts 2 Zeilen
ii nvidia-current-Updates Nvidia xorg driver, Kernel Module and vdpau Library
ii nvidia-settings-Updates Tool for configuring the NVIDIA graphics driver

Ich würde es hier allerdings vor allen anderen Maßnahmen auch erstmal noch mit dem normalen Nvidia-current probieren. Also den hier installierten, den -updates erst entfernen, und dann den current installieren.
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 22.01.2013, 19:35:55
Mag das Ding den Cinnamon etwa nicht? Mal Mate versuchen...

Öhm... Das Ding hat 128MB Ram auf der Graka. Nutzt die dann automatisch Shared-Ram? Muss dazu was im BIOS eingestellt werden??

Also im Bios ist keine einstellung möglich...

werd morgen mal versuchen das ganze mit mate laufen zu lassen...mal schaun obs was hilft...

graka sollte technisch ok sein, da windows ja ohne probleme läuft
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: leonidas am 22.01.2013, 19:38:35
Und, ich kann Dir nur nachdrücklich empfehlen, mal den normalen "nvidia-current"-Treiber zu probieren, wenn Du das nicht schon getan hast.
Das ist ja keine große Affäre, einfach den jetzigen entfernen, und den current stattdessen probieren.
Titel: Re: Mint 14 Cinnamon Installation Nvidia 8400m GS
Beitrag von: theslashy am 23.01.2013, 19:32:22
Man glaubt es kaum....mit mate läufts....

danke euch allen!! aber merkwürdig ists schon ^^