Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
06.05.2021, 21:24:51

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25569
  • Letzte: Noelpferd
Statistiken
  • Beiträge insgesamt: 733706
  • Themen insgesamt: 59122
  • Heute online: 638
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Probleme mit NVidia Hybridgrafikkarten  (Gelesen 3493 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #30 am: 28.05.2017, 14:29:33 »
hab die Commands von aeexe benutzt
wenn Du die Terminal-Ausgaben dazu zeigen würdest, wüsste man, was gemacht wurde.

Der nouveau-Treiber ist übrigens im Kernel enthalten, den muss man nicht extra herunterladen, soweit ich weiß.

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #31 am: 28.05.2017, 14:33:37 »
hab die Commands von aeexe benutzt
wenn Du die Terminal-Ausgaben dazu zeigen würdest, wüsste man, was gemacht wurde.

Der nouveau-Treiber ist übrigens im Kernel enthalten, den muss man nicht extra herunterladen, soweit ich weiß.

Code: [Auswählen]
sudo apt-get purge nvidia*
und dann
Code: [Auswählen]
sudo ubuntu-drivers autoinstall

 Hab beides genutzt, was im Terminal stand hab ich nun nicht mehr.

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #32 am: 28.05.2017, 14:36:21 »
Hi :)
nvidia purge ist ja ok, wenn es nicht klappt...
zum installieren benutze bitte die treiberverwaltung, dann kannst du verschiedene ausprobieren.
jeweils reboot nach install und purge..
« Letzte Änderung: 28.05.2017, 14:42:53 von ehtron »

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #33 am: 28.05.2017, 14:42:09 »
So 370 installiert rückfallmodus, werde es dann mit der 340 probieren

/Update mit der 340 kam kein Rückfallmodus mehr hmm.

//Update soo nach Neuinstallation hab ich endlich ein Prime Menu, obs funkt ist aber die Frage
« Letzte Änderung: 28.05.2017, 14:49:37 von b.reit »

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #34 am: 28.05.2017, 14:53:34 »
Kann das sein das LM 18.1 in Bezug auf Grafik und WLAN (und evtl. anderem) ziemlich buggy ist?
Die Probleme sind bei U/K/X/ubuntu 17.04 so nicht da (weil auf anderem Schlappi mit Xubuntu
keine Probleme).

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #35 am: 28.05.2017, 14:59:17 »
H:)
Zitat
Kann das sein das LM 18.1 in Bezug auf Grafik und WLAN (und evtl. anderem) ziemlich buggy ist?
das ist wie im richtigen leben, kommt immer auf die kombination an ;)

jain.. hybrit systeme machen gern mal probs.. 
und du vergleichst äpfel mit birnen.
mint 18.x fusst weiterhin auf ubuntu 16.04.

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #36 am: 28.05.2017, 15:00:19 »
Nachtrag, keine Funktion immer bei jedem Logout/In wechselt er auf Intel ..

/Update angeblich auf NVIDIA umgeschaltet..

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #37 am: 28.05.2017, 15:05:25 »
Also bei mir gibt es keine Probleme mit LM-18.1 und Hybridgrafik.
So ist die Situation: user@W530 ~ $ inxi -Gx
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GK107GLM [Quadro K2000M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1920x1080@60.00hz
           GLX Renderer: Quadro K2000M/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 375.39 Direct Rendering: Yes

user@W530 ~ $ lspci -nnk | egrep -i "VGA|3D|Display" -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:21f5]
Kernel driver in use: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107GLM [Quadro K2000M] [10de:0ffb] (rev a1)
Subsystem: Lenovo GK107GLM [Quadro K2000M] [17aa:21f5]
Kernel driver in use: nvidia

user@W530 ~ $ inxi -S
System:    Host: W530 Kernel: 4.4.0-78-generic x86_64 (64 bit) Desktop: Cinnamon 3.2.7
           Distro: Linux Mint 18.1 Serena
user@W530 ~ $ dpkg -l | grep nvidia
ii  nvidia-367                                  375.39-0ubuntu0.16.04.1                    amd64        Transitional package for nvidia-375
ii  nvidia-375                                  375.39-0ubuntu0.16.04.1                    amd64        NVIDIA binary driver - version 375.39
ii  nvidia-opencl-icd-367                       375.39-0ubuntu0.16.04.1                    amd64        Transitional package for nvidia-opencl-icd-375
ii  nvidia-opencl-icd-375                       375.39-0ubuntu0.16.04.1                    amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                                0.8.2linuxmint1                            amd64        Tools to enable NVIDIA's Prime
ii  nvidia-prime-applet                         1.0.6                                      all          An applet for NVIDIA Prime
ii  nvidia-settings                             361.42-0ubuntu1                            amd64        Tool for configuring the NVIDIA graphics driver
user@W530 ~ $
« Letzte Änderung: 28.05.2017, 15:09:57 von aexe »

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #38 am: 28.05.2017, 15:07:47 »
Die Settings sind aber viel mehr ausgeprägt als meine ^^, egal hauptsache das es vllt klappt. was eh nicht so sein wird

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #39 am: 28.05.2017, 15:11:46 »
Die Settings sind aber viel mehr ausgeprägt als meine
Was normal ist, wenn der nvidia Treiber auch läuft. ;)

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #40 am: 28.05.2017, 15:17:21 »
Die Settings sind aber viel mehr ausgeprägt als meine
Versteh ich jetzt nicht so ganz.
Meine Grafikkarte ist nicht exakt dieselbe, aber aus der gleichen Familie (GK107) wie Deine.
Ich wollte lediglich zeigen, das diese mit den richtigen Einstellungen unter LM-18.1 (Kernel 4.4.0-78) fehlerfrei funktioniert.

Kann das sein das LM 18.1 in Bezug auf Grafik und WLAN (und evtl. anderem) ziemlich buggy ist?
einer Meinung nach: Nein.
Ich denke, das ist eher eine Frage der Hardware, also des Rechner-Modells und der Settings = Einstellungen, die der Benutzer macht …
« Letzte Änderung: 28.05.2017, 15:24:00 von aexe »

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #41 am: 28.05.2017, 15:19:41 »
So, Probleme nun mit Steam na gut u. Prime funktioniert höchstwarscheinlich auch nicht, werde  wieder die 375 installieren.

Übers Terminal bekomme ich wenn ich steam eingebe

dominik@dominik-Aspire-V3-772 ~ $ steam
Running Steam on linuxmint 18.1 64-bit
STEAM_RUNTIME is enabled automatically
[2017-05-28 15:18:44] Startup - updater built Apr 25 2017 22:45:11
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)


OHOHOH hab endlich das umfangreiche Settings in den Einstellungen bekommen u. steam startet wieder.
« Letzte Änderung: 28.05.2017, 15:27:38 von b.reit »

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #42 am: 28.05.2017, 15:27:36 »
Hi :)
steam ist ne andere baustelle.. bitte nicht vermischen.
dafür nen eigenen thread auf machen .. danke :)

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #43 am: 28.05.2017, 15:32:03 »
Bei mir ist auch installiert: user@W530 ~ $ dpkg -l | grep dkms
ii  acpi-call-dkms                              1.1.0-2                                    all          Kernel module that enables you to call ACPI methods
ii  bbswitch-dkms                               0.8-3ubuntu1                               amd64        Interface for toggling the power on NVIDIA Optimus video cards
ii  dkms                                        2.2.0.3-2ubuntu11.3                        all          Dynamic Kernel Module Support Framework
ii  tp-smapi-dkms                               0.41-1                                     all          ThinkPad hardware/firmware access modules source - dkms version
Möglicherweise spielt das eine Rolle, dass der Treiber richtig installiert wird.
Das Paket "tp-smapi-dkms" braucht man nicht, wenn der Rechner kein Thinkpad ist.

Re: Probleme mit NVidia Hybridgrafikkarten
« Antwort #44 am: 28.05.2017, 15:34:25 »
Hi :)
dann zeig mal
dpkg -l nividia*und
uname -rund
lspci -nnk | egrep -i "VGA|3D|Display" -A2