Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.05.2021, 02:32:10

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 736355
  • Themen insgesamt: 59282
  • Heute online: 702
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 4
Gäste: 485
Gesamt: 489

Autor Thema: [erledigt] Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M  (Gelesen 6213 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #15 am: 04.03.2015, 23:20:36 »
Das verstehe ich nicht.  Irgendwie scheint der "imaginäre" Monitor da wieder rein zu spielen.
Ich muss mal googeln. Bei Bumblebee kann der ja auch stören.

Gibst du bitte xrandr komplett?
« Letzte Änderung: 04.03.2015, 23:27:28 von geobart »

Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #16 am: 04.03.2015, 23:54:47 »
xrandr
Zitat
xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768       60.0*+   60.1 
   1360x768       59.8     60.0 
   1024x768       60.0 
   800x600        60.3     56.2 
   640x480        59.9 
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
VGA-1-2 connected
   1024x768       60.0 
   800x600        60.3     56.2 
   848x480        60.0 
   640x480        59.9 
  1024x768 (0x43)   65.0MHz
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x44)   40.0MHz
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0x45)   36.0MHz
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz

edit: der imaginäre monitor namens "unbekannt" ist zur zeit deaktiviert, falls das für die ausgabe relevant sein sollte.

Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #17 am: 05.03.2015, 00:06:03 »
Aktivieren.
Wo deaktivierst du ihn?
Hast du ausser dem Notebook-Display noch was angeschlossen?
« Letzte Änderung: 05.03.2015, 00:09:53 von geobart »

Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #18 am: 05.03.2015, 00:17:28 »
er ist jetzt wieder aktiviert, mit neustart danach. ich hatte den imaginären bildschirm bei "einstellungen"  und dann "display" deaktiviert.

xrandr
Zitat
Screen 0: minimum 320 x 200, current 2390 x 768, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768       60.0*+   60.1 
   1360x768       59.8     60.0 
   1024x768       60.0 
   800x600        60.3     56.2 
   640x480        59.9 
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
VGA-1-2 connected 1024x768+1366+0 0mm x 0mm
   1024x768       60.0*
   800x600        60.3     56.2 
   848x480        60.0 
   640x480        59.9 
  1024x768 (0x43)   65.0MHz
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x44)   40.0MHz
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0x45)   36.0MHz
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz

an dem notebook ist gar nichts angeschlossen...obwohl: eine usb-funkmaus von speedlink ist und war immer angeschlossen. das wird doch nicht an der maus liegen?

edit: https://www.linuxmintusers.de/index.php?topic=13896.0  das hier klingt nach meinem problem mit dem zweiten bildschirm/arbeitsfläche. ich verstehe aber die lösung in diesem thread nicht


Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #19 am: 05.03.2015, 00:57:59 »
Bei dem Link geht es um den Arbeitsflächenwechsel, das hat mit 2. Bildschirm nichts zu tun.
Wenn der neu installierte Treiber den 2. Bildschirm verursacht hätte, wäre ich von einem Installationsfehler ausgegangen. aber der war ja schon vorher da. :o
Mit was für Auflösungen werden die beiden Bildschirme angezeigt?

Lässt sich da irgendetwas einstellen? Was?

Bitte auch mal cat /etc/X11/xorg.conf




Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #20 am: 05.03.2015, 01:26:07 »
Zitat
cat: /etc/X11/xorg.conf: Datei oder Verzeichnis nicht gefunden

benutze aktuell wieder den nouveau-treiber.

bei "display" kann ich folgendes einstellen: für den bildschirm "laptop": 1366x768, 1360x768, 1024x768, 800x600
für "unbekannt" gibt es 1024x768 und 800x600 und bei drehung geht bei diesem nur "normal"

kurioserweise kann ich bei beiden "als hauptbildschirm einstellen" klicken. am bild ändert sich aber nichts , wenn ich den "unbekannt" als hauptbildschirm auswähle. hmm.

edit: "bildschirm spiegeln" kann ich bei beiden noch wählen. wenn ich das mache, ist nur noch ein "gespiegelter bildschirm" 1024x768 da.
« Letzte Änderung: 05.03.2015, 01:33:02 von Loichte »

Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #21 am: 05.03.2015, 20:28:31 »
Hattest du den 2. Monitor auch bei deiner ersten Installation, die mit dem Nvidia 304 endete?
Zeige mal bitte cat /etc/default/grubund das jetzige inxi -G
Irgendwie schräg das ganze ;D ::)


Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #22 am: 05.03.2015, 21:31:31 »
ich habe den zweiten monitor immer gehabt. bei allen 4 oder 5 neuinstallationen von lm 17.1   
cat /etc/default/grub
Zitat
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

inxi -G
Zitat
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Card-2: NVIDIA GF108M [GeForce GT 540M]
           X.Org: 1.15.1 drivers: (unloaded: fbdev,vesa) FAILED: nouveau,intel Resolution: 1366x768@60.0hz, 1024x768@60.0hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 10.1.3

ich find das auch sehr alles sehr strange. das linux mint ist echt perfekt und ich würde das super gerne benutzen, aber die sache mit der grafik ist zum verzweifeln. nochmal vielen vielen dank, dass zu soviel zeit in mein problem investierst!

eine frage noch: wenn ich aus testzwecken in der treiberverwaltung dauernd zwischen nouveau und 331 hin- und herwechseln würde , ist das schlecht für das system oder macht das keine probleme?




Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #23 am: 05.03.2015, 22:20:03 »
Das ist kein Problem. Wenn  der 331 geladen ist, hast du im Menu>Einstellungen>Nvidia-Settings.
Vielleicht bietet das ja noch Möglichkeiten. Wenn der richtig lädt, hast Du dort auch einen Sektor für Nvidia-Prime. Wäre interessant, ob auf den Intel gewechselt werden kann.
Wenn Du da was änderst, auf "apply", dann wird es übernommen.
Der Nouveau bietet auch eine Prime-Umschaltmöglichkeit per Terminal.

Dein System hattest Du nach der NVIDIA-Installationsanleitung upgedatet?

De orig. Nvidia-Treiber muss ev. erst noch entfernt werden.
« Letzte Änderung: 05.03.2015, 22:32:57 von geobart »

Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #24 am: 05.03.2015, 22:36:40 »
mein sytsem hatte ich nach der nvidia-installationsanleitung geupdatetd, nur bei dem dritten punkt
sudo apt-get dist-upgrade konnte ich auswählen, ob ich gewissen dateien übersachreiben oder beibehalten will. die konsole meinte, dass der standardweg in diesem fall das beibehalten ist und das habe ich auch gemacht. ich weiß aber nicht mehr, welche dateinen das im detail waren.


Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #25 am: 05.03.2015, 22:51:41 »
ich habe jetzt wieder auf 331 umgestellt und neugestartet. jetzt erkennt er auch nur noch einen bildschirm "laptop". dann lag das wohl an dem nouveau-treiber. die grafik ist gefühlt abier viel schlechter jetzt, da ich dieses ruckeln beim scrollen im firefox habe. ich schalte jetzt mal in den nvidia-settings bei "nvidia prime" auf die intelkarte um und starte neu.

edit: wenn im prime die intelkarte angewählt ist verschwindet das ruckeln beim scrollen und ich habe optisch wahrgenommen genau die gleiche grafikleistung wie mit dem nouveau-teiber. und die grafik ist einfach nicht gut.z.b. wenn ich fotos ansehe, dann sehen die total mies aus. auch wenn ich z.b. bei youtube ein hd-1080-video ansehe ist es doch sehr pixlig. bis auf das ansehen der fotos( könnte man da vielleicht mit einem anderen bildbetrachter noch was rausholen?) ist die grafik ausserhalb vom browser "eigentlich" ok und vetretbar. im firefox wird das aber noch mal ne ganze ecke schlechter: schrift, bilder, videos.(gilt auch für andere browser)

« Letzte Änderung: 05.03.2015, 23:10:24 von Loichte »

Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #26 am: 05.03.2015, 23:10:31 »
wie es aussieht muss ich wohl auf das nächste große linux mint kernel- oder treiberupdate warten und hoffen, dass es dann besser für mich wird? ich will auf keinen fall zu windwos zurück!

Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #27 am: 06.03.2015, 03:02:46 »
Ich habe auch die Treiberprobleme bei Hybrid-Grafik ... allerdings Intel 4000 / AMD Radeon HD7670M.
Bei mir läßt sich der Treiber überhaupt nicht richtig installieren; das System (Mint Cinnamon 17.1) meldet zwar, dass der Treiber richtig installiert (was so nicht stimmt, denn die core-Komponenten des Treibers, installiert über Terminal, gibt einen Konflikt wohl mit einer INE-Komponente heraus; auch das Control Center von AMD läßt sich nicht öffnen (Einstellungen, Umschalten der Grafikprozessoren etc.

Falls von Interesse für Dich:
https://www.linuxmintusers.de/index.php?topic=25117.0

Nach all meinen Recherchen ist gerade die "Sache" mit der Hybrid-Grafik recht komplex und alles andere als einfach umsetzbar unter Linux.

Ach ja ... genau in der Hoffnung, dass ein neuerer Kernel die Erkennung der Hybrid-Grafik und die Unterstützung verbessert, hatte ich den damals (vor wenigen Tagen) aktuellsten Kernel installiert ..... mittlerweile gibt es ja einen noch aktuelleren. Das hat auch nichts gebracht.
« Letzte Änderung: 06.03.2015, 03:06:52 von Michelle_Br »

Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #28 am: 06.03.2015, 12:15:55 »
wie es aussieht muss ich wohl auf das nächste große linux mint kernel- oder treiberupdate warten und hoffen, dass es dann besser für mich wird? ich will auf keinen fall zu windwos zurück!

Ich bin ganz optimistisch, dass wir das noch hinkriegen seit der verd. 2. Monitor weg ist.
Ich glaube auch, dass der irgendwie vom Nouveau erzeugt wird.

Das "Blacklisten" des Nouveau  genügte ja nicht, vermutlich muss das Nouveau-Kernelmodul am "einspringen" gehindert werden. Muss ja auch irgendwie machbar sein. ::)

Melde mich heute abend wieder, noch ist dein System ja auch etwas "unordentlich".
« Letzte Änderung: 06.03.2015, 12:21:13 von geobart »

Re: Probleme mit nvidia-Hybrid-Grafikkarte GeForce GT540M
« Antwort #29 am: 06.03.2015, 13:42:05 »
Wenn ein Treiber auf der Blacklist steht, wird er nicht mehr geladen, kann also demnach auch nicht irgendwo zwischen funken.
Sonst wäre die Blacklist ja überflüssig.