Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
17.04.2021, 04:21:59

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25502
  • Letzte: j.red
Statistiken
  • Beiträge insgesamt: 729240
  • Themen insgesamt: 58836
  • Heute online: 414
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 3
Gäste: 231
Gesamt: 234

Autor Thema: [gelöst]  Beim Hochfahren erscheint kein Auswahlmenü, trotz Installation von Linux  (Gelesen 3936 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo, ich nochmal.
Wie gesagt habe ich Linux Mint 18 nun installiert, aber wenn ich den PC hochfahre, erscheint kein Auswahlmenü, um zwischen Windows und Linux zu wählen, sondern es startet sofort Windows. Ich weiß nicht, ob bei der Installation etwas schief gelaufen ist. Wie kann ich das Problem beheben?


Das ist der Codeblock der erscheint, wenn ich den Befehl sudo parted -l eingebe.
(füge ihn mal als Datei an)
« Letzte Änderung: 31.07.2016, 01:59:11 von monkey »

Neuer Rechner mit WIN10 und "efi-Partition" - das sollte ein Rechner im UEFI-Mode sein.
Dazu passt Partition "6" - "bios_grub" nicht.
Der Grub gehört in die "efi-Partition" - "1".
Kann bestimmt über das Terminal geändert werden - nur ich habe die Befehle nicht drauf.
Meldet sich bestimmt gleich jemand der es kann.
« Letzte Änderung: 30.07.2016, 16:48:32 von billyfox05 »

Wenn Linux als System starten würde  ...

Wie hast Du Linux denn Installiert? Bei "etwas anderes" wird man nach der Part. für Grub gefragt. Bei Linux neben Windows weiß ich das nicht!

Vielleicht weiß der helli oder der toffifee was  ::)

Schau mal ins UEFI-Bios wie da die Booreihenfolge ist!

Zitat
7. Nach der Installation eventuell noch "ubuntu" im UEFI-Setup unter dem Reiter Boot in
    der Bootreihenfolge an die oberste Stelle setzen.

monkey, hast du bei der Installation wie Nuffi geschrieben hat "etwas Anderes" oder "Linux neben Windows" genommen?

Zeig bitte mal die Ausgabe von
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOSaber bitte nicht als Bildschirmfoto sondern

Die Ausgabe bitte im Codeblock, den erstellst du mit folgender Schaltfläche:

Entweder zuerst auf das '#' klicken und dann zwischen den Klammern einfügen, oder erst einfügen, dann markieren und auf '#' klicken.
(gemopst bei Marco77)

@nuffi
Wenn Linux als System starten würde  ...das kriegen wir doch mit der grub2disc hin -
ich wollte aber nicht vorgreifen  ;D

Ich vermute, die DVD wurde zur Installation im BIOS-Modus gebootet, deshalb meine Anfrage.
Bin mir inzwischen ziemlich sicher dass es so war, denn eine bios_grub wird erstellt, wenn im BIOS-Modus auf einer GPT installiert wird.

Ich würde also sagen, neu installieren und vorher sicherstellen, dass die DVD im UEFI-Modus gebootet wurde.
« Letzte Änderung: 30.07.2016, 17:51:06 von helli »

@Helli
dass die DVD im UEFI-Modus gebootet wurde.für mich zum Verständnis - vllt. hilft es monkey auch
Wo/Wie wird das beim booten der DVD eingestellt ?
Spielt die BIOS/UEFI-Einstellung ( UEFI-Mode / Legacy-Mode ) beim booten keine Rolle ?
Wie verhält sich das beim USB-Stick ?

Meine Empfehlung wäre - vom USB-Stick zu installieren.
« Letzte Änderung: 30.07.2016, 18:17:25 von billyfox05 »


Wenn im UEFI-Setup CSM auf Enabled steht, hat man im Bootmenü die Wahl, ob man im UEFI- oder im BIOS-Modus booten möchte. Für UEFI muss man den Eintrag auswählen, wo UEFI davor steht.
In meinem Bild ist keine DVD eingelegt, aber der Stick ist 2 mal aufgeführt, er würde bei der markierten Auswahl im BIOS-Modus booten.

In welchem Modus das Linux dann wirklich gebootet wurde sagt die Ausgabe des Befehls
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
« Letzte Änderung: 30.07.2016, 18:44:26 von helli »

@helli
@nuffi
ich will nicht nerven - ich bemühe mich nur es zuverstehen.
Ihr schreibt beide von "CSM" - "Ums Verrecken" in meinem "UEFI im BIOS-Kleid" kann ich den Punkt nicht finden ?!  :o
Mein Bootmenu bei gestecktem USB-Stick / eingelegter DVD ( beides LM 18 (64) Cinnamon ) sieht so aus.
Im BIOS ist u.a. eingestellt: "Legacy-Unterstützung: deaktiviert"

CSM müssten bei dir dann die "legacy Bootquellen" sein.
CSM = Legacy = BIOS

Legacy und CSM sind nur unterschiedliche Bezeichnungen für die gleiche Sache.

Danke toffifee,
die legacy-Bootquellen kann ich aber nur anzeigen lassen / nutzen wenn ich umstelle auf
"Legacy-Unterstützung: aktiviert" und damit den UEFI-Mode verlasse.
und wenn der Rechner im "Legacy-Mode" läuft bootet der Stick und die DVD auch im "Legacy-Mode"
und wenn der Rechner im "UEFI-Mode" läuft bootet der Stick und die DVD auch im "UEFI-Mode"
Wenn du jetzt "JA" schreibst - ist der Samstag gerettet  ;D