Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
07.05.2021, 01:10:29

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25569
  • Letzte: Noelpferd
Statistiken
  • Beiträge insgesamt: 733729
  • Themen insgesamt: 59124
  • Heute online: 466
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 6
Gäste: 377
Gesamt: 383

Autor Thema: [erledigt] Mint 19 & 20 Cinnamon, Interval Music Compositor, Start mit möglich  (Gelesen 883 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hy, bräuchte mal eure Hilfe :)
Ich habe mir Interval Music Compositor installiert, beim Starten öffnet sich das Programm aber nicht.
Im Menü ist es vorhanden.
-------------------------------
Hier Mint 19 32 Bit

Virtual core pointer                    id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                    id=8 [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                    id=9 [slave  pointer  (2)]
⎜   ↳ RAPOO RAPOO 2.4G Wireless Device        id=11 [slave  pointer  (2)]
⎜   ↳ ImPS/2 Logitech Wheel Mouse              id=13 [slave  pointer  (2)]
⎣ Virtual core keyboard                    id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard              id=5 [slave  keyboard (3)]
    ↳ Power Button                            id=6 [slave  keyboard (3)]
    ↳ Power Button                            id=7 [slave  keyboard (3)]
    ↳ RAPOO RAPOO 2.4G Wireless Device        id=10 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            id=12 [slave  keyboard (3)]
    ↳ Logitech USB Receiver                    id=14 [slave  keyboard (3)]
    ↳ RAPOO RAPOO 2.4G Wireless Device        id=15 [slave  keyboard (3)]
System:    Host: miau Kernel: 4.15.0-140-generic i686 bits: 32
           Desktop: Cinnamon 3.8.9  Distro: Linux Mint 19 Tara
Machine:   Device: desktop Mobo: ASUSTeK model: P5LD2-TVM-SE v: Rev 1.xx serial: N/A
           BIOS: American Megatrends v: 0202 date: 10/13/2006
CPU:       Dual core Intel Pentium D (-MCP-) cache: 1024 KB
           clock speeds: max: 2800 MHz 1: 2800 MHz 2: 2800 MHz
Graphics:  Card: NVIDIA G72 [GeForce 7300 LE]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: nouveau (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x1024@60.02hz
           OpenGL: renderer: NV46 version: 2.1 Mesa 20.0.8
Audio:     Card-1 Intel NM10/ICH7 Family High Def. Audio Controller
           driver: snd_hda_intel
           Card-2 Ensoniq ES1371/ES1373 / Creative Labs CT2518
           driver: snd_ens1371
           Sound: Advanced Linux Sound Architecture v: k4.15.0-140-generic
Network:   Card-1: Realtek RTL-8110SC/8169SC Gigabit Ethernet driver: r8169
           IF: enp1s4 state: down mac: <filter>
           Card-2: Realtek RTL-8029(AS) driver: ne2k-pci
           IF: enp1s10 state: unknown speed: N/A duplex: N/A mac: <filter>
Drives:    HDD Total Size: 1612.3GB (12.2% used)
           ID-1: /dev/sda model: SAMSUNG_HD080HJ size: 80.0GB
           ID-2: /dev/sdb model: Hitachi_HUA72101 size: 1000.2GB
           ID-3: /dev/sdc model: WDC_WD5000AACS size: 500.1GB
           ID-4: USB /dev/sdh model: Business_Line size: 32.0GB
Partition: ID-1: / size: 91G used: 69G (81%) fs: ext4 dev: /dev/sdc1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 68.0C mobo: 49.0C gpu: 51.0
           Fan Speeds (in rpm): cpu: 1687 psu: 0 sys-1: 1180
Info:      Processes: 193 Uptime: 8:40 Memory: 848.3/2011.4MB
           Client: Shell (bash) inxi: 2.3.56
-------------------------------------

katze@miau:~$ intervalmusiccompositor
Exception in thread "main" java.lang.NoClassDefFoundError: javafx/beans/property/Property
at ch.retorte.intervalmusiccompositor.IntervalMusicCompositor.createUserPreferences(IntervalMusicCompositor.java:90)
at ch.retorte.intervalmusiccompositor.IntervalMusicCompositor.<init>(IntervalMusicCompositor.java:70)
at ch.retorte.intervalmusiccompositor.Main.main(Main.java:19)
Caused by: java.lang.ClassNotFoundException: javafx.beans.property.Property
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
... 3 more
katze@miau:~$
------------------------------

katze@miau:~$ sudo apt-get install intervalmusiccompositor
[sudo] Passwort für katze:             
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
intervalmusiccompositor ist schon die neueste Version (2.9.2).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
katze@miau:~$
----------------------------------
----------------------------------

Hier Mint 20 64 Bit

worf@date:~$ intervalmusiccompositor
Exception in thread "main" java.lang.NoClassDefFoundError: javafx/beans/property/Property
at ch.retorte.intervalmusiccompositor.IntervalMusicCompositor.createUserPreferences(IntervalMusicCompositor.java:90)
at ch.retorte.intervalmusiccompositor.IntervalMusicCompositor.<init>(IntervalMusicCompositor.java:70)
at ch.retorte.intervalmusiccompositor.Main.main(Main.java:19)
Caused by: java.lang.ClassNotFoundException: javafx.beans.property.Property
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
... 3 more
worf@date:~$
-----------------------------------------------
Zitat
worf@date:~$ sudo apt-get install intervalmusiccompositor
[sudo] Passwort für worf:         
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
intervalmusiccompositor ist schon die neueste Version (2.9.2).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
worf@date:~$
-------------------------------------------

Hilfe :)

« Letzte Änderung: 03.04.2021, 23:19:00 von blujaz »

Hat da einer vielleicht eine Alternative für mich, wenn es keine Lösung gibt?

Zitat
The Interval Music Compositor comes as a single executable file. No installation is needed therefore.
[ … ]
Start the Interval Music Compositor by double-clicking it
https://nwaldispuehl.github.io/interval-music-compositor/en/instructions
Zitat
Der retorte.ch Interval Music Compositor wird als einzelne, ausführbare Datei ausgeliefert. Man muss ihn also nicht installieren, sondern kann ihn einfach auf die Festplatte kopieren.
[ … ]
Starte den Interval Music Compositor indem du ihn doppelklickst
https://nwaldispuehl.github.io/interval-music-compositor/instructions
« Letzte Änderung: 28.03.2021, 22:25:57 von aexe »

Hi, Java ist drauf :)

katze@miau:~$ java -version
openjdk version "11.0.10" 2021-01-19
OpenJDK Runtime Environment (build 11.0.10+9-Ubuntu-0ubuntu1.18.04)
OpenJDK Server VM (build 11.0.10+9-Ubuntu-0ubuntu1.18.04, mixed mode, sharing)
katze@miau:~$

Verstehe ich da was nicht, mache ich was falsch, Kopf kratz :-X

Moin,
ich glaub nicht, dass du was falsch machst. Hier mit Mint 20 64Bit und derselben openjdk Version "11.0.10" gibt es dieselbe Fehlermeldung.



Ist denn openjfx überhaupt installiert?
Das ist bei LinuxMint nicht Standard.
« Letzte Änderung: 29.03.2021, 09:40:46 von aexe »

Was vermutest DU denn was die Abfrage in AW#5 herausfinden soll? 
Das ist deutlich mehr als eine Vermutung. Nämlich die Begründung und die Erklärung für den Terminal-Befehl. Schadet doch nicht, zu sagen, was damit erreicht werden soll.
Nicht jeder gibt so was ohne Bedenken ein, nur weil es ein Helfer einfordert.
« Letzte Änderung: 29.03.2021, 10:23:54 von aexe »


apt-cache policy openjfx


katze@miau:~$ apt-cache policy openjfx
openjfx:
  Installiert:           11.0.2+1-1~18.04.2
  Installationskandidat: 11.0.2+1-1~18.04.2
  Versionstabelle:
 *** 11.0.2+1-1~18.04.2 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/universe i386 Packages
        100 /var/lib/dpkg/status
     8u161-b12-1ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe i386 Packages
katze@miau:~$

Hmmmmmmmmm

sudo apt-get install  openjdk-8-jre
[sudo] Passwort für frost:             
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
openjdk-8-jre ist schon die neueste Version (8u282-b08-0ubuntu1~18.04).
openjdk-8-jre wurde als manuell installiert festgelegt.

E: Für Paket »openjdk-9-jre« existiert kein Installationskandidat.
Da würde ich das Programm versuchshalber einmal unter der 8er statt der 11er Version starten.
Das kannst auch in einem Livesystem angegehen. Erspart dir ggf. unnötige Bastelarbeit an der Installation.

Was soll ich genau machen, denke ich verstehe dich falsch :)



Hat da jetzt noch einer einen Lösungsvorschlag, dann würde ich das Thema hier gerne schließen. Zweimal Mint 19 und einmal Mint 20.1, zeigen das gleiche verhalten.

@blujaz

Was soll ich genau machen, ...
Versuchsweise das was ich beschrieben habe.
Livesystem starten
Ggf. die Pakete der aktuelleren (11er) Version entfernen und die ältere (8er) Version installieren. (Sowohl jre und jfx)
Im Anschluss den intervalmusiccompositor installieren und starten
Checken ob auch mit dieser Konfiguration die o.g. Meldung ausgegeben wird

Ich muss mir eingestehen das ich dich noch nicht akzentfrei verstehe, bin wohl noch nicht lange genug dabei.
Welche Pakete meinst du mit 11er und 8er? (Sowohl jre und jfx)?
-------------------------
intervalmusiccompositor deinstallieren
-------------------------
Ok, live aufsetzen
-------------------------
sudo apt-get remove 11?????????
sudo apt-get remove  8??????????
sudo apt-get install  intervalmusiccompositor
-------------------------

So verstehe ich das jetzt.

sudo apt-get remove 11?????????
sudo apt-get remove  8??????????
Hast du diese Befehle ernsthaft ins Terminal eingegeben?  ::)
Gemeint sind die Versionen von openjdk-8-jre und openjfx (siehe Antwort 10).

Ich habe mit der Live 19 MINT das durchgezogen

sudo apt-get install openjdk-8-jre
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  openjdk-8-jre-headless
Suggested packages:
  icedtea-8-plugin fonts-ipafont-gothic fonts-ipafont-mincho fonts-wqy-zenhei
The following NEW packages will be installed:
  openjdk-8-jre openjdk-8-jre-headless
0 upgraded, 2 newly installed, 0 to remove and 4 not upgraded.
Need to get 27.0 MB of archives.
After this operation, 97.7 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic/universe i386 openjdk-8-jre-headless i386 8u162-b12-1 [26.9 MB]
Get:2 http://archive.ubuntu.com/ubuntu bionic/universe i386 openjdk-8-jre i386 8u162-b12-1 [70.5 kB]
Fetched 27.0 MB in 7s (3735 kB/s)                                             
Selecting previously unselected package openjdk-8-jre-headless:i386.
(Reading database ... 236961 files and directories currently installed.)
Preparing to unpack .../openjdk-8-jre-headless_8u162-b12-1_i386.deb ...
Unpacking openjdk-8-jre-headless:i386 (8u162-b12-1) ...
Selecting previously unselected package openjdk-8-jre:i386.
Preparing to unpack .../openjdk-8-jre_8u162-b12-1_i386.deb ...
Unpacking openjdk-8-jre:i386 (8u162-b12-1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23+linuxmint3) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Setting up openjdk-8-jre-headless:i386 (8u162-b12-1) ...
OpenJDK Server VM warning: ignoring option PermSize=128m; support was removed in 8.0
Setting up openjdk-8-jre:i386 (8u162-b12-1) ...
update-alternatives: using /usr/lib/jvm/java-8-openjdk-i386/jre/bin/policytool to provide /usr/bin/policytool (policytool) in auto mode
Processing triggers for libc-bin (2.27-3ubuntu1) ...
..........................................

dann das IntervalMusicCompositor-linux_2.9.2_all.deb
............................................

~$ intervalmusiccompositor
Exception in thread "main" java.lang.NoClassDefFoundError: javafx/beans/property/Property
at ch.retorte.intervalmusiccompositor.IntervalMusicCompositor.createUserPreferences(IntervalMusicCompositor.java:90)
at ch.retorte.intervalmusiccompositor.IntervalMusicCompositor.<init>(IntervalMusicCompositor.java:70)
at ch.retorte.intervalmusiccompositor.Main.main(Main.java:19)
Caused by: java.lang.ClassNotFoundException: javafx.beans.property.Property
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:190)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
... 3 more
................................................

Programm laest sich im Memu nicht starten.

Was sollte ich jetzt im Terminal noch eingeben.


« Letzte Änderung: 30.03.2021, 22:50:08 von blujaz »

Erstmal ein Danke an alle :)
------------------------------------------

Der Interval Music Compositor installiert sich im Betriebssystem, sollte das so sein, was hat der da zu suchen? :'(