Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.05.2021, 01:22:05

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 736103
  • Themen insgesamt: 59269
  • Heute online: 476
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 4
Gäste: 418
Gesamt: 422

Autor Thema:  Zoneminder startet nicht  (Gelesen 568 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Zoneminder startet nicht
« am: 08.04.2021, 10:46:50 »
Hallo,
mein System: Mint20  Cinnamon Ulyana.
Zoneminder startet nicht, obwohl PHP und MYSQL installiert sind.
Wenn ich MYSQL starte, kommt die Meldung, dass der   mysql.service    nicht gefunden wurde, obwohl der mysql-server installiert ist,
wo dieser service m.E. zugehörig ist.
In Synaptic lässt sich auch kein    mysql.service    finden.
Kann mir jemand weiterhelfen, der Zoneminder installiert hat und evtl. diese Meldung bei der Installation schon hatte.
Danke für die Tipps/Ratschläge im Voraus!
hebero

Re: Zoneminder startet nicht
« Antwort #1 am: 08.04.2021, 10:57:28 »
Zeige doch bitte mal die Anleitung, nach der du vorgegangen bist. 90% der Anleitung sind schlichtweg falsch oder unvollständig.

Re: Zoneminder startet nicht
« Antwort #2 am: 08.04.2021, 11:34:52 »
hier der Link nach dem ich vorgegangen bin:
[urlhttps://zoneminder.readthedocs.io/en/stable/installationguide/ubuntu.html#easy-way-ubuntu-18-04-bionic][/url]
In Mint Cinnamon 18 hatte ich keine Probleme!

Re: Zoneminder startet nicht
« Antwort #3 am: 08.04.2021, 12:33:14 »
« Letzte Änderung: 08.04.2021, 12:39:44 von aexe »

Re: Zoneminder startet nicht
« Antwort #4 am: 08.04.2021, 13:02:21 »
https://zoneminder.readthedocs.io/en/stable/installationguide/ubuntu.html#easy-way-ubuntu-18-04-bionic
Danach hatte ich in einem frisch aufgesetzten Mint 19.3 Cinnamon 64bit installiert und einige Schritte (ich weiß nicht mehr was) liefen NICHT so wie dort beschrieben, ich habe mir dann aus Tutorials von YT das richtige zusammen gereimt.
Die Basis deines Mint 20 ist Ubuntu 20, somit ist die Anleitung eventuell überholt. Das haben die Macher von Zoneminder wohl auch mittlerweile begriffen, siehe Screenshot.
Leider scheint es auch keine Tutorials für Ubuntu 20.x oder Mint 20.x zu geben - das eigentlich sehr gute Tool ist wohl mangels Benutzbarkeit kaum in Verwendung, kann ich bestens nachvollziehen.

Edit: Lies' mal hier in den Kommentaren, dort gibt es auch das eine oder andere Problem, teils mit Feedback vom Entwickler:

https://www.youtube.com/watch?v=RhBsW8HkOG4
« Letzte Änderung: 08.04.2021, 13:16:04 von Isolator »

Re: Zoneminder startet nicht
« Antwort #5 am: 08.04.2021, 14:51:09 »
Ich habe es nun mit einer anderen Anweisung versucht, jedoch die gleichen Fehlermeldungen erhalten.
Den Link hierfür:    https://inepttech.com/zoneminder-on-ubuntu-20-04/
Weiter habe ich festgestellt, dass alle Anweisungen, ob für mint18 oder mint20 etc. die gleichen Fehlermeldungen ausgeben.
Ja schade, denn ich habe in früheren OS-Versionen gut mit Zoneminder arbeiten können.
Wo/Wie könnte man anregen, dass man dieses Programm wieder ordentlich installieren kann?
Ansonsten: Vielen Dank für die Tipps.
hebero

Re: Zoneminder startet nicht
« Antwort #6 am: 08.04.2021, 16:14:35 »
Wo/Wie könnte man anregen, dass man dieses Programm wieder ordentlich installieren kann?

Es gibt auch ein Forum - es scheint nicht tot zu sein, versuche es doch dort einmal: https://forums.zoneminder.com/

Re: Zoneminder startet nicht
« Antwort #7 am: 08.04.2021, 16:33:41 »
Danke für den Tipp.
Ich denke, es liegt im Grunde genommen, nicht an Zoneminder, sondern an in der Hauptsache an MYSQL. Es fehlt eben die notwendige Datei  mysql.service.
Die Datei müsste doch irgendwo zu beziehen sein. Vielleicht ergibt sich doch bei der Suche noch ein Zufallstreffer.

Re: Zoneminder startet nicht
« Antwort #8 am: 08.04.2021, 22:24:35 »
Dann zeig doch bitte mal:
systemctl status mysql
sudo systemctl is-enabled mysql
dpkg-query --no-pager -l mysql*

Re: Zoneminder startet nicht
« Antwort #9 am: 09.04.2021, 09:08:06 »
@pinky

ich@mint20:~$ systemctl status mysql
Unit mysql.service could not be found.
ich@mint20:~$ sudo systemctl is-enabled mysql
[sudo] Passwort für ich:           
Failed to get unit file state for mysql.service: Link has been severed
ich@mint20:~$ dpkg-query --no-pager -l mysql*
Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/
         Halb installiert/Trigger erWartet/Trigger anhängig
|/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler: GROSS=schlecht)
||/ Name                  Version                 Architektur  Beschreibung
+++-=====================-=======================-============-===================================================================
ii  mysql-client          8.0.23-0ubuntu0.20.04.1 all          MySQL database client (metapackage depending on the latest version)
un  mysql-client-5.5      <keine>                 <keine>      (keine Beschreibung vorhanden)
un  mysql-client-5.6      <keine>                 <keine>      (keine Beschreibung vorhanden)
un  mysql-client-5.7      <keine>                 <keine>      (keine Beschreibung vorhanden)
ii  mysql-client-8.0      8.0.23-0ubuntu0.20.04.1 amd64        MySQL database client binaries
un  mysql-client-core-5.5 <keine>                 <keine>      (keine Beschreibung vorhanden)
un  mysql-client-core-5.6 <keine>                 <keine>      (keine Beschreibung vorhanden)
un  mysql-client-core-5.7 <keine>                 <keine>      (keine Beschreibung vorhanden)
ii  mysql-client-core-8.0 8.0.23-0ubuntu0.20.04.1 amd64        MySQL database core client binaries
ii  mysql-common          5.8+1.0.5ubuntu2        all          MySQL database common files, e.g. /etc/mysql/my.cnf
un  mysql-common-5.6      <keine>                 <keine>      (keine Beschreibung vorhanden)
ii  mysql-server          8.0.23-0ubuntu0.20.04.1 all          MySQL database server (metapackage depending on the latest version)
un  mysql-server-5.5      <keine>                 <keine>      (keine Beschreibung vorhanden)
un  mysql-server-5.6      <keine>                 <keine>      (keine Beschreibung vorhanden)
un  mysql-server-5.7      <keine>                 <keine>      (keine Beschreibung vorhanden)
ii  mysql-server-8.0      8.0.23-0ubuntu0.20.04.1 amd64        MySQL database server binaries and system database setup
un  mysql-server-core-5.5 <keine>                 <keine>      (keine Beschreibung vorhanden)
un  mysql-server-core-5.6 <keine>                 <keine>      (keine Beschreibung vorhanden)
un  mysql-server-core-5.7 <keine>                 <keine>      (keine Beschreibung vorhanden)
ii  mysql-server-core-8.0 8.0.23-0ubuntu0.20.04.1 amd64        MySQL database server binaries

Re: Zoneminder startet nicht
« Antwort #10 am: 09.04.2021, 13:51:35 »
Da fällt mir erst einmal nur reinstall ein:
apt --reinstall install mysql-server

Re: Zoneminder startet nicht
« Antwort #11 am: 09.04.2021, 14:11:33 »
Dann kommt das: (Server ist installiert)

ich@mint20:~$ apt --reinstall install mysql-server
apt
Usage: apt command [options]
       apt help command [options]

Commands:
  add-repository   - Add entries to apt sources.list
  autoclean        - Erase old downloaded archive files
  autoremove       - Remove automatically all unused packages
  build            - Build binary or source packages from sources
  build-dep        - Configure build-dependencies for source packages
  changelog        - View a package's changelog
  check            - Verify that there are no broken dependencies
  clean            - Erase downloaded archive files
  contains         - List packages containing a file
  content          - List files contained in a package
  deb              - Install a .deb package
  depends          - Show raw dependency information for a package
  dist-upgrade     - Upgrade the system by removing/installing/upgrading packages
  download         - Download the .deb file for a package
  edit-sources     - Edit /etc/apt/sources.list with your preferred text editor
  dselect-upgrade  - Follow dselect selections
  full-upgrade     - Same as 'dist-upgrade'
  held             - List all held packages
  help             - Show help for a command
  hold             - Hold a package
  install          - Install/upgrade packages
  list             - List packages based on package names
  policy           - Show policy settings
  purge            - Remove packages and their configuration files
  recommends       - List missing recommended packages for a particular package
  rdepends         - Show reverse dependency information for a package
  reinstall        - Download and (possibly) reinstall a currently installed package
  remove           - Remove packages
  search           - Search for a package by name and/or expression
  show             - Display detailed information about a package
  showhold         - Same as 'held'
  showsrc          - Display all the source package records that match the given package name
  source           - Download source archives
  sources          - Same as 'edit-sources'
  unhold           - Unhold a package
  update           - Download lists of new/upgradable packages
  upgrade          - Perform a safe upgrade
  version          - Show the installed version of a package

Re: Zoneminder startet nicht
« Antwort #12 am: 09.04.2021, 14:30:23 »
Mein Fehler
sudo apt-get --reinstall install mysql-server

Re: Zoneminder startet nicht
« Antwort #13 am: 09.04.2021, 14:37:45 »
ich@mint20:~$ sudo apt-get --reinstall install mysql-server
[sudo] Passwort für ich:           
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  akonadi-server blender-data cakephp cakephp-scripts catdoc digikam-data
  ffmpegthumbs fonts-dejavu fonts-font-awesome fonts-glewlwyd gimp-data
  gnome-control-center-data gpsd gtk2-engines:i386 gtk2-engines-murrine:i386
  gtk2-engines-oxygen:i386 gtk2-engines-pixbuf:i386 language-selector-common
  language-selector-gnome libaio1:i386 libamd2 libao4:i386 libapparmor1:i386
  libappconfig-perl libasn1-8-heimdal:i386 libasound2:i386
  libasound2-plugins:i386 libastro1 libasyncns0:i386 libaudio2:i386
  libbabl-0.1-0 libblosc1 libbrotli1:i386 libcaca0:i386 libcamd2
  libcanberra-gtk-module:i386 libcanberra-gtk0:i386 libcanberra0:i386
  libcap2:i386 libcapi20-3:i386 libccolamd2 libcholmod3
  libclass-inspector-perl libclass-load-perl libclass-std-fast-perl
  libclass-std-perl libcolord-gtk1 libconvert-binhex-perl libcupsimage2:i386
  libcurl3-gnutls:i386 libdata-optlist-perl libdate-manip-perl libdbi-perl
  libdbus-glib-1-2:i386 libdcmtk14 libdevice-serialport-perl libdmtx0b
  libemail-date-format-perl libexif12:i386 libflac8:i386 libfluidsynth2:i386
  libgd3:i386 libgdbm-compat4:i386 libgdbm6:i386 libgegl-0.4-0 libgegl-common
  libgettextpo0:i386 libgexiv2-2 libgimp2.0 libglew2.1 libglu1-mesa:i386
  libgnutls-openssl27 libgphoto2-6:i386 libgphoto2-port12:i386 libgps26
  libgssapi3-heimdal:i386 libgupnp-av-1.0-2 libgupnp-dlna-2.0-3
  libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
  libhx509-5-heimdal:i386 libice6:i386 libieee1284-3:i386
  libimage-base-bundle-perl libimage-info-perl libinstpatch-1.0-2:i386
  libio-interface-perl libio-sessiondata-perl libio-socket-multicast-perl
  libjack-jackd2-0:i386 libjemalloc2 libjs-sphinxdoc libjs-underscore
  libkf5akonadi-data libkf5akonadicontact-data libkf5akonadicontact5abi1
  libkf5akonadicore-bin libkf5akonadicore5abi2 libkf5akonadiprivate5abi2
  libkf5akonadiwidgets5abi1 libkf5calendarcore5abi2 libkf5contacteditor5
  libkf5filemetadata-bin libkf5filemetadata-data libkf5filemetadata3
  libkf5itemmodels5 libkf5mime-data libkf5mime5abi2 libkf5notifyconfig-data
  libkf5notifyconfig5 libkf5prison5 libkf5sane-data libkrb5-26-heimdal:i386
  libldap-2.4-2:i386 liblensfun-data-v1 liblensfun1 libltdl7:i386 libmad0:i386
  libmarblewidget-qt5-28 libmediaart-2.0-0 libmetis5 libmicrohttpd12
  libmikmod3:i386 libmime-lite-perl libmime-tools-perl libmime-types-perl
  libmpg123-0:i386 libncursesw5:i386 libnet-sftp-foreign-perl
  libnghttp2-14:i386 libnspr4:i386 libnss3:i386 libodbc1:i386 libogg0:i386
  libopenal1:i386 libopencolorio1v5 libopencv-flann4.2 libopencv-ml4.2
  libopenvdb6.2 libosdcpu3.4.0 libosdgpu3.4.0 libossp-uuid-perl libossp-uuid16
  libparams-util-perl libpci3:i386 libperl5.30:i386 libphp-serialization-perl
  libpsl5:i386 libpulse-mainloop-glib0:i386 libpulse0:i386 libpulsedsp:i386
  libqrencode4 libqt5xmlpatterns5 libqtav1 libqtavwidgets1 libreadline8:i386
  libroken18-heimdal:i386 librtmp1:i386 librygel-core-2.6-2 librygel-db-2.6-2
  librygel-renderer-2.6-2 librygel-server-2.6-2 libsamplerate0:i386
  libsasl2-2:i386 libsasl2-modules:i386 libsasl2-modules-db:i386
  libsdl-image1.2:i386 libsdl-mixer1.2:i386 libsdl-net1.2:i386
  libsdl-ttf2.0-0:i386 libsdl1.2debian:i386 libsdl2-2.0-0:i386 libshp2
  libslang2:i386 libsm6:i386 libsndfile1:i386 libsndio7.0:i386
  libsoap-lite-perl libsoap-wsdl-perl libspnav0 libsqlite3-0:i386 libsquish0
  libssh-4:i386 libstdc++5:i386 libsub-install-perl libsys-cpu-perl
  libsys-meminfo-perl libsys-mmap-perl libtask-weaken-perl libtdb1:i386
  libtemplate-perl libterm-readkey-perl libtinfo5:i386 libtinyxml2.6.2v5
  libudev1:i386 libumfpack5 liburi-encode-perl libusb-1.0-0:i386
  libvorbis0a:i386 libvorbisenc2:i386 libvorbisfile3:i386
  libwayland-cursor0:i386 libwayland-egl1:i386 libwhoopsie-preferences0
  libwhoopsie0 libwind0-heimdal:i386 libwrap0:i386 libxaw7:i386
  libxkbcommon0:i386 libxmlrpc-lite-perl libxmu6:i386 libxpm4:i386
  libxslt1.1:i386 libxss1:i386 libxt6:i386 libxtst6:i386 libyaml-cpp0.6
  marble-plugins marble-qt-data odbcinst1debian2:i386 opencv-data php-apcu
  php-apcu-bc php-gd php7.4-gd rygel whoopsie-preferences xaw3dg:i386
  xsane-common zoneminder-doc
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 1 erneut installiert, 0 zu entfernen und 48 nicht aktualisiert.
Es müssen noch 0 B von 9.548 B an Archiven heruntergeladen werden.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
(Lese Datenbank ... 369104 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../mysql-server_8.0.23-0ubuntu0.20.04.1_all.deb ...
Entpacken von mysql-server (8.0.23-0ubuntu0.20.04.1) über (8.0.23-0ubuntu0.20.04.1) ...
mysql-server (8.0.23-0ubuntu0.20.04.1) wird eingerichtet ...

Re: Zoneminder startet nicht
« Antwort #14 am: 09.04.2021, 15:36:31 »
Und jetzt?
systemctl status mysql