Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
10.05.2021, 20:14:13

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 734462
  • Themen insgesamt: 59175
  • Heute online: 627
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Abhängigkeit nicht erfüllbar  (Gelesen 815 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Abhängigkeit nicht erfüllbar
« am: 14.04.2021, 18:45:21 »
Was läuft schief?

Abhängigkeit nicht erfüllbar: libgtk-3-0(>3.21.5)

marko@marko-System-Product-Name ~ $ sudo apt install /home/marko/Schreibtisch/opera-stable_75.0.3969.171_amd64.deb
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Hinweis: »opera-stable« wird an Stelle von »/home/marko/Schreibtisch/opera-stable_75.0.3969.171_amd64.deb« gewählt.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 opera-stable : Hängt ab von: libgtk-3-0 (>= 3.21.5) aber 3.18.9-1ubuntu3.3 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.



marko@marko-System-Product-Name ~ $ inxi -S
System:    Host: marko-System-Product-Name Kernel: 4.15.0-140-generic x86_64 (64 bit) Desktop: Cinnamon 3.6.7
           Distro: Linux Mint 18.3 Sylvia

Soll den Browser aktualisieren.



« Letzte Änderung: 18.04.2021, 16:24:09 von Bremer »

Re: Abhängigkeit nicht erfüllbar
« Antwort #1 am: 14.04.2021, 18:53:33 »
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 opera-stable : Hängt ab von: libgtk-3-0 (>= 3.21.5) aber 3.18.9-1ubuntu3.3 soll installiert werden

Hallo Bremer,
dein System ist zu alt für den aktuellen Browser.

Gruß
Whitie

Re: Abhängigkeit nicht erfüllbar
« Antwort #2 am: 14.04.2021, 18:55:05 »
Sorry, aber du reitest ein totes Pferd - LM 18.3 hat diesen Monat EOL (End of Life)
Vermutlich wird die Installation bei einem aktuelleren System funktionieren -
hier bei LM 20.1 ist libgtk-3-0 in der Version 3.24.20 vorhanden was den Anforderungen >=3.21.5 gerecht wird.

Re: Abhängigkeit nicht erfüllbar
« Antwort #3 am: 14.04.2021, 18:56:02 »
eventuell liegt es am Supportende von 18.3 wäre jetzt April 2021

Re: Abhängigkeit nicht erfüllbar
« Antwort #4 am: 14.04.2021, 18:59:58 »
Hallo Bremer!

Ubuntu 16.04 und somit Linux Mint 18.X haben ab diesem Monat keinen Support mehr.
Du solltest also ein aktuelles Betriebssystem installieren, oder auf mindestens Linux Mint 19 upgraden.

Installation von Linux Mint 19.X: https://www.linuxmintusers.de/index.php?action=wiki;page=Installationsanleitung_Linux_Mint_19_
Installation von Linux Mint 20.X: https://www.linuxmintusers.de/index.php?action=wiki;page=Installationsanleitung_Linux_Mint_20
Upgrade auf Linux Mint 19: https://www.linuxmintusers.de/index.php?action=wiki;page=Upgrade_LM18.3_auf_LM_19
« Letzte Änderung: 14.04.2021, 20:09:31 von tommix »

Re: Abhängigkeit nicht erfüllbar
« Antwort #5 am: 15.04.2021, 16:09:14 »
Ich reite totes Pferd??? .... mein System zu alt ???

Ich habe gebeten Euch um Helfen, aber Ihr überbringen Todesnachricht *HEUL*HEUL*HEUL*

Auf der anderen Seite... gut dass ich EOL (EndOfLife) mitbekommen habe....
===
Gut dann werde ich upgraden. Welchen Befehl muss ich dazu eingeben für das Upgraden?

DANKE für Nachrichten.

Re: Abhängigkeit nicht erfüllbar
« Antwort #6 am: 15.04.2021, 16:29:19 »
Steht doch schon im letzten Beitrag von @tommix. Bitte lies dir die Links durch!
Zuerst werden alle Daten gesichert. Am einfachsten und sichersten ist immer eine Neuinstallation.
Wenn es ein Upgrade sein soll, gehst du so vor: Upgrade auf LM 19 --> auf LM 19.3 --> auf LM 20 --> auf LM 20.1

https://www.linuxmintusers.de/index.php?action=wiki;page=Upgrade_LM18.3_auf_LM_19
https://blog.linuxmint.com/?p=3838
https://www.linuxmintusers.de/index.php?action=wiki;page=Upgrade_LM19.3_auf_LM_20
https://blog.linuxmint.com/?p=4020
« Letzte Änderung: 15.04.2021, 16:33:07 von skoopy »

Re: Abhängigkeit nicht erfüllbar
« Antwort #7 am: 15.04.2021, 16:29:28 »
Upgrade auf LM 19 --> auf LM 19.3 --> auf LM 20.x
Upgrade auf LM 19 --> auf LM 19.3 --> auf LM 20 --> LM 20.1  ;)

Re: Abhängigkeit nicht erfüllbar
« Antwort #8 am: 15.04.2021, 19:57:17 »
Dankeschön :-)


Re: Abhängigkeit nicht erfüllbar
« Antwort #9 am: 15.04.2021, 20:21:05 »
Backup nicht vergessen! Beim Upgrade kann etwas schiefgehen, wenn man nicht aufpasst und keine Erfahrung hat. Sicherer ist statt so einer Orgie über mehrere Versionen hinweg eine Neuinstallation. Und schneller auch.

Re: Abhängigkeit nicht erfüllbar
« Antwort #10 am: 16.04.2021, 20:27:32 »
Backup nicht vergessen! Beim Upgrade kann etwas schiefgehen, wenn man nicht aufpasst und keine Erfahrung hat. Sicherer ist statt so einer Orgie über mehrere Versionen hinweg eine Neuinstallation. Und schneller auch.

Hast vollkommen Recht mit Neuinstallation, allein von 18.3 auf 19 habe ich mehrere Stunden gebraucht :-)
Shifttime habe ich gemacht.

Für mich liegt der Vorteil "einer Orgie über mehrere Versionen" darin, dass alle meine Daten in die nächst höhere Version mitgenommen werden. Bei Neuinstallation müsste ich erneut zwei meiner Drucker mit dem System wieder bekanntmachen und auf das habe ich keine Lust. Bis ich den einen Drucker zum Laufen gebracht habe hat es mich schon einige Versuche gekostet. Heute will ich von 19 auf 19.3 springen.

vielen Dank und schönes WE dir und allen.

Re: Abhängigkeit nicht erfüllbar
« Antwort #11 am: 16.04.2021, 20:52:58 »
Wäre schade, wenn es beim letzten Schritt doch scheitert, daher würde ich nach jedem erfolgreichen Upgradeschritt ein Backup anlegen.

Re: Abhängigkeit nicht erfüllbar
« Antwort #12 am: 17.04.2021, 09:33:44 »
Bis ich den einen Drucker zum Laufen gebracht habe hat es mich schon einige Versuche gekostet.
Das ist verständlich, das Prozedere kann sich bei neueren Mint-Versionen aber auch vereinfacht haben. Ich würde nach so einer erfolgreichen Druckerinstallation einfach die Schritte dorthin notieren, damit ich sie beim nächsten Mal zügig durchführen kann. Wenn genügend Plattenplatz vorhanden ist, kann man sich das neue Mint auch neben das alte installieren und nach und nach alles einrichten.

Re: Abhängigkeit nicht erfüllbar
« Antwort #13 am: 17.04.2021, 12:03:58 »
ich reite nicht mehr totes Pferd Dank Euch

marko@marko-System-Product-Name ~ $ inxi -S
System:    Host: marko-System-Product-Name Kernel: 5.4.0-72-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.7
           Distro: Linux Mint 20 Ulyana


Re: Abhängigkeit nicht erfüllbar
« Antwort #14 am: 17.04.2021, 12:11:57 »
Prima. Dann würde ich dir den Schritt auf LM 20.1 auch empfehlen. Das geht immer sehr schnell und unkompliziert.
Bei Erscheinung eines neuen Point-Releases (LM 20.x) lohnt sich ein Upgrade, da in der Regel Dinge verbessert oder erweitert werden. https://blog.linuxmint.com/?p=4020