LMU - Das Hilfe Forum für Linux Mint

Hardware => Hardware stellt sich quer? => Thema gestartet von: bandit77 am 30.12.2020, 09:26:04

Titel: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 09:26:04
Hallo zusammen,

ich hatte vor ein paar Wochen das Problem mit den 3 Monitoren. Dabei habe ich festgestellt, dass wenn ich auf Bildschirm gehe, die Monitore angezeigt werden und ich durch umstöpseln an der Grafikkarte den Monitor zum laufen bekomme. Dies ging auch danach problemlos und der Monitor wurde immer erkannt. Es kommt aber auch vor und dies häuft sich, dass nur ein Monitor erkannt wird. Wenn ich dann auf "Bildschirm" gehe dann steht da unbekannt. Ist das nicht ein Zeichen, dass die Grafikkarte nicht richtig geladen wird? Kann es sein, dass das Mainboard und die Grafikkarte nicht zusammen passen?

Vielen Dank
Titel: Re: Grafikkarte nicht installiert
Beitrag von: tommix am 30.12.2020, 09:41:08
Geht es um den Rechner?

System:
  Host: bandit-System-Product-Name Kernel: 5.0.0-32-generic x86_64 bits: 64
  Desktop: MATE 1.22.2 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
  serial: <root required> BIOS: American Megatrends v: 4007 date: 12/08/2020
CPU:
  Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 1887 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 1888 2: 1889
  3: 2195 4: 1944 5: 1887 6: 2194 7: 2196 8: 1883 9: 2184 10: 1888 11: 2081
  12: 2111
Graphics:
  Device-1: NVIDIA driver: nvidia v: 455.38
  Display: x11 server: X.Org 1.20.8 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa
  resolution: 3440x1440~75Hz, 1920x1080~60Hz, 1920x1080~60Hz
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38
Audio:
  Device-1: NVIDIA driver: snd_hda_intel
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
  Device-3: Microsoft LifeCam HD-3000 type: USB
  driver: snd-usb-audio,uvcvideo
  Sound Server: ALSA v: k5.0.0-32-generic
Network:
  Device-1: Intel I211 Gigabit Network driver: igb
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: 3c:7c:3f:1c:86:07
Drives:
  Local Storage: total: 931.51 GiB used: 9.75 GiB (1.0%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T3X0C-00SJG0
  size: 931.51 GiB
Partition:
  ID-1: / size: 915.89 GiB used: 9.75 GiB (1.1%) fs: ext4
  dev: /dev/nvme0n1p1
Sensors:
  System Temperatures: cpu: 40.5 C mobo: N/A gpu: nvidia temp: 49 C
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0%
Info:
  Processes: 260 Uptime: 31m Memory: 15.65 GiB used: 1.14 GiB (7.3%)
  Shell: bash inxi: 3.0.32

   
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 09:43:06
ja, Genau um diesen Rechner
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 30.12.2020, 10:18:11
Ist es denn eine GeForce GTX 1650/PCIe/SSE2 die dort erwähnt ist?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: toffifee am 30.12.2020, 10:20:12
Was ist das denn für ein Kernel? 5.0.0??
Titel: Re: Grafikkarte nicht installiert
Beitrag von: tommix am 30.12.2020, 10:26:11
Off-Topic:
Macht heute wieder Spass!
Den Leuten alles aus der Nase zu ziehen!
   ??? ???
Titel: Re: Grafikkarte nicht installiert
Beitrag von: toffifee am 30.12.2020, 10:32:58
Also mal Butter bei die Fische. Ein aktuelles inxi bitte.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 10:36:59
Sorry für die leichte Verzögerung. Normalerweise versuche ich auch so schnell wie möglich zu antworten

Grafikkarte ist: Gigabyte Geforce GTX 1650 Windforce OC 4G

CPU: 6-Core AMD Ryzen 5 2600X (-MT MCP-) speed/min/max: 1775/2200/3600 MHz
Kernel: 5.4.0-47-generic x86_64 Up: 1h 21m Mem: 1270.3/15998.1 MiB (7.9%)
Storage: 931.51 GiB (1.4% used) Procs: 268 Shell: bash 4.4.20 inxi: 3.0.32
Titel: Re: Grafikkarte nicht installiert
Beitrag von: tommix am 30.12.2020, 10:40:59
Ja, gut!inxi -Fz
Titel: Re: Grafikkarte nicht installiert
Beitrag von: tommix am 30.12.2020, 10:42:10
Kernel 5.4.0-47! ist alt
Teste Kernel 5.4.0-58 und Kernel 5.8.0-33!
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 10:42:51
Bitte schön

System:
  Host: bandit-System-Product-Name Kernel: 5.4.0-47-generic x86_64 bits: 64
  Desktop: MATE 1.22.2 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
  serial: <filter> BIOS: American Megatrends v: 4007 date: 12/08/2020
CPU:
  Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 2063 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2004 2: 1898
  3: 2131 4: 1910 5: 1887 6: 1884 7: 1947 8: 2135 9: 2193 10: 2038 11: 2045
  12: 1901
Graphics:
  Device-1: NVIDIA driver: nvidia v: 455.38
  Display: x11 server: X.Org 1.20.8 driver: fbdev,modesetting,nouveau
  unloaded: vesa resolution: 1920x1080~77Hz
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8
Audio:
  Device-1: NVIDIA driver: snd_hda_intel
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
  Device-3: Microsoft LifeCam HD-3000 type: USB
  driver: snd-usb-audio,uvcvideo
  Sound Server: ALSA v: k5.4.0-47-generic
Network:
  Device-1: Intel I211 Gigabit Network driver: igb
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 13.29 GiB (1.4%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T3X0C-00SJG0
  size: 931.51 GiB
Partition:
  ID-1: / size: 467.87 GiB used: 13.29 GiB (2.8%) fs: ext4
  dev: /dev/nvme0n1p1
Sensors:
  System Temperatures: cpu: 50.1 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 267 Uptime: 1h 28m Memory: 15.62 GiB used: 1.27 GiB (8.2%)
  Shell: bash inxi: 3.0.32
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 30.12.2020, 11:21:30
Kernel sollte immer der aktuellste der Linie sein.

Würde hier vielleicht auch den 5.8. nehmen. was mich wundert, gestandene CPU wird erkannt, Board wird erkannt nur bei der Graka ist jetzt noch weniger und die ist auch nicht erst seit Gestern auf'n Markt.

inxi -G
sagt bestimmt auch nicht mehr ...
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 11:29:34
Bei dem Kernel wurde im Board gesagt ich solle auf diesen ausweichen. Der 5.4.0.58.64 macht Grafikprobleme. Der 5.8 Kernel wird nicht angeboten in der Aktualisierungsverwaltung. Wie kann ich diesen aktualisieren?

Wie ist das mit der Grafikkarte gemeint?

Bitte schön.

Graphics:
  Device-1: NVIDIA driver: nvidia v: 455.38
  Display: x11 server: X.Org 1.20.8 driver: fbdev,modesetting,nouveau
  unloaded: vesa resolution: 1920x1080~77Hz
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 30.12.2020, 11:37:11
Beim Kernel: 5.0.0-32 wird das erkannt:
 
Zitat
Graphics:
  Device-1: NVIDIA driver: nvidia v: 455.38
  Display: x11 server: X.Org 1.20.8 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa
  resolution: 3440x1440~75Hz, 1920x1080~60Hz, 1920x1080~60Hz
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38

Und beim 5.4.0-47 das nur:

Zitat
Graphics:
  Device-1: NVIDIA driver: nvidia v: 455.38
  Display: x11 server: X.Org 1.20.8 driver: fbdev,modesetting,nouveau
  unloaded: vesa resolution: 1920x1080~77Hz
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8

Muss aber jetzt erst weg, vielleicht haben andere mehr Wissen ... :)
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 11:39:46
Soll heißen? Ich gehe auf den anderen Kernel zurück?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 12:13:48
Kernel 5.4.0-58 soll nicht funktionieren. Jedenfalls war das die Aussage vor 2 Wochen.

Wie bekomme ich Kernel 5.8 installiert? In der Aktualisierungsverwaltung wird dieser nicht angeboten
Titel: Re: Grafikkarte nicht installiert
Beitrag von: toffifee am 30.12.2020, 12:34:58
Off-Topic:
Bereinigt um überflüssiges OT.

3 Monitore hat natürlich hier nicht jeder am Laufen. ;)
Grunsätzlich sind an der korrekten Erkennung nicht nur die GK, sondern auch die Kabel mit beteiligt. Besonders Auflösungen über FHD brauchen eine höhere Norm. Hast du das auch bedacht?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Flash63 am 30.12.2020, 12:36:15
Hallo,
Du kannst es ja mal mit einem Treiber aus dem aktuellen PPA testen.
Den vorhandenen Nvidia-Treiber zunächst entfernen und durch nouveau ersetzen. Dann das PPA hinzufügen und aktualiesieren:
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
Dann in der Treiberverwaltung schauen und den Nvidia wieder installieren.
Den 5.8 über die Aktualisierungsverwaltung - Ansicht - Kernel
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 12:55:13
Ich habe jetzt den Treiber wieder auf "quelloffen" gewechselt und danach neu gestartet. Danach waren alle Bildschirme sichtbar allerdings konnte ich diese nicht anordnen, aber erstmal egal.

Danach habe ich die zwei Sachen ausgeführt. Der Kernel 5.8 wird aber nicht in der Aktualisierungsverwaltung angezeigt :-(

sudo add-apt-repository ppa:graphics-drivers/ppa
[sudo] Passwort für bandit:           
Sie sind dabei das folgende PPA hinzuzufügen:
 Fresh drivers from upstream, currently shipping Nvidia.

## Current Status

Current long-lived branch release: `nvidia-430` (430.40)
Dropped support for Fermi series (https://nvidia.custhelp.com/app/answers/detail/a_id/4656)

Old long-lived branch release: `nvidia-390` (390.129)

For GF1xx GPUs use `nvidia-390` (390.129)
For G8x, G9x and GT2xx GPUs use `nvidia-340` (340.107)
For NV4x and G7x GPUs use `nvidia-304` (304.137) End-Of-Life!

Support timeframes for Unix legacy GPU releases:
https://nvidia.custhelp.com/app/answers/detail/a_id/3142

## What we're working on right now:

- Normal driver updates
- Help Wanted: Mesa Updates for Intel/AMD users, ping us if you want to help do this work, we're shorthanded.

## WARNINGS:

This PPA is currently in testing, you should be experienced with packaging before you dive in here:

Volunteers welcome!

### How you can help:

## Install PTS and benchmark your gear:

    sudo apt-get install phoronix-test-suite

Run the benchmark:

    phoronix-test-suite default-benchmark openarena xonotic tesseract gputest unigine-valley

and then say yes when it asks you to submit your results to openbechmarking.org. Then grab a cup of coffee, it takes a bit for the benchmarks to run. Depending on the version of Ubuntu you're using it might preferable for you to grabs PTS from upstream directly: http://www.phoronix-test-suite.com/?k=downloads

## Share your results with the community:

Post a link to your results (or any other feedback to): https://launchpad.net/~graphics-drivers-testers

Remember to rerun and resubmit the benchmarks after driver upgrades, this will allow us to gather a bunch of data on performance that we can share with everybody.

If you run into old documentation referring to other PPAs, you can help us by consolidating references to this PPA.

If someone wants to go ahead and start prototyping on `software-properties-gtk` on what the GUI should look like, please start hacking!

## Help us Help You!

We use the donation funds to get the developers hardware to test and upload these drivers, please consider donating to the "community" slider on the donation page if you're loving this PPA:

http://www.ubuntu.com/download/desktop/contribute
 Mehr Informationen: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
Zum Fortfahren bitte Eingabetaste drücken oder Strg+C zum Abbrechen

Executing: /tmp/apt-key-gpghome.Aq5j7moitV/gpg.1.sh --keyserver hkps://keyserver.ubuntu.com:443 --recv-keys 2388FF3BE10A76F638F80723FCAE110B1118213C
gpg: key FCAE110B1118213C: 12 Beglaubigungen wegen fehlender Schlüssel nicht geprüft
gpg: Schlüssel FCAE110B1118213C: "Launchpad PPA for Graphics Drivers Team" nicht geändert
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
gpg:              unverändert: 1
bandit@bandit-System-Product-Name:~$ sudo apt update
OK:1 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic InRelease
OK:2 http://archive.ubuntu.com/ubuntu bionic InRelease                         
OK:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease                 
OK:4 http://archive.canonical.com/ubuntu bionic InRelease                     
OK:5 https://repo.skype.com/deb stable InRelease                               
OK:6 http://archive.ubuntu.com/ubuntu bionic-backports InRelease               
OK:7 http://security.ubuntu.com/ubuntu bionic-security InRelease               
Ign:8 http://packages.linuxmint.com tricia InRelease                       
OK:9 http://packages.linuxmint.com tricia Release   
Paketlisten werden gelesen... Fertig                 
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Aktualisierung für 9 Pakete verfügbar. Führen Sie »apt list --upgradable« aus, um sie anzuzeigen.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: toffifee am 30.12.2020, 13:03:27
Den 5.8 gibt es für dein LM 19.3 auch nicht. Das PPA hinzufügen ändert nur die zur Verfügung stehenden Nvidia Treiber. Aktivieren muss man die natürlich auch. ;)

Wenn alle Monis mit dem Nouveau in richtiger Auflösung erkannt werden, dann liegt es an Kabeln schon mal nicht. :)

Generell würde ich auf so relativ aktueller Hardware ein möglichst aktuelles Mint mit möglichst aktuellen Kerneln installieren. Man könnte sich einen 16 GB Stick schnappen und es einfach mal testen mit LM 20.1 beta und Kernel 5.8....
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 13:19:03
Habe jetzt wieder auf den anderen Treiber umgestellt und neu gestartet. Allerdings wieder "unbekannt".

Bezüglich Linux Mint 20 wäre ich dafür. Allerdings habe ich mir hier bereits die Zähne ausgebissen bei der Installation. --> siehe alter Thread. Eventuell mit "Vor-Ort-Hilfe" via Skype?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 30.12.2020, 15:44:07
Kernel 5.4.0-58 soll nicht funktionieren. Jedenfalls war das die Aussage vor 2 Wochen.
...

Das war der 5.4.0-56 nmM, denn der 5.4.0-58 läuft hier 1a, allerdings Cinnamon und LM20.

Sehe ich aber richtig, das schon bei einem Monitor nicht erkannt wird ... ?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 17:31:23
Also ich habe jetzt noch einmal Linux Mint 20 mate heruntergeladen und einen Stick erstellt. Das ganze fährt auch erstmal hoch. Dann gehe ich auf installieren mit Sprachauswahl, zeit, Passwort etc. Wenn es dann anfängt zu installieren dauert es keine 5s und die Installation bricht ab und es kommt der Bildschirm.

Das funktioniert auch nicht bei Linux Mint 20 cinnamon.

Ich würde sehr gerne Linux Mint 20 mate installieren aber es funktioniert nicht. Was auffällt. Bei Linux Mint 19.3 Mint werden im Installationsfenster Bilder angezeigt, bei Linux Mint 20 nur ein weißes Fenster mit der Linux Umrahmung
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 18:07:43
wenn ich mich dann wieder anmelde und die Installation erneut vornehme kommt diese Fehlermeldung.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 19:03:09
Was ist eure Meinung? Diesen Thread schließen und neuen eröffnen zum Thema Linux Mint 20 Installation oder sollen wir hier weiter die Sache besprechen?
Ich weiß hier nicht weiter.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Flash63 am 30.12.2020, 19:08:59
Hatten wir das nicht auch schon probiert, Mint20 mit 5.8-Kernel von Live-USB?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 19:12:05
Richtig das hatten wir auch schon probiert. Ich habe versucht:

Linux Mint 19.3 mate  --> läuft, bekomme ich installiert
Linux Mint 20 cinnamon oder mate --> bekomme ich nicht installiert. --> siehe Bildschirmfotos

:-(
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 30.12.2020, 19:47:42
Im Moment bin ich ratlos ...  :-X  Mal heftig nachdenken ...
Titel: Re: Grafikkarte nicht installiert
Beitrag von: toffifee am 30.12.2020, 20:38:00
Ich habe da auch keine Idee zu, sehr ungewöhnlicher Verlauf.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 20:53:54
Würde es Sinn machen, die Grafikkarte zu entnehmen und dann versuchen Linux Mint 20 zu installieren?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 30.12.2020, 20:58:43
Hast Du onboard was? Oder eine andere? Dann sollte vielleicht nouveau-Treiber funzen ...
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 21:02:35
Onboard habe ich auch eine Grafikkarte. Aber nur zu Installationszwecke
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 30.12.2020, 21:06:38
Dann, Versuch macht kluch ... :)
Titel: Re: Grafikkarte nicht installiert
Beitrag von: toffifee am 30.12.2020, 21:14:16
Das in #22 und #23 gezeigte hat mE nichts mit der GK zu tun. Aber warum nicht?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 21:20:55
Würde es denn noch andere Möglichkeiten geben Linux Mint 20 zu installieren?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 30.12.2020, 21:24:39
Ich würde es mit der onboard versuchen, da 2 Systeme ja schon nicht wollen.

Als Ausschlussverfahren ...
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 22:36:27
Grafikkarte entnommen, Rechner tut aber nichts. Piept dreimal und das war es.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 30.12.2020, 22:39:53
Da ist irgendwas anderes inne Fritten ...
Titel: Re: Grafikkarte nicht installiert
Beitrag von: tommix am 30.12.2020, 22:41:30
Ich würde es mit der onboard versuchen, da 2 Systeme ja schon nicht wollen.

Als Ausschlussverfahren ...

Zitat
AMD Ryzen 5 2600X

Hat er ja nicht: X
Die CPU's mit Grafikkarte Onbord heißen XXXXG

Graphics:
  Device-1: NVIDIA driver: nvidia v: 455.38
  Display: x11 server: X.Org 1.20.8 driver: fbdev,modesetting,nouveau
  unloaded: vesa resolution: 1920x1080~77Hz
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8

Siehe meinen: 3700X ohne Grafikkarte.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 30.12.2020, 22:44:06
Ein Speicherriegel war mal bei mir defekt obwohl memtest nichts fand. Waren auch ganz seltene merkwürdige Verhaltensmuster.
Auch das Board sollte man nicht vergessen. Haarrisse oder defekte Ekos ...

Echt keinen Plan mehr ...
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 22:51:11
Hab gerade Mal im Handbuch nachgelesen. Dieses Signal bedeutet keine Grafikkarte gefunden. Das Mainboard hat aber HDMI und Display Port Anschluss. Eigentlich sollte es doch starten. Ins BIOS komme ich auch nicht.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 30.12.2020, 23:24:37
Also. Laut Hersteller funktioniert das Mainboard ohne Grafikkarte nur wenn die CPU einen integrierten Grafikchip besitzt. Also. Das Thema ist durch.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: tommix am 30.12.2020, 23:31:05
Habe ich ja geschrieben.
Alle Ryzen CPU die ein "X" als letztes haben haben keine GPU in der CPU onBoard.
Ich habe je auch keine im Ryzen 7 3700X.
Und AMD mit onBoard einer Nvidia schon gar nicht.
Deshalb hat AMD ja ATI gekauft.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Flash63 am 31.12.2020, 00:07:10
Hallo,
also die Grafikkarte sollte bei diesem ROG STRIX B450-F GAMING Board auf dem ersten PCIe-16 Steckplatz eingebaut sein.

Siehe Anleitung https://dlcdnets.asus.com/pub/ASUS/mb/SocketAM4/ROG_STRIX_B450_F_GAMING/G14401_ROG_STRIX_B450-F_GAMING_UM.pdf Seite  1-7/1-8.

Aber dennoch, sollte sie da schon eingebaut sein, probeweise auf den zweiten PCIe-16 Steckplatz umbauen. Im UEFI gibt es normalerweise auch irgendwo eine Option, ob zuerst die hier nicht vorhandene CPU-Grafik, initialisiert werden soll oder die im PCIe-Slot. Normalerweise sollte das egal sein, aber hier ist ja nichts "normal"
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 08:37:48
Erst noch einmal "Vielen Dank" für eure großartige Hilfe, auch wenn wir hier noch nicht so richtig weiter kommen.

Die Grafikkarte habe ich, laut Anleitung, auf Position zwei d.h. erster Steckplatz. Ich hatte die Karte auch schon auf dem zweiten Steckplatz und habe hier keinen Unterschied festgestellt.
Mit dem UEFI kann ich nichts sagen. Was mir aufgefallen ist. Beim Booten kann ich im BIOS UEFI USB oder UEFI Festplatte etc auswählen. Das ganze kann ich auch ohne UEFI auswählen. Ich habe mich grundsätzlich für OHNE UEFI entschieden da ich es nicht kenne :-(. Jetzt weiß ich nicht ob dies einen Einfluss haben könnte.

Zusammenfassung:
- Kernel 5.8 nur in Kombination mit Linux Mint 20 verfügbar --> lässt sich nicht installieren
- Mit Linux Mint 19.3 ist die Grafikkarteneinstellung irgendwie nicht richtig
- BIOS Update durchgeführt

Titel: Re: Grafikkarte nicht installiert
Beitrag von: Flash63 am 31.12.2020, 08:47:30
Ja gut, das UEFI musst Du schon selbst nach der Option für die Grafik durchsuchen. Die Dokumentation gibt das nicht her.

Test ob Secure-Boot abgeschaltet ist:
sudo apt install mokutil
mokutil --sb-state
Titel: Re: Grafikkarte nicht installiert
Beitrag von: nudels am 31.12.2020, 08:48:20
ev graka defekt
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 09:38:07
zur Graka habe ich folgende Optionen gefunden
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 09:38:39
und diese
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Flash63 am 31.12.2020, 09:55:14
Probiere die möglichen Modi für den entsprechenden PCIe-Slot doch mal durch, nicht "Auto". Was "sagt" mokutil?
SR-IOV im anderen Bild betrifft Virtualisierung, hier also nicht von Bedeutung.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 31.12.2020, 10:04:37
... und im 1. Bild ist der Scroll-Balken noch oben, was ist weiter unten ? ...

Aber warum sich nicht LM20 installieren lässt erschließt mich (noch) nicht.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Flash63 am 31.12.2020, 10:21:08
Aber warum sich nicht LM20 installieren lässt erschließt mich (noch) nicht.
Weil es nicht funktioniert und bei Start von USB in einem Blackscreen endet.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 31.12.2020, 10:22:24
Also es geht nicht weil es nicht ... Toll  ;D
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 10:32:32
Nur zur Info. Weder USB noch von CD bekomme ich LM 20 installiert. Obwohl ich ihr auf einem Notebook problemlos hinbekommen habe.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 31.12.2020, 10:36:42
...
Was "sagt" mokutil?
...

?

Ist entweder was banales das es nicht geht oder ein defekt ...
Titel: Re: Grafikkarte nicht installiert
Beitrag von: peterpolki am 31.12.2020, 12:04:11
noch von CD bekomme ich LM 20
das ist aber auch klar, die .iso passt auf keine CD
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 12:36:24
mit CD meine ich natürlich DVD, sorry.

Was meint ihr mit mokutil? Ich sehe das nicht?

Noch was. Ich habe in meiner Verzweiflung auch mal Ubunti 20.04 Mate installiert. Kurz vor Ende der Installation ist dann der Installer abgebrochen. Allerdings konnte ich danach Ubuntu ganz normal starten und auch die updates laden. Bildschirme erkannt nach Änderung des Grafiktreibers. Was nicht so richtig ging. Ich konnte aus der Softwareboutique zwar Programme aussuchen, bei der Installation habe ich aber nach ca. 1h abgebrochen, weil an dem Fortschrittsbalken sich nichts getan hat.
Meine Vermutung:
Wenn wir es schaffen Linux Mint 20 zu installieren dann sind vermutlich alle Probleme gelöst. Könnte man dies via Skype probieren???
Titel: Re: Grafikkarte nicht installiert
Beitrag von: toffifee am 31.12.2020, 12:46:04
Meine Vermutung:
Wenn wir es schaffen Linux Mint 20 zu installieren dann sind vermutlich alle Probleme gelöst.
Wie kommst du zu der?? Deine ständigen Probleme lassen mich da sehr zweifeln... ::)
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 12:47:49
Ständige Probleme? Eigentlich habe ich nur eins. LM 20 installieren. :'(
Wenn Ubuntu 20.04 funktioniert dann sollte auch LM 20 funktionieren
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Flash63 am 31.12.2020, 13:17:47
Also erneut gefragt. Was zeigt ...
sudo apt install mokutil
mokutil --sb-state
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 14:04:07
Sorry für die Wartezeit, ich hatte kein Betriebssystem mehr drauf. Habe jetzt wieder Linux Mint 19.3 drauf und alle Aktualisierungen. Kernel 5.0.0-32 ist aktiv

~$ sudo apt install mokutil
[sudo] Passwort für bandit:           
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden NEUEN Pakete werden installiert:
  mokutil
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 0 B von 22,3 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 67,6 kB Plattenplatz zusätzlich benutzt.
Vormals nicht ausgewähltes Paket mokutil wird gewählt.
(Lese Datenbank ... 298722 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../mokutil_0.3.0+1538710437.fb6250f-0ubuntu2~18.04.1_amd64.deb ...
Entpacken von mokutil (0.3.0+1538710437.fb6250f-0ubuntu2~18.04.1) ...
mokutil (0.3.0+1538710437.fb6250f-0ubuntu2~18.04.1) wird eingerichtet ...
Trigger für man-db (2.8.3-2ubuntu0.1) werden verarbeitet ...

mokutil --sb-state
EFI variables are not supported on this system
Titel: Re: Grafikkarte nicht installiert
Beitrag von: mensch. am 31.12.2020, 17:45:51
Wenn Ubuntu 20.04 funktioniert dann sollte auch LM 20 funktionieren

was genau würde denn dagegen sprechen das funktionierende ubuntu 20.04 weiterhin zu nutzen ... ?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 18:29:37
da spricht nichts dagegen. Mich hat halt irritiert das der Installer kurz vor Schluss abgebrochen hat. (Sowohl Minimalinstallation als auch Normalinstallation) Des Weiteren hat mich gewundert, dass der Fortschrittsbalken beim Installieren von zusätzlicher Software nach über 1h nicht weiter ging. Das hat alle irgendwie "Geschmäckle", irgendwie hat man das Gefühl, dass die Installation nicht sauber drauf ist.  Ansonsten bin ich offen. Laut einer Videovorstellung scheint es für mich egal zu sein welches Betriebssystem ich nutze. (Windows ausgeklammert)
Titel: Re: Grafikkarte nicht installiert
Beitrag von: mensch. am 31.12.2020, 18:52:29
@bandit77
solche probleme gibt es leider hin und wieder ... dass die software partout nicht mit der hardware möchte ... da kannste dann tagelang rumfrickeln oder einfach mal das os nutzen das stabil läuft ...

ich hatte den eindruck bei der verfolgung deines beitrags dass alles etwas hektisch gelaufen ist ... versuchs halt mal in ruhiger minute nochmal mit der installation ... es ist aber ratsam sich erstmal in die materie einzulesen ... z.b die befehle für das terminal ... wenn du erst anfängst dich damit zu beschäftigen wenn du danach gefragt wirst is schon blöd ...

https://www.linuxmintusers.de/index.php?action=wiki;page=Main_Page

hier findest du einiges was dich weiterbringen wird.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 19:06:05
Hektisch schon, aber nur weil ich nur rudimentäre Kenntnisse besitzen. D.h. ich kann es installieren und dann ist langsam Schluss. Allerdings wenn bei zig Betriebssystemen der Installer abbricht dann wird es langsam doof. Hektik hin oder her. Der Installer nimmt sich die Zeit die er braucht.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: mensch. am 31.12.2020, 19:23:06
Hektisch schon, aber nur weil ich nur rudimentäre Kenntnisse besitzen. D.h. ich kann es installieren und dann ist langsam Schluss. Allerdings wenn bei zig Betriebssystemen der Installer abbricht dann wird es langsam doof. Hektik hin oder her. Der Installer nimmt sich die Zeit die er braucht.

ich verstehe was du meinst ... ich habe hier noch ein notebook von acer liegen ... linux mint 19.2 lief super drauf ... 19.3 liess sich nicht installieren ... das mint 20 auch nicht ... frag mich nicht warum ...
also bleibt das 19.2 drauf ... läuft .

das schhöne ist ... du kannst erstmal mit einem live-system testen ob es deine hardware sauber anspricht oder unterstützt und musst nicht immer gleich alles installieren ... nur um festzustellen dass es nicht läuft .... :-)

Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 22:55:48
Guten Abend,

ich habe gerade Linux Mint 20 installiert. Dabei habe ich mich exakt an dieses Video gehalten.

https://www.youtube.com/watch?v=Ke1MRft3lLI&t=277s

Danach habe ich noch auf den Kernel 5.8.0-33 umgestellt.
Ich werde es beobachten. Momentan funktioniert erst einmal alles.

Ich wünsche allen einen guten Rutsch in ein besseres Jahr als dieses. Danke nochmals für eure Geduld und Hilfe!
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 31.12.2020, 23:04:31
... und die Graka ? Alles paletti?
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 31.12.2020, 23:07:19
Erstmal keine Auffälligkeiten. Funktioniert. Ich hoffe morgen auch noch.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 31.12.2020, 23:09:33
Kannst Du noch mal zeigen:

inxi -Fz
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 01.01.2021, 10:31:16
Seit letztes Jahr läuft nun alles, fehlt nur noch ... Antwort auf #69 ...  8)
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 01.01.2021, 12:36:46
Antwort kommt auch. Hatte gestern alles aus geschaltet.

Frohes neues Jahr noch.

Beim ersten Start dieses Jahr, wieder das gleiche Problem. habe dann in der Onboard Gerätekonfiguration dann PCIEX16_1 von Auto auf GEN1 gesetzt. Danach lief alles wieder ganz normal hoch.

System:
  Kernel: 5.8.0-33-generic x86_64 bits: 64 Desktop: MATE 1.24.0
  Distro: Linux Mint 20 Ulyana
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
  serial: <filter> BIOS: American Megatrends v: 4007 date: 12/08/2020
CPU:
  Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 1885 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 1887 2: 1883
  3: 2133 4: 2170 5: 1890 6: 1884 7: 1927 8: 1940 9: 2050 10: 2030 11: 2051
  12: 1970
Graphics:
  Device-1: NVIDIA TU117 [GeForce GTX 1650] driver: nvidia v: 455.38
  Display: x11 server: X.Org 1.20.8 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa
  resolution: 1920x1080~60Hz, 3440x1440~75Hz, 1920x1080~60Hz
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38
Audio:
  Device-1: NVIDIA driver: snd_hda_intel
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.8.0-33-generic
Network:
  Device-1: Intel I211 Gigabit Network driver: igb
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 20.36 GiB (2.2%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T3X0C-00SJG0
  size: 931.51 GiB
Partition:
  ID-1: / size: 915.89 GiB used: 20.36 GiB (2.2%) fs: ext4
  dev: /dev/nvme0n1p1
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 36 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 303 Uptime: 1m Memory: 15.62 GiB used: 1.10 GiB (7.0%)
  Shell: bash inxi: 3.0.38
bandit@bandit-System-Produc
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Nuffi am 01.01.2021, 12:45:46
da scheint es ja soweit zu gehen, auch mit mehreren Monitoren? Das war doch irgendwie auch Thema...

Aber der von Dir genommen Weg ist auch schon seit Juli hier im Wiki ...  ;)

https://www.linuxmintusers.de/index.php?action=wiki;page=Upgrade_LM19.3_auf_LM_20

Guten Abend,

ich habe gerade Linux Mint 20 installiert. Dabei habe ich mich exakt an dieses Video gehalten.

https://www.youtube.com/watch?v=Ke1MRft3lLI&t=277s
..

Viel Spass mit LM20 ...  :)
Titel: Re: Grafikkarte nicht installiert
Beitrag von: bandit77 am 01.01.2021, 12:47:56
3 Monitore gehen. So wie ich es mir vorgestellt habe.

Nochmals, herzlichen Dank für die Unterstützung.
Titel: Re: Grafikkarte nicht installiert
Beitrag von: toffifee am 01.01.2021, 13:20:08
Prima, dann setze bitte noch ein "gelöst" oder "erledigt": dazu den Eröffnungspost "ändern" und das Präfix setzen. Dann sehen andere gleich, dass hier keine Hilfe mehr notwendig ist. (Anleitung: https://www.linuxmintusers.de/index.php?topic=3603.0)
Titel: Re: Grafikkarte nicht installiert
Beitrag von: Flash63 am 01.01.2021, 17:22:02
Zitat
3 Monitore gehen. So wie ich es mir vorgestellt habe.
Auch mit Nvidia-Treiber?
Also lag es letztendlich an der Einstellung des PCIe-Modus im BIOS/UEFI?