Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
11.04.2021, 07:20:26

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25482
  • Letzte: Dragonx21
Statistiken
  • Beiträge insgesamt: 727710
  • Themen insgesamt: 58757
  • Heute online: 394
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 4
Gäste: 253
Gesamt: 257

Autor Thema:  Eingabepromt im Terminalfenster bei AD-Benutzern  (Gelesen 606 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Eingabepromt im Terminalfenster bei AD-Benutzern
« am: 06.01.2017, 23:37:48 »
Hallo,

ich habe wieder einmal mit Min Linux ein wenig rum experimentiert, diesmal die aktuelle Version 18.1 . Sieht mittlerweile wirklich schön aus und die AD-Integration mittels powerbroker hat auch gut geklappt.

Bei der Benutzung des Terminals habe ich allerdings, wie auch in früheren Versionen das Problem, dass dort nur das "$" als Prompt steht und nicht der aktuelle Benutzer und der Dateipfad. Auch das Blättern in alten Befehlen klappt nicht.

Erstelle ich einen neuen lokalen Benutzer, dann klappt dies immer, bei Domainbenutzern nie. Gibt es hierfür einen Trick, bzw. was wird denn da nicht mitgeladen?

Vielen Dank

Mike

Re: Eingabepromt im Terminalfenster bei AD-Benutzern
« Antwort #1 am: 07.01.2017, 13:43:05 »
Hi :)
schau mal im jeweiligen /home/user ordner nach der
.bashrc

ggf. von einem funktionierendem user übernehmen.

Re: Eingabepromt im Terminalfenster bei AD-Benutzern
« Antwort #2 am: 07.01.2017, 15:02:46 »
Hi ehtron,

das hatte ich schon probiert, ich habe die Datei von einem lokalen Benutzer kopiert, es hilf leider nichts. Offensichtlich passiert dies nur bei Domainnutzern, bei lokalen läd das Terminalserver die config.

Ist bestimmt etwas ganz einfaches  :(

Re: Eingabepromt im Terminalfenster bei AD-Benutzern
« Antwort #3 am: 08.01.2017, 22:36:48 »
Hallo,

ich habe mal noch ein wenig gelesen, oft bekommt ich bei diesem Problem den Hinweis, den folgenden Befehl zu nutzen, damit alles wieder funktioniert, die Cursortasten und TAB gehen auch nicht:

sudo chsh -s /bin/bash <username>

Leider bekomme ich dann die Meldung das der Benutzer in der Datei /etc/passwd nicht vorhanden ist. Dies stimmt natürlich auch, da der angemeldete Benutzer ja ein Domainbenutzer und kein lokaler ist.

Gibt es hierfür vielleicht ein Workaround, das gleiche Problem hatte ich auch schon bei der Version 17.3 und 18