Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
10.05.2021, 01:02:16

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25578
  • Letzte: pastirma
Statistiken
  • Beiträge insgesamt: 734351
  • Themen insgesamt: 59161
  • Heute online: 403
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 5
Gäste: 353
Gesamt: 358

Autor Thema: [erledigt] Problem mit Hybrid-grafik + NVIDIA GTX 850M und 'bumblebee'  (Gelesen 866 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Problem mit Hybrid-grafik + NVIDIA GTX 850M und 'bumblebee'
« am: 15.01.2015, 20:58:51 »
Hallo zusammen,

ich habe ein problem mit meiner hybrid-grafik und der NVIDIA GTX 850M graka in meinem
notebook (LM 17.1 Cinnamon 64bit)

Nach installation der nvidia-331 treiber (vorher lief nouveau) funktioniert jetzt
optirun glxgears
293 frames in 5.0 seconds = 58.539 FPS
300 frames in 5.0 seconds = 59.979 FPS
...

Aber einfach nur glxgears ohne 'optirun'
hat die gleichen werte  :o
glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
359 frames in 5.0 seconds = 71.639 FPS
300 frames in 5.0 seconds = 59.978 FPS
...

' optirun inxi -G' liefert:
Graphics:  Card: Intel 4th Gen Core Processor Integrated Graphics Controller
           X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
           GLX Renderer: GeForce GTX 850M/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 331.113

Ist 'bumblebee' jetzt richtig aufgesetzt ?
Warum läuft 'glxgears' mit dieser niedrigen frame-rate unter optirun ?

Bei 'optirun nvidia-settings -c :8 ' sehe ich auch die graka  ::)
Wie kann ich testen ob mein setup stimmt ?

Im voraus mal danke für eure unterstützung.
Gruß
« Letzte Änderung: 15.01.2015, 22:53:03 von r-m-w »

Re: Problem mit Hybrid-grafik + NVIDIA GTX 850M und 'bumblebee'
« Antwort #1 am: 15.01.2015, 22:52:34 »
Ok, .... sorry hätte zuerst mehr'googeln'  & lesen sollen ... :-[

hab das hier gefunden
https://github.com/Bumblebee-Project/Bumblebee/wiki/FAQ#how-to-check-nvidia-card-performances--they-seems-low

weiter unten steht
Zitat
Why do I get a much lower FPS with optirun glxgears in comparison with just glxgears?

Because glxgears is not a benchmarking tool. Try optirun glxspheres instead.
...

Nach installation von 'glxspheres' erhalte ich:
./glxspheres64
Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: Mesa DRI Intel(R) Haswell Mobile
61.162341 frames/sec - 68.257173 Mpixels/sec
59.993692 frames/sec - 66.952960 Mpixels/sec
...
...
optirun ./glxspheres64
Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GTX 850M/PCIe/SSE2
114.260870 frames/sec - 127.515131 Mpixels/sec
121.181106 frames/sec - 135.238115 Mpixels/sec
...

was ja schon mal ganz gut aussieht  :D

und
vblank_mode=0 primusrun glxgears
11178 frames in 5.0 seconds = 2235.348 FPS
13029 frames in 5.0 seconds = 2605.597 FPS
13059 frames in 5.0 seconds = 2611.773 FPS
13030 frames in 5.0 seconds = 2605.913 FPS

Also ... es scheint alles ok zu sein.
Nochmals sorry für meinen übereilten ersten beitrag.  :-*
Gruß