Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
21.06.2021, 09:37:11

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25691
  • Letzte: tommy36
Statistiken
  • Beiträge insgesamt: 741784
  • Themen insgesamt: 59656
  • Heute online: 456
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Mint 17 / Windows 7 grub/start probleme  (Gelesen 5286 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #30 am: 29.10.2014, 02:19:33 »
Hinweis zu PLOP:
Zitat
Achtung Linux Users: Installieren Sie LILO oder GRUB nicht in den Master Boot Record (MBR) sondern in den Bootsektor Ihrer Bootpartition. Der Plop Bootmanager ist kein Linux Loader und benötigt daher LILO oder GRUB im Bootsektor um Linux zu starten! Siehe Linux Bootmanager.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #31 am: 29.10.2014, 10:24:41 »
Plop braucht man eigentlich überhaupt nicht installieren, das gibt es auch als Live Iso.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #32 am: 29.10.2014, 10:33:36 »
Falls sich jedoch in diesem speziellen Fall Win über PLOP starten lässt, würde ich über eine Installation nachdenken, denn immer eine Live-CD im Laufwerk haben zu müssen ist auch nicht gerade wünschenswert.
Allerdings würde ich es auch erst mal mit der Live-CD versuchen.
« Letzte Änderung: 29.10.2014, 10:38:53 von helli »

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #33 am: 29.10.2014, 10:35:30 »
Zum starten von Windows reicht die SuperGrubDisk2, oder Rescatux.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #34 am: 29.10.2014, 11:23:37 »
Trotzdem hat helli Recht, daß ein Starten des Systems mit Hilfe einer CD höchst umständlich ist und sicher nicht im Sinne der Grub-Erfinder.
Wenn es nicht anders geht, ist es natürlich gut, die Möglichkeit (also eine entsprechende CD) zu haben.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #35 am: 29.10.2014, 11:28:11 »
Hi alle,

bis jetzt hab ich es mit keiner Methode geschafft.

Klar könnte ich den plop jetzt installieren, oder evtl mit super grub2 etc. starten.

Aber was mich wirklich nervt, ist, das es gegangen ist, und bei vielen anderen auch funktioniert.
Da kommt der Ehrgeiz durch :)

Ich kann es einfach nicht verstehen, warum?

Hab jetzt folgendes gemacht:

Auf der SSD habe ich win 7 installiert, und es startet wunderbar.
Auf nem Stick habe ich Mint 17 installiert (mit abgesteckter SSD). Läuft wunderbar.

Wenn ich im Bios dann auswähle: startet von SSD --> win läuft
                                                            startet von Stick --> mint läuft

Dann im Mint nen update-grub ausgeführt. Wenn ich jetzt vom Stick starte, kommt der Grub und zeigt mir auch win an.

ABER: Es startet nicht.

Jetzt hat der Grub nichts im MBR von der SSD liegen. Alles ist separiert.
Ich checks nimmer.

grub.cfg
### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows 7 (loader) (auf /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-A26C34F46C34C4B7' {
        insmod part_msdos
        insmod ntfs
        set root='hd0,msdos1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  A26C34F46C34C4B7
        else
          search --no-floppy --fs-uuid --set=root A26C34F46C34C4B7
        fi
        parttool ${root} hidden-
        chainloader +1
}
set timeout_style=menu
if [ "${timeout}" = 0 ]; then
  set timeout=10
fi
### END /etc/grub.d/30_os-prober ###

fdisk -l
Disk /dev/sda: 128.0 GB, 128035676160 bytes
255 Köpfe, 63 Sektoren/Spur, 15566 Zylinder, zusammen 250069680 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Festplattenidentifikation: 0xabc7a9dc

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          208894   250068991   124930049    f  W95 Erw. (LBA)
/dev/sda5          210944    94578687    47183872    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 16.0 GB, 16013852672 bytes
255 Köpfe, 63 Sektoren/Spur, 1946 Zylinder, zusammen 31277056 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Festplattenidentifikation: 0x000bb0f8

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sdb1   *        2048    27197439    13597696   83  Linux
/dev/sdb2        27199486    31275007     2037761    5  Erweiterte
/dev/sdb5        27199488    31275007     2037760   82  Linux Swap / Solaris

blkid

/dev/sda1: LABEL="System-reserviert" UUID="A26C34F46C34C4B7" TYPE="ntfs"
/dev/sda5: UUID="56E8D580E8D55EB5" TYPE="ntfs"
/dev/sdb1: UUID="b4f707b5-56b2-453d-954d-33953c7e3c71" TYPE="ext4"
/dev/sdb5: UUID="dde7a851-88d0-4001-9f27-4b78330b3d65" TYPE="swap"

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #36 am: 29.10.2014, 12:03:15 »
Was man anders machen könnte:
sda1 so groß als ntfs anlegen, dass es für Win reicht.
in sda2, der Erweiterten erst mal sda5 als ext4 über den gesamten verfügbaren Speicher der Erweiterten anlegen

Wenn nun Win auf sda1 installiert wird, kann es nicht diese kleine Boot-Partition anlegen.
Auf dem Stick müsste dann noch mal update-grub ausgeführt werden.

Ob das zum Erfolg führt, kann ich allerdings nicht sagen.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #37 am: 29.10.2014, 12:04:47 »
Neuer Ansatz:

Hab jetzt die SSD und den Stick in nen Laptop rein.
Und siehe da, es funktioniert. Ich kann vom grub Menü auf dem Stick das windows Booten. :o

Was soll das jetzt?
Sollte es am MB liegen? Defekt?

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #38 am: 29.10.2014, 12:48:06 »
Hi,

ich habs geschafft. Nach der Aktion mit dem Laptop hab ich mir das Bios nochmal vorgenommen.

Hab es wie schon geschrieben schon öfter auf default zurückgesetzt, und mit einigen parametern rum gespielt. Alles nichts genützt.
Jetzt hab ich mit allen rumgespielt, was da war, und sie da, ich hab den Eintrag gefunden, der es war.
Warum dieser? Was hat der damit zu tun? Da wär ich beim normalen Lesen niemals drauf gekommen?
Könnte mir vlt einer der Experten mir das mal erklären, was der damit zu tun hat.
Es ist der weiß markierte im Anhang.

Vielen Dank für euer Hilfe


Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #40 am: 29.10.2014, 13:02:08 »
Ok, und was hat des mit dem Problem zu tun?
Ich verstehe ned

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #41 am: 29.10.2014, 13:48:34 »
Zitat
Das Bundesamt für Sicherheit in der Informationstechnik (BSI) warnt vor dem Einsatz von TPM. Microsoft könne festlegen, welche Programme noch auf dem Computer installiert werden können, bereits eingerichtete Programme nachträglich unbrauchbar machen und Geheimdiensten helfen, fremde Computer zu kontrollieren. Die zuständigen Fachleute im Bundeswirtschaftsministerium, in der Bundesverwaltung und beim BSI warnen denn auch unmissverständlich vor dem Einsatz von Trusted Computing der neuen Generation in deutschen Behörden. "Durch den Verlust der vollen Oberhoheit über Informationstechnik" seien "die Sicherheitsziele 'Vertraulichkeit' und 'Integrität' nicht mehr gewährleistet." (Zeit-Online vom 20. August 2013, "Bundesregierung warnt vor Windows 8")
https://de.wikipedia.org/wiki/Trusted_Computing
Da steht auch noch mehr.
TPM : https://de.wikipedia.org/wiki/Trusted_Platform_Module
« Letzte Änderung: 29.10.2014, 13:54:02 von aexe »

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #42 am: 29.10.2014, 14:06:42 »
Muss mal raus:

Es kotzt mich an, was dieses Wintel-Gesindel immer wieder anstellt!!!!!!!!!

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #43 am: 29.10.2014, 14:27:03 »
Tja, wie jede Technik. Kann Fluch und Segen sein, das ist immer sehr subjektiv.
http://blog.techflaws.org/tc-faq-de/#2

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #44 am: 29.10.2014, 14:47:23 »
@hugohoelzer

Freut mich, dass deine Systeme wieder auf Zack sind. :)

Letztendlich hast du dir selbst geholfen.  8)