Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
21.06.2021, 09:59:11

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25691
  • Letzte: tommy36
Statistiken
  • Beiträge insgesamt: 741785
  • Themen insgesamt: 59656
  • Heute online: 456
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Mint 17 / Windows 7 grub/start probleme  (Gelesen 5287 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #15 am: 28.10.2014, 18:30:51 »
Ok, was soll ich genau sagen?

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #16 am: 28.10.2014, 18:38:11 »
Einfach den Code von aexe ins Terminal eingeben und das Ergebnis hier anzeigen.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #17 am: 28.10.2014, 18:44:22 »
sudo os-prober
  No volume groups found
/dev/sda1:Windows 7 (loader):Windows:chain

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #18 am: 28.10.2014, 18:54:15 »
Ist das jetzt der Zustand, nachdem du den MBR der Startpartition wieder mithilfe der WIN-CD hergestellt hast?

Es fehlt nämlich eine Anzeige zu deinem Mint.

Zeige doch bitte mal von Mint aus, wo genau dein GRUB steckt, sofern es vorhanden ist:
sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #19 am: 28.10.2014, 18:59:32 »
Das laufende System wird bei mir durch
sudo os-proberauch nicht angezeigt.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #20 am: 28.10.2014, 19:06:22 »
Das ist jetzt folgender Zustand:

Alles neu installiert. Danach mit win-cd gestartet, mbr repariert. Danach hat win gebootet.
Anschließend mit boot-repair von stick gestartet, grub repariert.

Das Grub menü kommt, aber win startet nicht

sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""

/dev/sda: GRUB 2 v1.99
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 00
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdb: Kein GRUB 00
/dev/sdb1: Kein GRUB 55aa
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 31c0

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #21 am: 28.10.2014, 19:29:46 »
Das ist bei mir auch so, daß der OS-Prober das laufende System nicht anzeigt.
Aber das Windows findet er ja.
Der Grub ist auch am richtigen Ort, nämlich auf sda.
 
Kopfkratz ...

Fällt mir nur noch ein, das irgendwas mit der Windows-Installation nicht hinhaut.
Da bin ich aber völlig ratlos.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #22 am: 28.10.2014, 19:32:23 »
  :o

Wenn ich mit der Win cd starte, und den mbr neu schreibe, startet windows problemlos

Hab das jetzt auch gemacht. Windows startet, leider kommt kein grub.

Wenn ich jetzt mit Super grub 2 starte, und manuell linux mint starte, geht es. Super grub 2 findet den grub ja anschenend

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #23 am: 28.10.2014, 20:17:00 »
Ich gehe mittlerweile auch davon aus, dass der Wurm bei WIN 7 zu suchen ist. Deshalb habe ich mal "rumgesucht".

Ich habe bei meiner Suche was gefunden. Allerdings kann ich mit dem Begriffen, die genannt werden, absolut nichts anfangen. Aber vielleicht ist hier ja jemand, der das "übersetzen" kann.

Jedenfalls hat es beim Themenersteller funktioniert - was genau das immer war. Siehe hier.
http://www.administrator.de/forum/nach-ubuntu-installation-bootet-windows-7-nicht-mehr-151775.html#comment-599169

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #24 am: 28.10.2014, 20:25:02 »
Und wenn in deinem Fall GRUB 2 der "Schuldige" ist?

Siehe mal hier:
http://blog.toadie.de/?p=884

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #25 am: 28.10.2014, 20:56:30 »
Ich Versuch jetzt mal den grub 2 wegzuschmeißen

Feedback kommt :)

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #26 am: 29.10.2014, 01:24:49 »
So, nach weiteren vergeblichen versuchen folgender Stand:

Alles wieder neu installiert. Weder mit Mint 13 noch Mint 17 geht es.

Habe Grub 2 deinstalliert und Grub installiert: Negativ

Mit drivemap rumgespielt laut dem anderen link: Negativ

folgender Stand:

Frische installation von Windows 7 und Linux Mint 13

sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: GRUB 2 v1.99
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdb: Kein GRUB 7c66
/dev/sdb1: Kein GRUB 31c0


os-prober
/dev/sda1:Windows 7 (loader):Windows:chain

fdisk -l

Disk /dev/sda: 128.0 GB, 128035676160 bytes
255 heads, 63 sectors/track, 15566 cylinders, total 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000662eb

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   123086847    61440000    7  HPFS/NTFS/exFAT
/dev/sda3       123088894   250068991    63490049    5  Extended
/dev/sda5       123088896   245991423    61451264   83  Linux
/dev/sda6       245993472   250068991     2037760   82  Linux swap / Solaris

cat /boot/grub/grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos5)'
  search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
  set locale_dir=($root)/boot/grub/locale
  set lang=de_DE
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
set menu_color_normal=white/black
set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
set gfxpayload="$1"
if [ "$1" = "keep" ]; then
set vt_handoff=vt.handoff=7
else
set vt_handoff=
fi
}
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry 'Linux Mint 13 Cinnamon 64-bit, 3.2.0-23-generic (/dev/sda5)' --class linuxmint --class gnu-linux --class gnu --class os {
recordfail
gfxmode $linux_gfx_mode
insmod gzio
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
linux /boot/vmlinuz-3.2.0-23-generic root=UUID=5bd5a53a-12da-4733-86df-e77beb510919 ro   quiet splash $vt_handoff
initrd /boot/initrd.img-3.2.0-23-generic
}
menuentry 'Linux Mint 13 Cinnamon 64-bit, 3.2.0-23-generic (/dev/sda5) -- recovery mode' --class linuxmint --class gnu-linux --class gnu --class os {
recordfail
insmod gzio
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
echo 'Loading Linux 3.2.0-23-generic ...'
linux /boot/vmlinuz-3.2.0-23-generic root=UUID=5bd5a53a-12da-4733-86df-e77beb510919 ro recovery nomodeset
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-3.2.0-23-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 7 (loader) (on /dev/sda1)" --class windows --class os {
insmod part_msdos
insmod ntfs
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set=root A26C34F46C34C4B7
chainloader +1
}
### END /etc/grub.d/30_os-prober ###






### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

Des kann doch alles nicht sein. Es hat ja alles für lange Zeit funktioniert.

Ich habe auch die alte Sicherung der Platte nochmal eingespielt, und dort Grub2 durch Grub ersetzt. Da ging genauso wenig.

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #27 am: 29.10.2014, 01:51:17 »
Ich kenne einen Fall, da musste nach der Installation von Mint13 mit der Win-DVD im Reparatur-Modus Bootrec /fixboot ausgeführt werden.
(Aber nicht Bootrec /fixmbr, sonst wäre der Grub ja wieder weg)

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #28 am: 29.10.2014, 02:00:43 »
Ok, verusch ich mal

Re: Mint 17 / Windows 7 grub/start probleme
« Antwort #29 am: 29.10.2014, 02:16:17 »
Wenn das nicht geht, versuch den PLOP Bootmanager. http://www.plop.at/de/bootmanagers.html
Also auch  bootrec /fixmbr und dann den PLOP installieren:  http://www.plop.at/de/bootmanager/mbrinstall.html