LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Installation & Updates => Thema gestartet von: hugohoelzer am 27.10.2014, 21:51:05

Titel: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 27.10.2014, 21:51:05
Hi alle,
ich bin nach einer durchzechten Nacht am verzweifeln.

Folgender Ausgangspunkt:

Habe seit 2 Jahren Linux Mint 13 parallel zu windows 7 am laufen (gehabt). Funktionierte immer tadellos.
Habe am Samstag Abend den PC entstaubt, alles abgesteckt gehabt, wieder dran, und dann wars geschehen.

Das Grub Menü kam wieder, ich konnte Mint booten, aber sobald ich win booten wollte, startet immer der PC neu!
Hab dann von der Win cd gestartet, den mbr neu geschrieben, und siehe da, win bootet, aber das grub menü kommt nicht mehr.

Fakt ist, das Win da ist und läuft.
Hab dann diverse tools versucht:
super grub2.....

Den grub kann ich damit auch neu erstellen, und Mint bootet wieder, aber beim win is es wieder das gleiche. Der PC bootet wieder.

Hab das ganze dann diverse male versucht. Sicherung zurückspielen (clonezilla der ganzen Platte 128 GB SSD)
Immer wieder das gleiche.
Beim ersten mal bootet win nicht. Neuerstellung mbr

bootrec /fixmbr
bootrec /fixboot
bcdedit /export c:\BCD_Backup
attrib bcd -s -h -r
bootrec /RebuildBcd

Beim PC start wird direkt win gebootet.

Dann wieder den Grub neu schreiben. Egal ob manuell, mit super Grub2, rescatux, boot-repair.... ich kann ihn neu schreiben, er kommt auch, win ist auch gelistet, aber der PC startet neu.

Hab jetzt auch schon folgendes gemacht.
128GB SSD komplett platt.
Windows 7 neu installiert im Bios-Modus
Die 100MB Partition auf 1GB erweitert, und direkt dahinter die Win-Partition.
Neustart von Windows mehrmals um sicherzugehen, das es alles korrekt ist.
Dann Mint 17 geladen und nach diversen Anleitungen mehrmals installiert. Unter anderem diese hier.
       https://www.linuxmintusers.de/index.php?page=12 (https://www.linuxmintusers.de/index.php?page=12)

Root, home und swap Partition schön sauber angelegt und Mint 17 installiert. Alles wunderbar.
Sobald ich dann den Rechner neu starte, und im Grub auf den win Eintrag geht, wieder das gleiche.

ich komm nicht weiter.

Bitte helft mir, den Blinden wieder sehend zu machen

Danke


Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 27.10.2014, 21:55:14
grub.cfg

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}
function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}
function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 --hint='hd0,msdos5'  b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8
else
  search --no-floppy --fs-uuid --set=root b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=-1
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=10
  # Fallback normal timeout code in case the timeout_style feature is
  # unavailable.
  else
    set timeout=10
  fi
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
set menu_color_normal=white/black
set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
set gfxpayload="$1"
if [ "$1" = "keep" ]; then
set vt_handoff=vt.handoff=7
else
set vt_handoff=
fi
}
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry 'Linux Mint 17 Cinnamon 64-bit, 3.13.0-24-generic (/dev/sda5)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
gfxmode $linux_gfx_mode
insmod gzio
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 --hint='hd0,msdos5'  b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8
else
  search --no-floppy --fs-uuid --set=root b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8
fi
linux /boot/vmlinuz-3.13.0-24-generic root=UUID=b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8 ro   quiet splash $vt_handoff
initrd /boot/initrd.img-3.13.0-24-generic
}
menuentry 'Linux Mint 17 Cinnamon 64-bit, 3.13.0-24-generic (/dev/sda5) -- recovery mode' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod gzio
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 --hint='hd0,msdos5'  b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8
else
  search --no-floppy --fs-uuid --set=root b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8
fi
echo 'Loading Linux 3.13.0-24-generic ...'
linux /boot/vmlinuz-3.13.0-24-generic root=UUID=b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8 ro recovery nomodeset
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-3.13.0-24-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry 'Memory test (memtest86+)' {
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 --hint='hd0,msdos5'  b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8
else
  search --no-floppy --fs-uuid --set=root b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8
fi
knetbsd /boot/memtest86+.elf
}
menuentry 'Memory test (memtest86+, serial console 115200)' {
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 --hint='hd0,msdos5'  b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8
else
  search --no-floppy --fs-uuid --set=root b2f3f2c7-f5ea-4970-aa97-c1be65bae0f8
fi
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows 7 (loader) (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-7A982BB7982B7135' {
insmod part_msdos
insmod ntfs
set root='hd0,msdos1'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  7A982BB7982B7135
else
  search --no-floppy --fs-uuid --set=root 7A982BB7982B7135
fi
parttool ${root} hidden-
chainloader +1
}
menuentry 'Windows 7 (loader) (on /dev/sda2)' --class windows --class os $menuentry_id_option 'osprober-chain-52B83062B83046AF' {
insmod part_msdos
insmod ntfs
set root='hd0,msdos2'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2 --hint='hd0,msdos2'  52B83062B83046AF
else
  search --no-floppy --fs-uuid --set=root 52B83062B83046AF
fi
parttool ${root} hidden-
chainloader +1
}
set timeout_style=menu
if [ "${timeout}" = 0 ]; then
  set timeout=10
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: toffifee am 27.10.2014, 22:02:53
Willkommen!
Merkwürdige Sache! Da du umgestöpselt hast, prüfe mal bitte, ob deine HD am selben Kanal hängt wie vorher. Nur so eine Idee.

Off-Topic:
Bitte lange Terminal Ausgaben in einen Codeblock setzen: https://www.linuxmintusers.de/index.php?topic=13961.msg151695#msg151695 (https://www.linuxmintusers.de/index.php?topic=13961.msg151695#msg151695)
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 27.10.2014, 22:05:38
des mit dem Kanal hab ich auch schon vermutet, leider weis ich nicht mehr wo er vor Samstag dran war :o

Hab aber seit heute Früh schon mindestens 10 mal komplett win und mint neu installiert, und immer wieder das gleiche, ohne abzustecken.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: toffifee am 27.10.2014, 22:07:56
Dann kannst du das 11. Mal wohl sparen! ;D
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 27.10.2014, 22:08:30
 :-*
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 28.10.2014, 12:33:38
Hab jetzt ne neue Platte dran, und wieder des gleiche.  :o

Hat jemand nen tip für mich?
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: doctourette am 28.10.2014, 13:46:37
BIOS/UEFI mal zurücksetzen?
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 28.10.2014, 14:14:37
BIOS hab ich Scho zurückgesetzt und Uefi is aus, war auch Scho immer aus
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: Hubsi_Gberg am 28.10.2014, 14:43:25
Hallo hugohoelzer

Möglicherweise hast du mit deinem Hin und Her deine Partitionstabelle gehörig durcheinander gebracht. Es können Reste von irgendwelchen Vorinstallationen übrig geblieben sein, die dir jetzt das Leben schwer machen. Bei WIN 7 und WIN 8 ist so was schon mal der Fall.

Wir hatten mal ein ähnliches Thema. Siehe hier:
https://www.linuxmintusers.de/index.php?topic=22108.msg288621#msg288621 (https://www.linuxmintusers.de/index.php?topic=22108.msg288621#msg288621)
Vielleicht musst du deiner Platte auch wieder eine jungfräuliche MSDOS-Tabelle beibringen.

Bedeutet allerdings, dass du deine Platte komplett platt machen und bei den "Wurzeln" wieder anfangen musst. Sofern du deinen Fehler nicht irgendwie einkreisen und bestimmen kannst, bleibt dir wohl nur dieser Weg. Falls du das machen solltest, dann "höre " auf den Rat im verlinkten Text und gebe deiner WIN-Partition gleich von Beginn an eine NTFS-Tabelle mit. Und das Boot-Flag nicht vergessen.


Noch ein weiterer Gedanke:
Ich gehe mal davon aus, dass du GRUB mit
sudo update-grubimmer aktuell gehalten hast, wenn es notwendig wurde. Denn sonst hatte GRUB womöglich immer eine falsche UUID der WIN-Partition und startete wieder durch, weil diese nicht gefunden wurde.

Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 28.10.2014, 14:52:15
Hi,
Den update-grub hab ich immer ausgeführt :o

Ich Versuch dann mal die Platte neu zu formatieren und ne medos Tabelle anzulegen.
Die ntfs für windows, ist da die kleine normalerweise 100mb gemeint, oder die normale Win Partition.
Ich Arbeit im BIOS Mode.

Danke
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: Hein98 am 28.10.2014, 15:10:38
Ich hatte hier gerade mal ein paar Zeitungsausschnitte gepostet, event. ist was hilfreiches dabei. Viel Glück!

https://www.linuxmintusers.de/index.php?topic=13168.msg299395#msg299395 (https://www.linuxmintusers.de/index.php?topic=13168.msg299395#msg299395)
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: Hubsi_Gberg am 28.10.2014, 15:27:24
Die ntfs für windows, ist da die kleine normalerweise 100mb gemeint, oder die normale Win Partition.
Ich Arbeit im BIOS Mode.


Ich meinte, wenn du Win wieder installierst, dann mache auf deiner HDD mit GParted eine Startpartition, der du eine NTFS-Tabelle mitgibst. Die Größe - denke ich - sollte wenigstens 60 GB sein. Wenn du viele Programme mit WIN 7 nutzen solltest, dann auf jeden Fall noch größer. Du musst auch bedenken, dass WIN 7 zeit seines Lebens Updates erhält, die eventuell zusätzlich Platz brauchen. 100 GB sind wohl ein guter Wert.

Den Rest der Platte lässt du unberührt, also mit der frisch erstellten MSDOS-Tabelle.

In die Startpartition installierst du - zu allererst - dein WIN 7.

Danach dein Linux Mint wieder installieren - entsprechend dieser guten Anleitung:
http://wiki.ubuntu-forum.de/index.php?title=Benutzer:Klaus_P (http://wiki.ubuntu-forum.de/index.php?title=Benutzer:Klaus_P)

Danach sollten deine beiden Systeme wieder miteinander können.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 28.10.2014, 17:46:59
Hi,

Folgendes durchgeführt.

Mint von Stick geladen

Mit gparted platte platt gemacht und neue msdos-Tabelle drauf
Ebenfalls ne 60 Gb ntfs für Win

Dann Win frisch installiert

Danach wieder mint von Stick gestartet und installiert.

Der selbe Mist wieder. Nach grub-update immernoch.

Sobald ich Win auswähle, startet der Rechner neu :o

Boot-repair bringt auch nix.

Danach start von Win cd
Reparatur Option
Eingabeaufforderung
Bootrec /fixmbr
Bootrec /fixboot

Der Rechner bootet windows, ohne grub anzuzeigen

Danach mittels Super grub 2 mint gestartet

Nach Anleitung grub komplett Deinstalliert und wieder drauf
Grub auf sda installiert

Grub wieder da, aber windows bootet nicht.

Die uuid und sda1 aus der grub.cfg sind richtig

Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: aexe am 28.10.2014, 18:28:21
Scheint so, als ob da immer der gleiche Fehler passiert.
Ohne mehr Information über den Installationsvorgang wird es aber schwierig sein, den zu finden.
Was zeigt denn vom Mint aus : sudo os-prober
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 28.10.2014, 18:30:51
Ok, was soll ich genau sagen?
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: Hubsi_Gberg am 28.10.2014, 18:38:11
Einfach den Code von aexe ins Terminal eingeben und das Ergebnis hier anzeigen.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 28.10.2014, 18:44:22
sudo os-prober
  No volume groups found
/dev/sda1:Windows 7 (loader):Windows:chain
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: Hubsi_Gberg am 28.10.2014, 18:54:15
Ist das jetzt der Zustand, nachdem du den MBR der Startpartition wieder mithilfe der WIN-CD hergestellt hast?

Es fehlt nämlich eine Anzeige zu deinem Mint.

Zeige doch bitte mal von Mint aus, wo genau dein GRUB steckt, sofern es vorhanden ist:
sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: helli am 28.10.2014, 18:59:32
Das laufende System wird bei mir durch
sudo os-proberauch nicht angezeigt.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 28.10.2014, 19:06:22
Das ist jetzt folgender Zustand:

Alles neu installiert. Danach mit win-cd gestartet, mbr repariert. Danach hat win gebootet.
Anschließend mit boot-repair von stick gestartet, grub repariert.

Das Grub menü kommt, aber win startet nicht

sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""

/dev/sda: GRUB 2 v1.99
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 00
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdb: Kein GRUB 00
/dev/sdb1: Kein GRUB 55aa
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 31c0
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: aexe am 28.10.2014, 19:29:46
Das ist bei mir auch so, daß der OS-Prober das laufende System nicht anzeigt.
Aber das Windows findet er ja.
Der Grub ist auch am richtigen Ort, nämlich auf sda.
 
Kopfkratz ...

Fällt mir nur noch ein, das irgendwas mit der Windows-Installation nicht hinhaut.
Da bin ich aber völlig ratlos.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 28.10.2014, 19:32:23
  :o

Wenn ich mit der Win cd starte, und den mbr neu schreibe, startet windows problemlos

Hab das jetzt auch gemacht. Windows startet, leider kommt kein grub.

Wenn ich jetzt mit Super grub 2 starte, und manuell linux mint starte, geht es. Super grub 2 findet den grub ja anschenend
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: Hubsi_Gberg am 28.10.2014, 20:17:00
Ich gehe mittlerweile auch davon aus, dass der Wurm bei WIN 7 zu suchen ist. Deshalb habe ich mal "rumgesucht".

Ich habe bei meiner Suche was gefunden. Allerdings kann ich mit dem Begriffen, die genannt werden, absolut nichts anfangen. Aber vielleicht ist hier ja jemand, der das "übersetzen" kann.

Jedenfalls hat es beim Themenersteller funktioniert - was genau das immer war. Siehe hier.
http://www.administrator.de/forum/nach-ubuntu-installation-bootet-windows-7-nicht-mehr-151775.html#comment-599169 (http://www.administrator.de/forum/nach-ubuntu-installation-bootet-windows-7-nicht-mehr-151775.html#comment-599169)
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: Hubsi_Gberg am 28.10.2014, 20:25:02
Und wenn in deinem Fall GRUB 2 der "Schuldige" ist?

Siehe mal hier:
http://blog.toadie.de/?p=884 (http://blog.toadie.de/?p=884)
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 28.10.2014, 20:56:30
Ich Versuch jetzt mal den grub 2 wegzuschmeißen

Feedback kommt :)
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 29.10.2014, 01:24:49
So, nach weiteren vergeblichen versuchen folgender Stand:

Alles wieder neu installiert. Weder mit Mint 13 noch Mint 17 geht es.

Habe Grub 2 deinstalliert und Grub installiert: Negativ

Mit drivemap rumgespielt laut dem anderen link: Negativ

folgender Stand:

Frische installation von Windows 7 und Linux Mint 13

sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: GRUB 2 v1.99
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdb: Kein GRUB 7c66
/dev/sdb1: Kein GRUB 31c0


os-prober
/dev/sda1:Windows 7 (loader):Windows:chain

fdisk -l

Disk /dev/sda: 128.0 GB, 128035676160 bytes
255 heads, 63 sectors/track, 15566 cylinders, total 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000662eb

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   123086847    61440000    7  HPFS/NTFS/exFAT
/dev/sda3       123088894   250068991    63490049    5  Extended
/dev/sda5       123088896   245991423    61451264   83  Linux
/dev/sda6       245993472   250068991     2037760   82  Linux swap / Solaris

cat /boot/grub/grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos5)'
  search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
  set locale_dir=($root)/boot/grub/locale
  set lang=de_DE
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
set menu_color_normal=white/black
set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
set gfxpayload="$1"
if [ "$1" = "keep" ]; then
set vt_handoff=vt.handoff=7
else
set vt_handoff=
fi
}
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry 'Linux Mint 13 Cinnamon 64-bit, 3.2.0-23-generic (/dev/sda5)' --class linuxmint --class gnu-linux --class gnu --class os {
recordfail
gfxmode $linux_gfx_mode
insmod gzio
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
linux /boot/vmlinuz-3.2.0-23-generic root=UUID=5bd5a53a-12da-4733-86df-e77beb510919 ro   quiet splash $vt_handoff
initrd /boot/initrd.img-3.2.0-23-generic
}
menuentry 'Linux Mint 13 Cinnamon 64-bit, 3.2.0-23-generic (/dev/sda5) -- recovery mode' --class linuxmint --class gnu-linux --class gnu --class os {
recordfail
insmod gzio
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
echo 'Loading Linux 3.2.0-23-generic ...'
linux /boot/vmlinuz-3.2.0-23-generic root=UUID=5bd5a53a-12da-4733-86df-e77beb510919 ro recovery nomodeset
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-3.2.0-23-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 5bd5a53a-12da-4733-86df-e77beb510919
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 7 (loader) (on /dev/sda1)" --class windows --class os {
insmod part_msdos
insmod ntfs
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set=root A26C34F46C34C4B7
chainloader +1
}
### END /etc/grub.d/30_os-prober ###






### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

Des kann doch alles nicht sein. Es hat ja alles für lange Zeit funktioniert.

Ich habe auch die alte Sicherung der Platte nochmal eingespielt, und dort Grub2 durch Grub ersetzt. Da ging genauso wenig.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: helli am 29.10.2014, 01:51:17
Ich kenne einen Fall, da musste nach der Installation von Mint13 mit der Win-DVD im Reparatur-Modus Bootrec /fixboot ausgeführt werden.
(Aber nicht Bootrec /fixmbr, sonst wäre der Grub ja wieder weg)
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 29.10.2014, 02:00:43
Ok, verusch ich mal
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: geobart am 29.10.2014, 02:16:17
Wenn das nicht geht, versuch den PLOP Bootmanager. http://www.plop.at/de/bootmanagers.html (http://www.plop.at/de/bootmanagers.html)
Also auch  bootrec /fixmbr und dann den PLOP installieren:  http://www.plop.at/de/bootmanager/mbrinstall.html (http://www.plop.at/de/bootmanager/mbrinstall.html)
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: helli am 29.10.2014, 02:19:33
Hinweis zu PLOP:
Zitat
Achtung Linux Users: Installieren Sie LILO oder GRUB nicht in den Master Boot Record (MBR) sondern in den Bootsektor Ihrer Bootpartition. Der Plop Bootmanager ist kein Linux Loader und benötigt daher LILO oder GRUB im Bootsektor um Linux zu starten! Siehe Linux Bootmanager.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: DocHifi am 29.10.2014, 10:24:41
Plop braucht man eigentlich überhaupt nicht installieren, das gibt es auch als Live Iso.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: helli am 29.10.2014, 10:33:36
Falls sich jedoch in diesem speziellen Fall Win über PLOP starten lässt, würde ich über eine Installation nachdenken, denn immer eine Live-CD im Laufwerk haben zu müssen ist auch nicht gerade wünschenswert.
Allerdings würde ich es auch erst mal mit der Live-CD versuchen.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: DocHifi am 29.10.2014, 10:35:30
Zum starten von Windows reicht die SuperGrubDisk2, oder Rescatux.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: aexe am 29.10.2014, 11:23:37
Trotzdem hat helli Recht, daß ein Starten des Systems mit Hilfe einer CD höchst umständlich ist und sicher nicht im Sinne der Grub-Erfinder.
Wenn es nicht anders geht, ist es natürlich gut, die Möglichkeit (also eine entsprechende CD) zu haben.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 29.10.2014, 11:28:11
Hi alle,

bis jetzt hab ich es mit keiner Methode geschafft.

Klar könnte ich den plop jetzt installieren, oder evtl mit super grub2 etc. starten.

Aber was mich wirklich nervt, ist, das es gegangen ist, und bei vielen anderen auch funktioniert.
Da kommt der Ehrgeiz durch :)

Ich kann es einfach nicht verstehen, warum?

Hab jetzt folgendes gemacht:

Auf der SSD habe ich win 7 installiert, und es startet wunderbar.
Auf nem Stick habe ich Mint 17 installiert (mit abgesteckter SSD). Läuft wunderbar.

Wenn ich im Bios dann auswähle: startet von SSD --> win läuft
                                                            startet von Stick --> mint läuft

Dann im Mint nen update-grub ausgeführt. Wenn ich jetzt vom Stick starte, kommt der Grub und zeigt mir auch win an.

ABER: Es startet nicht.

Jetzt hat der Grub nichts im MBR von der SSD liegen. Alles ist separiert.
Ich checks nimmer.

grub.cfg
### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows 7 (loader) (auf /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-A26C34F46C34C4B7' {
        insmod part_msdos
        insmod ntfs
        set root='hd0,msdos1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  A26C34F46C34C4B7
        else
          search --no-floppy --fs-uuid --set=root A26C34F46C34C4B7
        fi
        parttool ${root} hidden-
        chainloader +1
}
set timeout_style=menu
if [ "${timeout}" = 0 ]; then
  set timeout=10
fi
### END /etc/grub.d/30_os-prober ###

fdisk -l
Disk /dev/sda: 128.0 GB, 128035676160 bytes
255 Köpfe, 63 Sektoren/Spur, 15566 Zylinder, zusammen 250069680 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Festplattenidentifikation: 0xabc7a9dc

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          208894   250068991   124930049    f  W95 Erw. (LBA)
/dev/sda5          210944    94578687    47183872    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 16.0 GB, 16013852672 bytes
255 Köpfe, 63 Sektoren/Spur, 1946 Zylinder, zusammen 31277056 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Festplattenidentifikation: 0x000bb0f8

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sdb1   *        2048    27197439    13597696   83  Linux
/dev/sdb2        27199486    31275007     2037761    5  Erweiterte
/dev/sdb5        27199488    31275007     2037760   82  Linux Swap / Solaris

blkid

/dev/sda1: LABEL="System-reserviert" UUID="A26C34F46C34C4B7" TYPE="ntfs"
/dev/sda5: UUID="56E8D580E8D55EB5" TYPE="ntfs"
/dev/sdb1: UUID="b4f707b5-56b2-453d-954d-33953c7e3c71" TYPE="ext4"
/dev/sdb5: UUID="dde7a851-88d0-4001-9f27-4b78330b3d65" TYPE="swap"
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: helli am 29.10.2014, 12:03:15
Was man anders machen könnte:
sda1 so groß als ntfs anlegen, dass es für Win reicht.
in sda2, der Erweiterten erst mal sda5 als ext4 über den gesamten verfügbaren Speicher der Erweiterten anlegen

Wenn nun Win auf sda1 installiert wird, kann es nicht diese kleine Boot-Partition anlegen.
Auf dem Stick müsste dann noch mal update-grub ausgeführt werden.

Ob das zum Erfolg führt, kann ich allerdings nicht sagen.
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 29.10.2014, 12:04:47
Neuer Ansatz:

Hab jetzt die SSD und den Stick in nen Laptop rein.
Und siehe da, es funktioniert. Ich kann vom grub Menü auf dem Stick das windows Booten. :o

Was soll das jetzt?
Sollte es am MB liegen? Defekt?
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 29.10.2014, 12:48:06
Hi,

ich habs geschafft. Nach der Aktion mit dem Laptop hab ich mir das Bios nochmal vorgenommen.

Hab es wie schon geschrieben schon öfter auf default zurückgesetzt, und mit einigen parametern rum gespielt. Alles nichts genützt.
Jetzt hab ich mit allen rumgespielt, was da war, und sie da, ich hab den Eintrag gefunden, der es war.
Warum dieser? Was hat der damit zu tun? Da wär ich beim normalen Lesen niemals drauf gekommen?
Könnte mir vlt einer der Experten mir das mal erklären, was der damit zu tun hat.
Es ist der weiß markierte im Anhang.

Vielen Dank für euer Hilfe
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: DocHifi am 29.10.2014, 12:51:47
Guggst du hier:
https://de.wikipedia.org/wiki/Trusted_Execution_Technology
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 29.10.2014, 13:02:08
Ok, und was hat des mit dem Problem zu tun?
Ich verstehe ned
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: aexe am 29.10.2014, 13:48:34
Zitat
Das Bundesamt für Sicherheit in der Informationstechnik (BSI) warnt vor dem Einsatz von TPM. Microsoft könne festlegen, welche Programme noch auf dem Computer installiert werden können, bereits eingerichtete Programme nachträglich unbrauchbar machen und Geheimdiensten helfen, fremde Computer zu kontrollieren. Die zuständigen Fachleute im Bundeswirtschaftsministerium, in der Bundesverwaltung und beim BSI warnen denn auch unmissverständlich vor dem Einsatz von Trusted Computing der neuen Generation in deutschen Behörden. "Durch den Verlust der vollen Oberhoheit über Informationstechnik" seien "die Sicherheitsziele 'Vertraulichkeit' und 'Integrität' nicht mehr gewährleistet." (Zeit-Online vom 20. August 2013, "Bundesregierung warnt vor Windows 8")
https://de.wikipedia.org/wiki/Trusted_Computing
Da steht auch noch mehr.
TPM : https://de.wikipedia.org/wiki/Trusted_Platform_Module
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: geobart am 29.10.2014, 14:06:42
Muss mal raus:

Es kotzt mich an, was dieses Wintel-Gesindel immer wieder anstellt!!!!!!!!!
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: gas103 am 29.10.2014, 14:27:03
Tja, wie jede Technik. Kann Fluch und Segen sein, das ist immer sehr subjektiv.
http://blog.techflaws.org/tc-faq-de/#2 (http://blog.techflaws.org/tc-faq-de/#2)
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: Hubsi_Gberg am 29.10.2014, 14:47:23
@hugohoelzer

Freut mich, dass deine Systeme wieder auf Zack sind. :)

Letztendlich hast du dir selbst geholfen.  8)
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 29.10.2014, 15:01:03
Trotzdem ein große Danke an alle hier
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: doctourette am 29.10.2014, 17:12:54
Aha, also doch.  ;)
Ist dieser Dreck per default eingeschaltet?
Titel: Re: Mint 17 / Windows 7 grub/start probleme
Beitrag von: hugohoelzer am 29.10.2014, 20:41:23
Ne, eben nicht, deshalb hat's ja nach dem zurückstellen auf Default ned funktioniert.
Warum es mal eingeschalten war, weis ich ned :o