Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
29.07.2021, 10:59:58

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25789
  • Letzte: Trobilo3
Statistiken
  • Beiträge insgesamt: 747354
  • Themen insgesamt: 60112
  • Heute online: 349
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [erledigt] Linux Maus und Keyboard hängen , keine Funktion , erst nach rein raus des USB ok  (Gelesen 1167 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

....$PATH ?  den 755 mod haben ? das verstehe ich nicht , sagt mir noch gar nichts  ::)
Was ist ein shebang ?
Ja also shebang ist umgangssprachlich für die Zeichenkombination #! gefolgt einer Pfadangabe.
Das kennst du ja schon, nur die Bezeichnung hast du scheinbar noch nicht gehört.
Das mit dem PATH war aber meine Fehler, du hast ja schon einen absoluten Pfad in der crontab eingegeben. Insofern spielt das jetzt für dich eigentlich keine Rolle.
Hättest du da nur
* * * * * Mausstart.sheingegeben, dann müsste Mausstart.sh in einem $PATH dir sein.
mit dem absoluten Pfad wie bei dir ist es aber wie gesagt egal.
Den modus des Skriptes könntest du aber mal überprüfen mit
llwenn du im $HOME dir bist, und gegebenenfalls mit
sudo chmod 755 DEINSCRIPTeditieren.
Eventuell war das dein Problem.
Ansonsten auf pinky hören, der scheint sein Beispiel ja überprüft zu haben dann wird das wohl stimmen :)

Moin,
du willst wahrscheinlich das, dass System einfach durchstartet. Oder?
Zeig doch bitte mal:
cat /etc/default/grubFunktioniert denn jetzt die Maus?
Gruß
Wolfgang
« Letzte Änderung: 12.06.2021, 19:18:54 von Wolfgang58 »

der scheint sein Beispiel ja überprüft zu haben
Das scheint mir grundsätzlich eine gute Idee zu sein. ;)

Wenn Du die Eingabe-Taste drückst, sollte der ausgewählte Eintrag im Grub-Menü sofort umgesetzt werden.

Ja, trotzdem für meine Eltern irreführend...  ;) ambesten wieder weg das Ding

Maus, bisher gut.....

Hier der Grub
home@home-desktop:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet usbcore.autosuspend=-1"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_TIMEOUT=0
home@home-desktop:~$
« Letzte Änderung: 12.06.2021, 19:31:17 von RainerKol »

FranzStahl

  • Gast

Soll ich nun das DISPLAY=:0 davor setzen und dann könnte es gehen ?
Ich hab’s gerade ausprobiert mit einer sleep-Zeit von 30 s. Funktioniert einwandfrei. Schöne Sache, da kann man Leute damit ärgern, wenn sie einen für ein paar Minuten an den Rechner lassen  ;D

Guten Morgen,
also deine >grub< sieht eigentlich gut aus, warum >GRUB_TIMEOUT=0< unten steht und nicht im oberen Block weiß ich auch nicht. Hast du diesen Eintrag gemacht?
Im Prinzip sollte das so aussehen:
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet usbcore.autosuspend=-1"
GRUB_CMDLINE_LINUX=""
Der Rest ist Kommentar oder mit >#< auskommentiert.
Bitte überprüfe deine >grub< schau das es so aussieht.
Solltest du bei booten das >Mintlogo< vermissen, dann musst die Zeile so aussehen:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"Danach bitte:
sudo update-grub
Sollte das so nicht funktionieren und das >Grubmenü< wird weiterhin angezeigt dann führe bitte folgendes aus:
echo "set timeout_style=hidden                                               
set timeout=0" | sudo tee /boot/grub/custom.cfg
Gruß
Wolfgang
« Letzte Änderung: 13.06.2021, 07:20:42 von Wolfgang58 »

GRUB_TIMEOUT_STYLE=hidden
das widerspricht aber
startet Mint nun immer mit den GNU Grub Menü, wo der Timer abläuft und dann erst Mint weiterbootet.
Genau das sollte mit dem oben zitierten Eintrag nicht passieren.
Zitat
hidden    Es wird kein GRUB-Menü angezeigt und die mit GRUB_TIMEOUT eingestellte Zeit gewartet, bis das System nach der voreingestellten Zeit startet. Durch kurzzeitiges Drücken von Esc innerhalb dieses Zeitfensters kann das GRUB-Menü angezeigt und eine Auswahl vorgenommen werden.

GRUB_HIDDEN_TIMEOUT_QUIET=true
ist dann überflüssig bzw. falsch, weil veraltet.
siehe auch https://wiki.ubuntuusers.de/GRUB_2/Konfiguration/#Die-Textdatei-etc-default-grub
Bevor das Ganze noch konfuser wird als es eh schon ist.

edit
Die Datei /etc/default/grub kann ganz bequem in einem Editor mit Rootrechten bearbeitet werden. Nach Änderungen und Speichern der Datei ist ein sudo update-grub notwendig, damit diese beim nächsten Start wirksam werden.
« Letzte Änderung: 13.06.2021, 07:54:27 von aexe »

Genau das sollte mit dem oben zitierten Eintrag nicht passieren.
Moin,
eben das passiert aber und gut >GRUB_HIDDEN_TIMEOUT_QUIET=true< sollte raus. Das Problem das nun das >Grubmenü< angezeigt wird ist entstanden, als  >usbcore.autosuspend=-1< hinzugefügt wurde und dies hat mit dem Menüproblem nichts zu tun.
Das nun das Menü angezeigt wird, liegt daran das ein Grub-Script beim update ausgeführt wurde welches noch nie ausgeführt wurde (Warum auch immer!) in diesem Script wird ein >Timeout< Standardmäßig festgelegt und läßt sich auch nicht durch die >grub< beeinflussen. Nun wird aber beim update-grub auch eine >custum.cfg< in /boot/grub/ ausgewertet und diese sorgt dann dafür das, dass Menü nicht angezeigt wir. Das Problem besteht übrigens erst seit Ubuntu 20.04.

@aexe:
Bevor das Ganze noch konfuser wird als es eh schon ist.
Was meinst du damit? Was ist konfus?
Wenn du den Thread meinst, gebe ich dir recht... ;)
Gruß
Wolfgang
« Letzte Änderung: 14.06.2021, 05:15:15 von Wolfgang58 »

Off-Topic:
Wenn du den Thread meinst
Ja, so ist es. Hab ja selbst schon genug OT dazu geschrieben, #2 #17. Hilft nur nix.
Und von der Eingangsfrage sind wir inzwischen weit weg.
« Letzte Änderung: 13.06.2021, 09:12:51 von aexe »

Ja, trotzdem für meine Eltern irreführend...  ;) ambesten wieder weg das Ding

Maus, bisher gut.....
Mich würde zuerst einmal interessieren, ob das Mouse und Keyboard Problem mit deaktiviertem autosuspend dauerhaft behoben ist? Minütlich über cron die Maus zu reaktivieren kann ja nicht die Lösung sein.

HI, ja die Maus ist bisher gut, habe ich oben bei "18" schon geschrieben ....
Ich werde eure HInweise mal abarbeiten.
Vielen Dank dafür. Na klar interressiert mich immer noch warum der Contab nicht funktioniert, aber das mache
ich dann eine neuen Beitrag nur auf Contab bezogen auf.

Gruss und Danke
Rainer

Hallo,
der Tip mit
echo "set timeout_style=hidden                                               
set timeout=0" | sudo tee /boot/grub/custom.cfg

hat alles wieder ins Lot gebracht. Danke euch.

Auch die Maus macht keine Zicken mehr, zumindest bis jetzt. Es ist durch den Grub Eintrag zu der Maus Freeze Thematik anscheined Abhilfe geschaffen.
Supi, Danke.

Aber, meine Eltern haben wieder was neues und nun wird es glaube ich "kompliziert".... neues Thema dann.
Ich schließe dieses nun.