Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
26.07.2021, 14:49:23

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25781
  • Letzte: Martina1
Statistiken
  • Beiträge insgesamt: 746877
  • Themen insgesamt: 60069
  • Heute online: 391
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr  (Gelesen 1175 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ich habe Linux Mint 19.2 Cinnamon am laufen.

Meine Anwendungsverwaltung lässt sich zwar noch öffnen aber wenn ich auf eine Anwendung klicke, werden keine weiteren Informationen geladen und ich kann sie auch nicht installieren. (siehe Bild im Anhang)

Was kann ich da machen?

Hallo und willkommen bei LMU!

Starte doch die Anwendungsverwaltung mal mit folgendem Befehl aus dem Terminal und kopiere die Ausgabe hier in einen Codeblock:mintinstallWie du einen Codeblock erstellst, steht oben in der Hilfe: https://www.linuxmintusers.de/index.php?action=wiki;page=Editor_Maske_f%C3%BCr_eigenen_Beitrag

Hi :)
läuft die paket auffrischung in
synaptic oder aktualisierungsverwaltung durch

oder ausbabe von
sudo apt-get updatebringen (ausgaben immer codeblock)

Hey, Danke für die Antworten!
(Ich bin in der Zwischenzeit umgezogen darum hat es bei mir jetzt etwas länger gedauert)

Also hier sind die Ergebnisse von:

mintinstall
MintInstall: Detected system architecture: 'x86_64'
Installer: User pkgcache is most recent, using it.

MintInstall: Deleting old screenshots

** (mintinstall.py:17346): WARNING **: 12:13:51.234: Found icon of unknown type, skipping it: unknown

** (mintinstall.py:17346): WARNING **: 12:13:51.234: Found icon of unknown type, skipping it: unknown
MintInstall: Downloaded new reviews
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1802, in on_flowbox_child_activated
    self.show_package(child.get_child().pkginfo, previous_page)
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1994, in show_package
    self.builder.get_object("application_icon").set_from_pixbuf(self.get_application_icon(pkginfo, 64))
AttributeError: 'NoneType' object has no attribute 'set_from_pixbuf'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 154, in apport_excepthook
    os.O_WRONLY | os.O_CREAT | os.O_EXCL, 0o640), 'wb') as f:
FileNotFoundError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/var/crash/_usr_lib_linuxmint_mintinstall_mintinstall.py.1000.crash'

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1802, in on_flowbox_child_activated
    self.show_package(child.get_child().pkginfo, previous_page)
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1994, in show_package
    self.builder.get_object("application_icon").set_from_pixbuf(self.get_application_icon(pkginfo, 64))
AttributeError: 'NoneType' object has no attribute 'set_from_pixbuf'
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1802, in on_flowbox_child_activated
    self.show_package(child.get_child().pkginfo, previous_page)
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1994, in show_package
    self.builder.get_object("application_icon").set_from_pixbuf(self.get_application_icon(pkginfo, 64))
AttributeError: 'NoneType' object has no attribute 'set_from_pixbuf'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 154, in apport_excepthook
    os.O_WRONLY | os.O_CREAT | os.O_EXCL, 0o640), 'wb') as f:
FileNotFoundError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/var/crash/_usr_lib_linuxmint_mintinstall_mintinstall.py.1000.crash'

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1802, in on_flowbox_child_activated
    self.show_package(child.get_child().pkginfo, previous_page)
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1994, in show_package
    self.builder.get_object("application_icon").set_from_pixbuf(self.get_application_icon(pkginfo, 64))
AttributeError: 'NoneType' object has no attribute 'set_from_pixbuf'


ehtron: 
Ich aktuallisiere mein Sysem regenläßig mit der Aktualisierungsverwaltung(!), das läuft so weit problemlos.


« Letzte Änderung: 10.06.2021, 23:05:46 von theAkrobat »

Meinst du wirklich die Anwendungsverwaltung?
Wäre mir neu dass man über die Anwendungsverwaltung Programme auch updaten kann.
Oder meinst du die Aktualisierungsverwaltung?
Das sind immerhin zwei verschiedene Dinge.

Die Anwendungsverwaltung und die Aktualisierungsverwaltung sind unterschiedliche Programme.
Die Fehlermeldungen in der Ausgabe von mintinstall (Anwendungsverwaltung) dürften meines Wissen nach nicht auftauchen. Hast du irgendwelche Systemdateien entfernt oder verändert?
Bring bitte die gewünschte Ausgabe von sudo apt-get update

@ Kreuz Elf: Danke für den Hinweis! Ich meinte die Aktualisierungsverwaltung und habe es in dem Post korrigiert.

Das ist das Ergebnis von:
sudo apt-get update
Ign:1 http://mirror.bauhuette.fh-aachen.de/linuxmint tina InRelease
OK:3 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu bionic InRelease   
Holen:2 http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease [1.559 B]
OK:4 http://mirror.bauhuette.fh-aachen.de/linuxmint tina Release               
OK:5 http://ftp.halifax.rwth-aachen.de/ubuntu bionic InRelease                 
OK:6 http://ftp.halifax.rwth-aachen.de/ubuntu bionic-updates InRelease         
OK:7 http://ftp.halifax.rwth-aachen.de/ubuntu bionic-backports InRelease       
OK:8 https://updates.signal.org/desktop/apt xenial InRelease                   
OK:9 http://archive.canonical.com/ubuntu bionic InRelease                     
OK:10 https://repo.skype.com/deb stable InRelease                             
OK:11 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease               
OK:12 http://security.ubuntu.com/ubuntu bionic-security InRelease             
Fehl:2 http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease
  Die folgenden Signaturen waren ungültig: EXPKEYSIG DFA175A75104960E Emulators OBS Project <Emulators@build.opensuse.org>
OK:14 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease 
Es wurden 1.559 B in 2 s geholt (753 B/s).
Paketlisten werden gelesen... Fertig
W: Während der Überprüfung der Signatur trat ein Fehler auf. Das Depot wurde nicht aktualisiert und die vorherigen Indexdateien werden verwendet. GPG-Fehler: http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease: Die folgenden Signaturen waren ungültig: EXPKEYSIG DFA175A75104960E Emulators OBS Project <Emulators@build.opensuse.org>
W: Fehlschlag beim Holen von http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/./InRelease Die folgenden Signaturen waren ungültig: EXPKEYSIG DFA175A75104960E Emulators OBS Project <Emulators@build.opensuse.org>
W: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.

Aha also ne fehlende Paketquelle macht normalerweise nichts kaputt in den sonstigen Programmen.
Dass mit deiner Anwendungs / Aktualisierungsverwaltung was nicht stimmt wird wohl andere Gründe haben.
Sonst hätte ich dieses Problem auch schon mal gehabt.
Aber wenn du updates von Kommandozeile aus machen kannst kannst du ja versuchen eben diese Anwendungs / Aktualisierungsverwaltung zu updaten / neu zu installieren.
Ich denke das hatten die Vorredner wohl auch im Sinn.
« Letzte Änderung: 11.06.2021, 00:01:10 von Kreuz Elf »

Hallo,
Falls deinem Problem vor Themeneröffnung kritische Aktionen wie Hinzufügen von PPA etc. vorausgingen wäre es einen Versuch wert das PPA zu deaktivieren und erneut zu aktualisieren. Falls der Fehler dann immer noch besteht mit Timeshift oder einem anderen vorhandenen Backup zurück zu setzen.

Nachtrag: PPA's und zusätzliche Paketquellen lassen sich über die Akt.-Verwaltung > Bearbeiten > Paketquellen ... De- / Aktivieren
« Letzte Änderung: 11.06.2021, 15:26:27 von kuehhe1 »

Ich meinte die Aktualisierungsverwaltung und habe es in dem Post korrigiert.
Nein, es ist die Anwendungsverwaltung (= mintinstall).
Mal bitte dem Vorschlag von @kuehhe1 folgen. Alle PPAs und Zusätzliche Paketquellen deaktivieren. Dann mal bitte:
apt clean
apt update
Dann nochmal die Anwendungsverwaltung öffnen und Feedback ob OK.

Ich habe die PPAs und auch die Zusätzlichen Paketquellen deaktiviert und dann:

apt clean
apt update

Ausgeführt, aber das Problem bei der Anwendungsverwaltung ist noch immer unverändert.

Soll ich die PPAs und die Zusätzlichen Paketquellen wieder aktivieren?


Gebt mir auch gerne mal Feedback wie das für euch ist, dass ich so lange brauche um zu antworten. Ich habe noch bis August einen recht unsteten Alltag und daher gerade noch nicht so beständig die Ruhe, um verlässlich und schnell zu antworten.
Ich weiß nicht ob das hier jemanden irritiert oder ob das der ungeschriebenen Forums Etikette entspricht.
Danke das ihr euch die Zeit nehmt und mit meinem Thema auseinander setzt! :) 

Hi :)
solange der fehler noch besteht, ppa und zusätzliche deaktiviert lassen.

gehe mal auf einen anderen spiegelserver oder auf die standard server.

Ich habe die Spiegelserver gewechselt aber es hat sich nichts getan.

FranzStahl

  • Gast
Mal so in’s Blaue:
sudo dpkg --configure -asudo apt-get install -fsudo apt-get update

Hi :)
und bringe die jeweiligen ausgaben bitte als codeblock (befehl mit kopieren)