Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
29.07.2021, 10:53:54

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25789
  • Letzte: Trobilo3
Statistiken
  • Beiträge insgesamt: 747354
  • Themen insgesamt: 60112
  • Heute online: 349
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Virtual Box funktioniert plötzlich nicht mehr  (Gelesen 1109 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Virtual Box funktioniert plötzlich nicht mehr
« am: 04.06.2021, 18:48:32 »
Servus die Runde,
jetzt hatte ich Windows 10 / 64bit so schön in der VirtualBox. Lief prima, bis seit vorgestern. Kein erkennbarer Grund, keine Updates und der Bildschirm in VB bleibt schwarz. Es gibt irgendwelche Aktivitäten, die Symbole in der VB-Leiste zeigen solche bei den Laufwerken, auch der Cursor mit dem "Warten"- Kreis blinkt ab und zu auf. Gibt es eine Lösung?
Falls es von Bedeutung sein könnte: das Problem trat auf, nachdem ich Linux mit aktiver VB länger im Bereitschaftsmodus hatte.
Das heutige Linux- Kernel- Update hat an der Situation (wie zu vermuten war) nichts geändert.
Mint 20.1 Cinnamon, Vers. 4.8.6 - Virtual Box 6.1.16_Ubuntu r 140961
« Letzte Änderung: 17.06.2021, 21:54:45 von GeorgH »

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #1 am: 04.06.2021, 18:55:24 »
Hast du die VM immer runtergefahren oder den Zustand gespeichert?

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #2 am: 04.06.2021, 19:16:38 »
Im Normalfall habe ich Win in der VB heruntergefahren und dann die VB beendet. Den Zustand gespeichert habe ich noch nie, leider habe ich auch erst jetzt die Option eines Sicherungspunktes bemerkt. War davor noch zu beschäftigt, die Sache zum Laufen zu bringen.

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #3 am: 04.06.2021, 21:47:07 »
Ich hatte genau das Selbe nach einem Windows (Feature) Update. Half am Ende nur letzten Sicherungspunkt aktivieren.
Jetzt ziehe ich die neuen Windows Versionen immer mit dem Media Creation Tool und installiere dann.

Gruß
Whitie

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #4 am: 05.06.2021, 09:32:03 »
Nun, genau solche Updates waren mit ein Grund, warum ich Win in VB laufen lassen will. Da habe ich ihm nämlich das Netzwerk gekappt  ;D

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #5 am: 06.06.2021, 15:23:38 »
Hi :)
maschine mal zurückgesetzt (gekillt?)

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #6 am: 06.06.2021, 15:36:04 »
Hi,
VB oder Linux gesamt? Kam aber bei beiden erinnungsgemäß nicht vor. VB erst, nachdem der Bildschirm schwarz blieb. Da benutzte ich "Ausschalten per ACPI". Zurücksetzen habe ich auch schon probiert, hat nichts geändert.
Aber, es gibt aktuelle Neuigkeiten. Ich habe Win10 in VB (also das, worum es hier geht) heute mit aktiviertem Netzwerk gestartet. Der Bildschirm ist zwar nach wie vor schwarz, es gab aber jede Menge Aktivität. Die Systemüberwachung zeigt eine durchgehend erhöhte Prozessoraktivität und auch im Netzwerk ist ständig - wenngleich auf niedrigem Level - was los. Zwischendurch ist mir aber jetzt auch Linux komplett eingefroren, da nutzte nur noch der lange Druck auf den Netzschalter.
Noch etwas hat mich verblüfft: ich habe im Erkunden, was denn da alles bei VB existiert, den Punkt "Maschine / Dateimanager..." angeklickt. Das war das Ergebnis: (siehe Bild)

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #7 am: 06.06.2021, 15:50:47 »
Hi :)
warum zeigst du das verzeichnis deines host systems?
dürfte nix mit dem guest zu tun haben.

hört sich an, als wenn der guest startet aber kein bild erzeugt wird.
aber ein fenster wird aufgebaut? 
passiert was im vollbild?  hosttaste F


Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #8 am: 06.06.2021, 16:17:33 »
Hi,
nun, weil da eben steht, daß kein Gastsystem vorhanden wäre!
Ja, alles scheint normal zu starten bzw. auch zu laufen, nur dort, wo die Windows- Oberfläche sein sollte, ist es nur Schwarz. Die Umschaltung hat diesbezüglich nichts verändert.
Inzwischen habe ich auch in VB direkt den Punkt "Log" genauer angesehen, soweit mein Verständnis der Aufzeichnungen reicht, scheint Windows tatsächlich zu laufen, nur das mit dem Bild klappt aus irgendeinem Grund nicht. Ich habe hier einmal die meiner Meinung nach letzten Meldungen von diesem Start kopiert:
00:11:10.601882 AHCI#0: Port 0 reset
00:11:10.603249 VD#0: Cancelling all active requests
00:26:42.196959 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=00007f4bfc000000 w=1920 h=1007 bpp=32 cbLine=0x1E00 flags=0xD origin=0,0
00:26:44.445243 GUI: UIFrameBufferPrivate::performResize: Size=1920x1007, Using fallback buffer since no source bitmap is provided

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #9 am: 13.06.2021, 12:31:15 »
Zu den fehlenden Sitzungen:
Vielleicht wird hier nur nicht der Ordner gefunden, in welchem die *.vbox- bzw. *.vdi-Dateien liegen.

Zum schwarzen Bildschirm:
Wenn das Gast-System nicht gerade im Vollbild läuft, zeigt Virtual Box im Fenster an, ob das Gast-System gestartet wurde.
In der Virtual Box-Programm-Oberfläche sollte es ebenfalls angezeigt werden.
Als möglichen Grund für den schwarzen Bildschirm würde ich eine Änderung (Update usw.) im Gast-System (also in Win 10) mit in Betracht ziehen. Hier hat es bei Updates in den letzten Monaten immer mal wieder Probleme in verschiedenen Zusammenhängen gegeben,
die sich bei Win 10 als direkt laufendes System (also nicht in Virtual Box) gezeigt haben.
Die können unter Win 10 in Virtual Box dann auch auftreten und den nächsten Start von Win 10 stören oder verhindern.

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #10 am: 14.06.2021, 09:51:23 »
Danke für diesen Hinweis. Nein, Update kommt nicht in Frage. Hätte ich erstens bemerkt, und zweitens (siehe #4) hätte Windows auch keine Möglichkeit dazu gehabt. Hatte bislang noch keine Zeit, mich um das Thema weiter zu kümmern.

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #11 am: 14.06.2021, 12:59:58 »
So, ich habe jetzt einen neuen Anlauf unternommen. Ich wollte ausprobieren, ob es möglich ist, Windows von der Installations- DVD her zu reparieren. Leider kommt immer die Meldung, daß auf das Boot- Laufwerk (ja, ich habe F12 / Laufwerk auswählen gemacht) nicht zugegriffen werden kann. Da ich mit den verschiedenen Optionen noch nicht vertraut bin, bin ich mir jetzt unklar, warum. An sich wäre die DVD bootfähig, ich habe das aktuelle System von der DVD aus erstellt. Habe ich bei den Einstellungen etwas übersehen? Ich habe einmal die aktuelle Konfiguration abgebildet.

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #12 am: 15.06.2021, 14:31:47 »
Hi :)
wähle unter massenspeicher > ide controller per cd symbol dein win$ boot iso aus.


Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #13 am: 15.06.2021, 17:20:37 »
Lösung ist wahrscheinlich ganz einfach ..... Du musst den vbox DISPLAY ABSICHTLICH falsch setzen (also trotz Fehlermeldung so speichern)... Grund: Kann nix mit VBSVgX dingbums anfangen..... Probier s mal hat bei mir immer geholfen, inseb. nach Update ....nicht nur unter Windows

PS: SCHLAGE vor - Stelle Deine VMs um auf QEMU/KVM ist schneller, leichtlaefuiger, TRIM geht, und opensource (anders als der extp Dreck vom ORACLE). Deine VM kannste problemlos soweit meine Erfahrung nach QEMU format konvertieren...

Re: Virtual Box funktioniert plötzlich nicht mehr
« Antwort #14 am: 15.06.2021, 17:32:27 »
Hi :)
wähle unter massenspeicher > ide controller per cd symbol dein win$ boot iso aus.
an welchem controller das hängt, spielt keine Rolle
~$ vboxmanage showvminfo dualLM
...
Storage Controller Bootable (0):        on
SATA (0, 0): /home/lm-m-csm-gpt/vm/dualLM.vdi (UUID: b35ed962-17bd-40c7-9db6-fe67529c5c6f)
SATA (1, 0): /home/lm-m-csm-gpt/vm/LM-X.vdi (UUID: e00d87c5-c880-41b0-864c-b4c320682930)
SATA (2, 0): /home/lm-m-csm-gpt/vm/LM-Mate-GPT-CSM.vdi (UUID: 5a72f586-00e6-438e-9f0b-d5eafc22606f)
SATA (3, 0): /home/lm-m-csm-gpt/vm/2-esp.vdi (UUID: 84f2db59-601f-4029-9a3a-5174a3353d5c)
SATA (4, 0): /home/lm-m-csm-gpt/vm/garuda.vdi (UUID: 98e4f41b-f18d-467f-be86-66e7275c86af)
SATA (5, 0): /home/lm-m-csm-gpt/vm/win1.vdi (UUID: 41455d0b-d13a-4468-829d-f62fff39a06a)
SATA (6, 0): /media/lm-m-csm-gpt/iso/Win/Win10_20H2_v2_German_x64.iso (UUID: 03374a96-8b5e-4bd0-bf41-2afb2ab6ab70)