Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
20.09.2021, 22:51:59

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25925
  • Letzte: Janzek
Statistiken
  • Beiträge insgesamt: 754587
  • Themen insgesamt: 60667
  • Heute online: 623
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  ThinkStation P320 - Lüfter: Volle Drehzahl bei Linux Mint 20.1, Win10 passt  (Gelesen 656 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Guten Tag Allerseits,

Euch bitte ich um Rat.
Auf einer Thinkstation P320 wurde nach Win10 Linux Mint 20.1 Cinnamon installiert (Dual Boot, eine Festplatte je Betriebssystem).

Alles funktioniert super - bis auf die Lüfter: Die Lüfter von CPU, Grafikkarte und der Gehäuselüfter drehen nach dem Boot in Linux  auf voller Drehzahl und regeln nicht herunter. Nach dem Boot in Windows 10 hingegen passen Sie die Drehzahl an.

Im BIOS gibt es bezüglich der Lüfter die ICE (Intelligent Cooling Engine), meines Wissens eine interne Lenovo-Lösung. Hier lassen sich nur die Profile der Lüfter anpassen, weitere Einstellungen existieren nicht. ICE sollte meines Wissens eigentlich unabhängig vom Betriebssystem sein.

Bei dem Befehl sensors werden die Coretemps und nur eine Lüfterdrehzahl angegeben. sensors-detect findet auch nicht mehr.

Im Lenovo-Forum hat mich jemand auf Ubuntu 16.04 LTS und Treiber aufmerksam gemacht. Also installiert: Dasselbe Problem.

Wisst ihr welche Treiber die Lüfter regeln?
Ist die OEM-Lüftersteuerung im Weg? (Bei zwei ThinkPads gabs nie Probleme :-)

Beste Grüße
Chris

Herzlich willkommen im Grünen! :)
Im Lenovo-Forum hat mich jemand auf Ubuntu 16.04 LTS
Das ist gerade aus dem Support und somit wäre das auch keine Lösung gewesen.
Zeige mal bitte die Ausgabe von
inxi -FzAusgabe bitte zur besseren Lesbarkeit als Text im Codeblock zeigen!! Dazu den Text im Editor auswählen und mit der '#' Schaltfläche formatieren. Siehe auch oben im Forums-Menü unter "Hilfe".

Hallo toffifee,

Herzlich willkommen im Grünen!
Danke! Es freut mich hier willkommen zu sein.  :D

Das ist gerade aus dem Support ...
Ja, Ubuntu 16.04 war wohl mal zertifiziert auf der P320, ich wollte deshalb wissen ob es damit funktioniert.

Ausgabe von: inxi -Fz:

##@##:~$ inxi -Fz
System:    Kernel: 5.4.0-72-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa
Machine:   Type: Desktop System: LENOVO product: 30BGS1BV00 v: ThinkStation P320 serial: <filter>
           Mobo: LENOVO model: 103D v: SDK0J40697 WIN 3305074637757 serial: <filter> UEFI: LENOVO v: S06KT57A date: 01/28/2021
CPU:       Topology: Quad Core model: Intel Core i7-6700 bits: 64 type: MT MCP L2 cache: 8192 KiB
           Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 4: 800 5: 800 6: 800 7: 800 8: 800
Graphics:  Device-1: NVIDIA GP106GL [Quadro P2000] driver: nouveau v: kernel
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz
           OpenGL: renderer: NV136 v: 4.3 Mesa 20.2.6
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel
           Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.4.0-72-generic
Network:   Device-1: Intel Ethernet I219-LM driver: e1000e
           IF: eno1 state: down mac: <filter>
           Device-2: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee
           IF: wls3 state: up mac: <filter>
Drives:    Local Storage: total: 350.27 GiB used: 18.42 GiB (5.3%)
           ID-1: /dev/sda vendor: SanDisk model: SD8TB8U256G1001 size: 238.47 GiB
           ID-2: /dev/sdb vendor: Crucial model: CT120BX500SSD1 size: 111.79 GiB
Partition: ID-1: / size: 109.04 GiB used: 18.41 GiB (16.9%) fs: ext4 dev: /dev/sdb2
Sensors:   System Temperatures: cpu: 33.5 C mobo: N/A gpu: nouveau temp: 36 C
           Fan Speeds (RPM): N/A gpu: nouveau fan: 2399
Info:      Processes: 228 Uptime: 10m Memory: 15.57 GiB used: 1.14 GiB (7.3%) Shell: bash inxi: 3.0.38
##@##:~$
« Letzte Änderung: 06.05.2021, 17:54:43 von derChris »

Hi :)
recht neu..
versuche mal den 5.8er kernel > aktualisierungsverwaltung > ansicht

und
einbinden des nvidia treiber moduls > treiberverwaltung

mk

  • ***
Hier eine weitere Idee: Versuche es mit dem Tool "Thinkfan". Ich hatte einmal ein ähnliches Problem mit einem Ideapad. Der Lüfter lief zwar nicht auf Volldrehzahl aber er lief andauernd. Ich habe dann im Internet recherchiert und bin auf einen Beitrag gestoßen, in dem ein Supporter schrieb, man könne das Tool "Thinkfan", wenngleich es eigentlich für Thinkpads gedacht ist, auch für andere Lenovo-Produkte ausprobieren. Das habe ich gemacht, konfiguriert und gut war's mit dem Lüfter. Bei Interesse kannst Du hinter folgenden Links Genaueres dazu lesen (Ein Gelingen kann natürlich nicht garantiert werden):
https://thinkwiki.de/Thinkfan
https://www.linuxmintusers.de/index.php?topic=36218.0

Hier würde ich erst den Tipp von ehtron versuchen, eher ich an der Lüftersteuerung herum spielen würde.

mk

  • ***
Richtig, deshalb schrieb ich von einer weiteren Idee.

Hallo Allerseits,

danke für die Tipps.

... den 5.8er kernel ...
Gerne. Das ich den Kernel so wechseln kann wusste ich nicht. Jetzt ist:
System:    Kernel: 5.8.0-50-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 UlyssaLeider keine Besserung mit den Lüftern  :(

Ich hatte den
nvidia-driver-460, Version 460.73.01-0ubuntu.20.04.1, NVIDIA driver metapackageausprobiert, der wurde vom Driver Manager empfohlen. Allerdings kam dann eine Warnung, das (sinngemäß) die Grafik wenig performant wäre.

Tool "Thinkfan"
Habe ich ausprobiert. Aber beim neuladen des moduls nach (https://thinkwiki.de/Thinkfan)
##@##:~$ sudo modprobe -v thinkpad_acpi
insmod /lib/modules/5.8.0-50-generic/kernel/drivers/char/nvram.ko
insmod /lib/modules/5.8.0-50-generic/kernel/drivers/platform/x86/thinkpad_acpi.ko fan_control=1
modprobe: ERROR: could not insert 'thinkpad_acpi': No such device
Mich hätte es auch gewundert hätte es so funktioniert, ein erfolgreiches sensors-detect ist Voraussetzung für Thinkfan. Und daran scheitert es bereits ...

Bisheriges Fazit:
1. Fettes Danke für Eure Unterstützung!
2. Wie geht es weiter? Wenn ich auf andere Hardware umsteige - egal ob Fertig-PC oder Eigenbau - ist ja auch nicht sicher ob alles Linux Mint kompatibel ist, speziell denke ich da an Lüftersteuerung und Quadro-Karte ...  ;)
Was meint Ihr dazu? - Äh,  dazu neues Thema eröffnen, oder?

Beste Grüße
Chris

Hi :)
Zitat
ausprobiert, der wurde vom Driver Manager empfohlen. Allerdings kam dann eine Warnung, das (sinngemäß) die Grafik wenig performant wäre.

so eine warnung ist mir bei richtiger nutzung der treiberverwaltung noch nicht unter gekommen.

## Abschluss ##

Hallo Allerseits,

trotz eurer Untersützung habe ich das Problem nicht lösen können.
Ich werde es mit anderer Hardware ausprobieren - ev. sind dann die Probleme verschwunden.

Grüße
Chris

Off-Topic:
PS: Wie kann ich den Status dieses Themas auf "erfolglos geschlossen" stellen oder macht das ein Admin - oder wie ist das hier gelöst?
(habe unter "Hilfe" nichts dazu gefunden)
« Letzte Änderung: 10.05.2021, 09:44:43 von derChris »

PS: Wie kann ich den Status dieses Themas auf "erfolglos geschlossen" stellen oder macht das ein Admin - oder wie ist das hier gelöst?
(habe unter "Hilfe" nichts dazu gefunden)
einfach auf "erledigt" setzen.