LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Newbie Fragen => Thema gestartet von: theAkrobat am 05.06.2021, 08:35:57

Titel: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: theAkrobat am 05.06.2021, 08:35:57
Ich habe Linux Mint 19.2 Cinnamon am laufen.

Meine Anwendungsverwaltung lässt sich zwar noch öffnen aber wenn ich auf eine Anwendung klicke, werden keine weiteren Informationen geladen und ich kann sie auch nicht installieren. (siehe Bild im Anhang)

Was kann ich da machen?
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: skoopy am 05.06.2021, 09:19:26
Hallo und willkommen bei LMU!

Starte doch die Anwendungsverwaltung mal mit folgendem Befehl aus dem Terminal und kopiere die Ausgabe hier in einen Codeblock:mintinstallWie du einen Codeblock erstellst, steht oben in der Hilfe: https://www.linuxmintusers.de/index.php?action=wiki;page=Editor_Maske_f%C3%BCr_eigenen_Beitrag
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: ehtron am 06.06.2021, 15:20:10
Hi :)
läuft die paket auffrischung in
synaptic oder aktualisierungsverwaltung durch

oder ausbabe von
sudo apt-get updatebringen (ausgaben immer codeblock)
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: theAkrobat am 08.06.2021, 12:28:02
Hey, Danke für die Antworten!
(Ich bin in der Zwischenzeit umgezogen darum hat es bei mir jetzt etwas länger gedauert)

Also hier sind die Ergebnisse von:

mintinstall
MintInstall: Detected system architecture: 'x86_64'
Installer: User pkgcache is most recent, using it.

MintInstall: Deleting old screenshots

** (mintinstall.py:17346): WARNING **: 12:13:51.234: Found icon of unknown type, skipping it: unknown

** (mintinstall.py:17346): WARNING **: 12:13:51.234: Found icon of unknown type, skipping it: unknown
MintInstall: Downloaded new reviews
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1802, in on_flowbox_child_activated
    self.show_package(child.get_child().pkginfo, previous_page)
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1994, in show_package
    self.builder.get_object("application_icon").set_from_pixbuf(self.get_application_icon(pkginfo, 64))
AttributeError: 'NoneType' object has no attribute 'set_from_pixbuf'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 154, in apport_excepthook
    os.O_WRONLY | os.O_CREAT | os.O_EXCL, 0o640), 'wb') as f:
FileNotFoundError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/var/crash/_usr_lib_linuxmint_mintinstall_mintinstall.py.1000.crash'

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1802, in on_flowbox_child_activated
    self.show_package(child.get_child().pkginfo, previous_page)
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1994, in show_package
    self.builder.get_object("application_icon").set_from_pixbuf(self.get_application_icon(pkginfo, 64))
AttributeError: 'NoneType' object has no attribute 'set_from_pixbuf'
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1802, in on_flowbox_child_activated
    self.show_package(child.get_child().pkginfo, previous_page)
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1994, in show_package
    self.builder.get_object("application_icon").set_from_pixbuf(self.get_application_icon(pkginfo, 64))
AttributeError: 'NoneType' object has no attribute 'set_from_pixbuf'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 154, in apport_excepthook
    os.O_WRONLY | os.O_CREAT | os.O_EXCL, 0o640), 'wb') as f:
FileNotFoundError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/var/crash/_usr_lib_linuxmint_mintinstall_mintinstall.py.1000.crash'

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1802, in on_flowbox_child_activated
    self.show_package(child.get_child().pkginfo, previous_page)
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 1994, in show_package
    self.builder.get_object("application_icon").set_from_pixbuf(self.get_application_icon(pkginfo, 64))
AttributeError: 'NoneType' object has no attribute 'set_from_pixbuf'


ehtron: 
Ich aktuallisiere mein Sysem regenläßig mit der Aktualisierungsverwaltung(!), das läuft so weit problemlos.


Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: Kreuz Elf am 10.06.2021, 16:53:50
Meinst du wirklich die Anwendungsverwaltung?
Wäre mir neu dass man über die Anwendungsverwaltung Programme auch updaten kann.
Oder meinst du die Aktualisierungsverwaltung?
Das sind immerhin zwei verschiedene Dinge.
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: skoopy am 10.06.2021, 19:06:00
Die Anwendungsverwaltung und die Aktualisierungsverwaltung sind unterschiedliche Programme.
Die Fehlermeldungen in der Ausgabe von mintinstall (Anwendungsverwaltung) dürften meines Wissen nach nicht auftauchen. Hast du irgendwelche Systemdateien entfernt oder verändert?
Bring bitte die gewünschte Ausgabe von sudo apt-get update
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: theAkrobat am 10.06.2021, 23:16:27
@ Kreuz Elf: Danke für den Hinweis! Ich meinte die Aktualisierungsverwaltung und habe es in dem Post korrigiert.

Das ist das Ergebnis von:
sudo apt-get update
Ign:1 http://mirror.bauhuette.fh-aachen.de/linuxmint tina InRelease
OK:3 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu bionic InRelease   
Holen:2 http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease [1.559 B]
OK:4 http://mirror.bauhuette.fh-aachen.de/linuxmint tina Release               
OK:5 http://ftp.halifax.rwth-aachen.de/ubuntu bionic InRelease                 
OK:6 http://ftp.halifax.rwth-aachen.de/ubuntu bionic-updates InRelease         
OK:7 http://ftp.halifax.rwth-aachen.de/ubuntu bionic-backports InRelease       
OK:8 https://updates.signal.org/desktop/apt xenial InRelease                   
OK:9 http://archive.canonical.com/ubuntu bionic InRelease                     
OK:10 https://repo.skype.com/deb stable InRelease                             
OK:11 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease               
OK:12 http://security.ubuntu.com/ubuntu bionic-security InRelease             
Fehl:2 http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease
  Die folgenden Signaturen waren ungültig: EXPKEYSIG DFA175A75104960E Emulators OBS Project <Emulators@build.opensuse.org>
OK:14 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease 
Es wurden 1.559 B in 2 s geholt (753 B/s).
Paketlisten werden gelesen... Fertig
W: Während der Überprüfung der Signatur trat ein Fehler auf. Das Depot wurde nicht aktualisiert und die vorherigen Indexdateien werden verwendet. GPG-Fehler: http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease: Die folgenden Signaturen waren ungültig: EXPKEYSIG DFA175A75104960E Emulators OBS Project <Emulators@build.opensuse.org>
W: Fehlschlag beim Holen von http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/./InRelease Die folgenden Signaturen waren ungültig: EXPKEYSIG DFA175A75104960E Emulators OBS Project <Emulators@build.opensuse.org>
W: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: Kreuz Elf am 10.06.2021, 23:54:44
Aha also ne fehlende Paketquelle macht normalerweise nichts kaputt in den sonstigen Programmen.
Dass mit deiner Anwendungs / Aktualisierungsverwaltung was nicht stimmt wird wohl andere Gründe haben.
Sonst hätte ich dieses Problem auch schon mal gehabt.
Aber wenn du updates von Kommandozeile aus machen kannst kannst du ja versuchen eben diese Anwendungs / Aktualisierungsverwaltung zu updaten / neu zu installieren.
Ich denke das hatten die Vorredner wohl auch im Sinn.
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: kuehhe1 am 11.06.2021, 10:33:19
Hallo,
Falls deinem Problem vor Themeneröffnung kritische Aktionen wie Hinzufügen von PPA etc. vorausgingen wäre es einen Versuch wert das PPA zu deaktivieren und erneut zu aktualisieren. Falls der Fehler dann immer noch besteht mit Timeshift oder einem anderen vorhandenen Backup zurück zu setzen.

Nachtrag: PPA's und zusätzliche Paketquellen lassen sich über die Akt.-Verwaltung > Bearbeiten > Paketquellen ... De- / Aktivieren
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: pinky am 11.06.2021, 13:27:38
Ich meinte die Aktualisierungsverwaltung und habe es in dem Post korrigiert.
Nein, es ist die Anwendungsverwaltung (= mintinstall).
Mal bitte dem Vorschlag von @kuehhe1 folgen. Alle PPAs und Zusätzliche Paketquellen deaktivieren. Dann mal bitte:
apt clean
apt update
Dann nochmal die Anwendungsverwaltung öffnen und Feedback ob OK.
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: theAkrobat am 28.06.2021, 14:05:14
Ich habe die PPAs und auch die Zusätzlichen Paketquellen deaktiviert und dann:

apt clean
apt update

Ausgeführt, aber das Problem bei der Anwendungsverwaltung ist noch immer unverändert.

Soll ich die PPAs und die Zusätzlichen Paketquellen wieder aktivieren?


Gebt mir auch gerne mal Feedback wie das für euch ist, dass ich so lange brauche um zu antworten. Ich habe noch bis August einen recht unsteten Alltag und daher gerade noch nicht so beständig die Ruhe, um verlässlich und schnell zu antworten.
Ich weiß nicht ob das hier jemanden irritiert oder ob das der ungeschriebenen Forums Etikette entspricht.
Danke das ihr euch die Zeit nehmt und mit meinem Thema auseinander setzt! :) 
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: ehtron am 28.06.2021, 15:29:30
Hi :)
solange der fehler noch besteht, ppa und zusätzliche deaktiviert lassen.

gehe mal auf einen anderen spiegelserver oder auf die standard server.
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: theAkrobat am 28.06.2021, 22:07:12
Ich habe die Spiegelserver gewechselt aber es hat sich nichts getan.
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: FranzStahl am 28.06.2021, 22:20:57
Mal so in’s Blaue:
sudo dpkg --configure -asudo apt-get install -fsudo apt-get update
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: ehtron am 29.06.2021, 14:34:23
Hi :)
und bringe die jeweiligen ausgaben bitte als codeblock (befehl mit kopieren)
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: theAkrobat am 04.07.2021, 08:51:28
Hey,

ich hab die Befehle mal eingegeben.

bei dem ersten
sudo dpkg --configure -a
hat sich nach dem mein Passwort abgefragt wurde nichts mehr weiter getan.

Hier das Ergebnis von
sudo apt-get install -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  linux-headers-4.15.0-142 linux-headers-4.15.0-142-generic
  linux-headers-4.15.0-143 linux-headers-4.15.0-143-generic
  linux-image-4.15.0-142-generic linux-image-4.15.0-143-generic
  linux-modules-4.15.0-142-generic linux-modules-4.15.0-143-generic
  linux-modules-extra-4.15.0-142-generic
  linux-modules-extra-4.15.0-143-generic
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 6 nicht aktualisiert.

Ich habe dann auch noch mal
sudo apt autoremove
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  linux-headers-4.15.0-142 linux-headers-4.15.0-142-generic
  linux-headers-4.15.0-143 linux-headers-4.15.0-143-generic
  linux-image-4.15.0-142-generic linux-image-4.15.0-143-generic
  linux-modules-4.15.0-142-generic linux-modules-4.15.0-143-generic
  linux-modules-extra-4.15.0-142-generic
  linux-modules-extra-4.15.0-143-generic
0 aktualisiert, 0 neu installiert, 10 zu entfernen und 6 nicht aktualisiert.
Nach dieser Operation werden 699 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] j
(Lese Datenbank ... 427118 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von linux-headers-4.15.0-142-generic (4.15.0-142.146) ...
Entfernen von linux-headers-4.15.0-142 (4.15.0-142.146) ...
Entfernen von linux-headers-4.15.0-143-generic (4.15.0-143.147) ...
Entfernen von linux-headers-4.15.0-143 (4.15.0-143.147) ...
Entfernen von linux-modules-extra-4.15.0-142-generic (4.15.0-142.146) ...
Entfernen von linux-image-4.15.0-142-generic (4.15.0-142.146) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-142-generic
/etc/kernel/postrm.d/zz-update-grub:
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
GRUB-Konfigurationsdatei wird erstellt …
Linux-Abbild gefunden: /boot/vmlinuz-4.15.0-147-generic
initrd-Abbild gefunden: /boot/initrd.img-4.15.0-147-generic
Linux-Abbild gefunden: /boot/vmlinuz-4.15.0-144-generic
initrd-Abbild gefunden: /boot/initrd.img-4.15.0-144-generic
Linux-Abbild gefunden: /boot/vmlinuz-4.15.0-143-generic
initrd-Abbild gefunden: /boot/initrd.img-4.15.0-143-generic
Linux-Abbild gefunden: /boot/vmlinuz-4.15.0-54-generic
initrd-Abbild gefunden: /boot/initrd.img-4.15.0-54-generic
Hinzufügen des Boot-Menü Eintrages für die EFI Firmware Konfiguration
erledigt
Entfernen von linux-modules-extra-4.15.0-143-generic (4.15.0-143.147) ...
Entfernen von linux-image-4.15.0-143-generic (4.15.0-143.147) ...
/etc/kernel/prerm.d/dkms:
dkms: removing: nvidia 460.80 (4.15.0-143-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  nvidia
Version: 460.80
Kernel:  4.15.0-143-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-143-generic/kernel/drivers/char/drm/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-modeset.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-143-generic/kernel/drivers/char/drm/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-drm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-143-generic/kernel/drivers/char/drm/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-uvm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-143-generic/kernel/drivers/char/drm/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod...

DKMS: uninstall completed.
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-143-generic
/etc/kernel/postrm.d/zz-update-grub:
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
GRUB-Konfigurationsdatei wird erstellt …
File descriptor 10 (/var/lib/dpkg/triggers/linux-update-4.15.0-142-generic (deleted)) leaked on vgs invocation. Parent PID 30484: /usr/sbin/grub-probe
File descriptor 10 (/var/lib/dpkg/triggers/linux-update-4.15.0-142-generic (deleted)) leaked on vgs invocation. Parent PID 30484: /usr/sbin/grub-probe
Linux-Abbild gefunden: /boot/vmlinuz-4.15.0-147-generic
initrd-Abbild gefunden: /boot/initrd.img-4.15.0-147-generic
Linux-Abbild gefunden: /boot/vmlinuz-4.15.0-144-generic
initrd-Abbild gefunden: /boot/initrd.img-4.15.0-144-generic
Linux-Abbild gefunden: /boot/vmlinuz-4.15.0-54-generic
initrd-Abbild gefunden: /boot/initrd.img-4.15.0-54-generic
File descriptor 10 (/var/lib/dpkg/triggers/linux-update-4.15.0-142-generic (deleted)) leaked on vgs invocation. Parent PID 30992: /usr/sbin/grub-probe
File descriptor 10 (/var/lib/dpkg/triggers/linux-update-4.15.0-142-generic (deleted)) leaked on vgs invocation. Parent PID 30992: /usr/sbin/grub-probe
File descriptor 10 (/var/lib/dpkg/triggers/linux-update-4.15.0-142-generic (deleted)) leaked on lvs invocation. Parent PID 31119: /bin/sh
Hinzufügen des Boot-Menü Eintrages für die EFI Firmware Konfiguration
erledigt
Entfernen von linux-modules-4.15.0-142-generic (4.15.0-142.146) ...
Entfernen von linux-modules-4.15.0-143-generic (4.15.0-143.147) ...

Das ist das Ergebnis für:
sudo apt-get update
Ign:1 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com tina InRelease
OK:2 http://archive.canonical.com/ubuntu bionic InRelease                     
OK:3 http://ftp-stud.hs-esslingen.de/ubuntu bionic InRelease                   
OK:4 http://ftp-stud.hs-esslingen.de/ubuntu bionic-updates InRelease           
OK:5 http://ftp-stud.hs-esslingen.de/ubuntu bionic-backports InRelease         
OK:6 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com tina Release
Holen:7 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Holen:9 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [48,5 kB]
Holen:10 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [60,5 kB]
Holen:11 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2.464 B]
Es wurden 200 kB in 1 s geholt (147 kB/s).                                   
Paketlisten werden gelesen... Fertig

An dem Problem mit der Anwendungsverwaltung hat sich aber immer noch nichts getan.

Kann man die Anwendungsverwaltung mal deinstallieren und wieder neu installieren? Könnte das was bringen?
Was wären da die Befehle für? 
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: billyfox05 am 04.07.2021, 10:14:19
Beim deinstallieren werden andere Pakete mit entfernt - siehe im Codeblock die Simulation
billyfox@aiolm:~$ apt purge mintinstall -s
[sudo] Passwort für billyfox:         
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  mint-meta-cinnamon* mint-meta-core* mintinstall*
0 aktualisiert, 0 neu installiert, 3 zu entfernen und 0 nicht aktualisiert.
Purg mint-meta-cinnamon [2021.01.02]
Purg mint-meta-core [2021.01.02]
Purg mintinstall [8.0.5]
Das wäre mir erstmal zu riskant - und ändert auch nichts an den "Einstellungen" in deinem /home -
hier befindet sich im Verzeichnis ".cache" der Ordner "mintinstall" - benenne den einmal um in z.B. "ORGmintinstall" -
Dateimanager schließen und die Anwendungsverwaltung starten - wie sieht es jetzt aus ?
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: theAkrobat am 05.07.2021, 09:33:53
Hab den Ordner entsprechend umbenannt, aber geändert hat sich nichts.
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: ehtron am 05.07.2021, 14:19:08
Hi :)
Zitat
Was kann ich da machen?
synaptic nutzen .. eh besser ;)

oder auf 19.3 gehen und hoffen... ;)
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: pinky am 05.07.2021, 18:05:04
Hab den Ordner entsprechend umbenannt, aber geändert hat sich nichts.
In der Anwendungsverwaltung, im Menü, Bitte die Paketliste auffrischen hast du schon versucht?
Titel: Re: Anwendungsverwaltung läd keine Programinformationen und installiert nichts mehr
Beitrag von: pinky am 05.07.2021, 21:30:02
Hab den Ordner entsprechend umbenannt, aber geändert hat sich nichts.
Was liefert dann
ls -al ~/.cache/mintinstall/