Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
20.09.2018, 22:47:19

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 20799
  • Letzte: Pathor
Statistiken
  • Beiträge insgesamt: 548843
  • Themen insgesamt: 44221
  • Heute online: 539
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online

Autor Thema: [gelöst]  WLAN funktioniert nicht und Touchpad macht Probleme  (Gelesen 1161 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #15 am: 13.06.2018, 22:11:19 »
LM 19 habe ich schon ausprobiert, aber weder das WLAN noch das Touchpad geht damit.

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #16 am: 13.06.2018, 22:21:43 »
Na ja, scheint nicht ohne Gefriemel möglich zu sein.
Aber ich denke mit LM-19 sind die Chancen größer, es hinzubekommen.
Mit LM-18 kriegst Du ja nicht mal das Firmware-Paket installiert und andere Sachen sind auch deutlich älter.
Das passt dann alles nicht für die ziemlich neue Hardware.

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #17 am: 13.06.2018, 22:41:30 »
Nun ist ja erst BETA mal schauen wie es nach dem Release der endgültigen Version aussieht.
Frag mich nur warum mein Touchpad mit 4.10 geht und allen danach bis 4.15 nicht ???

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #18 am: 14.06.2018, 06:21:28 »
Installation:
# zuvor in den entsprechenden Ordner mit dem Paket wechseln
cd ~/Downloads
sudo dpkg -i linux-firmware_1.173_all.deb
sudo apt-mark auto linux-firmware
Neustart und abfragen:
dmesg | egrep -i 'iwlwifi|ucode'
iwconfig
Kann auch sein, dass Du einen noch aktuelleren Kernel und Firmware benötigst.
« Letzte Änderung: 14.06.2018, 06:30:36 von Flash63 »

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #19 am: 14.06.2018, 14:58:18 »
In eigener Sache, ich wurde darauf hingewiesen, ich solle Crossposting kenntlich machen.

Tut mir leid, ich wollte nicht gegen bestehende Regeln verstoßen !

HINWEIS: Ich habe im https://forums.linuxmint.com/viewtopic.php?f=64&t=271040&p=1480836#p1480836 Forun die gleiche Frage gestellt.
« Letzte Änderung: 14.06.2018, 15:42:00 von Jerry O´Neel »

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #20 am: 14.06.2018, 21:11:47 »
Installation:
# zuvor in den entsprechenden Ordner mit dem Paket wechseln
cd ~/Downloads
sudo dpkg -i linux-firmware_1.173_all.deb
sudo apt-mark auto linux-firmware
Neustart und abfragen:
dmesg | egrep -i 'iwlwifi|ucode'
iwconfig
Kann auch sein, dass Du einen noch aktuelleren Kernel und Firmware benötigst.


Die Ausgabe sagt:

linuxuser@LinuxUser-Alienware-17-R5 ~ $ iwconfig
lo        no wireless extensions.

enp70s0   no wireless extensions.

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #21 am: 14.06.2018, 21:31:53 »
Ich habe jetzt nebenher noch weiter Live Systeme getestet:

Ubuntu 18.04 ----------> kein Touchpad kein WLAN
linuxmint 19 beta ---------->  kein Touchpad kein WLAN
lmde-2-201701-cinnamon ----------> Touchpad geht kein WLAN
debian-live-9.4.0 ----------> Touchpad geht kein WLAN

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #22 am: 15.06.2018, 07:05:49 »
Ich habe durch Zufall folgendes gefunden:   https://www.intel.de/content/www/de/de/support/articles/000005511/network-and-i-o/wireless-networking.html

nun habe ich mir die 2 Pakete

iwlwifi-9000-pu-b0-jf-b0-34.618819.0.tgz
iwlwifi-9260-th-b0-jf-b0-34.618819.0.tgz

heruntergeladen, entpackt und in das Verzeichnis lib/firmware kopiert.

Nun weis ich aber nicht weiter was ich machen muss um das jetzt anzuwenden. Hat jemand eine Idee ?

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #23 am: 15.06.2018, 08:18:54 »
Statt des unnötige Vollzitats wäre es hilfreich, einfach mal die Fehlerabfrage auszuführen. Dann erkennt man wahrscheinlich den Fehler.

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #24 am: 15.06.2018, 08:35:41 »
Statt des unnötige Vollzitats wäre es hilfreich, einfach mal die Fehlerabfrage auszuführen. Dann erkennt man wahrscheinlich den Fehler.

Sehr schön, iwconfig =

linuxuser@LinuxUser-Alienware-17-R5 ~ $ iwconfig
lo        no wireless extensions.

enp70s0   no wireless extensions.

mehr habe ich nicht hin bekommen.

Ich bin kein Linux Profi und benötige genaue Angaben wie ich was genau machen soll, tut mir leid das es so ist wie es eben ist.

Hilfreiche Form wäre z.B.:

Im Terminal den Befehl "iwconfig" eingeben, dann Passwort eingeben, Ergebnis bitte hier posten.

Nicht:

Installation:
Code: [Auswählen]
# zuvor in den entsprechenden Ordner mit dem Paket wechseln
cd ~/Downloads
sudo dpkg -i linux-firmware_1.173_all.deb
sudo apt-mark auto linux-firmware
Neustart und abfragen:
Code: [Auswählen]
dmesg | egrep -i 'iwlwifi|ucode'
iwconfig

Damit fange ich nicht all zu viel an, sorry.
« Letzte Änderung: 15.06.2018, 08:56:54 von Jerry O´Neel »

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #25 am: 15.06.2018, 09:04:35 »
Genaue Angaben hast Du bekommen, und jetzt bereits doppelt zitiert, nur anscheinend immer noch nicht ausgeführt. Oder kommt keine Ausgabe?

Erweiterte Abfrage bei verwendetem 4.15.x-Kernel:
sudo modprobe -v iwlwifi
dmesg | egrep -i 'iwlwifi|ucode'
lspci -nnk | grep -i intel -A3
Befehlszeilen am besten kopieren um Tippfehler zu vermeiden.

https://wiki.ubuntuusers.de/dmesg/
https://wiki.ubuntuusers.de/grep/ (egrep)
« Letzte Änderung: 15.06.2018, 09:10:29 von Flash63 »

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #26 am: 15.06.2018, 11:32:14 »
was für ein Notebook ist das ?

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #27 am: 15.06.2018, 13:04:12 »
was für ein Notebook ist das ?
Ist am Anfang ersichtlich: Dell Notebook Alienware 17 R5

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #28 am: 15.06.2018, 15:01:03 »
So nun habe ich die 3 Befehle

sudo modprobe -v iwlwifi
dmesg | egrep -i 'iwlwifi|ucode'    <------ da bin ich mir nicht sicher ob das so richtig ist da es keine Ausgabe gegeben hat.
lspci -nnk | grep -i intel -A3

wie gefordert nacheinander ausgeführt:


linuxuser@LinuxUser-Alienware-17-R5 ~ $ sudo modprobe -v iwlwifi
[sudo] Passwort für linuxuser:
insmod /lib/modules/4.15.0-23-generic/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
linuxuser@LinuxUser-Alienware-17-R5 ~ $ dmesg | egrep -i 'iwlwifi|ucode'
linuxuser@LinuxUser-Alienware-17-R5 ~ $ lspci -nnk | grep -i intel -A3
00:00.0 Host bridge [0600]: Intel Corporation Device [8086:3ec4] (rev 07)
DeviceName: Onboard - Other
Subsystem: Dell Device [1028:0877]
00:01.0 PCI bridge [0604]: Intel Corporation Sky Lake PCIe Controller (x16) [8086:1901] (rev 07)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:01.1 PCI bridge [0604]: Intel Corporation Sky Lake PCIe Controller (x8) [8086:1905] (rev 07)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:01.2 PCI bridge [0604]: Intel Corporation Sky Lake PCIe Controller (x4) [8086:1909] (rev 07)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:02.0 Display controller [0380]: Intel Corporation Device [8086:3e9b]
DeviceName: Onboard - Video
Subsystem: Dell Device [1028:0877]
Kernel driver in use: i915
--
00:04.0 Signal processing controller [1180]: Intel Corporation Skylake Processor Thermal Subsystem [8086:1903] (rev 07)
DeviceName: Onboard - Other
Subsystem: Dell Skylake Processor Thermal Subsystem [1028:0877]
Kernel driver in use: proc_thermal
--
00:12.0 Signal processing controller [1180]: Intel Corporation Device [8086:a379] (rev 10)
DeviceName: Onboard - Other
Subsystem: Dell Device [1028:0877]
Kernel driver in use: intel_pch_thermal
Kernel modules: intel_pch_thermal
00:14.0 USB controller [0c03]: Intel Corporation Device [8086:a36d] (rev 10)
DeviceName: Onboard - Other
Subsystem: Dell Device [1028:0877]
Kernel driver in use: xhci_hcd
00:14.2 RAM memory [0500]: Intel Corporation Device [8086:a36f] (rev 10)
DeviceName: Onboard - Other
Subsystem: Dell Device [1028:0877]
00:15.0 Serial bus controller [0c80]: Intel Corporation Device [8086:a368] (rev 10)
DeviceName: Onboard - Other
Subsystem: Dell Device [1028:0877]
Kernel driver in use: intel-lpss
Kernel modules: intel_lpss_pci
00:16.0 Communication controller [0780]: Intel Corporation Device [8086:a360] (rev 10)
DeviceName: Onboard - Other
Subsystem: Dell Device [1028:0877]
Kernel driver in use: mei_me
--
00:17.0 SATA controller [0106]: Intel Corporation Device [8086:a353] (rev 10)
DeviceName: Onboard - SATA
Subsystem: Dell Device [1028:0877]
Kernel driver in use: ahci
--
00:1b.0 PCI bridge [0604]: Intel Corporation Device [8086:a340] (rev f0)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1b.4 PCI bridge [0604]: Intel Corporation Device [8086:a32c] (rev f0)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1d.0 PCI bridge [0604]: Intel Corporation Device [8086:a330] (rev f0)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1d.6 PCI bridge [0604]: Intel Corporation Device [8086:a336] (rev f0)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1d.7 PCI bridge [0604]: Intel Corporation Device [8086:a337] (rev f0)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:a30e] (rev 10)
DeviceName: Onboard - Other
Subsystem: Dell Device [1028:0877]
00:1f.3 Audio device [0403]: Intel Corporation Device [8086:a348] (rev 10)
DeviceName: Onboard - Sound
Subsystem: Dell Device [1028:0877]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:1f.4 SMBus [0c05]: Intel Corporation Device [8086:a323] (rev 10)
DeviceName: Onboard - Other
Subsystem: Dell Device [1028:0877]
Kernel modules: i2c_i801
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device [8086:a324] (rev 10)
DeviceName: Onboard - Other
Subsystem: Dell Device [1028:0877]
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1c60] (rev a1)
--
47:00.0 Network controller [0280]: Intel Corporation Device [8086:2526] (rev 29)
Subsystem: Bigfoot Networks, Inc. Device [1a56:1550]
linuxuser@LinuxUser-Alienware-17-R5 ~ $

Re: WLAN funktioniert nicht und Touchpad macht Probleme
« Antwort #29 am: 15.06.2018, 16:02:44 »
Es wird ein aktueller Treiber benötigt, welcher manuell installiert werden muss, da die erforderliche Sub-ID dem Treiber nicht bekannt ist:
47:00.0 Network controller [0280]: Intel Corporation Device [8086:2526] (rev 29)
Subsystem: Bigfoot Networks, Inc. Device [1a56:1550]
Installation über Kabelverbindung:
sudo apt install git
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi
sudo make defconfig-iwlwifi-public
sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
make -j4
sudo make install
Neustart und erneut prüfen.

PS: die Installation ist nur für den aktuell verwendeten Kernel gültig!

https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
« Letzte Änderung: 15.06.2018, 21:21:49 von Flash63 »