Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
07.05.2021, 09:34:32

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25569
  • Letzte: Noelpferd
Statistiken
  • Beiträge insgesamt: 733753
  • Themen insgesamt: 59127
  • Heute online: 558
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Softwareverwaltung, Synaptics und Aktualisierungen funktionieren nicht  (Gelesen 2699 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Vielen Dank schon mal für die schnellen Hilfen der Profis hier im Forum.
Bin leider im Linux noch ein wenig unbedarft, aber begeistert, wie sauber und klar das System läuft.
Nur habe ich bei meiner ANGSTINSTALLATION (Auf einer Virtuellen Maschine von Oracle auf meinem 64bit Windows Professional System) vielleicht ein paar kleine Probleme erzeugt.
Ich habe das Maya / Cinnymon sauber von der erzeugten (aber ungeprüften) ISO DVD installiert.
Das hat ganz ohne Probleme funktioniert.
Doch ich hatte auch die üblichen Probleme mit den Sprachpaketen bei Firefox und Thunderbird.
Das Ding funktioniert in der Virtuellen Maschine tadellos. Ich kann sogar Videos mit Bild und Ton in einer Super Qualität abspielen, ohne das ich das irgendwie an der Prozessorauslastung merke. (Hut Ab) Dann laufen alle Internetseiten schneller und flüssiger. Als auf dem Windows System (Auch Wenn die virtuelle Maschine aus ist)

Dann habe ich versucht von der Teamviewer Seite die Ubuntu Version von Teamviewer zu installieren.
Das hat nicht funktioniert. Daraufhin habe ich aus dem Forum ein paar Befehlszeilen in das Terminal kopiert, die mir ein paar liebe Kollegen bereitgestellt haben.
Das hat aber alles keinen Erfolg gebracht.
Bin dann immer auf eine Synapics Paketverwaltung hingewiesen worden.
Doch der Klick auf den Button aus der Menüauswahl brachte keine (wirklich überhauptkeine) Reaktion.

Dann habe ich mir gedacht, Du musst mal wie bei Windows ein Update machen. Vielleicht wird das dann besser.
Die Aktualisierung beginnt auch zu laufen und ich kann so irgendwas von über 400 Aktualisierungen einspielen.
Das habe ich dann auch gestartet und er hat mit einem Ladeprozess begonnen und gefragt, ob er die weiteren 5 Pakete dafür auch installieren soll.
Das habe ich bejaht und dann ist er mit einem Fehlercode 127 abgebrochen.

Naja dachte ich. Das System läuft ja ohne Updates auch ganz gut.
Wollte aber gerne die Programme wie Firefox o.Ä. in Deutsch.
Habe dazu aber im Programm selber nichts gefunden.
Dann habe ich mir auf der Mozilla Seite die neueste Version (15) runtergeladen, doch ich bekomme die nicht installiert.
Ist halt anders wie bei Windows, auch den Button im Menü, mit dem ich unter Windows das Update machen kann fehlt bei mir.
Dann habe ich gelesen, man müsste den Firefox über die Softwareverwaltung entfernen, und einfach neu installieren.

Doch die Softwareverwaltung funktioniert nicht richtig. Ich kann mir zwar alle Programme auswählen und deinstallieren oder installieren.
Es passiert aber nichts. ER beginnt die Vorgänge, bleibt bei allen kurz bei 55% stehen und geht dann auf 100% aber es wird kein Programm installiert oder deinstalliert.
Und somit bin ich jetzt mit meinem Latein am Ende.

Das weitere Problem, daß ich meine verfügbaren Netzlaufwerke (fritzbox etc.) nicht eingebunden bekomme.
Ich bekomme die zwar im Filesystem im Ordner Media angezeigt, kann aber nicht darauf zugreifen.
Dort bekomme ich die Meldung ".. no permissions.."

Liebe Grüße von einem Anfänger.

Gib mal im Terminal folgendes ein:
sudo apt-get install -fDas beseitigt evtl. Abhängigkeitsprobleme. Und danach ein
sudo apt-get updateund ein
sudo apt-get dist-upgrade
Sollte es im Terminal eine Fehlermeldung geben, bitte posten.
(Terminal deswegen weil es aussagekräftiogere Fehlermeldungen gibt)

Edit: Befehle berichtigt
« Letzte Änderung: 02.10.2012, 14:14:58 von TiKaey »

Das erste hat schon nicht funktioniert.

Siehe Meldung aus dem Terminal.

sudo apt-get install -f
[sudo] password for jan:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 434 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
install-info (4.13a.dfsg.1-8ubuntu2) wird eingerichtet ...
/var/lib/dpkg/info/install-info.postinst: 32: /var/lib/dpkg/info/install-info.postinst: update-info-dir: not found
dpkg: Fehler beim Bearbeiten von install-info (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 127 zurück
Fehler traten auf beim Bearbeiten von:
 install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)

Da ist ja auch schon wieder der Fehlerwert 127

Gruß, Jan Wichtmann

sudo apt-get install upgradeDas install ist nicht nötig, hab ich so auch noch nie gesehen.
Ein sudo apt-get update und sudo apt-get dist-upgrade reicht aus.

Hier hat jemand beschrieben wie er den Fehler bei sich beheben konnte:
http://www.phz.fi/2011/11/13/debian-install-info-postinst-update-info-dir-not-found/

Er hat angefangen zu installieren.
nach einigen Miunte brach er aber wieder mit der Fehlercode 127 ab.

hier der letzte Rest aus dem Terminal:
t-vmmouse amd64 1:12.9.0-0ubuntu0.1 [15,1 kB]
Hole:22 http://archive.ubuntu.com/ubuntu/ precise-updates/main xserver-xorg-video-intel amd64 2:2.17.0-1ubuntu4.1 [238 kB]
Hole:23 http://archive.ubuntu.com/ubuntu/ precise-updates/main xserver-xorg-video-vmware amd64 1:12.0.1-1ubuntu1.1 [77,5 kB]
Es wurden 78,0 MB in 4 min 31 s geholt (287 kB/s)                             
Extrahiere Vorlagen aus Paketen: 100%
Vorkonfiguration der Pakete ...
install-info (4.13a.dfsg.1-8ubuntu2) wird eingerichtet ...
/var/lib/dpkg/info/install-info.postinst: 32: /var/lib/dpkg/info/install-info.postinst: update-info-dir: not found
dpkg: Fehler beim Bearbeiten von install-info (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 127 zurück
Fehler traten auf beim Bearbeiten von:
 install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)

Mit diesen Meldungen kann ich aber jetzt nichts mehr anfangen.

Gruß, Jan

P.S. er schreibt da öfter was von 32. Ich habe aber eigentlich die 64bit Version installiert.

Die 32 ist eine Zeilehnnummer..
Was hast du denn jetzt verändert, seit dem letten Versuch?

Und benutze doch bitte Code-Tags (Die Raute-Symbol bei den Smileys)

Entschuldigung, ich bin halt noch unerfahren in solchen foren.

Habe auch die Lösung aus Deinen Link auf die Debian Lösung nicht verstanden.

Ok ich versuche es nochmal.
Ich habe nichts geändert. Habe den Befehl
sudo apt-get dist-upgrade
in die Zeile des Terminals copiert.

und dann begann er zu Arbeiten:
...xserver-xorg-input-evdev xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xserver-xorg-video-intel
  xserver-xorg-video-vmware zeitgeist zeitgeist-core zenity zenity-common
434 aktualisiert, 10 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen noch 78,0 MB von 470 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 219 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? j
Hole:1 http://archive.ubuntu.com/ubuntu/ precise-updates/main base-files amd64 6.5ubuntu6.2 [69,7 kB]
Hole:2 http://archive.ubuntu.com/ubuntu/ precise-updates/main libdbus-1-3 amd64 1.4.18-1ubuntu1.1 [145 kB]
Hole:3 http://archive.ubuntu.com/ubuntu/ precise-updates/main gir1.2-dbusmenu-gtk-0.4 amd64 0.6.2-0ubuntu0.1 [3.284 B]
Hole:4 http://archive.ubuntu.com/ubuntu/ precise-updates/main libdbusmenu-gtk4 amd64 0.6.2-0ubuntu0.1 [31,3 kB]
Hole:5 http://archive.ubuntu.com/ubuntu/ precise-updates/main gir1.2-dbusmenu-glib-0.4 amd64 0.6.2-0ubuntu0.1 [7.142 B]
Hole:6 http://archive.ubuntu.com/ubuntu/ precise-updates/main libdbusmenu-glib4 amd64 0.6.2-0ubuntu0.1 [47,7 kB]
Hole:7 http://archive.ubuntu.com/ubuntu/ precise-updates/main libdbusmenu-gtk3-4 amd64 0.6.2-0ubuntu0.1 [31,4 kB]
Hole:8 http://archive.ubuntu.com/ubuntu/ precise-updates/main xserver-xorg-core amd64 2:1.11.4-0ubuntu10.8 [1.719 kB]
Hole:9 http://archive.ubuntu.com/ubuntu/ precise-updates/main dbus amd64 1.4.18-1ubuntu1.1 [360 kB]
Hole:10 http://archive.ubuntu.com/ubuntu/ precise-updates/main linux-image-3.2.0-31-generic amd64 3.2.0-31.50 [38,5 MB]
Hole:11 http://archive.ubuntu.com/ubuntu/ precise-updates/main dbus-x11 amd64 1.4.18-1ubuntu1.1 [22,0 kB]
Hole:12 http://archive.ubuntu.com/ubuntu/ precise-updates/main linux-firmware all 1.79.1 [23,1 MB]
Hole:13 http://archive.ubuntu.com/ubuntu/ precise-updates/main linux-generic amd64 3.2.0.31.34 [1.716 B]
Hole:14 http://archive.ubuntu.com/ubuntu/ precise-updates/main linux-image-generic amd64 3.2.0.31.34 [2.606 B]
Hole:15 http://archive.ubuntu.com/ubuntu/ precise-updates/main linux-headers-3.2.0-31 all 3.2.0-31.50 [11,7 MB]
Hole:16 http://archive.ubuntu.com/ubuntu/ precise-updates/main linux-headers-3.2.0-31-generic amd64 3.2.0-31.50 [983 kB]
Hole:17 http://archive.ubuntu.com/ubuntu/ precise-updates/main linux-headers-generic amd64 3.2.0.31.34 [2.598 B]
Hole:18 http://archive.ubuntu.com/ubuntu/ precise-updates/main linux-libc-dev amd64 3.2.0-31.50 [866 kB]
Hole:19 http://archive.ubuntu.com/ubuntu/ precise-updates/main xserver-xorg-input-evdev amd64 1:2.7.0-0ubuntu1.2 [33,3 kB]
Hole:20 http://archive.ubuntu.com/ubuntu/ precise-updates/main xserver-xorg-input-synaptics amd64 1.6.2-1ubuntu1~precise2 [71,1 kB]
Hole:21 http://archive.ubuntu.com/ubuntu/ precise-updates/main xserver-xorg-input-vmmouse amd64 1:12.9.0-0ubuntu0.1 [15,1 kB]
Hole:22 http://archive.ubuntu.com/ubuntu/ precise-updates/main xserver-xorg-video-intel amd64 2:2.17.0-1ubuntu4.1 [238 kB]
Hole:23 http://archive.ubuntu.com/ubuntu/ precise-updates/main xserver-xorg-video-vmware amd64 1:12.0.1-1ubuntu1.1 [77,5 kB]
Es wurden 78,0 MB in 4 min 31 s geholt (287 kB/s)                             
Extrahiere Vorlagen aus Paketen: 100%
Vorkonfiguration der Pakete ...
install-info (4.13a.dfsg.1-8ubuntu2) wird eingerichtet ...
/var/lib/dpkg/info/install-info.postinst: 32: /var/lib/dpkg/info/install-info.postinst: update-info-dir: not found
dpkg: Fehler beim Bearbeiten von install-info (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 127 zurück
Fehler traten auf beim Bearbeiten von:
 install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)

Danach erfolgte von mir keine Eingabe mehr.

Zitat
Habe auch die Lösung aus Deinen Link auf die Debian Lösung nicht verstanden.
Schade.. habe gerade leider nicht die Zeit das ausführlicher zu machen, evtl. findet sich ja noch jemand, der dir die Anleitung auf deutsch zusammenfasst.


P.S. Kein Grund sich zu entschuldigen.. würde ich nicht berücksichtigen, dass die evtl. Unerfahren im Umgang mit Foren bist, würde ich dich einfach ignorieren ;)

Unterprozess installiertes post-installation-Skript gab den Fehlerwert 127 zurückLaut UU-Wikki, http://wiki.ubuntuusers.de/Paketverwaltung/Problembehebung#Die-Installation-Deinstallation-von-Paketen-endet-mit-Fehlermeldungen
kann man im Zweifel dieses Script umbenennen.
Eine wie dort steht, nicht ganz saubere Lösung, aber sie funktioniert, ich musste dies auch schon mal tun.

Wegen der Debian-Lösung: Wenn bash installiert ist, kann es das kaum sein.
@jwichtmann: Zeig mal die Ausgabe von
dpkg -l | grep bash

Sauron

  • Gast
Die Fehlermeldung tritt beim Paket install-info auf.

Zitat
Vorkonfiguration der Pakete ...
install-info (4.13a.dfsg.1-8ubuntu2) wird eingerichtet ...
/var/lib/dpkg/info/install-info.postinst: 32: /var/lib/dpkg/info/install-info.postinst: update-info-dir: not found
dpkg: Fehler beim Bearbeiten von install-info (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 127 zurück
Fehler traten auf beim Bearbeiten von:
 install-info
dpkg findet update-info-dir: not found nicht. Man müsste schauen was in Zeile 32 der /var/lib/dpkg/info/install-info.postinst steht, um genau zu wissen warum der Fehler auftritt. Ich meine durch ein reinstall von install-info sollte der Fehler weg sein.

Zitat von: DocHifi
Code: sudo apt-get install upgrade
Das install ist nicht nötig, hab ich so auch noch nie gesehen.
Der Befehl würde das Paket upgrade installieren  ;)

« Letzte Änderung: 02.10.2012, 11:53:23 von Sauron »

Meine Nachfrage beruht auf dem Link von atze Aw #4.

Zitat
The problem in my case was that apt-get had removed bash, and update-info-dir requires /bin/bash.

Ist bash installiert, fällt diese Sache schon mal weg.

Auf die TerminalAnweisung von Leonisdas kam folgendes zurück:
$ dpkg -l | grep bash
rc  bash                                   4.2-2ubuntu2                            GNU Bourne Again SHell
rc  bash-completion                        1:1.3-1ubuntu8                          programmable completion for the bash shell
ii  command-not-found                      0.2.46ubuntu6                           Suggest installation of packages in interactive bash sessions
$

Da ich noch nicht viel mit dem System gemacht habe, kann ich das einfach nochmal PLATT machen und neu installieren.
Das geht ja recht schnell.
Ich könnte mir auch noch eine neue virtuelle Maschine einrichten und darauf Mint 13 Mate installieren.

Immerhin stimmt es, dass das Paket bash bei Dir nicht installiert ist.
Du könntest Dir das mal von hier runterladen:
http://de.archive.ubuntu.com/ubuntu/pool/main/b/bash/bash_4.2-2ubuntu2_amd64.deb

und das dann mit
sudo dpkg -i bash_4.2-2ubuntu2_amd64.debinstallieren. Den Befehl musst Du im Verzeichnis absetzen, wo das heruntergeladene Paket liegt. Also wenn es etwa im Download-Ordner in Deinem persönlichen Verzeichnis liegt nach dem Herunterladen, dann vorher noch:
cd Downloads