Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
09.05.2021, 01:21:21

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25573
  • Letzte: 7Delta
Statistiken
  • Beiträge insgesamt: 734150
  • Themen insgesamt: 59153
  • Heute online: 419
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 6
Gäste: 387
Gesamt: 393

Autor Thema:  Linux Mint 13 Maya: "could not write bytes: broken pipe" nach dem Booten  (Gelesen 2371 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo zusammen,
ich bin Linux Anfänger und spiele seit einigen Tagen mit Linux Mint 13 Maya 32bit & Mate herum.
Habe Windows XP und Linux auf dem Rechner. Leider erscheint nach dem Booten nicht der Anmeldebildschirm von mdm,
sondern oben rechts "could not write bytes: broken pipe" und sonst gar nichts. Der Monitor zeigt in diesem Fall tty7 an.
Ich muss dann erst "Strg+Alt+F8" drücken, um zum Login-Menü auf tty8 zu kommen.

Wenn ich im Recovery-Modus boote und dann den Boot-Vorgang fortsetze, passiert das nicht. Der Monitor zeigt am Ende des Bootens
normal das Login-Display von mdm.

Was kann ich tun?

1. Warum erscheint auf tty7 "could not write bytes: broken pipe" ?
2. Warum erscheint das Login auf tty8 ?
3. Gibt es evtl. eine Möglichkeit (vielleicht per startup-Script?) auf dem Monitor direkt das Login-Display zu sehen?

Nun bin ich gespannt auf Eure TIpps, Gruß,
eppi

Nachsatz:
Habe in in /var/log/ConsoleKit/history folgendes gefunden:
1348421985.414 type=SEAT_SESSION_ADDED : seat-id='Seat1' session-id='Session1' session-type='' session-x11-display=':0' session-x11-display-device='/dev/tty8' session-display-device='' session-remote-host-name='' session-is-local=TRUE session-unix-user=1000 session-creation-time='2012-09-23T17:39:45.408543Z'

Kann man den Wert für session-x11-display-device irgendwie ändern?
« Letzte Änderung: 23.09.2012, 21:15:55 von eppi »

Zitat
could not write bytes: broken pipe
Das ist ein bekannter Bug, erscheint hier auch, daher glaube ich, das dein Problem woanders liegt.
Denn das System fährt trotzdem hoch, nicht nur bei mir.
Der X-server ist bei Mint immer auf tty8, warum auch immer.

Danke für die Antwort DocHifi.

Aber was ist mit
1348421985.414 type=SEAT_SESSION_ADDED : seat-id='Seat1' session-id='Session1' session-type='' session-x11-display=':0' session-x11-display-device='/dev/tty8' session-display-device='' session-remote-host-name='' session-is-local=TRUE session-unix-user=1000 session-creation-time='2012-09-23T17:39:45.408543Z'in /var/log/ConsoleKit/history ?

Kann man den Wert für session-x11-display-device irgendwie ändern?

Da kann ich leider nichts zu sagen, sorry. :(

djeli

  • Gast
Zitat
could not write bytes: broken pipe
Kommt bei mir auch ab und an (nicht jedesmal),läuft aber alles normal weiter.

Zitat
Kann man den Wert für session-x11-display-device irgendwie ändern?
Leider auch kein wissen darüber. Sorry

Bei mir kommt diese Meldung häufiger beim Herunterfahren, nie beim Booten. Der Rechner fährt dann aber trotzdem herunter. Ich habe das beobachtet auf meinem Notebook (LM 13 Cinnamon, 64 Bit) und auf meinem Desktop (LM 13 Xfce, 64 Bit).

Zitat
Bei mir kommt diese Meldung häufiger beim Herunterfahren, nie beim Booten.
Das ist die Meldung vom hochfahren, aber die siehst du da  erst beim runterfahren,
Weil dann der Xserver weg ist, vorher wird sie vom Bootsplash verdeckt.
Wenn man den weg nimmt, so wie bei mir, sieht man es,
Wobei sie bei mir zur Zeit nicht mehr auftaucht.
« Letzte Änderung: 25.09.2012, 10:38:30 von DocHifi »