Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.04.2021, 03:30:50

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 729653
  • Themen insgesamt: 58863
  • Heute online: 407
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 1
Gäste: 388
Gesamt: 389

Autor Thema: [gelöst]  Installation LM17.1 auf Acer-Notebook im UEFI-Mode klappt nicht  (Gelesen 3510 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Installation LM17.1 auf Acer-Notebook im UEFI-Mode klappt nicht
« am: 06.03.2015, 09:54:24 »
Installation LinuxMint im UEFI-Modus klappt nicht

Ich nutze schon lange Linux, zuerst Suse, dann Unbuntu, aber halt als Anwender. Nun freue ich mich auf das LinuxMint, das ich erstmal auf meinem neuen Notebook installieren will, nur leider klappt die Installation nicht.

Ich möchte "linuxmint-17.1.cinnamon-64bit.iso" auf meinem Notebook (acer aspire E11,  E3-111-C3W0) installieren, parallel zu Win8.1.

Zuerst habe ich es im Boot-Modus "legacy" probiert.

Nach einigen Versuchen ist das GRUB-Menü erschienen und ich konnte Mint installieren. Dabei habe ich bei der Installation die Festplatte manuell partitioniert ("etwas anderes"). Aber der "legacy"-Modus bootet unzuverlässig: in mehr als 50% der Fälle funktioniert beim Hochfahren die Tastatur im GRUB-Menü nicht, auch bietet GRUB keine Möglichkeit, Win8 zu starten. Wenn ich es dann geschafft habe, das installierte Mint laufen zu lassen und es beende, dann bleibt mein Notebook stehen bei der Zeile "will halt now". Ausschalten muß ich dann von Hand(!). Mein Fazit: mein Notebook funktioniert nicht richtig mit legacy, Win8 ist nicht erreichbar. Offenbar habe ich die volle Funktion meines Notebooks nur mit UEFI.

Installationsversuche mit Boot-Modus UEFI

UEFI-Einstellungen im Acer-Boot-Setup: Unter "Security" steht "Secure Boot Mode : Standard". Das wird in schwarzer Schrift angezeigt und ist nicht veränderbar. Unter "Boot" steht "Secure Boot: [enabled]" auch in schwarzer Schrift, ist auch nicht veränderbar.

Weil mir das DVD-Laufwerk zum Probieren zu langsam ist, habe ich die Iso-Datei mit "isotousb.exe" auf meinen USB-Stick geladen. Der USB-Stick verhält sich nach meiner Beobachtung genauso wie das CD/DVD-Laufwerk.

Mit F12 erreiche ich beim Booten das Auswahl-Menü des Boot-Mangers, so dass ich vom USB-Stick aus booten kann. Dann erscheint das Grub-Menü mit der Überschrift: "GNU GRUB version 2.00-7ubuntu11", während beim Booten im legacy-Mode stets "GNU GRUB Version 2.02~beta2-9ubuntu1" erschien. Bei allen 3 Auswahl-Balken
   "Start Linux Mint"
   "compatibility mode"
   "check integrity"
          (auch hier wird Win8 nicht aufgeführt)
wird der USB-Stick kurz aktiviert, anschließend bleibt er stehen. "Hundert mal probiert", es ist kein Weiterkommen. Die DVD verhält sich genauso.

Alternativ kann ich das Grub-Auswahl-Menü z.B. mit "c"=command-line verlassen. Dann erscheint "grub>". Gebe ich dann "halt" ein, fährt der Rechner runter und schaltet sich aus.

Warum bricht die Installation ab? Könnte ich z.B. das Grub-Menü mit "e" verlassen, um die  setup-Befehle zu verändern? Wie verändern?

Oder liegt es am "Secure Mode"? Wie kann ich diese Einstellung im Boot-Menü verändern?

Ich bin dankbar für Hinweise!

Solpra
« Letzte Änderung: 06.03.2015, 21:20:25 von solpra »

Kann Dir leider nicht direkt helfen, da ich aus der Windows-Welt raus bin  ;D , habe aber das gefunden:

http://wiki.ubuntu-forum.de/index.php?title=Benutzer:Klaus_P#Kleiner_Leitfaden_zur_Installation_auf_UEFI-Rechnern

vielleicht hilft es.  :)

Hallo nativeworld,

es hat geklappt!
in Deinem Link fand ich den entscheidenden Hinweis:
"Möglicher Weise muss erst ein Security-Passwort eingerichtet werden bevor es(=SecureBoot) deaktiviert werden kann (z.B. bei Acer-NB-Modellen)."
Ich habe in den Boot-Einstellungen ein Supervisor Password eingegeben, anschließend konnte ich die Einstellung vornehmen "Secure Boot : disabled". Und dann lief es!!!
Auch Windows 8.1 kann ich nun im Grub-Menü starten.
Herzlichen Dank für Deinen Hinweis!

Noch ein kleiner Nachtrag:
* Wie in anderen Hinweisen angegeben hatte ich in Win8.1 "Fastboot" bzw. "Schnellstart" ausgeschaltet.
* In Win8.1 habe ich in den Energiespar-Einstellungen bei der Eingabe zum Ausschalten auf "Herunterfahren" gestellt, die Einstellung stand auf "Ruhezustand".
* Bei der manuellen Partitionierung hatte ich nur eine Partition als "logisch" definiert (home). Insgesamt habe ich 9 Partitionen, wobei 5 Partitionen von Win8.1 beansprucht werden, LinuxMint hat die Partitionen swap, root, home und bios-grub. Ich war unsicher, ob ich das so richtig ist, aber es funktioniert.

solpra

Mit UEFI kenn ich mich auch nicht aus, aber sicher ist das Mint nicht mit Secure Boot funktioniert.

Wenn du das nicht auf disable stellen kannst wir die Installation nicht funktionieren.
Du könntest dir mal ein Ubuntu Live-System brennen das sollte auch mit Secure Boot installierbar sein.

Ansonsten soll der Link den nativeworld gepostet hat gut Info's liefern.


Wunderbare Sache und viel Spaß mit Linux.
Auf das es nur noch wenig Gründe gibt, in Zukunft Win starten zu müssen...  ;)

Prima! Dann setze bitte noch ein Gelöst: dazu den 1. Beitrag "ändern" und das Präfix setzen. Dann sehen andere gleich, dass hier keine Hilfe mehr erforderlich ist.

Zitat
Dann setze bitte noch ein Gelöst:
Das kann nur der TE, das kommt davon, wenn andere sich an Beiträge anhängen.

Mit UEFI kenn ich mich auch nicht aus, aber sicher ist das Mint nicht mit Secure Boot funktioniert.

das ist blödsinn.. mein mein aldi-akoya-notebook funktioniert sehr gut mit eingeschaltetem secure-boot..
man muss nur dem nv-ram den passenden schlüssel, ersatzweise hash, zufügen...

Klar ich kann auch das Uefi ausbauen und durch ein Bios ersetzen, aber das ist nicht der einfache und übliche Weg.
Grundsätzlich kann LM nicht mit SecureBoot installiert werden.