LMU - Das Hilfe Forum für Linux Mint

Erste Schritte - erste Probleme => Newbie Fragen => Thema gestartet von: pmm am 02.07.2018, 20:29:43

Titel: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 02.07.2018, 20:29:43
LM19 Cinnamon Neuinstallation auf SSD

Habe auf meinem Läppi heute früh die HDD gegen eine 850EVO SSD getauscht. Beides waren 500GB. Auf der HDD lief vorher LM18.3 Cinnamon.
Habe mir die neueste ISO geladen und gebrannt die hier https://www.linuxmintusers.de/index.php?topic=49491.0 (https://www.linuxmintusers.de/index.php?topic=49491.0) verlinkt ist.
Schon beim Booten der DVD kamen dieverse Fehlermelungen (habe ich natürlich vergessen) aber der Bootvorgang ging nach einiger Zeit weiter und ich konnte die Installation starten.
Wie auch vorher auf der HDD mit LM18.3 habe ich die Standardinstallation mit LUKS gewählt die FP wie vorgeschlagen eingeteilt übernommen. Auch die Option persönliches Daten verschlüsseln habe ich wie vorher gewählt.
Nach Installation den Neustart vorgenommen und es startete nicht sofort wie nach 18.3 die LUKS abfrage sonder ein Menü mit 4 Optionen, u. a. Linux starten MEM test usw. Habe Linux starten gewählt. Es dauerte .... aber irgendwann kam die Anmeldeabfrage für den Benutzer, dann ....... bald mal der Desktop.
Bis hierhin dachte ich noch naja erster Start wird vllt. noch etwas konfiguriert.
Eben noch einmal gestartet und die Zeiten genommen.

ca. 2´20" bis zur LUKS Abfrage
+ 1´50" bis zum Anmeldebildschirm
+ 2´40" bis zum LM Bildschirm aber ohne Icon
+ 1´20" bis der Desktop zur Verfügung stand.
Macht Summa etwas über 7 Minuten >:(
Einziger Unterschied vorher/nachher HDD->SSD LM18.3 Cinnamon->LM19 Cinnamon.
Es besteht zwar die Möglichkeit das die SSD alles so langsam macht, allein mir fehlt der Glaube. Leider sehe ich auch während des Bootvorgang nicht ob es an einer Stelle hakt. Gibt es einen Log-File? Oder kann ich einen generieren der während des bootens protokolliert um einen mögliche Fehler zu entdecken?
Sonst vllt. eine Idee woran es liegen kann?
Möchte eine Installation vom LM18.3 auf die SSD noch vermeiden.
Beim Beenden erscheinen auch kurz 2 Zeilen mit Meldung. Leider nur Handyfoto.
Danke schon mal für Hilfe.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: Notiz am 02.07.2018, 20:36:29
Falls bei Dir Kernel 4.15.0-24.26 läuft, boote mal mit einem älteren Kernel.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: aexe am 02.07.2018, 22:27:58
Wenig Information, selbst wenn man viel überflüssiges Beiwerk (654 kB) weg lässt.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 03.07.2018, 06:06:31
Wenig Information, selbst wenn man viel überflüssiges Beiwerk (654 kB) weg lässt.

Deshalb hatte ich gefragt ob es eine Möglichkeit gibt ein Logfile zu erstellen beim Booten. Dann hätte ich vllt. relevantere Infos.
Und das Beiwerk sollte den Unterschied verdeutlichen zwischen LM18.3 & LM19 inkl. der Vorgehensweise bei der Installation und der verwendeten bzw. der geänderten HW.
Leider war während des Bootvorgangs und des Beendens keine anderen Bildschirmausgaben sichtbar als der gelieferte.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 03.07.2018, 06:13:37
Falls bei Dir Kernel 4.15.0-24.26 läuft, boote mal mit einem älteren Kernel.

Es läuft 4.15.0-23 als aktiv.
Vorhanden sind ausserdem 4.15.0-20
und 4.15.0-22 als installiert.
Weitere Kernel ausserhalb der 4.15er Reihe sind nicht vorhanden.
 ;) Wie kann ich denn überhaupt gezielt einen anderen Kernel wählen? Ich habe mal 4.15.0-20 "installiert". Aber wie bekomme ich den z. B. auf aktiv?
Danke
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: aexe am 03.07.2018, 06:16:35
https://www.linuxmintusers.de/index.php?action=wiki;page=Auf_einen_%C3%A4lteren_Kernel_zur%C3%BCck_gehen
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: quattro175 am 03.07.2018, 08:54:07
Hallo,

ich hatte das gleiche Problem mit der langen Boot-Phase und als Übeltäter die "Verschlüsselung der persönlichen Daten" (das Häkchen bei der Installation) ausgemacht. Habe deshalb nochmal neu installiert ohne Verschlüsselung und siehe da, die Boot-Zeiten mit der SSD sind wieder wie zu 18.3-er Zeiten!
Ich habe mir leider die Fehlermeldung nicht gespeichert, aber es war etwas mit "EncFS", das nicht sofort gestartet werden konnte. Vielleicht hat ja jemand der Erfahrenen hier einen Tipp - braucht es bei der Option ggf. eine weitere Partition?
Habe momentan keinen Zugriff auf meinen Rechner, aber werde heute Abend nochmal reinschauen...

Gruß,
Daniel

Nachtrag: Unter 18.3 hatte ich meine Daten auch verschlüsselt, allerdings dort noch mit einer separaten home-Partition. Den diversen Fürsprachen folgend und weil ich auch schon einmal Platzprobleme hatte, habe ich für 19 nur noch eine große EXT4-Partition. Nebendran ist noch eine WIN10-Installation (brauche ich leider noch immer für z.B. iTunes... :-/ )
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 03.07.2018, 14:55:32
https://www.linuxmintusers.de/index.php?action=wiki;page=Auf_einen_%C3%A4lteren_Kernel_zur%C3%BCck_gehen

 :) Danke habe über "anderen kernel aktivieren" deinen link nicht gefunden, oder heute früh übersehen.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 03.07.2018, 15:00:45

ich hatte das gleiche Problem mit der langen Boot-Phase und als Übeltäter die "Verschlüsselung der persönlichen Daten" (das Häkchen bei der Installation) ausgemacht. Habe deshalb nochmal neu installiert ohne Verschlüsselung und siehe da, die Boot-Zeiten mit der SSD sind wieder wie zu 18.3-er Zeiten!


Wie kommt man auf so eine Vermutung! Oder gab es irgendwo einen Hinweis? Hattest Du auch die gesamte FP verschlüsselt, z. B. mit LUKS?
Und eine Frage dazu ..... kann ich "persönliche Daten" nachträglich entschlüsseln oder geht das nur über die Deaktivierung bei einer Neuinstallation? :(
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: quattro175 am 03.07.2018, 21:41:57
Ich habe jetzt zu Dokumentationszwecken nochmal mit der "offiziellen" ISO (Kernel 4.15.0-20) neu installiert und bei den Abfragen zu User, Computername etc. das Häkchen gesetzt: "Persönliche Daten verschlüsseln". Im Partitionierungsbereich habe ich nicht die Möglichkeit dieses auszuwählen, weil ich zum einen nur eine Partition für LM19 frei habe und WIN10 bereits installiert ist. Ich müsste die Festplatte komplett löschen, um dort die Auswahl zur Verschlüsselung zu haben.
Der erste Systemstart von der Platte mit dem Originalkernel funktioniert zeitlich noch ok. Ging heute m.E. etwas schneller als gestern, aber ich habe es nicht gestoppt. Hole ich mir dann die verfügbaren Aktualisierungen inkl. Kernel 4.15.0-24 habe ich die deutliche Zeitverzögerung beim Systemstart!

@pmm: Fündig geworden bin ich in den "Protokollen" (einfach im Menü aufrufen): Da stand ziemlich häufig der Satz "Failed to start Cryptography Setup for cryptswap1." Das hat mich auf die Idee mit dem Häkchen bei der Verschlüsselung gebracht...

Ich werde also auch wieder auf den Start-Kernel zurück gehen, in der Hoffnung, das alsbald eine Lösung für das Problem gefunden wird. Ohne Verschlüsselung (hatte ich aufgrund des Fehlers danach ja gemacht) funktionierte bei mir der 24er Kernel aber ohne Probleme!
Ich hänge mal meine Fehlermeldungen aus dem systemd-Protokoll an, vielleicht hat ja jemand eine Idee. Anmerkung hierzu: Ich habe keine separate SWAP-Partition eingerichtet, wofür auch immer "cryptswap1" sonst nötig sein soll...  :o

Edit:
Ich muss meine Aussage leider revidieren: auch der 20er Kernel braucht nun als Standard eingerichtet lange zum Booten und im Protokoll tauchen die gleichen Fehlermeldungen auf... Also Neuinstallation ohne Verschlüsselung und für die wirklich sensiblen Daten nutze ich wieder Cryptkeeper.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: OlliFri am 04.07.2018, 00:53:34
Habe nach langen stöbern im Netz, im Debian Forum einen interessanten Post gefunden. Dem nach braucht man nur
sudo apt install havegedinstallieren und der Spuck ist vorbei.
Bei mir hat es voll gefunzt.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: helli am 04.07.2018, 01:26:58
Zitat
Da stand ziemlich häufig der Satz "Failed to start Cryptography Setup for cryptswap1."
Ich vermute, dass in der Datei /etc/crypttab eine UUID gespeichert war, die es auf dem Rechner nicht gab und es wurde 1 1/2 Minuten nach der Partition gesucht.

Hab eben mal Mint 19 mit verschlüsseltem Benutzerverzeichnis ohne Swap-Partition mit /swapfile installiert.
Die /etc/crypttab wird falsch angelegt und Swap funktioniert nicht:
vorher:
cryptswap1 /target/swapfile /dev/urandom swap,offset=1024,cipher=aes-xts-plain64

nachher:
cryptswap1 /swapfile /dev/urandom swap,offset=1024,cipher=aes-xts-plain64
Nun funktioniert Swap.
Allerdings hängt der Rechner noch ziemlich lange bei "Scanning for Btrfs filesystem.
Dagegen hat auch sudo apt install haveged nicht geholfen.
So, mühsam ernährt sich das Eichhörnchen, btrfs-tools und btrfs-progs gepurget und wieder etwas schneller.
Aber der Hänger gefällt mir noch nicht:
[    3.582605] Console: switching to colour frame buffer device 170x48
[    3.647369] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   36.194798] random: crng init done
[   41.301428] EXT4-fs (sda9): mounted filesystem with ordered data mode. Opts: (null)
Auch das wäre gelöst, es liegt an der Kernelversion, mit 4.4.0-130-generic habe ich den Hänger nicht.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: aexe am 04.07.2018, 03:24:21
Habe nach langen stöbern im Netz, im Debian Forum einen interessanten Post gefunden.
Ein Link dahin?
Das ist ja wirklich eine merkwürdige Sache.
Apt sagt dazu:
Zitat
haveged ist ein Userspace-Daemon zur Bereitstellung von Entropie.
Er hängt nicht von den Standardmechanismen zur »Ernte« von Zufälligkeit zur Füllung
des System-Entropiepools ab. Das ist wichtig für Systeme mit hohen Entropieanforderungen oder beschränkter Benutzerinteraktion (z.B. Server ohne Anzeigegeräte [headless]).

haveged verwendet HAVEGE (Hardware Volatile Entropy Gathering und Expansion) zur Wartung eines 1M großen Pools von zufälligen Bytes, um /dev/random zu füllen, wenn die Versorgung mit zufälligen Bits in /dev/random unter die untere Schranke des Geräts fällt.

Weitere Informationen über HAVEGE finden Sie unter
[url]http://www.irisa.fr/caps/projects/hipsor/[/url]
Ich will jetzt nicht bezweifeln, dass die Installation dieser Software eine Besserung gebracht hat.
Aber warum ist die plötzlich notwendig für einen ordentlichen Systemstart?
Früher ging es ja auch ohne sie. Da war doch dann offenbar genügend "Entropie" zur Verfügung und Randomisierung hat auch funktioniert.
Ob das mit Schutzmaßnahmen gegen Spectre & Co zu tun hat?
Erscheint mir völlig irre, die Sache, das übersteigt mein nächtliches Begriffsvermögen.
Aber ich gestehe, dass ich schon Probleme damit habe, zu verstehen, was Entropie ist.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: quattro175 am 04.07.2018, 08:18:02
@helli:
Die "etc/crypttab" wird ja bei der Installation vermutlich selbständig angelegt. Wie kann es dann zu einer falschen UUID kommen? Ich habe ja auf eine frisch angelegte Partition installiert.
Aber wenn ich dich richtig verstehe, kann ich mit installiertem "haveged" mein Zeit-Problem lösen, BtrFS benutze ich nicht. Oder wird trotzdem danach gesucht?

@aexe:
Zitat
...zur Wartung eines 1M großen Pools von zufälligen Bytes, um /dev/random zu füllen, wenn die Versorgung mit zufälligen Bits in /dev/random unter die untere Schranke des Geräts fällt.

Ohne jetzt philosophieren zu wollen, aber das könnte z.B. erklären, warum es die Sache beschleunigt, die Maus zu bewegen, sprich Zufallsdaten zu erzeugen, siehe hier: https://www.linuxmintusers.de/index.php?topic=49521.msg690875#msg690875 (https://www.linuxmintusers.de/index.php?topic=49521.msg690875#msg690875)
Aber befriedigend ist das nun wirklich nicht...  ;D
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: helli am 04.07.2018, 08:50:09
Zitat
Die "etc/crypttab" wird ja bei der Installation vermutlich selbständig angelegt.
Ja, aber bei mir wurde sie falsch angelegt und wir hatten hier auch einen Fall, da ging es nicht um /swapfile, sondern es war eine falsche UUID für die Swap-Partition eingetragen. Ich habe keine Ahnung, weshalb das System solche Fehler macht.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 04.07.2018, 09:04:59
Guten Morgen,
habe gestern noch einmal das Läppi gestartet wobei mir nach kurzer Zeit häufige FP Zugriffe aufgefallen sind obwohl das Ding nur einfach rumstand. Habe eine Seite in FF aufgehabt und mir dann die Auslastungen angesehen (Bilder).
Es ist zwar nicht das schnellste aber die Anzeigen find ich bedenklich ::)
Dazu heute mal nach dem Start direkt das Protokoll aufgerufen und den Inhalt von "wichtig" entnommen (s. Text).

08:37:59 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:37:39 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:37:28 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:37:08 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:36:58 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:36:37 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:36:27 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:36:06 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:35:55 pulseaudio: [pulseaudio] pid.c: Daemon already running.
08:35:54 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:35:34 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:35:24 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:35:22 cinnamon-sessio: CRITICAL: t+60,88787s: We failed, but the fail whale is dead. Sorry....
08:35:13 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:35:03 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:34:53 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:34:32 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:34:20 kernel: Error parsing options; rc = [-2]
08:34:20 kernel: Could not find valid key in user session keyring for sig specified in mount option: [5de76133ba09d9e0]
08:32:44 lightdm: PAM adding faulty module: pam_kwallet5.so
08:32:42 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:32:21 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:32:11 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:31:50 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:31:39 wpa_supplicant: dbus: Failed to construct signal
08:31:36 kernel: acer_wmi: Unsupported machine has AMW0_GUID1, unable to load
08:31:35 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:31:35 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:31:35 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
08:31:35 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
08:31:35 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:plane A] flip_done timed out
08:31:35 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
08:31:35 kernel: [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:plane A] flip_done timed out
08:31:35 kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
Sind auf jeden Fall genügend Fehlermeldungen dabei.
Vllt. kann ja jemand damit was anfangen, mir als Anfänger hilft das nichts.
Habe auch die HDD mit LM18.3 Cinnamon 64 noch. Notfalls kann ich falls gewünscht die noch einmal einbauen und das Log zum Vergleich produzieren wenn es hilft (muss aber nicht sein  :D)
Den Tip von OlliFri sudo apt install haveged habe ich noch nicht testen können.

Sonnigen Tag noch
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 04.07.2018, 09:11:58

Die /etc/crypttab wird falsch angelegt und Swap funktioniert nicht:
vorher:
cryptswap1 /target/swapfile /dev/urandom swap,offset=1024,cipher=aes-xts-plain64

nachher:
cryptswap1 /swapfile /dev/urandom swap,offset=1024,cipher=aes-xts-plain64


Bei mir sieht das so aus sdb5_crypt UUID=8942caa5-e66a-406e-aa82-8dbffb2fc371 none luks,discard
cryptswap1 UUID=fef89b13-0938-4160-893d-681298e50a31 /dev/urandom swap,offset=1024,cipher=aes-xts-plain64
Was auch immer mir das nicht sagt  ;)
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: helli am 04.07.2018, 09:19:22
Poste bitte mal die Ausgabe von
sudo blkiddann kann ich dir zuminest sagen, ob die 2. Zeile richtig ist.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: DJ-Bino am 04.07.2018, 12:12:09
Hallo,
 
auch ich hatte bis eben das Problem mit dem langsamen   
Bootvorgang nach dem Kernel-Update. 
 
Mir hat der Tipp mit der Installation von haveged sehr geholfen.
Nichts desto trotz sehe ich es wie einige andere User auch, dass
es vor dem Update dieses Problem nicht gab.
 
Beim mir läuft Linux Mint 19 auf einem Acer Aspire VN7-591G Laptop. 
/dev/sda1: UUID="367ba6ba-02c3-49ce-b928-b0b53c823216" TYPE="swap" PARTUUID="f270cc53-01"
/dev/sda2: UUID="b8c2cfb4-a7b7-4123-b55d-cfd6c889d428" TYPE="ext4" PARTUUID="f270cc53-02"
/dev/sdb1: LABEL="DATEN" UUID="fb1de87f-53b9-42c3-a542-5b076e6f2e2b" TYPE="ext4" PARTUUID="e339ec3b-01"
 
Es ist nichts verschlüsselt. 
 
 
Gruß 
Dieter 



Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: quattro175 am 04.07.2018, 20:57:36
Ich nähere mich allmählich wieder dem Optimum an Bootzeit.  ;D
Viele Schritte führten zum Ziel. Ich habe nochmals neu installiert mit der von mir bereits beschriebenen Option der "verschlüsselten persönlichen Daten". Neustart wird anschließend wieder extrem zäh, die Kernel-Updates verschlechtern die Sache noch.
Von Clem himself kam in den Kommentaren zum inzwischen möglichen Upgrade 18.3->19 folgende Aussage:
Zitat
July 4, 2018 at 2:43 pm
Check if /etc/initramfs-tools/conf.d/resume contains a UUID which doesn’t exist (you can list your UUIDs with “blkid”). If it does, remove this file. This is known to cause boot delays.
Other than that, don’t hesitate to use “systemd-analyze critical-chain” to troubleshoot your boot sequence.
In der "resume" stand bei mir tatsächlich eine UUID, die es auf meinem System nicht gibt, also Datei gelöscht. Hat aber nicht viel geholfen.
Nächster Schritt war die Installation von "haveged" - wesentliche Beschleunigung des Bootvorgangs!!
Und letzter Schritt schließlich die von Helli beschriebene falsch erstellte "crypttab".
Nach der langen Reise sieht mein Startprotokoll nun so aus: (nicht an den Uhrzeiten stören, habe die Uhr noch nicht justiert)
22:30:06 pulseaudio: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
22:29:40 kernel: Error parsing options; rc = [-2]
22:29:40 kernel: Could not find valid key in user session keyring for sig specified in mount option: [ded3fc902cde6f84]
22:29:37 lightdm: PAM adding faulty module: pam_kwallet5.so
22:29:35 wpa_supplicant: dbus: Failed to construct signal

Hat eventuell noch jemand eine Idee bezüglich des Pulseaudio-Fehlers? Ich werde daraus nicht schlau...
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 05.07.2018, 07:13:26
Poste bitte mal die Ausgabe von
sudo blkiddann kann ich dir zuminest sagen, ob die 2. Zeile richtig ist.
[/quote

bitte
medion@medion-laptom:~$ sudo blkid
[sudo] Passwort für medion:
/dev/mapper/sdb5_crypt: UUID="0v0DOH-lLWi-Tzbf-bPyD-eUMe-LL2M-kH1NJe" TYPE="LVM2_member"
/dev/mapper/mint--vg-root: UUID="5ab2338e-a4a1-4670-84c2-c8aeaf801cc9" TYPE="ext4"
/dev/sdb1: UUID="7dd0b985-5df4-4811-b4ee-d2e7c7d8e17f" TYPE="ext4" PARTUUID="64ff2bac-01"
/dev/sdb5: UUID="8942caa5-e66a-406e-aa82-8dbffb2fc371" TYPE="crypto_LUKS" PARTUUID="64ff2bac-05"
/dev/mapper/mint--vg-swap_1: UUID="fef89b13-0938-4160-893d-681298e50a31" TYPE="swap"
/dev/mapper/cryptswap1: UUID="284d05a2-ae7e-4da9-aaac-b624e13ffbf3" TYPE="swap"
medion@medion-laptom:~$


Als Bemerkung vlt. Der Startvorgang bis LUKS dauert ähnlich lange (nun aber von SSD) wie auch bei LM18.3 Cinnamon (noch mit HDD). Die längste Wartezeit entsteht bei mir mMn nach der Eingabe bei der Anmeldung am Desktop.
 :D ja ich weiß, sollte auch medion-laptop und nicht laptom heißen. Hoffe das auch ändern zu können.

Mmmhh irgendwie erscheint mein zusätzlicher Text auch im Code-Block?
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: helli am 05.07.2018, 07:41:18
Hast ja sicher schon selbst gesehen, die UUID in deiner crypttab sind richtig.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 06.07.2018, 05:35:15
Hast ja sicher schon selbst gesehen, die UUID in deiner crypttab sind richtig.

 :D Der war jetzt wirklich gut.
Aber vielen Dank für das Vertrauen in meine (nicht wirklich vorhandene) Kompetenz.
Aber im Ernst, als Neubenutzer von Linux sehe ich das leider nicht ..... aber ich verlasse mich mal darauf das deine Aussage zutrifft.
Behebt damit natürlich nicht das grundsätzliche Problem vieler. Bekomme für mein Medion Laptop wohl dieses WE 8GB RAM (derzeit 3GB) und werde dann noch einmal LM19 Cinnamon ohne LUKS und ohne Verschlüsselung des priv. Verzeichnisses installieren.
Ergebniss werde ich wohl Anfang nächster Woche mitteilen können.

Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: helli am 06.07.2018, 07:49:44
sdb5_crypt UUID=8942caa5-e66a-406e-aa82-8dbffb2fc371 none luks,discard
cryptswap1 UUID=fef89b13-0938-4160-893d-681298e50a31 /dev/urandom swap,offset=1024,cipher=aes-xts-plain64
habe ich mit
/dev/sdb5: UUID="8942caa5-e66a-406e-aa82-8dbffb2fc371" TYPE="crypto_LUKS" PARTUUID="64ff2bac-05"
/dev/mapper/mint--vg-swap_1: UUID="fef89b13-0938-4160-893d-681298e50a31" TYPE="swap"
und bin so zu dem Schluss gekommen.
Ich habe aber nicht auf
/dev/mapper/cryptswap1: UUID="284d05a2-ae7e-4da9-aaac-b624e13ffbf3" TYPE="swap"geachtet und bin mir nun nicht mehr ganz sicher.

Bei mir sieht der Eintrag in der crypttab so aus
cryptswap1 /swapfile /dev/urandom swap,offset=1024,cipher=aes-xts-plain64Da steht auch nicht die UUID von
/dev/mapper/cryptswap1: UUID="63249324-405d-4864-9351-fd85dbd2e9ae" TYPE="swap"drin, die gehört wohl doch nicht in die crypttab.

Eben mal ausprobiert, da sucht das System zusätzlich beim Start 1 1/2 Minuten nach swap.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 06.07.2018, 15:32:55
@helli

meine crypttab sieht ja so aus
sdb5_crypt UUID=8942caa5-e66a-406e-aa82-8dbffb2fc371 none luks,discard
cryptswap1 UUID=fef89b13-0938-4160-893d-681298e50a31 /dev/urandom swap,offset=1024,cipher=aes-xts-plain64
möchte gerne eine Änderung vornehmen um zu testen, bin aber nicht sicher was da raus soll oder was ich auskommentieren muss.
Weiteres Problem wird sein das die Datei schreibgeschützt erscheint wenn ich diese öffne. Und ich die Rechte nicht ändern kann/darf da die Datei root gehört :). Zumindest behauptet das Nemo + r. Maustaste.
Danke.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: helli am 06.07.2018, 15:51:24
Wenn du /etc durch Rechtsklick als Administrator öffnest und dann die crypttab öffnest, hast du erweiterte Rechte zum Bearbeiten der Datei.
Bei mir hat das Ändern aber zu einer zusätzlichen Verzögerung des Systemstarts geführt, weshalb ich nicht zum Ersetzen der UUID
fef89b13-0938-4160-893d-681298e50a31durch die blkid-Ausgabe für /dev/mapper/cryptswap1
284d05a2-ae7e-4da9-aaac-b624e13ffbf3raten würde, ich hab das dann auch wieder rückgängig gemacht.
Es war ja nur ein Versuch um zu ermitteln, ob eventull doch die UUID der /dev/mapper/cryptswap1 in die crypttab gehört.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 07.07.2018, 17:49:19
Wenn du /etc durch Rechtsklick als Administrator öffnest und dann die crypttab öffnest, hast du erweiterte Rechte zum Bearbeiten der Datei.
Bei mir hat das Ändern aber zu einer zusätzlichen Verzögerung des Systemstarts geführt, weshalb ich nicht zum Ersetzen der UUID
fef89b13-0938-4160-893d-681298e50a31durch die blkid-Ausgabe für /dev/mapper/cryptswap1
284d05a2-ae7e-4da9-aaac-b624e13ffbf3raten würde, ich hab das dann auch wieder rückgängig gemacht.
Es war ja nur ein Versuch um zu ermitteln, ob eventull doch die UUID der /dev/mapper/cryptswap1 in die crypttab gehört.


Vielen Dank

Dann Lasse ich das mit der Änderung und installiere nächste Woche noch einmal LM 19 neu und ohne Verschlüsselung der pr. Verzeichnisses.
Da ich ja sowieso LUKS auswähle und nur ich den alten Läppi nutze ist es rel. egal. Wollte halt nur testen ob es eben mit den pr. Verzeichnissen geht für den Desktop
der ja von mehreren genutzt wird.
Vllt. gibt's ja bald eine Lösung  :D für das langsame Starten.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: pmm am 11.07.2018, 08:31:52
LM19 Cinnamon
FP mit LUKS und persönliches Verz. verschlüsselt, habe den aktiven Kernel ....24 gegen -23 und -20 ausgetauscht. Brachte keinen sichtbaren Erfolg.
LM19 Cinnamon neu installiert mit LUKS "ohne" versch. pers. Verz., brachte auch nichts.
Beim booten der DVD erscheinen auch die bekannten Fehlermeldungen. Screenshot #0,
Dann wieder LM18.3 Cinnamon & LUKS ohne versch. persö. Verz. installiert. Ohne Fehlermeldung und mit guter Performance. Werde wohl erst einmal dabei bleiben und evtl. auf LM19 updaten ohne Neuinstallation je nachdem wie weit der Läppi bis dahin eingerichtet ist.
Mein Problem ist zwar nicht gelöst da ich gerne LM19 genutzt hätte aber es hat sich "erst einmal" erledigt  ;)
Mir fehlen die Kenntnisse um mich zu oft mit Linux zu beschäftigen. Mal was testen und ausprobieren nach Anweiung ist ja noch ganz OK .... aber hauptsächtlich sollte es einfach nur funktionieren.
Setze es auf erledigt.
Allen die geholfen haben mit Tipps & Tricks, Danke.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: Anatoll am 19.09.2018, 10:51:40
Klinke mich mal eben ein!
Linux Mint 19 Cinnamon "persönliches Verz. verschlüsselt" Problem bei der Startzeit. Habe das selbe Problem. Nun habe ich in einem Forum Hilfe bekommen und die schaute so aus.:

Habe es erst mit vim versucht was aber für mich als Anfänger zu hoch war also Standard-Texteditor und.:  sudo xed /etc/initramfs-tools/conf.d/resume
Dort steht/stand.:  RESUME=UUID= und lange Zahlenreihe
Ich hatte den Hinweiß erhalten die zu ändern in.:  RESUME=none= "Zahlenreihe löschen" wobei das "none" auch klein geschrieben werden musste.
Danach ebenfalls im Terminal.:  sudo update-initramfs -u
Ebenfalls danach.:  sudo reboot

Mein Systemstart lag bei ungefähr 100 Sekunden.
Jetzt liegt er bei 80 Sekunden.
System läuft stabil. Keinen blassen schimmer was da abgeht, ich habe als Neuling gar keine Ahnung, aber mit der Hilfe etwas Glück. Sorry, wollte es nur mal
berichten ...
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: Avoca am 19.09.2018, 21:02:37
Bei mir gab es ein ganz ähnliches Problem

durch
sudo nano /etc/default/grub
und deaktivieren der Ausblendungen:
GRUB_HIDDEN_TIMEOUT_QUIET=false
konnte man beim hochfahren direkt sehen wo genau es klemmt.
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: aexe am 19.09.2018, 21:41:19
GRUB_HIDDEN_TIMEOUT_QUIET=false konnte man beim hochfahren direkt sehen wo genau es klemmt.
Das halte ich für einen Irrtum.
Damit wird nur der unter GRUB_HIDDEN_TIMEOUT eingestellte Wert auf dem Monitor als Countdown angezeigt.
Mit der  ⇧ -Taste kann dann das Auswahlmenü innerhalb der Zeitspanne sichtbar gemacht werden.
https://wiki.ubuntuusers.de/GRUB_2/Konfiguration/#Bedeutung-der-Variablen

Text-Ausgaben beim Hoch- und Runterfahren bekommt man mit der Zeile: GRUB_CMDLINE_LINUX_DEFAULT="noplymouth"
Titel: Re: Neuinstallation von LM19 Cinnamon bootet extrem langsam
Beitrag von: Anatoll am 23.09.2018, 09:32:53
Bei mir gab es ein ganz ähnliches Problem

durch
sudo nano /etc/default/grub
und deaktivieren der Ausblendungen:
GRUB_HIDDEN_TIMEOUT_QUIET=false
konnte man beim hochfahren direkt sehen wo genau es klemmt.

Bei mir liegt es wohl auch daran das ich eine HDD Festplatte nutze und keine SSD, und somit wären die Zeiten bei mir normal!