Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
16.05.2021, 23:56:26

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25602
  • Letzte: zanu1947
Statistiken
  • Beiträge insgesamt: 735808
  • Themen insgesamt: 59256
  • Heute online: 818
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Startzeit System  (Gelesen 2906 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: Startzeit System
« Antwort #45 am: 05.04.2021, 15:28:19 »
Der Support für die Version 18 läuft ja jetzt aus. Mir bleibt nur noch die Hoffnung, dass noch jemand bei der Umstellung auf die neueste Version auch eine fast Verdopplung der Zeit im userspace hat (siehe Antwort #38) und die Ursache dann hier mitteilt. Mir gelingt es nicht, die Schwachstelle bei gleicher Hardware und fast gleicher installierter Software zu finden.

Re: Startzeit System
« Antwort #46 am: 09.04.2021, 14:39:25 »
Nach dem Einschalten des Rechners zeigte meine FritzBox (7.25) für heute ein Sendevolumen von 571 MB.
Das kostet sicher Zeit - werde das weiter beobachten.
Dieses Problem hatte ich schon einmal, auch mit Hilfe von AVM konnte ich es nicht lösen.

Re: Startzeit System
« Antwort #47 am: 09.04.2021, 19:39:49 »
Wie im Startbeitrag geschrieben, habe ich eine Zeitlücke von ca. 90 Sekunden gesucht, die inzwischen nur noch ca. 18 Sekunden beträgt.
Mal ein bisschen ins Blaue hinein geraten. Kann es sein, das ein fsck lief, während der 90 sec.? Der taucht imho nicht im systemd-analyze auf, weil das ja nur die Startzeiten der einzelnen units analysiert. Aufschluss sollte ein Blick ins journal geben. Dafür ist es auch hilfreich, wenn man die Bootmeldungen nicht mit irgendwelchen Bildchen zupflastert, denn dann kann man sofort sehen, wo es hängt.

Re: Startzeit System
« Antwort #48 am: 10.04.2021, 08:23:13 »
Bin für jeden Hinweis dankbar. Den Befehl 'sudo touch /forcefsck' hatte ich in der vorangegangenen Sitzung nicht gestartet. Die Aktualisierungsverwaltung läuft bei mir nicht automatisch.
Beim Start laufen in schneller Folge OK-Meldungen über den Bildschirm, dann bleibt er für etwa eine Minute dunkel bis der Startton kommt.
$ journalctl -b -p crit
-- Logs begin at Sun 2021-04-04 12:07:19 CEST, end at Sat 2021-04-10 08:15:27 CEST. --
-- No entries --
$ journalctl -b -p err
-- Logs begin at Sun 2021-04-04 12:07:19 CEST, end at Sat 2021-04-10 08:17:01 CEST. --
Apr 10 08:05:43 OP-390 pulseaudio[1516]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy bl>
Apr 10 08:11:26 OP-390 kernel: sd 4:0:0:0: [sdc] No Caching mode page found
Apr 10 08:11:26 OP-390 kernel: sd 4:0:0:0: [sdc] Assuming drive cache: write through
$ journalctl -b -p warning
-- Logs begin at Sun 2021-04-04 12:07:19 CEST, end at Sat 2021-04-10 08:17:23 CEST. --
Apr 10 08:04:06 OP-390 kernel: MDS CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/admin-guide/hw-vuln/mds.html for more details.
Apr 10 08:04:06 OP-390 kernel:   #3
Apr 10 08:04:06 OP-390 kernel: ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
Apr 10 08:04:06 OP-390 kernel: platform eisa.0: EISA: Cannot allocate resource for mainboard
Apr 10 08:04:06 OP-390 kernel: platform eisa.0: Cannot allocate resource for EISA slot 1
Apr 10 08:04:06 OP-390 kernel: platform eisa.0: Cannot allocate resource for EISA slot 2
Apr 10 08:04:06 OP-390 kernel: platform eisa.0: Cannot allocate resource for EISA slot 3
Apr 10 08:04:06 OP-390 kernel: platform eisa.0: Cannot allocate resource for EISA slot 4
Apr 10 08:04:06 OP-390 kernel: platform eisa.0: Cannot allocate resource for EISA slot 5
Apr 10 08:04:06 OP-390 kernel: platform eisa.0: Cannot allocate resource for EISA slot 6
Apr 10 08:04:06 OP-390 kernel: platform eisa.0: Cannot allocate resource for EISA slot 7
Apr 10 08:04:06 OP-390 kernel: platform eisa.0: Cannot allocate resource for EISA slot 8
Apr 10 08:04:06 OP-390 kernel: ata1.01: failed to resume link (SControl 0)
Apr 10 08:04:06 OP-390 kernel: ata2.01: failed to resume link (SControl 0)
Apr 10 08:04:06 OP-390 kernel: ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20190816/utaddress-204)
Apr 10 08:04:06 OP-390 kernel: ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20190816/utaddress-204)
Apr 10 08:04:06 OP-390 kernel: ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20190816/utaddress-204)
Apr 10 08:04:06 OP-390 kernel: ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20190816/utaddress-204)
Apr 10 08:04:06 OP-390 kernel: lpc_ich: Resource conflict(s) found affecting gpio_ich
Apr 10 08:04:06 OP-390 kernel: r8169 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
Apr 10 08:04:42 OP-390 kernel: kauditd_printk_skb: 13 callbacks suppressed
Apr 10 08:04:42 OP-390 udisksd[620]: failed to load module mdraid: libbd_mdraid.so.2: cannot open shared object file: No such file or directory
Apr 10 08:04:44 OP-390 udisksd[620]: Failed to load the 'mdraid' libblockdev plugin
Apr 10 08:05:01 OP-390 systemd[1]: kerneloops.service: Found left-over process 871 (kerneloops) in control group while starting unit. Ignoring.
Apr 10 08:05:01 OP-390 systemd[1]: This usually indicates unclean termination of a previous run, or service implementation deficiencies.
Apr 10 08:05:10 OP-390 systemd-resolved[564]: Using degraded feature set (UDP) for DNS server 192.168.178.1.
Apr 10 08:05:15 OP-390 postfix/postfix-script[1653]: warning: symlink leaves directory: /etc/postfix/./makedefs.out
Apr 10 08:05:43 OP-390 pulseaudio[1516]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy block>
Apr 10 08:05:58 OP-390 cinnamon-session[1569]: WARNING: t+37,01100s: Detected that screensaver has appeared on the bus
Apr 10 08:11:26 OP-390 kernel: sd 4:0:0:0: [sdc] No Caching mode page found
Apr 10 08:11:26 OP-390 kernel: sd 4:0:0:0: [sdc] Assuming drive cache: write through
Apr 10 08:11:27 OP-390 kernel: FAT-fs (sdc): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
Apr 10 08:11:57 OP-390 xdg-desktop-por[3801]: Failed to get application states: GDBus.Error:org.freedesktop.portal.Error.Failed: Could not get window list
Apr 10 08:12:39 OP-390 gnome-terminal-[2358]: g_menu_insert_item: assertion 'G_IS_MENU_ITEM (item)' failed
Apr 10 08:15:26 OP-390 gnome-terminal-[2358]: g_menu_insert_item: assertion 'G_IS_MENU_ITEM (item)' failed
Apr 10 08:16:08 OP-390 gnome-terminal-[2358]: g_menu_insert_item: assertion 'G_IS_MENU_ITEM (item)' failed
Apr 10 08:17:23 OP-390 gnome-terminal-[2358]: g_menu_insert_item: assertion 'G_IS_MENU_ITEM (item)' failed
Auch hier konnte ich im Internet keine Lösung für mein Problem finden.
« Letzte Änderung: 10.04.2021, 08:37:17 von OptiPlex »

Re: Startzeit System
« Antwort #49 am: 12.04.2021, 19:39:30 »
Den Befehl 'sudo touch /forcefsck' hatte ich in der vorangegangenen Sitzung nicht gestartet.
Ich weiß ja nicht, wie du dein System konfiguriert hast. Je nach Konfiguration läuft ein fsck periodisch beim Booten. Aber wenn du schreibst, dass du die Bootmeldungen verfolgst, würdest du sehen, wenn ein fsck stattfände. Wenn der Bildschirm schwarz bleibt, muss die Ursache woanders liegen. Ich würde mir mal das journal des entsprechenden Bootvorgangs in Ruhe und Gänze ansehen.
Ein weiterer Rateversuch: Schau dir mal /var/log/lightdm an.

Re: Startzeit System
« Antwort #50 am: 13.04.2021, 18:45:42 »
Habe an einem Tag nur einfache Dinge erledigt (Aktualisierung, E-Mail, Firefox, Hypnotix?, ...). An nächsten Tag konnte ich keine E-Mails abrufen, der Internet-Zugang war verloren gegangen. Dieses Problem muss ich erst lösen, siehe
https://www.linuxmintusers.de/index.php?PHPSESSID=bf0756ae9e26704d273d93983f78a5af&topic=68503.0
Vom USB-Stick boote ich das System in etwa einer halben Minute.
« Letzte Änderung: 14.04.2021, 13:21:50 von OptiPlex »

Re: Startzeit System
« Antwort #51 am: 15.04.2021, 15:08:53 »
Habe neu installiert - ohne weitere Einrichtung:
$ systemd-analyze
Startup finished in 6.545s (kernel) + 41.111s (userspace) = 47.656s
graphical.target reached after 41.093s in userspace
Siehe Antwort #38
==============================
Nach Installation meiner Anwendungen:
$ systemd-analyze
Startup finished in 6.290s (kernel) + 1min 7.355s (userspace) = 1min 13.645s
graphical.target reached after 1min 7.333s in userspace
« Letzte Änderung: 15.04.2021, 21:16:14 von OptiPlex »

Re: Startzeit System
« Antwort #52 am: 15.04.2021, 15:12:37 »
Ja, das ist normal so für eine Festplatte.

Re: Startzeit System
« Antwort #53 am: 16.04.2021, 15:40:16 »
Habe neu installiert, das Problem besteht aber weiter.
Frage: Soll ich hier weiter posten oder eine neues Thema eröffnen?

Re: Startzeit System
« Antwort #54 am: 16.04.2021, 19:52:39 »
Off-Topic:
Versuch mal über den Tip nachzudenken, eine SSD zu kaufen. Die Kleinen kosten um 20 €, die mit 500 GB hatte Tommix erst in einem anderen Thread zu 55 € verlinkt.
Du wirst mit der Startzeit deutlich herunter kommen, wenn Du eine SSD einsetzt. Grob wird das etwa eine Minute weniger sein. Dein guter I3 wird wieder eine gewaltige Wubdität entwickeln, die einen im ersten Augenblick wirklich überrascht.
Du kannst aber auch basteln und basteln und mit der Zeit etwas herunterkommen, wahrscheinlich aber auch irgendwie dein System wieder verbaseln. Der Aufwand, der dahinter steht, wird immens sein, aber man kann auch eine sehr steile Lernkurve haben.

Re: Startzeit System
« Antwort #55 am: 20.04.2021, 15:38:07 »
Suche nach der Ursache der deutlich längeren Startzeit zwischen 18.3 und 20.1, die sich wie nun ermittelt aus der Installation zusätzlicher Anwendungen, die ich auch in 18.3 mit Startzeit 39 sec installiert hatte, ergibt . Sicher bringt eine SSD einen Zeitgewinn, aber wie ermittle ich das Programm für die erhöhte Startzeit wie in Antwort #51 gezeigt?

Re: Startzeit System
« Antwort #56 am: 20.04.2021, 18:28:43 »
Anhaltspunkte haben wir dir doch einige geben. Umsetzen musst du das schon selbst, siehe z.B. Antworten 9, 32, 34 und 35.

Re: Startzeit System
« Antwort #57 am: 25.04.2021, 17:21:28 »
$ journalctl -b | grep failed
Apr 25 17:05:49 OP-390 kernel: acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
Apr 25 17:05:49 OP-390 kernel: ata1.01: failed to resume link (SControl 0)
Apr 25 17:05:49 OP-390 kernel: ata2.01: failed to resume link (SControl 0)
Apr 25 17:06:19 OP-390 systemd[1]: Starting GRUB failed boot detection...
Apr 25 17:06:20 OP-390 systemd[1]: Finished GRUB failed boot detection.
Apr 25 17:06:25 OP-390 thermald[649]: I/O warning : failed to load external entity "/etc/thermald/thermal-conf.xml"
Apr 25 17:06:25 OP-390 thermald[649]: [WARN]sysfs write failed /sys/devices/virtual/powercap/intel-rapl/intel-rapl:0/enabled
Apr 25 17:06:25 OP-390 thermald[649]: I/O warning : failed to load external entity "/etc/thermald/thermal-conf.xml"
Apr 25 17:06:25 OP-390 thermald[649]: I/O warning : failed to load external entity "/etc/thermald/thermal-conf.xml"
Apr 25 17:06:27 OP-390 udisksd[652]: failed to load module mdraid: libbd_mdraid.so.2: cannot open shared object file: No such file or directory
Apr 25 17:07:00 OP-390 dbus-daemon[632]: [system] Activation via systemd failed for unit 'dbus-org.bluez.service': Unit dbus-org.bluez.service not found.
Apr 25 17:07:00 OP-390 pulseaudio[1553]: GetManagedObjects() failed: org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.bluez.service not found.
Apr 25 17:10:36 OP-390 gnome-terminal-[2290]: g_menu_insert_item: assertion 'G_IS_MENU_ITEM (item)' failed
Apr 25 17:13:55 OP-390 gnome-terminal-[2290]: g_menu_insert_item: assertion 'G_IS_MENU_ITEM (item)' failed
Apr 25 17:28:10 OP-390 gnome-terminal-[4319]: g_menu_insert_item: assertion 'G_IS_MENU_ITEM (item)' failed
Habe nach allen Fehlern im Internet recherchiert und nichts gefunden, was ich in meinem System ändern muss.
Sieht das hier jemand anders?
« Letzte Änderung: 25.04.2021, 17:30:23 von OptiPlex »

Re: Startzeit System
« Antwort #58 am: 30.04.2021, 16:11:06 »
Wo finde ich die Teile von Anwendungsprogrammen, die eventuell beim Systemstart laufen?
Kenne bisher nur Einstellungen -> Startprogramme (~/.config/autostart).
$ cat /etc/crontab
# /etc/crontab: system-wide crontab
# Unlike any other crontab you don't have to run the `crontab'
# command to install the new version when you edit this file
# and files in /etc/cron.d. These files also have username fields,
# that none of the other crontabs do.

SHELL=/bin/sh
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin

# Example of job definition:
# .---------------- minute (0 - 59)
# |  .------------- hour (0 - 23)
# |  |  .---------- day of month (1 - 31)
# |  |  |  .------- month (1 - 12) OR jan,feb,mar,apr ...
# |  |  |  |  .---- day of week (0 - 6) (Sunday=0 or 7) OR sun,mon,tue,wed,thu,fri,sat
# |  |  |  |  |
# *  *  *  *  * user-name command to be executed
17 * * * * root    cd / && run-parts --report /etc/cron.hourly
25 6 * * * root test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )
47 6 * * 7 root test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.weekly )
52 6 1 * * root test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.monthly )
#

Re: Startzeit System
« Antwort #59 am: 30.04.2021, 16:27:58 »
Ganz „einfach”:
das Wirthsche Gesetz macht leider auch vor Linuxbasierten OS nicht halt.

https://de.wikipedia.org/wiki/Wirthsches_Gesetz