Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
23.10.2017, 17:03:12

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 18930
  • Letzte: Rolw
Statistiken
  • Beiträge insgesamt: 486001
  • Themen insgesamt: 39137
  • Heute online: 345
  • Am meisten online: 679
  • (03.04.2017, 15:20:01)
Benutzer Online

Autor Thema:  Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg  (Gelesen 1494 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #30 am: 10.08.2017, 07:54:08 »
Moin "cappy0815",
das sieht es doch schon mal ganz gut aus.
Da der Sound in den Anwendungen (YouTube, Browser, Player usw.) funktioniert und du die Systemklänge aus den Verzeichnissen direkt abspielen kannst sind eigentlich ALSA und PulseAudio komplett installiert. Was fehlt ist das automatischen Abspielen der Systemklänge.

Der einzige Unterschied den ich erkenne besteht in der Terminal Ausgabe von:
Code: [Auswählen]
gsettings list-recursively org.cinnamon.desktop.sound
org.cinnamon.desktop.sound volume-sound-enabled true

Das sieht bei mir so aus:
Zitat
kuehhe1:
gsettings list-recursively org.cinnamon.desktop.sound
org.cinnamon.desktop.sound volume-sound-enabled false

Da scheint eine Einstellung bei uns anders zu stehen und verhindert bei dir die Ausgabe, nur wo bzw. worin?
Bist du sicher das du in Menü>Einstellungen>Klang die Sounds "Ein" und Effektlautstärke für die Systemklänge Hochgeregelt hast.
klang
klang

Man könnte auch im dconf-Editor (falls installiert, wenn nicht mit Synaptic nachholen) die Aktivierung/Deaktivierung der Sounds kontrollieren, aber nur kontrollieren! Unter: org/cinnamon/sounds finden sich die Einstellungen, der dconf-Editor selbst ist wie ein Laufwerk strukturiert.
 
« Letzte Änderung: 10.08.2017, 09:24:18 von kuehhe1 »

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #31 am: 10.08.2017, 08:16:18 »
Moin moin,

ich habe wirklich alle Lautstärker-Reglern in allen hier im Thread erwähnten GUIs und Reglern kontrolliert. Da ist nichts auf MUTE.

[...]Was fehlt ist das automatischen Abspielen der Systemklänge.[...]

Auch wenn ich auf "Play" klicke werden die Systemklänge nicht abgespielt. Aus dem NEmo-Verzeichnis ja.
Als ob ein "interner Mediaplayer" oder sowas nicht funzen würde. Das System weiß scheinbar nicht, was es mit den Audio-Files machen soll.

Zitat
[,,,]
Der einzige Unterschied den ich erkenne besteht in der Terminal Ausgabe von:
Code: [Auswählen]
gsettings list-recursively org.cinnamon.desktop.sound
org.cinnamon.desktop.sound volume-sound-enabled true

Das sieht bei mir so aus:
Zitat
kuehhe1:
gsettings list-recursively org.cinnamon.desktop.sound
org.cinnamon.desktop.sound volume-sound-enabled false

Da scheint eine Einstellung bei uns anders zu stehen und verhindert bei dir die Ausgabe, nur wo bzw. worin?
[...]

Komischerweise, sieht mein TRUE sogar plausibler aus, oder?

Zitat
[...]Bist du sicher das du in Menü>Einstellungen>Klang die Sounds "Ein" und Effektlautstärke für die Systemklänge Hochgeregelt hast.[...]

... gucke ich mir nachher nochmal an, aber das habe ich alles kontrolliert, bevor ich hier im Forum ne Frage gestellt habe.

Zitat
[...]
Man könnte auch im dconf-Editor (falls installiert, wenn nicht mit Synaptic nachholen) die Aktivierung/Deaktivierung der Sounds kontrollieren, aber nur kontrollieren! Unter: org/cinnamon/sounds finden sich die Einstellungen, der dconf-Editor selbst ist wie ein Laufwerk strukturiert.

... auch das sehe ich mir nachher nochmal an.

Vielen Dank nochmal für die Mühe.

Was passiert eigentlich, wenn ich per USB-Stick einfach nochmal drüber installiere??? :-)

Cappy

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #32 am: 10.08.2017, 09:23:55 »
Das System weiß scheinbar nicht, was es mit den Audio-Files machen soll.
Das solltest du mal durch re-Klick auf ein Audio File festlegen: Öffnen mit>andere Anwendung: Auswahl z.B. Banshee>zur Liste hinzufügen. Ein anschließender Doppelklick auf die Datei sollte dann Banshee starten und die Datei abspielen.

Komischerweise, sieht mein TRUE sogar plausibler aus, oder?
Stimmt eigentlich.

... auch das sehe ich mir nachher nochmal an.
Ok, kontrolliere den Soundeffektregler und die Einstellung im dconf-Editor.

Es wäre sehr hilfreich wenn sich ein Profi wie "Z-App" hier noch mal einklinken würde. ;)

Was passiert eigentlich, wenn ich per USB-Stick einfach nochmal drüber installiere??? :-)
Off-Topic:
Drüber geht wohl kaum, wenn dann eine komplette Neuinstallation. Wenns kein Produktivsystem ist würde ich mir hier vom Bord die LM18.2 Cinn. als ISO ziehen, auf einen USB-Stick brennen und Neu installieren, in der Hoffnung das sich die Ungereimtheiten erledigen. Wobei ich bei einer kompletten Neuinstallation eine eigene /home Partition bevorzugen würde, die intakte /home darf aber bei späterer neuerlicher Installationen nicht formatiert werden.
« Letzte Änderung: 10.08.2017, 19:47:17 von kuehhe1 »

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #33 am: 10.08.2017, 09:31:42 »
Ich muss mich an dieser Stelle ausklinken, denn unter KDE scheint doch alles etwas anders organisiert zu sein.
Noch zwei Fragen: Käme evtl. eine Neuinstallation des gesamten Systems in Frage?
Für was benötigst Du die Systemklänge überhaupt (ich habe sie auf meinem Rechner abgestellt)?

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #34 am: 11.08.2017, 13:35:45 »
Mahlzeit,

also ... momentan sieht es so aus.
Die Klangeinstellungen abe ich ALLE nochmal kontrolliert. Es ist wirklich nirgendwo etwas auf MUTE oder offensichtlich deaktiviert, oder so.

Das System weiß scheinbar nicht, was es mit den Audio-Files machen soll.
Das solltest du mal durch re-Klick auf ein Audio File festlegen: Öffnen mit>andere Anwendung: Auswahl z.B. Banshee>zur Liste hinzufügen. Ein anschließender Doppelklick auf die Datei sollte dann Banshee starten und die Datei abspielen.[...]

Nee ... da habe ich mich falsch ausgedrückt. Wenn ich Dateien aus nemo doppelklicke werden sie mit sound abgespielt. Wähle ich die gleichen Dateien als Systemklang aus und drücke auf den kleinen Play-Button, werden sie NICHT abgespielt.
Zitat
Ok, kontrolliere den Soundeffektregler und die Einstellung im dconf-Editor.

Habe ich ... sieht nach meinem Verständnis alles gut aus ...

Komisch komisch komisch ... alles

Cappy

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #35 am: 11.08.2017, 17:04:55 »
Wähle ich die gleichen Dateien als Systemklang aus und drücke auf den kleinen Play-Button, werden sie NICHT abgespielt.
Man oh man, schwierige Geburt.

Bist du in der Gruppe "audio" eingetragen? Kontrolle mit:
grep "^audio" /etc/group | grep "$USER" | wc -l
Bei Ausgabe einer 1 wäre das der Fall, bei Ausgabe einer "0" nicht, versuche testhalber dich unter Menü>Systemverwaltung>Benutzer und Gruppen>(Passwortabfrage) deinen User unter "Gruppen" der Gruppe "audio" durch ein [ X ] hinzufügen. Info: ich selbst gehöre der Gruppe "audio" an.


Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #36 am: 11.08.2017, 17:16:51 »
grep "^audio" /etc/group | grep "$USER" | wc -lWarum so kompliziert?
Ein einfaches groupsreicht doch aus, so viele Gruppen gibt es nun ja nicht.
groups
heinz adm fax cdrom sudo dip plugdev netdev lpadmin scanner saned sambashare vboxusers
Und wie man sieht, braucht es die Gruppe audio auch nicht, ich hab Systemklänge, wenn ich sie denn wollte.

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #37 am: 11.08.2017, 17:36:21 »
Und wie man sieht, braucht es die Gruppe audio auch nicht, ich hab Systemklänge, wenn ich sie denn wollte.
Die Zugehörigkeit zur Gruppe "audio" ist in meinem Fall KODI geschuldet und findet sich auch im UU-Thema zur Audio Problembehebung. Hab mich gerade mal aus der Gruppe "audio" ausgetragen, Neustart auch hier funktionieren die Systemklänge ohne "audio" Zugehörigkeit.

Eine Suche nach "sound" im dconf-Editor ergab einige Funde, so gibts im Schema: org.gnome.settings-daemon.plugins.sound eine Möglichkeit das standardmäßig gesetzte Gnome Plugin zu deaktivieren, kein Unterschied, die Systemsounds werden bei mir immer abgespielt.

Zwischenzeitlich habe ich auf LM18.2 Cinn. Upgegraded, der Sound läuft. Einziger Unterschied wäre jetzt noch im Kernel, nicht jeder verträgt sich mit der verwendeten Hardware. Ich verwende bewußt 4.4.0-91 und bei dir werkelt 4.10.0-30. Falls du eine Neuinstallation in Erwägung ziehen solltest würde ich vorher über die Aktualisierungsverwaltung eine andere Kernel-Schiene (4.4, 4.8, 4.11) installieren.

Momentan hab keine weitere Idee mehr.   :-[
« Letzte Änderung: 11.08.2017, 19:36:33 von kuehhe1 »

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #38 am: 11.08.2017, 21:20:25 »
Nabend,

sehr eigenartig. In der audio-gruppe bin ich tatsächlich nicht.
Eine Neuinstallation könnte schon passieren, ja ... habe meistens keine Lust alles nochmal neu zu machen.
Vielleicht lebe ich auch einfach ohne Systemsounds. Nervt mich nur aus prinzip.

Kannes sein, dass es da irgendwie eine Verknüpfung zwischen Player und Systemklängen erwischt hat?
Nemo weiß, wie es soundfiles abspielt ... die Abteilung Systemklänge scheinbar nicht mehr ...

Cappy

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #39 am: 11.08.2017, 21:40:49 »
Stellt sich die Frage wer oder was ist der Player der Systemklänge?
Wenn du das in Erfahrung gebracht hast kannst du das Paket mit Syslog des autoremove abgleichen.

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #40 am: 11.08.2017, 21:49:15 »
Zitat
sehr eigenartig. In der audio-gruppe bin ich tatsächlich nicht.
Wie schon erwähnt, brauchst du das auch nicht sein.

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #41 am: 11.08.2017, 22:45:37 »
Schau mal nach ob "indicator-sound" installiert ist. Es gehört laut Synaptic auch zu pulseaudio. Eigenschaften: "System sound indicator".
Falls installier: mit Synaptic erneut installieren, Neustart und Systemsounds testen, falls Test negativ: Deinstallieren, Neustarten und erneut installieren.
Falls nicht installiert: Installieren, Neustarten, Systemsounds Testen.

Andere Frage: funktioniert(e) der Sound mit einem 18.2 Live-System?
Dazu gibt's ein älteres 17.3 Thema mit gleicher Sympthomatik. Dortiger Tip, dass gesamte Verzeichnis ~/.config/pulse aus dem Live-System zu kopieren,  ist allemal einen Versuch wert und vielleicht die Lösung....

« Letzte Änderung: 13.08.2017, 15:47:08 von kuehhe1 »

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #42 am: 12.08.2017, 21:24:25 »
Wr nicht installiert, aber das war es auch nicht.
Das Verzeichnis aus der Live-Version werde ich nächste Woche zu Hause mal testen.

Cappy

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #43 am: 13.08.2017, 11:26:09 »
Dann schau dir auch "nochmals" das UU-Wiki zu PulseAudio an, insbesondere den Abschnitt "Reset". Dort wird mit dem Befehl:
mv ~/.config/pulse ~/.config/pulse-backup angeraten das /pulse Verzeichnis samt enthaltenen configs durch umbenennen zu sichern und anschließendes Starten von pulseaudio neu erstellen zu lassen, vielleicht eine Möglichkeit.
« Letzte Änderung: 13.08.2017, 12:06:25 von kuehhe1 »

Re: Linux Mint 18.2 64bit / Cinnamon-Version - Sound plötzlich weg
« Antwort #44 am: 13.08.2017, 13:32:04 »
... auch nicht :-)