Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.04.2021, 16:39:51

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 729581
  • Themen insgesamt: 58856
  • Heute online: 709
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Gelöst Installation erkennt vorhandenes Windows 10 nicht. / Bootmgr is missing  (Gelesen 1871 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo Community,

Ich habe bisher Windows 7 Professional und OpenSuse auf meinem Rechner.
(1x SSD und 1x SATA mit NTFS Partitionen) gehabt.

Der Grubloader hat es ermöglicht zwischen den Betriebssystemen auszuwählen und dann zu Booten.

Ein Upgrade von Suse war nicht erfolgreich (PC fror dauernd ein).
Da ich schon davor mit Suse ohnehin unzufrieden war,
wollte ich nun Suse durch ein anderes Linux
ersetzen.

Zusammenfassung:
- Windows 7 und Open Suse auf einer SSD
- Partitionen mit Linux gelöscht
- Windows lässt sich nicht mehr starten (Bootmgr is missing)
- Wiederherstellungsversuche MBR über Windows scheitern
- Zugriff über Super Grub 2 möglich
- Wie nun LinuxMint so installieren, dass wieder beide Systeme normal starten?

1.)  Suse und Windows: Installationsmanager hat nur Windows erkannt

Der Installationsmanager (DVD ISO, gebootet) erkannte jedoch nur Linux und nicht Windows bei der Frage,
ob zusätzlich installiert werden soll.

2.) Fehler: Das Löschen einiger Partitionen

Also startete ich wieder Windows 7 und löschte einfach alle Linux Partitionen.
Ich ging davon aus, dass der Installationsmanager von Linux dann Windows erkennen würde und eine parallele Installation anböte.
Doch nun starteten keine Linux-ISOs mehr.

Ich habe den MBR offenbar gelöscht, beim löschen der Linux Partitionen, denn ein Windows-Start
war nicht mehr möglich.

Fehlermeldung: "Bootmgr is missing Press Ctrl+Alt+Del"

3.)  Rettung: Super Grub 2

Mit Super Grub2 kann ich nun über DVD als Startmedium Windows starten.

4.)  Windows Upgrade

Ich hoffte ein Windows Upgrade auf Win10 löste das Problem.
Win 10 läuft nun zwar, lässt sich aber nur mit Super Grub 2 starten.

5.) Fehler beim Installieren anderer Distris

Status:
DVD Linux - Iso's ließen sich nicht starten,

Fehler der Installations-DVDS:

Fedora 31:
Fatal: Failed to find a root filesystem dracut-iniqueue [644]

Elementary OS 5.1. Hera:
Kernel panic not syncing VFS unable to mount root fs on unkown block 00



6.) Partitionen im Überblick
Die Datenträgerverwaltung von Windows sagt mir Folgendes:

Datenträger 0
Basis
238,47 GB
Online

101 MB
Nicht zugeordnet

C:
130.07 GB NTFS
Fehlerfrei (Startpartition, Aktiv, Absturzabbild, Primäre Partition)

580 MB
Fehlerfrei (Wiederherstellungspartition)

107,74 GB
Nicht zugeordnet (hier soll Linux hin)

####

Datenträger 1
Basis
1863.02 GB Erweiterte Partition mit diversen NTFS Partitionen, deren Laufwerksbuchstaben von D bis P reichen.
Online

"

Wobei Laufwerk C Primär ist, alle anderen sind logisch.


7.) Windows Bootmanager

EasyBCD gibt an:

Zur Zeit existieren insgesamt 2 Einträge im Bootloader.

Voreinstellung: Windows 10
Wartezeit: 30 Sekunden
Startlaufwerk: H:\

Eintrag #1
Name: Windows 10
BCD ID: {current}
Laufwerk: C:\
Bootloader Pfad: \WINDOWS\system32\winload.exe

Eintrag #2
Name: Grub 2 For Windows
BCD ID: {e38bf017-56b6-11ea-9c4a-d050992eefda}
Laufwerk: C:\
Bootloader Pfad: \grub2\g2bootmgr\gnugrub.kernel.bios

Was mich wundert ist, dass das Startlaufwerk auf H liegt. Müsste dies nicht auch C sein?

8.) Grub 2 for Windows

Mit "Grub 2 For Windows" habe ich gehofft aus dem laufenden Windows 10 heraus
Grub neu installieren zu können um somit wieder starten zu können.

Diesen Bootmanager aufzurufen klappt aber auch nur über Super Grub 2 von DVD aus.



9.) Installationsstatus mit Mint

Linux Mint Cinnamon (heute heruntergeladen, 64bit ISO), Installation startet fehlerfrei.
Dazu weiter unten mehr.
Die Live-Distribution läuft normal.
Ich komme im Installationsmenü bis zur Anzeige der Partitionen.

Hier die Herausforderung:

Mint erkennt Windows 10 nicht.

Vorausgewählt ist die SATA-Festplatte. Die ist bei Linux mit sda/ und weiteren benannt.
Die SSD wiederum (auf der Win10 liegt) ist bei Linux mit sdb/ und weiteren benannt.
Gerät für Bootloader-Installation könnte ich aussuchen.


10.)  Bios-Angaben

Im Bios steht bei den Boot Option Priorities:
#1 SATA
#2 AHCI DVD-Laufwerk
#3 AHCI DVD-Laufwerk
#4 UEFI Built-in

AHCI P0 (SDD Festplatte) taucht nur auf bei Select boot device,
führt aber zum selben Fehler (Bootmgr is missing Press Ctrl+Alt+Del).



Wie fahre ich nun am Besten fort,
mit dem Ergebnis nach der Installation wieder zwischen Linux und windows auswählen zu können ohne über DVD zu gehen?


Ich hoffe ihr könnt mir helfen, nach dem ich den dummen Fehler mit dem Löschen der Linuxpartitionen gemacht habe :-(
Viele Grüße
Benjamin

« Letzte Änderung: 27.02.2020, 23:32:48 von Ben80 »

Hallo und willkommen bei LMU.

Starte bitte mal das Live-System und zeige bitte:
sudo parted --listinxi -Fz[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
Danke

Hallo @tommix,
herzlichen Dank für die sehr schnelle Antwort. Anbei gewünschte Information:

Modell: ATA SAMSUNG SSD 830 (scsi)
Festplatte  /dev/sda:  256GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      106MB   140GB  140GB  primary  ntfs         boot
 2      140GB   140GB  608MB  primary  ntfs         diag


Modell: ATA ST2000DM001-1CH1 (scsi)
Festplatte  /dev/sdb:  2000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe   Typ       Dateisystem  Flags
 1      8225kB  2000GB  2000GB  extended               LBA
 5      8258kB  403GB   403GB   logical   ntfs
 6      403GB   805GB   403GB   logical   ntfs
 7      805GB   966GB   161GB   logical   ntfs
 8      966GB   1074GB  107GB   logical   ntfs
 9      1074GB  1181GB  107GB   logical   ntfs         boot
10      1181GB  1611GB  429GB   logical   ntfs
11      1611GB  1691GB  80,5GB  logical   ntfs
12      1691GB  1745GB  53,7GB  logical   ntfs
13      1745GB  1825GB  80,5GB  logical   ntfs
14      1825GB  1874GB  48,3GB  logical   ntfs
15      1874GB  1922GB  48,3GB  logical   ntfs
16      1922GB  1986GB  64,4GB  logical   ntfs
17      1986GB  2000GB  14,0GB  logical   ntfs


Modell: HL-DT-ST BDDVDRW CH10LS20 (scsi)
Festplatte  /dev/sr0:  4700MB
Sektorgröße (logisch/physisch): 2048B/2048B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 2      1925kB  12,0MB  10,1MB  primary               esp


System:
  Host: mint Kernel: 5.0.0-32-generic x86_64 bits: 64
  Desktop: Cinnamon 4.4.5 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Desktop Mobo: ASRock model: 990FX Killer serial: <filter>
  BIOS: American Megatrends v: P1.10 date: 05/14/2014
CPU:
  Topology: 8-Core model: AMD FX-8350 bits: 64 type: MCP L2 cache: 2048 KiB
  Speed: 1433 MHz min/max: 1400/4000 MHz Core speeds (MHz): 1: 1780 2: 1869
  3: 2068 4: 2033 5: 1447 6: 2089 7: 2261 8: 3158
Graphics:
  Device-1: NVIDIA GK104 [GeForce GTX 660 Ti] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1200~60Hz, 1920x1200~60Hz
  OpenGL: renderer: NVE4 v: 4.3 Mesa 19.0.8
Audio:
  Device-1: AMD SBx00 Azalia driver: snd_hda_intel
  Device-2: NVIDIA GK104 HDMI Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.0.0-32-generic
Network:
  Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet driver: alx
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.05 TiB used: 98.9 MiB (0.0%)
  ID-1: /dev/sda vendor: Samsung model: SSD 830 Series size: 238.47 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST2000DM001-1CH164 size: 1.82 TiB
Partition:
  ID-1: / size: 7.81 GiB used: 98.9 MiB (1.2%) fs: overlay source: ERR-102
Sensors:
  System Temperatures: cpu: 25.0 C mobo: N/A gpu: nouveau temp: 40 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 1530
Info:
  Processes: 210 Uptime: 9m Memory: 15.62 GiB used: 931.0 MiB (5.8%)
  Shell: bash inxi: 3.0.32


mint@mint:~$ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
BIOS

Bei dem letzten Befehl kam lediglich der Begriff "BIOS" zum Vorschein.

Viele Grüße :-)

Vorausgewählt ist die SATA-Festplatte. Die ist bei Linux mit sda/ und weiteren benannt.
Die SSD wiederum (auf der Win10 liegt) ist bei Linux mit sdb/ und weiteren benannt.

Das stimmt nicht:

/sda ist die 256 GB SSD;
/sdb ist die 2 TB HDD;

Dann versuche doch bitte einfach mal Linux Mint auf die SSD (/dev/sda) in den nicht zugewiesenen Bereich 140 GB bis 256 GB zu installieren.

Aber ob Windows10 dann startet??

Zitat
Das stimmt nicht:

/sda ist die 256 GB SSD;
/sdb ist die 2 TB HDD;

Danke für die Korrektur. Plötzlich bietet Linux Mint an, sich neben Windows zu installieren.  :o
Ich trinke, rauche und nehme nichts... Seltsam, ich bin mir 100%ig sicher, dass "Festplatte löschen und Linux Mint installieren" der oberste Eintrag war.

Ich wähle jetzt den Punkt "neben Windows 10 installieren" aus. Hoffentlich ist das nicht was im Argen...
Daumen drücken...

Bevor ich nun weitermache und mir wieder die nächste Partition zerschieße, anbei zwei Bildschirmfotos. Wie kann ich Partition 5 auf der sda zuordnen, also woher weiß ich, welche Mint jetzt nehmen möchte?

Ja ! Passt.

Hey tommix,

die Installation war erfolgreich. Das System läuft. Und: Ich kann wieder von Festplatte booten.
Leider nur Linux.

Wenn ich Windows über den Bootmanager von LinuxMinut booten will, wird der Bildschirm schwarz und oben rechts blinkt ein Cursor.
Mit Super Grub 2 (über DVD) startet Windows weiterhin normal.

Kann ich irgendwie den funktionierenden Eintrag aus Super Grub 2 (von-dvd-jpg) Windows Vista/7/8/2008 (R2) (Direct /bootmgr) ... (hd0,msdos 9)
in dem neuen Bootmenü von Linux Mint in den dortigen Eintrag Windows 10 (neues-bootmenue.jpg und details.jpg) einfügen?

Der Verweis im Grub - Menü geht auf die Festplatte /dev/sdb9.
Der eigentliche Windows - Bootloader deines Systems auf der SSD /dev/sda ist Defekt.
Dieser müsste repariert werden.

Hmm...
Der Bootloader von der DVD startet Windows.

Der andere Bootloader nicht. Gibt es keine Möglichkeit dem auf der Festplatte befindlichen Bootloader den selben Bootbefehl beizubringen?

Den Versuch den Windowsbootmanager zu reparieren habe ich ja erfolglos unternommen.

Der Bootloader von der DVD startet Windows.

Welches Windows?  /dev/sda1  oder  /dev/sdb9?

Das ist der spannende Punkt, ich habe den Bootloader abfotografiert: ich kann nicht erkennen (im Gegensatz zu dem Bootmanager von Linux Mint) wie/welchen Pfad die DVD wählt um das Windows 10 zu starten.

Oder verstehe ich die Frage falsch?

PS. : ich habe ja nur ein Windows. Keine zwei.

Wenn ich das richtig lese, greift Supergrub auf /dev/sdb9 zu.

Es ist beides Grub 2.02 richtig🤔?

Linux Mint versucht hd1/msdos 9 und
dev/sdb9. Das klappt nicht.

Die DVD versucht hd0/msdos9. Das dev/... finde ich dort nicht. Es funktioniert auch nur der hd0/msdos9 Eintrag mit direct /bootmgr.

Mir ist unklar, warum es einmal hd1 und einmal hd0 ist. Aber müsste nicht genau diese Anpassung bei dem Mint-Bootmanager zum Erfolg führen?