Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
29.11.2021, 15:38:23

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 765137
  • Themen insgesamt: 61386
  • Heute online: 630
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Linux Mint 19.1 Cinnamon, Add-on Video DownloadHelper in Firefox macht Probleme  (Gelesen 393 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ahoi allerseits,

das Add-on "Video DownloadHelper" in Firefox zickt auf meinem Laptop ständig rum, während es auf meinem PC bei gleichem Betriebssystem 19.1 Cinnamon tadellos funktioniert.

Konkret funktionieren viele Videodownloads nicht. Als Fehlermeldung wird immer folgendes angezeigt :


Sammeln von ...... fehlgeschlagen

/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavdevice.so.58)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavfilter.so.7)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavformat.so.58)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavcodec.so.58)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libswresample.so.3)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libswscale.so.5)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavutil.so.56)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavutil.so.56)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libvpx.so.6)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libwebpmux.so.3)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libwebp.so.7)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libaom.so.0)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libmp3lame.so.0)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libopenjp2.so.7)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libopus.so.0)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libvorbis.so.0)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libx264.so.161)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libx265.so.188)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libxvidcore.so.4)

Kann jemand etwas damit anfangen und mir eine Lösung anbieten ?

Danke, tibo
« Letzte Änderung: 16.10.2021, 00:40:13 von tibo »

Bedaure lmumischabln,

ich kann mit Deinem Beitrag noch nichts anfangen. Könntest Du bitte noch mal für einen Dummy wie mich konkreter werden ?

Danke, tibo

So, ich habe " ldd --version " mal in meinen Terminal eingegeben.
Als Ausgabe kommt dann : " Ubuntu GLIBC 2.27-3ubuntu 1.4 ".

War das angefragt ?
« Letzte Änderung: 16.10.2021, 01:13:37 von tibo »

Versuche es mal mit folgendem Add-on:
YouTube Video and Audio Downloader
Funktioniert  bei mir unter LM Mate 20.2 sehr gut. Hat auch noch nützliche Erweiterung.

Besten Dank für Eure Hinweise.

Bei der Recherche im Weltnetz war mir schon klar geworden, daß die neueren GNU C library Versionen nur über einen Systemupgrade zu bekommen sind. Es wundert mich jedoch, daß die gleiche Konstellation mit den gleichen Versionen von Betriebssystem und DownloadHelper im PC fehlerlos arbeitet, im Laptop dagegen nicht.

Werde dann wohl das System auf Version Mint 20+ aktualisieren.

Danke, tibo
« Letzte Änderung: 16.10.2021, 00:37:56 von tibo »

Yihaaa, ich habe es jetzt hin bekommen. Ohne Systemupgrade. Mit viel Suchen im Weltnetz.

Es gibt für den Downloadhelper eine Begleitanwendung für die schwierigen Downloads. Ich hatte bislang davon die Version für glibc 2.31 installiert. Es gibt allerdings für ältere Betriebssysteme auch eine Version für glibc 2.27. Schwupp 2.31 vom Laptop gelöscht und dann 2.27 neu installiert.

Und das alles nur, weil lmumischabln mit seinem lapidaren
Zitat
     ?  ?  ? ldd --version
mich zum Selberdenken angeregt und damit letztendlich doch noch auf die richtige Spur gelockt hat.

Gut gemacht ! Danke !
« Letzte Änderung: 16.10.2021, 00:36:41 von tibo »

thebookkeeper

  • aka AnanasDampf
  • *****
Die Fehlermeldungen bezogen sich eh' nur auf die CoApp.
... Es gibt allerdings für ältere Betriebssysteme auch eine Version für glibc 2.27 ...
https://www.downloadhelper.net/install-coapp
und dann klicken auf Other system installers

Off-Topic:
thebookkeeper@Dell-DV051:~$ ldd --version
ldd (Ubuntu GLIBC 2.27-3ubuntu1.4) 2.27
...

Meine CoApp-Version ist die net.downloadhelper.coapp-1.6.3-1_i386-glibc-2.27.deb
« Letzte Änderung: 16.10.2021, 02:18:48 von thebookkeeper »

@ thebookkeeper

Zitat
https://www.downloadhelper.net/install-coapp
und dann klicken auf Other system installers

Genau da bin ich letztendlich nach vier Stunden Recherche gelandet. Und habe dabei wieder einiges gelernt.

 :D